FlyCapture2: Related Pages

FlyCapture2 2.12.3.2
  • Main Page
  • Related Pages
  • Modules
  • Namespaces
  • Classes
  • Files
Related Pages
Here is a list of all related documentation pages:
  • Software Licensing Information
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Software Licensing Information

  • Modules
  • Namespaces
  • Classes
  • Files
Software Licensing Information
License table
Component | License
FlyCapture2

Copyright © 2017 FLIR Integrated Imaging Solutions, Inc. All Rights Reserved. This software is the confidential and proprietary information of FLIR Integrated Imaging Solutions, Inc. ("Confidential Information"). You shall not disclose such Confidential Information and shall use it only in accordance with the terms of the license agreement you entered into with FLIR Integrated Imaging Solutions, Inc. (FLIR).

FLIR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. FLIR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.

AdapterList | The Code Project Open License (CPOL) http://www.codeproject.com/info/cpol10.aspx
Boost | Boost Software License http://www.boost.org/users/license.html
FFMPEG | LGPv2.1 License https://www.ffmpeg.org/legal.html
FreeImage | FreeImage public license http://freeimage.sourceforge.net/freeimage-license.txt
GTK | LGPv2.1 License http://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt
Libusb | LGPLv2.1 License http://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt
Libraw1394

LGPLv2.0 License http://www.gnu.org/licenses/old-licenses/lgpl-2.0.txt

Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Modules

  • Files
Modules
Here is a list of all modules:
  • Global constants
  • Enumerations
  • GigE specific enumerations
  • Structures
    • GigE specific structures
    • IIDC specific structures
    • Image saving structures.
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Global constants

Variables
Global constants

Variables

static const unsigned int | sk_maxStringLength = 512
The maximum length that is allocated for a string.
static const unsigned int | sk_maxNumPorts = 32
The maximum number of ports one device can have.

Variable Documentation

const unsigned int sk_maxNumPorts = 32 [static]

The maximum number of ports one device can have.

const unsigned int sk_maxStringLength = 512 [static]

The maximum length that is allocated for a string.

Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Enumerations

Enumerations
Enumerations

Enumerations

enum ErrorType {
PGRERROR_UNDEFINED = -1,
PGRERROR_OK,
PGRERROR_FAILED,
PGRERROR_NOT_IMPLEMENTED,
PGRERROR_FAILED_BUS_MASTER_CONNECTION,
PGRERROR_NOT_CONNECTED,
PGRERROR_INIT_FAILED,
PGRERROR_NOT_INTITIALIZED,
PGRERROR_INVALID_PARAMETER,
PGRERROR_INVALID_SETTINGS,
PGRERROR_INVALID_BUS_MANAGER,
PGRERROR_MEMORY_ALLOCATION_FAILED,
PGRERROR_LOW_LEVEL_FAILURE,
PGRERROR_NOT_FOUND,
PGRERROR_FAILED_GUID,
PGRERROR_INVALID_PACKET_SIZE,
PGRERROR_INVALID_MODE,
PGRERROR_NOT_IN_FORMAT7,
PGRERROR_NOT_SUPPORTED,
PGRERROR_TIMEOUT,
PGRERROR_BUS_MASTER_FAILED,
PGRERROR_INVALID_GENERATION,
PGRERROR_LUT_FAILED,
PGRERROR_IIDC_FAILED,
PGRERROR_STROBE_FAILED,
PGRERROR_TRIGGER_FAILED,
PGRERROR_PROPERTY_FAILED,
PGRERROR_PROPERTY_NOT_PRESENT,
PGRERROR_REGISTER_FAILED,
PGRERROR_READ_REGISTER_FAILED,
PGRERROR_WRITE_REGISTER_FAILED,
PGRERROR_ISOCH_FAILED,
PGRERROR_ISOCH_ALREADY_STARTED,
PGRERROR_ISOCH_NOT_STARTED,
PGRERROR_ISOCH_START_FAILED,
PGRERROR_ISOCH_RETRIEVE_BUFFER_FAILED,
PGRERROR_ISOCH_STOP_FAILED,
PGRERROR_ISOCH_SYNC_FAILED,
PGRERROR_ISOCH_BANDWIDTH_EXCEEDED,
PGRERROR_IMAGE_CONVERSION_FAILED,
PGRERROR_IMAGE_LIBRARY_FAILURE,
PGRERROR_BUFFER_TOO_SMALL,
PGRERROR_IMAGE_CONSISTENCY_ERROR,
PGRERROR_INCOMPATIBLE_DRIVER,
PGRERROR_FORCE_32BITS = FULL_32BIT_VALUE
}
The error types returned by functions. More...
enum BusCallbackType {
BUS_RESET,
ARRIVAL,
REMOVAL,
CALLBACK_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
The type of bus callback to register a callback function for. More...
enum GrabMode {
DROP_FRAMES,
BUFFER_FRAMES,
UNSPECIFIED_GRAB_MODE,
GRAB_MODE_FORCE_32BITS = FULL_32BIT_VALUE
}
The grab strategy employed during image transfer. More...
enum GrabTimeout {
TIMEOUT_NONE = 0,
TIMEOUT_INFINITE = -1,
TIMEOUT_UNSPECIFIED = -2,
GRAB_TIMEOUT_FORCE_32BITS = FULL_32BIT_VALUE
}
Timeout options for grabbing images. More...
enum BandwidthAllocation {
BANDWIDTH_ALLOCATION_OFF = 0,
BANDWIDTH_ALLOCATION_ON = 1,
BANDWIDTH_ALLOCATION_UNSUPPORTED = 2,
BANDWIDTH_ALLOCATION_UNSPECIFIED = 3,
BANDWIDTH_ALLOCATION_FORCE_32BITS = FULL_32BIT_VALUE
}
Bandwidth allocation options for 1394 devices. More...
enum InterfaceType {
INTERFACE_IEEE1394,
INTERFACE_USB2,
INTERFACE_USB3,
INTERFACE_GIGE,
INTERFACE_UNKNOWN,
INTERFACE_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
Interfaces that a camera may use to communicate with a host. More...
enum PropertyType {
BRIGHTNESS,
AUTO_EXPOSURE,
SHARPNESS,
WHITE_BALANCE,
HUE,
SATURATION,
GAMMA,
IRIS,
FOCUS,
ZOOM,
PAN,
TILT,
SHUTTER,
GAIN,
TRIGGER_MODE,
TRIGGER_DELAY,
FRAME_RATE,
TEMPERATURE,
UNSPECIFIED_PROPERTY_TYPE,
PROPERTY_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
Camera properties. More...
enum FrameRate {
FRAMERATE_1_875,
FRAMERATE_3_75,
FRAMERATE_7_5,
FRAMERATE_15,
FRAMERATE_30,
FRAMERATE_60,
FRAMERATE_120,
FRAMERATE_240,
FRAMERATE_FORMAT7,
NUM_FRAMERATES,
FRAMERATE_FORCE_32BITS = FULL_32BIT_VALUE
}
Frame rates in frames per second. More...
enum VideoMode {
VIDEOMODE_160x120YUV444,
VIDEOMODE_320x240YUV422,
VIDEOMODE_640x480YUV411,
VIDEOMODE_640x480YUV422,
VIDEOMODE_640x480RGB,
VIDEOMODE_640x480Y8,
VIDEOMODE_640x480Y16,
VIDEOMODE_800x600YUV422,
VIDEOMODE_800x600RGB,
VIDEOMODE_800x600Y8,
VIDEOMODE_800x600Y16,
VIDEOMODE_1024x768YUV422,
VIDEOMODE_1024x768RGB,
VIDEOMODE_1024x768Y8,
VIDEOMODE_1024x768Y16,
VIDEOMODE_1280x960YUV422,
VIDEOMODE_1280x960RGB,
VIDEOMODE_1280x960Y8,
VIDEOMODE_1280x960Y16,
VIDEOMODE_1600x1200YUV422,
VIDEOMODE_1600x1200RGB,
VIDEOMODE_1600x1200Y8,
VIDEOMODE_1600x1200Y16,
VIDEOMODE_FORMAT7,
NUM_VIDEOMODES,
VIDEOMODE_FORCE_32BITS = FULL_32BIT_VALUE
}
DCAM video modes. More...
enum Mode {
MODE_0 = 0,
MODE_1,
MODE_2,
MODE_3,
MODE_4,
MODE_5,
MODE_6,
MODE_7,
MODE_8,
MODE_9,
MODE_10,
MODE_11,
MODE_12,
MODE_13,
MODE_14,
MODE_15,
MODE_16,
MODE_17,
MODE_18,
MODE_19,
MODE_20,
MODE_21,
MODE_22,
MODE_23,
MODE_24,
MODE_25,
MODE_26,
MODE_27,
MODE_28,
MODE_29,
MODE_30,
MODE_31,
NUM_MODES,
MODE_FORCE_32BITS = FULL_32BIT_VALUE
}
Camera modes for DCAM formats as well as Format7. More...
enum PixelFormat {
PIXEL_FORMAT_MONO8 = 0x80000000,
PIXEL_FORMAT_411YUV8 = 0x40000000,
PIXEL_FORMAT_422YUV8 = 0x20000000,
PIXEL_FORMAT_444YUV8 = 0x10000000,
PIXEL_FORMAT_RGB8 = 0x08000000,
PIXEL_FORMAT_MONO16 = 0x04000000,
PIXEL_FORMAT_RGB16 = 0x02000000,
PIXEL_FORMAT_S_MONO16 = 0x01000000,
PIXEL_FORMAT_S_RGB16 = 0x00800000,
PIXEL_FORMAT_RAW8 = 0x00400000,
PIXEL_FORMAT_RAW16 = 0x00200000,
PIXEL_FORMAT_MONO12 = 0x00100000,
PIXEL_FORMAT_RAW12 = 0x00080000,
PIXEL_FORMAT_BGR = 0x80000008,
PIXEL_FORMAT_BGRU = 0x40000008,
PIXEL_FORMAT_RGB = PIXEL_FORMAT_RGB8,
PIXEL_FORMAT_RGBU = 0x40000002,
PIXEL_FORMAT_BGR16 = 0x02000001,
PIXEL_FORMAT_BGRU16 = 0x02000002,
PIXEL_FORMAT_422YUV8_JPEG = 0x40000001,
NUM_PIXEL_FORMATS = 20,
UNSPECIFIED_PIXEL_FORMAT = 0
}
Pixel formats available for Format7 modes. More...
enum BusSpeed {
BUSSPEED_S100,
BUSSPEED_S200,
BUSSPEED_S400,
BUSSPEED_S480,
BUSSPEED_S800,
BUSSPEED_S1600,
BUSSPEED_S3200,
BUSSPEED_S5000,
BUSSPEED_10BASE_T,
BUSSPEED_100BASE_T,
BUSSPEED_1000BASE_T,
BUSSPEED_10000BASE_T,
BUSSPEED_S_FASTEST,
BUSSPEED_ANY,
BUSSPEED_SPEED_UNKNOWN = -1,
BUSSPEED_FORCE_32BITS = FULL_32BIT_VALUE
}
Bus speeds. More...
enum PCIeBusSpeed {
PCIE_BUSSPEED_2_5,
PCIE_BUSSPEED_5_0,
PCIE_BUSSPEED_UNKNOWN = -1,
PCIE_BUSSPEED_FORCE_32BITS = FULL_32BIT_VALUE
}
enum DriverType {
DRIVER_1394_CAM,
DRIVER_1394_PRO,
DRIVER_1394_JUJU,
DRIVER_1394_VIDEO1394,
DRIVER_1394_RAW1394,
DRIVER_USB_NONE,
DRIVER_USB_CAM,
DRIVER_USB3_PRO,
DRIVER_GIGE_NONE,
DRIVER_GIGE_FILTER,
DRIVER_GIGE_PRO,
DRIVER_GIGE_LWF,
DRIVER_UNKNOWN = -1,
DRIVER_FORCE_32BITS = FULL_32BIT_VALUE
}
Types of low level drivers that flycapture uses. More...
enum ColorProcessingAlgorithm {
DEFAULT,
NO_COLOR_PROCESSING,
NEAREST_NEIGHBOR,
EDGE_SENSING,
HQ_LINEAR,
RIGOROUS,
IPP,
DIRECTIONAL_FILTER,
WEIGHTED_DIRECTIONAL_FILTER,
COLOR_PROCESSING_ALGORITHM_FORCE_32BITS = FULL_32BIT_VALUE
}
Color processing algorithms. More...
enum BayerTileFormat {
NONE,
RGGB,
GRBG,
GBRG,
BGGR,
BT_FORCE_32BITS = FULL_32BIT_VALUE
}
Bayer tile formats. More...
enum ImageFileFormat {
FROM_FILE_EXT = -1,
PGM,
PPM,
BMP,
JPEG,
JPEG2000,
TIFF,
PNG,
RAW,
IMAGE_FILE_FORMAT_FORCE_32BITS = FULL_32BIT_VALUE
}
File formats to be used for saving images to disk. More...

Enumeration Type Documentation

enum BandwidthAllocation

Bandwidth allocation options for 1394 devices.

Enumerator:
BANDWIDTH_ALLOCATION_OFF

Do not allocate bandwidth.

BANDWIDTH_ALLOCATION_ON

Allocate bandwidth.

This is the default setting.

BANDWIDTH_ALLOCATION_UNSUPPORTED

Bandwidth allocation is not supported by either the camera or operating system.

BANDWIDTH_ALLOCATION_UNSPECIFIED

Not specified.

This leaves the current setting unchanged.

BANDWIDTH_ALLOCATION_FORCE_32BITS
enum BayerTileFormat

Bayer tile formats.

Enumerator:
NONE

No bayer tile format.

RGGB

Red-Green-Green-Blue.

GRBG

Green-Red-Blue-Green.

GBRG

Green-Blue-Red-Green.

BGGR

Blue-Green-Green-Red.

BT_FORCE_32BITS
enum BusCallbackType

The type of bus callback to register a callback function for.

Enumerator:
BUS_RESET

Register for all bus events.

ARRIVAL

Register for arrivals only.

REMOVAL

Register for removals only.

CALLBACK_TYPE_FORCE_32BITS
enum BusSpeed

Bus speeds.

Enumerator:
BUSSPEED_S100

100Mbits/sec.

BUSSPEED_S200

200Mbits/sec.

BUSSPEED_S400

400Mbits/sec.

BUSSPEED_S480

480Mbits/sec.

Only for USB2 cameras.

BUSSPEED_S800

800Mbits/sec.

BUSSPEED_S1600

1600Mbits/sec.

BUSSPEED_S3200

3200Mbits/sec.

BUSSPEED_S5000

5000Mbits/sec.

Only for USB3 cameras.

BUSSPEED_10BASE_T

10Base-T.

Only for GigE Vision cameras.

BUSSPEED_100BASE_T

100Base-T.

Only for GigE Vision cameras.

BUSSPEED_1000BASE_T

1000Base-T (Gigabit Ethernet).

Only for GigE Vision cameras.

BUSSPEED_10000BASE_T

10000Base-T.

Only for GigE Vision cameras.

BUSSPEED_S_FASTEST

The fastest speed available.

BUSSPEED_ANY

Any speed that is available.

BUSSPEED_SPEED_UNKNOWN

Unknown bus speed.

BUSSPEED_FORCE_32BITS
enum ColorProcessingAlgorithm

Color processing algorithms.

Please refer to our knowledge base at article at http://www.ptgrey.com/support/kb/index.asp?a=4&q=33 for complete details for each algorithm.

Enumerator:
DEFAULT

Default method.

NO_COLOR_PROCESSING

No color processing.

NEAREST_NEIGHBOR

Fastest but lowest quality.

Equivalent to FLYCAPTURE_NEAREST_NEIGHBOR_FAST in FlyCapture.

EDGE_SENSING

Weights surrounding pixels based on localized edge orientation.

HQ_LINEAR

Well-balanced speed and quality.

RIGOROUS

Slowest but produces good results.

IPP

Multithreaded with similar results to edge sensing.

DIRECTIONAL_FILTER

Best quality but much faster than rigorous.

WEIGHTED_DIRECTIONAL_FILTER

Weighted pixel average from different directions.

COLOR_PROCESSING_ALGORITHM_FORCE_32BITS
enum DriverType

Types of low level drivers that flycapture uses.

Enumerator:
DRIVER_1394_CAM

PGRCam.sys.

DRIVER_1394_PRO

PGR1394.sys.

DRIVER_1394_JUJU

firewire_core.

DRIVER_1394_VIDEO1394

video1394.

DRIVER_1394_RAW1394

raw1394.

DRIVER_USB_NONE

No usb driver used just BSD stack.

(Linux only)

DRIVER_USB_CAM

PGRUsbCam.sys.

DRIVER_USB3_PRO

PGRXHCI.sys.

DRIVER_GIGE_NONE

no gige drivers used,MS/BSD stack.

DRIVER_GIGE_FILTER

PGRGigE.sys.

DRIVER_GIGE_PRO

PGRGigEPro.sys.

DRIVER_GIGE_LWF

PgrLwf.sys.

DRIVER_UNKNOWN

Unknown driver type.

DRIVER_FORCE_32BITS
enum ErrorType

The error types returned by functions.

Enumerator:
PGRERROR_UNDEFINED

Undefined.

PGRERROR_OK

Function returned with no errors.

PGRERROR_FAILED

General failure.

PGRERROR_NOT_IMPLEMENTED

Function has not been implemented.

PGRERROR_FAILED_BUS_MASTER_CONNECTION

Could not connect to Bus Master.

PGRERROR_NOT_CONNECTED

Camera has not been connected.

PGRERROR_INIT_FAILED

Initialization failed.

PGRERROR_NOT_INTITIALIZED

Camera has not been initialized.

PGRERROR_INVALID_PARAMETER

Invalid parameter passed to function.

PGRERROR_INVALID_SETTINGS

Setting set to camera is invalid.

PGRERROR_INVALID_BUS_MANAGER

Invalid Bus Manager object.

PGRERROR_MEMORY_ALLOCATION_FAILED

Could not allocate memory.

PGRERROR_LOW_LEVEL_FAILURE

Low level error.

PGRERROR_NOT_FOUND

Device not found.

PGRERROR_FAILED_GUID

GUID failure.

PGRERROR_INVALID_PACKET_SIZE

Packet size set to camera is invalid.

PGRERROR_INVALID_MODE

Invalid mode has been passed to function.

PGRERROR_NOT_IN_FORMAT7

Error due to not being in Format7.

PGRERROR_NOT_SUPPORTED

This feature is unsupported.

PGRERROR_TIMEOUT

Timeout error.

PGRERROR_BUS_MASTER_FAILED

Bus Master Failure.

PGRERROR_INVALID_GENERATION

Generation Count Mismatch.

PGRERROR_LUT_FAILED

Look Up Table failure.

PGRERROR_IIDC_FAILED

IIDC failure.

PGRERROR_STROBE_FAILED

Strobe failure.

PGRERROR_TRIGGER_FAILED

Trigger failure.

PGRERROR_PROPERTY_FAILED

Property failure.

PGRERROR_PROPERTY_NOT_PRESENT

Property is not present.

PGRERROR_REGISTER_FAILED

Register access failed.

PGRERROR_READ_REGISTER_FAILED

Register read failed.

PGRERROR_WRITE_REGISTER_FAILED

Register write failed.

PGRERROR_ISOCH_FAILED

Isochronous failure.

PGRERROR_ISOCH_ALREADY_STARTED

Isochronous transfer has already been started.

PGRERROR_ISOCH_NOT_STARTED

Isochronous transfer has not been started.

PGRERROR_ISOCH_START_FAILED

Isochronous start failed.

PGRERROR_ISOCH_RETRIEVE_BUFFER_FAILED

Isochronous retrieve buffer failed.

PGRERROR_ISOCH_STOP_FAILED

Isochronous stop failed.

PGRERROR_ISOCH_SYNC_FAILED

Isochronous image synchronization failed.

PGRERROR_ISOCH_BANDWIDTH_EXCEEDED

Isochronous bandwidth exceeded.

PGRERROR_IMAGE_CONVERSION_FAILED

Image conversion failed.

PGRERROR_IMAGE_LIBRARY_FAILURE

Image library failure.

PGRERROR_BUFFER_TOO_SMALL

Buffer is too small.

PGRERROR_IMAGE_CONSISTENCY_ERROR

There is an image consistency error.

PGRERROR_INCOMPATIBLE_DRIVER

The installed driver is not compatible with the library.

PGRERROR_FORCE_32BITS
enum FrameRate

Frame rates in frames per second.

Enumerator:
FRAMERATE_1_875

1.875 fps.

FRAMERATE_3_75

3.75 fps.

FRAMERATE_7_5

7.5 fps.

FRAMERATE_15

15 fps.

FRAMERATE_30

30 fps.

FRAMERATE_60

60 fps.

FRAMERATE_120

120 fps.

FRAMERATE_240

240 fps.

FRAMERATE_FORMAT7

Custom frame rate for Format7 functionality.

NUM_FRAMERATES

Number of possible camera frame rates.

FRAMERATE_FORCE_32BITS
enum GrabMode

The grab strategy employed during image transfer.

This type controls how images that stream off the camera accumulate in a user buffer for handling.

Enumerator:
DROP_FRAMES

Grabs the newest image in the user buffer each time the RetrieveBuffer() function is called.

Older images are dropped instead of accumulating in the user buffer. Grabbing blocks if the camera has not finished transmitting the next available image. If the camera is transmitting images faster than the application can grab them, images may be dropped and only the most recent image is stored for grabbing. Note that this mode is the equivalent of flycaptureLockLatest in earlier versions of the FlyCapture SDK.

BUFFER_FRAMES

Images accumulate in the user buffer, and the oldest image is grabbed for handling before being discarded.

This member can be used to guarantee that each image is seen. However, image processing time must not exceed transmission time from the camera to the buffer. Grabbing blocks if the camera has not finished transmitting the next available image. The buffer size is controlled by the numBuffers parameter in the FC2Config struct. Note that this mode is the equivalent of flycaptureLockNext in earlier versions of the FlyCapture SDK.

UNSPECIFIED_GRAB_MODE

Unspecified grab mode.

GRAB_MODE_FORCE_32BITS
enum GrabTimeout

Timeout options for grabbing images.

Enumerator:
TIMEOUT_NONE

Non-blocking wait.

TIMEOUT_INFINITE

Wait indefinitely.

TIMEOUT_UNSPECIFIED

Unspecified timeout setting.

GRAB_TIMEOUT_FORCE_32BITS
enum ImageFileFormat

File formats to be used for saving images to disk.

Enumerator:
FROM_FILE_EXT

Determine file format from file extension.

PGM

Portable gray map.

PPM

Portable pixmap.

BMP

Bitmap.

JPEG

JPEG.

JPEG2000

JPEG 2000.

TIFF

Tagged image file format.

PNG

Portable network graphics.

RAW

Raw data.

IMAGE_FILE_FORMAT_FORCE_32BITS
enum InterfaceType

Interfaces that a camera may use to communicate with a host.

Enumerator:
INTERFACE_IEEE1394

IEEE-1394 (Includes 1394a and 1394b).

INTERFACE_USB2

USB 2.0.

INTERFACE_USB3

USB 3.0.

INTERFACE_GIGE

GigE.

INTERFACE_UNKNOWN

Unknown interface.

INTERFACE_TYPE_FORCE_32BITS
enum Mode

Camera modes for DCAM formats as well as Format7.

Enumerator:
MODE_0
MODE_1
MODE_2
MODE_3
MODE_4
MODE_5
MODE_6
MODE_7
MODE_8
MODE_9
MODE_10
MODE_11
MODE_12
MODE_13
MODE_14
MODE_15
MODE_16
MODE_17
MODE_18
MODE_19
MODE_20
MODE_21
MODE_22
MODE_23
MODE_24
MODE_25
MODE_26
MODE_27
MODE_28
MODE_29
MODE_30
MODE_31
NUM_MODES

Number of modes.

MODE_FORCE_32BITS
enum PCIeBusSpeed
Enumerator:
PCIE_BUSSPEED_2_5
PCIE_BUSSPEED_5_0

2.5 Gb/s

PCIE_BUSSPEED_UNKNOWN

5.0 Gb/s

PCIE_BUSSPEED_FORCE_32BITS

Speed is unknown.

enum PixelFormat

Pixel formats available for Format7 modes.

Enumerator:
PIXEL_FORMAT_MONO8

8 bits of mono information.

PIXEL_FORMAT_411YUV8

YUV 4:1:1.

PIXEL_FORMAT_422YUV8

YUV 4:2:2.

PIXEL_FORMAT_444YUV8

YUV 4:4:4.

PIXEL_FORMAT_RGB8

R = G = B = 8 bits.

PIXEL_FORMAT_MONO16

16 bits of mono information.

PIXEL_FORMAT_RGB16

R = G = B = 16 bits.

PIXEL_FORMAT_S_MONO16

16 bits of signed mono information.

PIXEL_FORMAT_S_RGB16

R = G = B = 16 bits signed.

PIXEL_FORMAT_RAW8

8 bit raw data output of sensor.

PIXEL_FORMAT_RAW16

16 bit raw data output of sensor.

PIXEL_FORMAT_MONO12

12 bits of mono information.

PIXEL_FORMAT_RAW12

12 bit raw data output of sensor.

PIXEL_FORMAT_BGR

24 bit BGR.

PIXEL_FORMAT_BGRU

32 bit BGRU.

PIXEL_FORMAT_RGB

24 bit RGB.

PIXEL_FORMAT_RGBU

32 bit RGBU.

PIXEL_FORMAT_BGR16

R = G = B = 16 bits.

PIXEL_FORMAT_BGRU16

64 bit BGRU.

PIXEL_FORMAT_422YUV8_JPEG

JPEG compressed stream.

NUM_PIXEL_FORMATS

Number of pixel formats.

UNSPECIFIED_PIXEL_FORMAT

Unspecified pixel format.

enum PropertyType

Camera properties.

Not all properties may be supported, depending on the camera model.

Enumerator:
BRIGHTNESS

Brightness.

AUTO_EXPOSURE

Auto exposure.

SHARPNESS

Sharpness.

WHITE_BALANCE

White balance.

HUE

Hue.

SATURATION

Saturation.

GAMMA

Gamma.

IRIS

Iris.

FOCUS

Focus.

ZOOM

Zoom.

PAN

Pan.

TILT

Tilt.

SHUTTER

Shutter.

GAIN

Gain.

TRIGGER_MODE

Trigger mode.

TRIGGER_DELAY

Trigger delay.

FRAME_RATE

Frame rate.

TEMPERATURE

Temperature.

UNSPECIFIED_PROPERTY_TYPE

Unspecified property type.

PROPERTY_TYPE_FORCE_32BITS
enum VideoMode

DCAM video modes.

Enumerator:
VIDEOMODE_160x120YUV444

160x120 YUV444.

VIDEOMODE_320x240YUV422

320x240 YUV422.

VIDEOMODE_640x480YUV411

640x480 YUV411.

VIDEOMODE_640x480YUV422

640x480 YUV422.

VIDEOMODE_640x480RGB

640x480 24-bit RGB.

VIDEOMODE_640x480Y8

640x480 8-bit.

VIDEOMODE_640x480Y16

640x480 16-bit.

VIDEOMODE_800x600YUV422

800x600 YUV422.

VIDEOMODE_800x600RGB

800x600 RGB.

VIDEOMODE_800x600Y8

800x600 8-bit.

VIDEOMODE_800x600Y16

800x600 16-bit.

VIDEOMODE_1024x768YUV422

1024x768 YUV422.

VIDEOMODE_1024x768RGB

1024x768 RGB.

VIDEOMODE_1024x768Y8

1024x768 8-bit.

VIDEOMODE_1024x768Y16

1024x768 16-bit.

VIDEOMODE_1280x960YUV422

1280x960 YUV422.

VIDEOMODE_1280x960RGB

1280x960 RGB.

VIDEOMODE_1280x960Y8

1280x960 8-bit.

VIDEOMODE_1280x960Y16

1280x960 16-bit.

VIDEOMODE_1600x1200YUV422

1600x1200 YUV422.

VIDEOMODE_1600x1200RGB

1600x1200 RGB.

VIDEOMODE_1600x1200Y8

1600x1200 8-bit.

VIDEOMODE_1600x1200Y16

1600x1200 16-bit.

VIDEOMODE_FORMAT7

Custom video mode for Format7 functionality.

NUM_VIDEOMODES

Number of possible video modes.

VIDEOMODE_FORCE_32BITS
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigE specific enumerations

Enumerations
GigE specific enumerations

These enumerations are specific to GigE camera operation only. More...

Enumerations

enum GigEPropertyType {
HEARTBEAT,
HEARTBEAT_TIMEOUT,
PACKET_SIZE,
PACKET_DELAY
}
Possible properties that can be queried from the camera. More...

Detailed Description

These enumerations are specific to GigE camera operation only.

Enumeration Type Documentation

enum GigEPropertyType

Possible properties that can be queried from the camera.

Enumerator:
HEARTBEAT
HEARTBEAT_TIMEOUT
PACKET_SIZE
PACKET_DELAY
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Structures

Classes | Modules | Typedefs
Structures
Collaboration diagram for Structures:

Classes

struct | FC2Version
The current version of the library. More...
class | PGRGuid
A GUID to the camera. More...
struct | IPAddress
IPv4 address. More...
struct | Format7ImageSettings
Format 7 image settings. More...
struct | FC2Config
Configuration for a camera. More...
struct | PropertyInfo
Information about a specific camera property. More...
struct | Property
A specific camera property. More...
struct | TriggerModeInfo
Information about a camera trigger property. More...
struct | TriggerMode
A camera trigger. More...
struct | StrobeInfo
A camera strobe property. More...
struct | StrobeControl
A camera strobe. More...
struct | TimeStamp
Timestamp information. More...
struct | ConfigROM
Camera configuration ROM. More...
struct | CameraInfo
Camera information. More...
struct | EmbeddedImageInfoProperty
Properties of a single embedded image info property. More...
struct | EmbeddedImageInfo
Properties of the possible embedded image information. More...
struct | ImageMetadata
Metadata related to an image. More...
struct | LUTData
Information about the camera's look up table. More...
struct | CameraStats
Camera diagnostic information. More...
struct | PNGOption
Options for saving PNG images. More...

Modules

GigE specific structures

These structures are specific to GigE camera operation only.

IIDC specific structures

These structures are specific to IIDC camera operation only.

Image saving structures.

These structures define various parameters used for saving images.

Typedefs

typedef PropertyInfo | TriggerDelayInfo
The TriggerDelayInfo structure is identical to PropertyInfo.
typedef Property | TriggerDelay
The TriggerDelay structure is identical to Property.

Typedef Documentation

typedef Property TriggerDelay

The TriggerDelay structure is identical to Property.

typedef PropertyInfo TriggerDelayInfo

The TriggerDelayInfo structure is identical to PropertyInfo.

Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigE specific structures

Classes
GigE specific structures
Structures

These structures are specific to GigE camera operation only. More...

Collaboration diagram for GigE specific structures:

Classes

struct | IPAddress
IPv4 address. More...
struct | MACAddress
MAC address. More...
struct | GigEProperty
A GigE property. More...
struct | GigEStreamChannel
Information about a single GigE stream channel. More...
struct | GigEConfig
Configuration for a GigE camera. More...
struct | GigEImageSettingsInfo
Format 7 information for a single mode. More...
struct | GigEImageSettings
Image settings for a GigE camera. More...

Detailed Description

These structures are specific to GigE camera operation only.

Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: IIDC specific structures

Classes
IIDC specific structures
Structures

These structures are specific to IIDC camera operation only. More...

Collaboration diagram for IIDC specific structures:

Classes

struct | Format7ImageSettings
Format 7 image settings. More...
struct | Format7Info
Format 7 information for a single mode. More...
struct | Format7PacketInfo
Format 7 packet information. More...

Detailed Description

These structures are specific to IIDC camera operation only.

Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Image saving structures.

Classes | Typedefs
Image saving structures.
Structures

These structures define various parameters used for saving images. More...

Collaboration diagram for Image saving structures.:

Classes

struct | PNGOption
Options for saving PNG images. More...
struct | PPMOption
Options for saving PPM images. More...
struct | PGMOption
Options for saving PGM images. More...
struct | TIFFOption
Options for saving TIFF images. More...
struct | JPEGOption
Options for saving JPEG image. More...
struct | JPG2Option
Options for saving JPEG2000 image. More...
struct | BMPOption
Options for saving Bitmap image. More...
struct | MJPGOption
Options for saving MJPG files. More...
struct | H264Option
Options for saving H264 files. More...
struct | AVIOption
Options for saving AVI files. More...
struct | EventOptions
Options for enabling device event registration. More...
struct | EventCallbackData

Typedefs

typedef void(* | CameraEventCallback )(void *data)

Detailed Description

These structures define various parameters used for saving images.

Typedef Documentation

typedef void(* CameraEventCallback)(void *data)
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
AVIOption | Options for saving AVI files
AVIRecorder | Functionality for the user to record images to an AVI file
BMPOption | Options for saving Bitmap image
BusManager | Functionality for the user to get an PGRGuid for a desired camera or device easily
Camera | The Camera object represents a physical camera that uses the IIDC register set
CameraBase | Abstract base class that defines a general interface to a camera
CameraControlDlg | The CameraControlDlg object represents a dialog that provides a graphical interface to a specified camera
CameraInfo | Camera information
CameraSelectionDlg | The CameraSelectionDlg object represents a dialog that provides a graphical interface that lists the number of cameras available to the library
CameraStats | Camera diagnostic information
ConfigROM | Camera configuration ROM
EmbeddedImageInfo | Properties of the possible embedded image information
EmbeddedImageInfoProperty | Properties of a single embedded image info property
Error | The Error object represents an error that is returned from the library
EventCallbackData |
EventOptions | Options for enabling device event registration
FC2Config | Configuration for a camera
FC2Version | The current version of the library
FlyCapture3ApiGuiWrapper |
Format7ImageSettings | Format 7 image settings
Format7Info | Format 7 information for a single mode
Format7PacketInfo | Format 7 packet information
GCCamera |
GigECamera | The GigECamera object represents a physical Gigabit Ethernet camera
GigEConfig | Configuration for a GigE camera
GigEImageSettings | Image settings for a GigE camera
GigEImageSettingsInfo | Format 7 information for a single mode
GigEProperty | A GigE property
GigEStreamChannel | Information about a single GigE stream channel
H264Option | Options for saving H264 files
Image | Used to retrieve images from a camera, convert between multiple pixel formats and save images to disk
ImageMetadata | Metadata related to an image
ImageStatistics | The ImageStatistics object represents image statistics for an image
Internal |
IPAddress | IPv4 address
JPEGOption | Options for saving JPEG image
JPG2Option | Options for saving JPEG2000 image
LUTData | Information about the camera's look up table
MACAddress | MAC address
MJPGOption | Options for saving MJPG files
NodeMap |
PGMOption | Options for saving PGM images
PGRGuid | A GUID to the camera
PNGOption | Options for saving PNG images
PPMOption | Options for saving PPM images
Property | A specific camera property
PropertyInfo | Information about a specific camera property
StrobeControl | A camera strobe
StrobeInfo | A camera strobe property
SyncManager |
SystemInfo | Description of the system
TIFFOption | Options for saving TIFF images
TimeStamp | Timestamp information
TopologyNode | Topology information that can be used to generate a tree structure of all cameras and devices connected to a computer
TriggerMode | A camera trigger
TriggerModeInfo | Information about a camera trigger property
Utilities | The Utility class is generally used to query for general system information such as operating system, available memory etc
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: AVIOption Struct Reference

  • Class Hierarchy
  • Class Members
  • FlyCapture2
  • AVIOption
Public Member Functions | Public Attributes
AVIOption Struct Reference
Image saving structures.

Options for saving AVI files. More...

List of all members.

Public Member Functions

AVIOption ()

Public Attributes

float | frameRate
Frame rate of the stream.
unsigned int | reserved [256]
Reserved for future use.

Detailed Description

Options for saving AVI files.

Constructor & Destructor Documentation

AVIOption ( ) [inline]

Member Data Documentation

float frameRate

Frame rate of the stream.

unsigned int reserved[256]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: AVIRecorder Class Reference

  • FlyCapture2
  • AVIRecorder
Public Member Functions
AVIRecorder Class Reference

The AVIRecorder class provides the functionality for the user to record images to an AVI file. More...

List of all members.

Public Member Functions

AVIRecorder ()
Default constructor.
virtual | ~AVIRecorder ()
Default destructor.
virtual Error | AVIOpen (const char *pFileName, AVIOption *pOption)
Open an AVI file in preparation for writing Images to disk.
virtual Error | AVIOpen (const char *pFileName, MJPGOption *pOption)
Open an MJPEG AVI file in preparation for writing Images to disk.
virtual Error | AVIOpen (const char *pFileName, H264Option *pOption)
Open an H.264 video file in preparation for writing Images to disk.
virtual Error | AVIAppend (Image *pImage)
Append an image to the AVI/MP4 file.
virtual Error | AVIClose ()
Close the AVI/MP4 file.
virtual void | SetMaximumAVISize (unsigned int size)
Set the maximum file size (in megabytes) of a AVI/MP4 file.

Detailed Description

The AVIRecorder class provides the functionality for the user to record images to an AVI file.

Constructor & Destructor Documentation

AVIRecorder ( )

Default constructor.

virtual ~AVIRecorder ( ) [virtual]

Default destructor.

Member Function Documentation

virtual Error AVIAppend ( Image * pImage ) [virtual]

Append an image to the AVI/MP4 file.

Parameters:
pImage The image to append.
Returns:
An Error indicating the success or failure of the function.
virtual Error AVIClose ( ) [virtual]

Close the AVI/MP4 file.

See also:
AVIOpen()
Returns:
An Error indicating the success or failure of the function.
virtual Error AVIOpen | ( | const char * | pFileName,
 |  | AVIOption * | pOption
 | ) |  | [virtual]

Open an AVI file in preparation for writing Images to disk.

The size of AVI files is limited to 2GB. The filenames are automatically generated using the filename specified.

Parameters:
pFileName | The filename of the AVI file.
pOption | Options to apply to the AVI file.
See also:
SetMaximumAVISize()
AVIClose()
Returns:
An Error indicating the success or failure of the function.
virtual Error AVIOpen | ( | const char * | pFileName,
 |  | MJPGOption * | pOption
 | ) |  | [virtual]

Open an MJPEG AVI file in preparation for writing Images to disk.

The size of AVI files is limited to 2GB. The filenames are automatically generated using the filename specified.

Parameters:
pFileName | The filename of the AVI file.
pOption | MJPEG options to apply to the AVI file.
See also:
SetMaximumAVISize()
AVIClose()
MJPGOption
Returns:
An Error indicating the success or failure of the function.
virtual Error AVIOpen | ( | const char * | pFileName,
 |  | H264Option * | pOption
 | ) |  | [virtual]

Open an H.264 video file in preparation for writing Images to disk.

If the file extension is not specified, MP4 will be used as the default container. Consult ffmpeg documentation for a list of supported containers.

Parameters:
pFileName | The filename of the video file.
pOption | H.264 options to apply to the video file.
See also:
AVIClose()
H264Option
Returns:
An Error indicating the success or failure of the function.
virtual void SetMaximumAVISize ( unsigned int size ) [virtual]

Set the maximum file size (in megabytes) of a AVI/MP4 file.

A new AVI/MP4 file is created automatically when file size limit is reached. Setting a maximum size of 0 indicates no limit on file size.

Parameters:
size The maximum AVI file size in MB.
See also:
AVIAppend()
The documentation for this class was generated from the following file:
  • AVIRecorder.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: BMPOption Struct Reference

  • FlyCapture2
  • BMPOption
Public Member Functions | Public Attributes
BMPOption Struct Reference
Image saving structures.

Options for saving Bitmap image. More...

List of all members.

Public Member Functions

BMPOption ()

Public Attributes

bool | indexedColor_8bit
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Options for saving Bitmap image.

Constructor & Destructor Documentation

BMPOption ( ) [inline]

Member Data Documentation

bool indexedColor_8bit
unsigned int reserved[16]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: BusManager Class Reference

  • FlyCapture2
  • BusManager
Public Member Functions | Static Public Member Functions
BusManager Class Reference

The BusManager class provides the functionality for the user to get an PGRGuid for a desired camera or device easily. More...

List of all members.

Public Member Functions

BusManager ()
Default constructor.
virtual | ~BusManager ()
Default destructor.
virtual Error | FireBusReset (PGRGuid *pGuid)
Fire a bus reset.
virtual Error | GetNumOfCameras (unsigned int *pNumCameras)
Gets the number of cameras attached to the PC.
virtual Error | GetCameraFromIPAddress (IPAddress ipAddress, PGRGuid *pGuid)
Gets the PGRGuid for a camera with the specified IPv4 address.
virtual Error | GetCameraFromIndex (unsigned int index, PGRGuid *pGuid)
Gets the PGRGuid for a camera on the PC.
virtual Error | GetCameraFromSerialNumber (unsigned int serialNumber, PGRGuid *pGuid)
Gets the PGRGuid for a camera on the PC.
virtual Error | GetCameraSerialNumberFromIndex (unsigned int index, unsigned int *pSerialNumber)
Gets the serial number of the camera with the specified index.
virtual Error | GetInterfaceTypeFromGuid (PGRGuid *pGuid, InterfaceType *pInterfaceType)
Gets the interface type associated with a PGRGuid.
virtual Error | GetNumOfDevices (unsigned int *pNumDevices)
Gets the number of devices.
virtual Error | GetDeviceFromIndex (unsigned int index, PGRGuid *pGuid)
Gets the PGRGuid for a device.
virtual Error | ReadPhyRegister (PGRGuid guid, unsigned int page, unsigned int port, unsigned int address, unsigned int *pValue)
Read a phy register on the specified device.
virtual Error | WritePhyRegister (PGRGuid guid, unsigned int page, unsigned int port, unsigned int address, unsigned int value)
Write a phy register on the specified device.
virtual Error | GetUsbLinkInfo (PGRGuid guid, unsigned int *pValue)
Read usb link info for the port that the specified device is connected to.
virtual Error | GetUsbPortStatus (PGRGuid guid, unsigned int *pValue)
Read usb port status for the port that the specified device is connected to.
virtual Error | GetTopology (TopologyNode *pNode)
Gets the topology information for the PC.
virtual Error | RegisterCallback (BusEventCallback busEventCallback, BusCallbackType callbackType, void *pParameter, CallbackHandle *pCallbackHandle)
Register a callback function that will be called when the specified callback event occurs.
virtual Error | UnregisterCallback (CallbackHandle callbackHandle)
Unregister a callback function.
virtual Error | RescanBus ()
Force a rescan of the buses.
Error | IsCameraControlable (PGRGuid *pGuid, bool *pControlable)
Query CCP status on camera with corresponding PGRGuid.

Static Public Member Functions

static Error | ForceIPAddressToCamera (MACAddress macAddress, IPAddress ipAddress, IPAddress subnetMask, IPAddress defaultGateway)
Force the camera with the specific MAC address to the specified IP address, subnet mask and default gateway.
static Error | ForceAllIPAddressesAutomatically ()
Force all cameras on the network to be assigned sequential IP addresses on the same subnet as the netowrk adapters that they are connected to.
static Error | ForceAllIPAddressesAutomatically (unsigned int serialNumber)
Force a camera on the network to be assigned an IP address on the same subnet as the netowrk adapters that it is connected to.
static Error | DiscoverGigECameras (CameraInfo *gigECameras, unsigned int *arraySize)
Discover all cameras connected to the network even if they reside on a different subnet.

Detailed Description

The BusManager class provides the functionality for the user to get an PGRGuid for a desired camera or device easily.

Once the camera or device token is found, it can then be used to connect to the camera or device through the camera class or device class. In addition, the BusManager class provides the ability to be notified when a camera or device is added or removed or some event occurs on the PC.

Constructor & Destructor Documentation

BusManager ( )

Default constructor.

virtual ~BusManager ( ) [virtual]

Default destructor.

Member Function Documentation

static Error DiscoverGigECameras | ( | CameraInfo * | gigECameras,
 |  | unsigned int * | arraySize
 | ) |  | [static]

Discover all cameras connected to the network even if they reside on a different subnet.

This is useful in situations where GigE Vision cameras are using IP addresses in a subnet different from the host's subnet. After discovering the camera, it is easy to use ForceIPAddressToCamera() to set a different IP configuration.

Parameters:
gigECameras | Pointer to an array of CameraInfo structures.
arraySize | Size of the array. Number of discovered cameras is returned in the same value.
Returns:
An Error indicating the success or failure of the function. If the error is PGRERROR_BUFFER_TOO_SMALL then arraySize will contain the minimum size needed for gigECameras array.
virtual Error FireBusReset ( PGRGuid * pGuid ) [virtual]

Fire a bus reset.

The actual bus reset is only fired for the specified 1394 bus, but it will effectively cause a global bus reset for the library.

Parameters:
pGuid PGRGuid of the camera or the device to cause bus reset.
Returns:
An Error indicating the success or failure of the function.
static Error ForceAllIPAddressesAutomatically ( ) [static]

Force all cameras on the network to be assigned sequential IP addresses on the same subnet as the netowrk adapters that they are connected to.

This is useful in situations where GigE Vision cameras are using IP addresses in a subnet different from the host's subnet.

Returns:
An Error indicating the success or failure of the function.
static Error ForceAllIPAddressesAutomatically ( unsigned int serialNumber ) [static]

Force a camera on the network to be assigned an IP address on the same subnet as the netowrk adapters that it is connected to.

This is useful in situations where GigE Vision cameras are using IP addresses in a subnet different from the host's subnet.

Returns:
An Error indicating the success or failure of the function.
static Error ForceIPAddressToCamera | ( | MACAddress | macAddress,
 |  | IPAddress | ipAddress,
 |  | IPAddress | subnetMask,
 |  | IPAddress | defaultGateway
 | ) |  | [static]

Force the camera with the specific MAC address to the specified IP address, subnet mask and default gateway.

This is useful in situations where GigE Vision cameras are using IP addresses in a subnet different from the host's subnet.

Parameters:
macAddress | MAC address of the camera.
ipAddress | IP address to set on the camera.
subnetMask | Subnet mask to set on the camera.
defaultGateway | Default gateway to set on the camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetCameraFromIndex | ( | unsigned int | index,
 |  | PGRGuid * | pGuid
 | ) |  | [virtual]

Gets the PGRGuid for a camera on the PC.

It uniquely identifies the camera specified by the index and is used to identify the camera during a Camera::Connect() call.

Parameters:
index | Zero based index of camera.
pGuid | Unique PGRGuid for the camera.
See also:
GetCameraFromSerialNumber()
Returns:
An Error indicating the success or failure of the function.
virtual Error GetCameraFromIPAddress | ( | IPAddress | ipAddress,
 |  | PGRGuid * | pGuid
 | ) |  | [virtual]

Gets the PGRGuid for a camera with the specified IPv4 address.

Parameters:
ipAddress | IP address to get GUID for.
pGuid | Unique PGRGuid for the camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetCameraFromSerialNumber | ( | unsigned int | serialNumber,
 |  | PGRGuid * | pGuid
 | ) |  | [virtual]

Gets the PGRGuid for a camera on the PC.

It uniquely identifies the camera specified by the serial number and is used to identify the camera during a Camera::Connect() call.

Parameters:
serialNumber | Serial number of camera.
pGuid | Unique PGRGuid for the camera.
See also:
GetCameraFromIndex()
Returns:
An Error indicating the success or failure of the function.
virtual Error GetCameraSerialNumberFromIndex | ( | unsigned int | index,
 |  | unsigned int * | pSerialNumber
 | ) |  | [virtual]

Gets the serial number of the camera with the specified index.

Parameters:
index | Zero based index of desired camera.
pSerialNumber | Serial number of camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetDeviceFromIndex | ( | unsigned int | index,
 |  | PGRGuid * | pGuid
 | ) |  | [virtual]

Gets the PGRGuid for a device.

It uniquely identifies the device specified by the index.

Parameters:
index | Zero based index of device.
pGuid | Unique PGRGuid for the device.
See also:
GetNumOfDevices()
Returns:
An Error indicating the success or failure of the function.
virtual Error GetInterfaceTypeFromGuid | ( | PGRGuid * | pGuid,
 |  | InterfaceType * | pInterfaceType
 | ) |  | [virtual]

Gets the interface type associated with a PGRGuid.

This is useful in situations where there is a need to enumerate all cameras for a particular interface.

Parameters:
pGuid | The PGRGuid to get the interface for.
pInterfaceType | The interface type of the PGRGuid.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetNumOfCameras ( unsigned int * pNumCameras ) [virtual]

Gets the number of cameras attached to the PC.

Parameters:
pNumCameras The number of cameras attached.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetNumOfDevices ( unsigned int * pNumDevices ) [virtual]

Gets the number of devices.

This may include hubs, host controllers and other hardware devices (including cameras).

Parameters:
pNumDevices The number of devices found.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetTopology ( TopologyNode * pNode ) [virtual]

Gets the topology information for the PC.

Parameters:
pNode TopologyNode object that will contain the topology information.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetUsbLinkInfo | ( | PGRGuid | guid,
 |  | unsigned int * | pValue
 | ) |  | [virtual]

Read usb link info for the port that the specified device is connected to.

Parameters:
guid PGRGuid of the device to read from.
pValue Value read from the card register.
 Bit 15:0  = Link Error Count. Default = 0. This field returns the number of link errors detected by the port.
 Bit 19:16 = Rx Lane Count. Default = 0. This field that identifies the number of Receive Lanes negotiated by the port.
 Bit 23:20 = Tx Lane Count. Default = 0. This field that identifies the number of Transmit Lanes negotiated by the port.
 Bit 31:24 = Reserved.

Refer to XHCI 1.1 section 5.4.10 for Port Link Info https://www.intel.com/content/dam/www/public/us/en/documents/technical-specifications/extensible-host-controler-interface-usb-xhci.pdf

Returns:
An Error indicating the success or failure of the function.

virtual Error GetUsbPortStatus | ( | PGRGuid | guid,
 |  | unsigned int * | pValue
 | ) |  | [virtual]

Read usb port status for the port that the specified device is connected to.

Parameters:
guid PGRGuid of the device to read from.
pValue Value read from the card register.
 Bit 0 = Current Connect Status. Default = 0.
         1 = A device is connected to the port
         0 = A device is not connected.
         This value reflects the current state of the port, and may not correspond directly to the event that caused the Connect Status Change (CSC) bit to be set to 1.
 Bit 1 = Port Enabled/Disabled. Default = 0. 1 = Enabled. 0 = Disabled.
 Bit 2 = Reserved.
 Bit 3 = Over-current Active. Default = 0.
         1 = This port currently has an over-current condition.
         0 = This port does not have an over-current condition.
 Bit 4 = Port Reset. Default = 0.
         1 = Port Reset signaling is asserted.
         0 = Port is not in Reset.
 Bit 8:5 = Port Link State. Default = RxDetect(5). This field is used to power manage the port and reflects its current link state.
 Bit 9 = Port Power. Default = 1. This flag reflects a port's logical, power control state.
         0 = This port is in the powered-off state.
         1 = This port is not in the powered-off state.
 Bit 13:10 = Port Speed. Default = 0. This field identifies the speed of the connected USB Device. This field is only relevant if a device is connected, in all other cases this field shall indicate Undefined Speed.
             0 : Undefined speed
             1-15 : Protocol Speed ID (refer to other sections)
 Bit 15:14 = Port Indicator Control. Default = 0. 0 = Port indicators are off.
             1 = Amber. 2 = Green. 3 = Undefined.
 Bit 16 = Port Link State Write Strobe. Default = 0.
          When this bit is set to 1 on a write reference to this register, this flag enables writes to the PLS field.
 Bit 17 = Connect Status Change. Default = 0.
          1 = Change in current connect status. 0 = No change.
 Bit 18 = Port Enabled/Disabled Change. Default = 0.
          1 = change in PED. 0 = No change.
 Bit 19 = Warm Port Reset Change. Default = 0. This bit is set when Warm Reset processing on this port completes.
          0 = No change. 1 = Warm Reset complete.
 Bit 20 = Over current change. Default = 0.
          This bit shall be set to a 1 when there is a 0 to 1 or 1 to 0 transition of Over-current Active.
 Bit 21 = Port Reset Change. Default = 0. This flag is set to 1 due to a 1 to 0 transition of Port Reset.
 Bit 22 = Port Link State Change. Default = 0. This flag is set to 1 due to PLS transitions (refer to document)
 Bit 23 = Port Config Error Change. Default = 0. This flag indicates that the port failed to configure its link partner.
          0 = No change. 1 = Port Config Error detected.
 Bit 24 = Cold Attach Status. Default = 0.
          1 = Far-end receiver terminations were detected in the disconnected state and the root hub port state machine was unable to advance to the enabled state.
          0 - This flag is 0 if PP is 0 or for USB2 protocol parts.
 Bit 25 = Wake on Connect Enable. Default = 0. Writing this bit to a 1 enables to port to be sensitive to device connects as system wake up events.
 Bit 26 = Wake on Disconnect Enable. Default = 0. Writing this bit to a 1 enables the port to be sensitive to device disconnects as system wake up events.
 Bit 27 = Wake on Over-current Enable. Default = 0. Writing this bit to a 1 enables the port to be sensitive to over-current conditions as system wake up events.
 Bit 29:28 = Reserved
 Bit 30 = Device Removable. This flag indicates if this port has a removable device attached.
          1 = Device is non-removable. 0 = Device is removable.
 Bit 31 = Warm Port Reset. Default = 0. This flag shall always return 0 when read. Refer to document for writing.

Refer to XHCI 1.1 section 5.4.8 for Port Status https://www.intel.com/content/dam/www/public/us/en/documents/technical-specifications/extensible-host-controler-interface-usb-xhci.pdf

Returns:
An Error indicating the success or failure of the function.

Error IsCameraControlable | ( | PGRGuid * | pGuid,
 |  | bool * | pControlable
 | ) |  |

Query CCP status on camera with corresponding PGRGuid.

This is useful to determine if a GigE camera can be controlled.

Parameters:
pGuid | PGRGuid of the camera
pControlable | Indicates whether camera is controllable
Returns:
An Error indicating the success or failure of the function.
virtual Error ReadPhyRegister | ( | PGRGuid | guid,
 |  | unsigned int | page,
 |  | unsigned int | port,
 |  | unsigned int | address,
 |  | unsigned int * | pValue
 | ) |  | [virtual]

Read a phy register on the specified device.

The full address to be read from is determined by the page, port and address.

Parameters:
guid | PGRGuid of the device to read from.
page | Page to read from.
port | Port to read from.
address | Address to read from.
pValue | Value read from the phy register.
Returns:
An Error indicating the success or failure of the function.
virtual Error RegisterCallback | ( | BusEventCallback | busEventCallback,
 |  | BusCallbackType | callbackType,
 |  | void * | pParameter,
 |  | CallbackHandle * | pCallbackHandle
 | ) |  | [virtual]

Register a callback function that will be called when the specified callback event occurs.

Parameters:
busEventCallback | Pointer to function that will receive the callback.
callbackType | Type of callback to register for.
pParameter | Callback parameter to be passed to callback.
pCallbackHandle | Unique callback handle used for unregistering callback.
See also:
UnregisterCallback()
Returns:
An Error indicating the success or failure of the function.
virtual Error RescanBus ( ) [virtual]

Force a rescan of the buses.

This does not trigger a bus reset. The camera objects will be invalidated only if the camera network topology is changed (ie. a camera is disconnected or added)

Returns:
An Error indicating the success or failure of the function.
virtual Error UnregisterCallback ( CallbackHandle callbackHandle ) [virtual]

Unregister a callback function.

Parameters:
callbackHandle Unique callback handle.
See also:
RegisterCallback()
Returns:
An Error indicating the success or failure of the function.
virtual Error WritePhyRegister | ( | PGRGuid | guid,
 |  | unsigned int | page,
 |  | unsigned int | port,
 |  | unsigned int | address,
 |  | unsigned int | value
 | ) |  | [virtual]

Write a phy register on the specified device.

The full address to be written to is determined by the page, port and address.

Parameters:
guid | PGRGuid of the device to write to.
page | Page to write to.
port | Port to write to.
address | Address to write to.
value | Value to write to phy register.
Returns:
An Error indicating the success or failure of the function.
The documentation for this class was generated from the following file:
  • BusManager.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Camera Class Reference

  • FlyCapture2
  • Camera
Public Member Functions | Static Public Member Functions
Camera Class Reference

The Camera object represents a physical camera that uses the IIDC register set. More...

Inheritance diagram for Camera:
[legend]
Collaboration diagram for Camera:
[legend]

List of all members.

Public Member Functions

Camera ()
Default constructor.
virtual | ~Camera ()
Default destructor.
virtual Error | Connect (PGRGuid *pGuid=NULL)
The following functions are inherited from CameraBase.
virtual Error | Disconnect ()
Disconnects the camera object from the camera.
virtual bool | IsConnected ()
Checks if the camera object is connected to a physical camera specified by a GUID.
virtual Error | SetCallback (ImageEventCallback callbackFn, const void *pCallbackData=NULL)
Sets the callback data to be used on completion of image transfer.
virtual Error | StartCapture (ImageEventCallback callbackFn=NULL, const void *pCallbackData=NULL)
Starts isochronous image capture.
virtual Error | RetrieveBuffer (Image *pImage)
Retrieves the the next image object containing the next image.
virtual Error | StopCapture ()
Stops isochronous image transfer and cleans up all associated resources.
virtual Error | WaitForBufferEvent (Image *pImage, unsigned int eventNumber)
Retrieves the next image event containing the next part of the image.
virtual Error | SetUserBuffers (unsigned char *const pMemBuffers, int size, int numBuffers)
Specify user allocated buffers to use as image data buffers.
virtual Error | GetConfiguration (FC2Config *pConfig)
Get the configuration associated with the camera object.
virtual Error | SetConfiguration (const FC2Config *pConfig)
Set the configuration associated with the camera object.
virtual Error | GetCameraInfo (CameraInfo *pCameraInfo)
Retrieves information from the camera such as serial number, model name and other camera information.
virtual Error | GetPropertyInfo (PropertyInfo *pPropInfo)
Retrieves information about the specified camera property.
virtual Error | GetProperty (Property *pProp)
Reads the settings for the specified property from the camera.
virtual Error | SetProperty (const Property *pProp, bool broadcast=false)
Writes the settings for the specified property to the camera.
virtual Error | GetGPIOPinDirection (unsigned int pin, unsigned int *pDirection)
Get the GPIO pin direction for the specified pin.
virtual Error | SetGPIOPinDirection (unsigned int pin, unsigned int direction, bool broadcast=false)
Set the GPIO pin direction for the specified pin.
virtual Error | GetTriggerModeInfo (TriggerModeInfo *pTriggerModeInfo)
Retrieve trigger information from the camera.
virtual Error | GetTriggerMode (TriggerMode *pTriggerMode)
Retrieve current trigger settings from the camera.
virtual Error | SetTriggerMode (const TriggerMode *pTriggerMode, bool broadcast=false)
Set the specified trigger settings to the camera.
virtual Error | FireSoftwareTrigger (bool broadcast=false)
Fire the software trigger according to the DCAM specifications.
virtual Error | GetTriggerDelayInfo (TriggerDelayInfo *pTriggerDelayInfo)
Retrieve trigger delay information from the camera.
virtual Error | GetTriggerDelay (TriggerDelay *pTriggerDelay)
Retrieve current trigger delay settings from the camera.
virtual Error | SetTriggerDelay (const TriggerDelay *pTriggerDelay, bool broadcast=false)
Set the specified trigger delay settings to the camera.
virtual Error | GetStrobeInfo (StrobeInfo *pStrobeInfo)
Retrieve strobe information from the camera.
virtual Error | GetStrobe (StrobeControl *pStrobeControl)
Retrieve current strobe settings from the camera.
virtual Error | SetStrobe (const StrobeControl *pStrobeControl, bool broadcast=false)
Set current strobe settings to the camera.
virtual Error | GetLUTInfo (LUTData *pData)
Query if LUT support is available on the camera.
virtual Error | GetLUTBankInfo (unsigned int bank, bool *pReadSupported, bool *pWriteSupported)
Query the read/write status of a single LUT bank.
virtual Error | GetActiveLUTBank (unsigned int *pActiveBank)
Get the LUT bank that is currently being used.
virtual Error | SetActiveLUTBank (unsigned int activeBank)
Set the LUT bank that will be used.
virtual Error | EnableLUT (bool on)
Enable or disable LUT functionality on the camera.
virtual Error | GetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, unsigned int *pEntries)
Get the LUT channel settings from the camera.
virtual Error | SetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, const unsigned int *pEntries)
Set the LUT channel settings to the camera.
virtual Error | GetMemoryChannel (unsigned int *pCurrentChannel)
Retrieve the current memory channel from the camera.
virtual Error | SaveToMemoryChannel (unsigned int channel)
Save the current settings to the specfied current memory channel.
virtual Error | RestoreFromMemoryChannel (unsigned int channel)
Restore the specfied current memory channel.
virtual Error | GetMemoryChannelInfo (unsigned int *pNumChannels)
Query the camera for memory channel support.
virtual Error | GetEmbeddedImageInfo (EmbeddedImageInfo *pInfo)
Get the current status of the embedded image information register, as well as the availability of each embedded property.
virtual Error | SetEmbeddedImageInfo (EmbeddedImageInfo *pInfo)
Sets the on/off values of the embedded image information structure to the camera.
virtual Error | WriteRegister (unsigned int address, unsigned int value, bool broadcast=false)
Write to the specified register on the camera.
virtual Error | ReadRegister (unsigned int address, unsigned int *pValue)
Read the specified register from the camera.
virtual Error | WriteRegisterBlock (unsigned short addressHigh, unsigned int addressLow, const unsigned int *pBuffer, unsigned int length)
Write to the specified register block on the camera.
virtual Error | ReadRegisterBlock (unsigned short addressHigh, unsigned int addressLow, unsigned int *pBuffer, unsigned int length)
Read from the specified register block on the camera.
virtual Error | GetCycleTime (TimeStamp *timeStamp)
Returns a Timestamp struct containing 1394 CYCLE_TIME information.
virtual Error | GetStats (CameraStats *pStats)
virtual Error | ResetStats ()
virtual Error | RegisterEvent (EventOptions *pOpts)
virtual Error | DeregisterEvent (EventOptions *pOpts)
virtual Error | RegisterAllEvents (EventOptions *pOpts)
virtual Error | DeregisterAllEvents (void)

Static Public Member Functions

static Error | StartSyncCapture (unsigned int numCameras, const Camera **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL)
static const char * | GetRegisterString (unsigned int registerVal)
Returns a text representation of the register value.

DCAM Formats

These functions deal with DCAM video mode and frame rate on the camera.

They are only used for firewire and usb2 cameras.

virtual Error | GetVideoModeAndFrameRateInfo (VideoMode videoMode, FrameRate frameRate, bool *pSupported)
Query the camera to determine if the specified video mode and frame rate is supported.
virtual Error | GetVideoModeAndFrameRate (VideoMode *pVideoMode, FrameRate *pFrameRate)
Get the current video mode and frame rate from the camera.
virtual Error | SetVideoModeAndFrameRate (VideoMode videoMode, FrameRate frameRate)
Set the specified video mode and frame rate to the camera.

Format7

These functions deal with Format7 custom image control on the camera.

virtual Error | GetFormat7Info (Format7Info *pInfo, bool *pSupported)
Retrieve the availability of Format7 custom image mode and the camera capabilities for the specified Format7 mode.
virtual Error | ValidateFormat7Settings (const Format7ImageSettings *pImageSettings, bool *pSettingsAreValid, Format7PacketInfo *pPacketInfo)
Validates Format7ImageSettings structure and returns valid packet size information if the image settings are valid.
virtual Error | GetFormat7Configuration (Format7ImageSettings *pImageSettings, unsigned int *pPacketSize, float *pPercentage)
Get the current Format7 configuration from the camera.
virtual Error | SetFormat7Configuration (const Format7ImageSettings *pImageSettings, unsigned int packetSize)
Set the current Format7 configuration to the camera.
virtual Error | SetFormat7Configuration (const Format7ImageSettings *pImageSettings, float percentSpeed)
Set the current Format7 configuration to the camera.

Detailed Description

The Camera object represents a physical camera that uses the IIDC register set.

The object must first be connected to using Connect() before any other operations can proceed.

It is possible for more than 1 Camera object to connect to a single physical camera. However, isochronous transmission to more than 1 Camera object is not supported.

Constructor & Destructor Documentation

Camera ( )

Default constructor.

virtual ~Camera ( ) [virtual]

Default destructor.

Member Function Documentation

virtual Error Connect ( PGRGuid * pGuid = NULL ) [virtual]

The following functions are inherited from CameraBase.

See CameraBase.h for further information.

Implements CameraBase.

virtual Error DeregisterAllEvents ( void ) [virtual]

Implements CameraBase.

virtual Error DeregisterEvent ( EventOptions * pOpts ) [virtual]

Implements CameraBase.

virtual Error Disconnect ( ) [virtual]

Disconnects the camera object from the camera.

This allows another physical camera specified by a GUID to be connected to the camera object.

See also:
Connect()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error EnableLUT ( bool on ) [virtual]

Enable or disable LUT functionality on the camera.

Parameters:
on Whether to enable or disable LUT.
See also:
GetLUTInfo()
GetLUTChannel()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error FireSoftwareTrigger ( bool broadcast = false ) [virtual]

Fire the software trigger according to the DCAM specifications.

Parameters:
broadcast Whether the action should be broadcast.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetActiveLUTBank ( unsigned int * pActiveBank ) [virtual]

Get the LUT bank that is currently being used.

For cameras with PGR LUT, the active bank is always 0.

Parameters:
pActiveBank The currently active bank.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetCameraInfo ( CameraInfo * pCameraInfo ) [virtual]

Retrieves information from the camera such as serial number, model name and other camera information.

Parameters:
pCameraInfo Pointer to the camera information structure to be filled.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetConfiguration ( FC2Config * pConfig ) [virtual]

Get the configuration associated with the camera object.

Parameters:
pConfig Pointer to the configuration structure to be filled.
See also:
SetConfiguration()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetCycleTime ( TimeStamp * timeStamp ) [virtual]

Returns a Timestamp struct containing 1394 CYCLE_TIME information.

Parameters:
registerVal The register value to query.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetEmbeddedImageInfo ( EmbeddedImageInfo * pInfo ) [virtual]

Get the current status of the embedded image information register, as well as the availability of each embedded property.

Parameters:
pInfo Structure to be filled.
See also:
SetEmbeddedImageInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetFormat7Configuration | ( | Format7ImageSettings * | pImageSettings,
 |  | unsigned int * | pPacketSize,
 |  | float * | pPercentage
 | ) |  | [virtual]

Get the current Format7 configuration from the camera.

This call will only succeed if the camera is already in Format7.

Parameters:
pImageSettings | Current image settings.
pPacketSize | Current packet size.
pPercentage | Current packet size as a percentage.
See also:
GetFormat7Info()
ValidateFormat7Settings()
SetFormat7Configuration()
GetVideoModeAndFrameRate()
Returns:
An Error indicating the success or failure of the function.
virtual Error GetFormat7Info | ( | Format7Info * | pInfo,
 |  | bool * | pSupported
 | ) |  | [virtual]

Retrieve the availability of Format7 custom image mode and the camera capabilities for the specified Format7 mode.

The mode must be specified in the Format7Info structure in order for the function to succeed.

Parameters:
pInfo | Structure to be filled with the capabilities of the specified mode and the current state in the specified mode.
pSupported | Whether the specified mode is supported.
See also:
ValidateFormat7Settings()
GetFormat7Configuration()
SetFormat7Configuration()
Returns:
An Error indicating the success or failure of the function.
virtual Error GetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int * | pDirection
 | ) |  | [virtual]

Get the GPIO pin direction for the specified pin.

This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
pDirection | Direction of the pin. 0 for input, 1 for output.
See also:
SetGPIOPinDirection()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetLUTBankInfo | ( | unsigned int | bank,
 |  | bool * | pReadSupported,
 |  | bool * | pWriteSupported
 | ) |  | [virtual]

Query the read/write status of a single LUT bank.

Parameters:
bank | The bank to query.
pReadSupported | Whether reading from the bank is supported.
pWriteSupported | Whether writing to the bank is supported.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | unsigned int * | pEntries
 | ) |  | [virtual]

Get the LUT channel settings from the camera.

Parameters:
bank | Bank to retrieve.
channel | Channel to retrieve.
sizeEntries | Number of entries in LUT table to read.
pEntries | Array to store LUT entries.
See also:
GetLUTInfo()
EnableLUT()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetLUTInfo ( LUTData * pData ) [virtual]

Query if LUT support is available on the camera.

Note that some cameras may report support for the LUT and return an inputBitDepth of 0. In these cases use log2(numEntries) for the inputBitDepth.

Parameters:
pData The LUT structure to be filled.
See also:
EnableLUT()
GetLUTChannel()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetMemoryChannel ( unsigned int * pCurrentChannel ) [virtual]

Retrieve the current memory channel from the camera.

Parameters:
pCurrentChannel Current memory channel.
See also:
SaveToMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetMemoryChannelInfo ( unsigned int * pNumChannels ) [virtual]

Query the camera for memory channel support.

If the number of channels is 0, then memory channel support is not available.

Parameters:
pNumChannels Number of memory channels supported.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
RestoreFromMemoryChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetProperty ( Property * pProp ) [virtual]

Reads the settings for the specified property from the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. If auto is on, the integer and abs values returned may not be consistent with each other.

Parameters:
pProp Pointer to the Property structure to be filled.
See also:
GetPropertyInfo()
SetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetPropertyInfo ( PropertyInfo * pPropInfo ) [virtual]

Retrieves information about the specified camera property.

The property type must be specified in the PropertyInfo structure passed into the function in order for the function to succeed.

Parameters:
pPropInfo Pointer to the PropertyInfo structure to be filled.
See also:
GetProperty()
SetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

static const char* GetRegisterString ( unsigned int registerVal ) [static]

Returns a text representation of the register value.

Parameters:
registerVal The register value to query.
Returns:
The text representation of the register.

Reimplemented from CameraBase.

virtual Error GetStats ( CameraStats * pStats ) [virtual]

Implements CameraBase.

virtual Error GetStrobe ( StrobeControl * pStrobeControl ) [virtual]

Retrieve current strobe settings from the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
pStrobeControl Structure to receive strobe settings.
See also:
GetStrobeInfo()
SetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetStrobeInfo ( StrobeInfo * pStrobeInfo ) [virtual]

Retrieve strobe information from the camera.

Parameters:
pStrobeInfo Structure to receive strobe information.
See also:
GetStrobe()
SetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerDelay ( TriggerDelay * pTriggerDelay ) [virtual]

Retrieve current trigger delay settings from the camera.

Parameters:
pTriggerDelay Structure to receive trigger delay settings.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerDelayInfo ( TriggerDelayInfo * pTriggerDelayInfo ) [virtual]

Retrieve trigger delay information from the camera.

Parameters:
pTriggerDelayInfo Structure to receive trigger delay information.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerMode ( TriggerMode * pTriggerMode ) [virtual]

Retrieve current trigger settings from the camera.

Parameters:
pTriggerMode Structure to receive trigger mode settings.
See also:
GetTriggerModeInfo()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerModeInfo ( TriggerModeInfo * pTriggerModeInfo ) [virtual]

Retrieve trigger information from the camera.

Parameters:
pTriggerModeInfo Structure to receive trigger information.
See also:
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetVideoModeAndFrameRate | ( | VideoMode * | pVideoMode,
 |  | FrameRate * | pFrameRate
 | ) |  | [virtual]

Get the current video mode and frame rate from the camera.

If the camera is in Format7, the video mode will be VIDEOMODE_FORMAT7 and the frame rate will be FRAMERATE_FORMAT7.

Parameters:
pVideoMode | Current video mode.
pFrameRate | Current frame rate.
See also:
GetVideoModeAndFrameRateInfo()
SetVideoModeAndFrameRate()
Returns:
An Error indicating the success or failure of the function.
virtual Error GetVideoModeAndFrameRateInfo | ( | VideoMode | videoMode,
 |  | FrameRate | frameRate,
 |  | bool * | pSupported
 | ) |  | [virtual]

Query the camera to determine if the specified video mode and frame rate is supported.

Parameters:
videoMode | Video mode to check.
frameRate | Frame rate to check.
pSupported | Whether the video mode and frame rate is supported.
See also:
GetVideoModeAndFrameRate()
SetVideoModeAndFrameRate()
Returns:
An Error indicating the success or failure of the function.
virtual bool IsConnected ( ) [virtual]

Checks if the camera object is connected to a physical camera specified by a GUID.

See also:
Connect()
Disconnect()
Returns:
Whether Connect() was called on the camera object.

Implements CameraBase.

virtual Error ReadRegister | ( | unsigned int | address,
 |  | unsigned int * | pValue
 | ) |  | [virtual]

Read the specified register from the camera.

Parameters:
address | DCAM address to be read from.
pValue | The value that is read.
See also:
WriteRegister()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error ReadRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Read from the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to read from.
addressLow | Bottom 32 bits of the 48 bits absolute address to read from.
pBuffer | Array to store read data.
length | Size of array, in quadlets.
See also:
WriteRegisterBlock()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error RegisterAllEvents ( EventOptions * pOpts ) [virtual]

Implements CameraBase.

virtual Error RegisterEvent ( EventOptions * pOpts ) [virtual]

Implements CameraBase.

virtual Error ResetStats ( ) [virtual]

Implements CameraBase.

virtual Error RestoreFromMemoryChannel ( unsigned int channel ) [virtual]

Restore the specfied current memory channel.

Parameters:
channel Memory channel to restore from.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error RetrieveBuffer ( Image * pImage ) [virtual]

Retrieves the the next image object containing the next image.

If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been retrieved by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be retrieved. Note that for the BUFFER_FRAMES case, if retrieval does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image retrieval.

Parameters:
pImage Pointer to Image object to store image data.
See also:
StartCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SaveToMemoryChannel ( unsigned int channel ) [virtual]

Save the current settings to the specfied current memory channel.

Parameters:
channel Memory channel to save to.
See also:
GetMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetActiveLUTBank ( unsigned int activeBank ) [virtual]

Set the LUT bank that will be used.

Parameters:
activeBank The bank to be set as active.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetCallback | ( | ImageEventCallback | callbackFn,
 |  | const void * | pCallbackData = NULL
 | ) |  | [virtual]

Sets the callback data to be used on completion of image transfer.

To clear the current stored callback data, pass in NULL for both arguments.

Parameters:
callbackFn | A function to be called when a new image is received.
pCallbackData | A pointer to data that can be passed to the callback function.
See also:
StartCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetConfiguration ( const FC2Config * pConfig ) [virtual]

Set the configuration associated with the camera object.

Parameters:
pConfig Pointer to the configuration structure to be used.
See also:
GetConfiguration()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetEmbeddedImageInfo ( EmbeddedImageInfo * pInfo ) [virtual]

Sets the on/off values of the embedded image information structure to the camera.

Parameters:
pInfo Structure to be used.
See also:
GetEmbeddedImageInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetFormat7Configuration | ( | const Format7ImageSettings * | pImageSettings,
 |  | unsigned int | packetSize
 | ) |  | [virtual]

Set the current Format7 configuration to the camera.

Parameters:
pImageSettings | Image settings to be written to the camera.
packetSize | Packet size to be written to the camera.
See also:
GetFormat7Info()
ValidateFormat7Settings()
GetFormat7Configuration()
Returns:
An Error indicating the success or failure of the function.
virtual Error SetFormat7Configuration | ( | const Format7ImageSettings * | pImageSettings,
 |  | float | percentSpeed
 | ) |  | [virtual]

Set the current Format7 configuration to the camera.

Parameters:
pImageSettings | Image settings to be written to the camera.
percentSpeed | Percentage of packet size to be written to the camera.
See also:
GetFormat7Info()
ValidateFormat7Settings()
GetFormat7Configuration()
Returns:
An Error indicating the success or failure of the function.
virtual Error SetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int | direction,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the GPIO pin direction for the specified pin.

This is useful if there is a need to set the pin into an input pin (i.e. to read the voltage) off the pin without setting it as a trigger source. This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
direction | Direction of the pin. 0 for input, 1 for output.
broadcast | Whether the action should be broadcast.
See also:
GetGPIOPinDirection()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | const unsigned int * | pEntries
 | ) |  | [virtual]

Set the LUT channel settings to the camera.

Parameters:
bank | Bank to set.
channel | Channel to set.
sizeEntries | Number of entries in LUT table to write. This must be the same size as numEntries returned by GetLutInfo().
pEntries | Array containing LUT entries to write.
See also:
GetLUTInfo()
EnableLUT()
GetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetProperty | ( | const Property * | pProp,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Writes the settings for the specified property to the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. The absControl flag controls whether the absolute or integer value is written to the camera. Use GetPropertyInfo() to query which options are available for a specific property.

Parameters:
pProp | Pointer to the Property structure to be used.
broadcast | Whether the action should be broadcast.
See also:
GetPropertyInfo()
GetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetStrobe | ( | const StrobeControl * | pStrobeControl,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set current strobe settings to the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
pStrobeControl | Structure providing strobe settings.
broadcast | Whether the action should be broadcast.
See also:
GetStrobeInfo()
GetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetTriggerDelay | ( | const TriggerDelay * | pTriggerDelay,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the specified trigger delay settings to the camera.

Parameters:
pTriggerDelay | Structure providing trigger delay settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetTriggerMode | ( | const TriggerMode * | pTriggerMode,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the specified trigger settings to the camera.

Parameters:
pTriggerMode | Structure providing trigger mode settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetUserBuffers | ( | unsigned char *const | pMemBuffers,
 |  | int | size,
 |  | int | numBuffers
 | ) |  | [virtual]

Specify user allocated buffers to use as image data buffers.

To prevent image tearing, the size of each buffer should be equal to ((unsigned int)(bufferSize + packetSize - 1)/packetSize) * packetSize. The total size should be (size * numBuffers) or larger. The packet Size that should be used differs between interfaces: Firewire: Use the Format7 packet size. Usb2: First round to Format7 packet size then round to 512 bytes. Usb3: Use a packet size of 1024 bytes. GigE: No need to do any rounding on GigE

Parameters:
pMemBuffers | Pointer to memory buffers to be written to.
size | The size of each buffer (in bytes).
numBuffers | Number of buffers in the array.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetVideoModeAndFrameRate | ( | VideoMode | videoMode,
 |  | FrameRate | frameRate
 | ) |  | [virtual]

Set the specified video mode and frame rate to the camera.

It is not possible to set the camera to VIDEOMODE_FORMAT7 or FRAMERATE_FORMAT7. Use the Format7 functions to set the camera into Format7.

Parameters:
videoMode | Video mode to set to camera.
frameRate | Frame rate to set to camera.
See also:
GetVideoModeAndFrameRateInfo()
GetVideoModeAndFrameRate()
Returns:
An Error indicating the success or failure of the function.
virtual Error StartCapture | ( | ImageEventCallback | callbackFn = NULL,
 |  | const void * | pCallbackData = NULL
 | ) |  | [virtual]

Starts isochronous image capture.

It will use either the current video mode or the most recently set video mode of the camera. The optional callback function parameter is called on completion of image transfer. When a callback function is specified, the grab mode will determine how images are delivered. If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been delivered by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be delivered. Note that for the BUFFER_FRAMES case, if delivery does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image delivery Alternatively, the callback parameter can be set to NULL and RetrieveBuffer() can be called as a blocking call to get the image data.

Parameters:
callbackFn | A function to be called when a new image is received.
pCallbackData | A pointer to data that can be passed to the callback function.
See also:
RetrieveBuffer()
StartSyncCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

static Error StartSyncCapture | ( | unsigned int | numCameras,
 |  | const Camera ** | ppCameras,
 |  | const ImageEventCallback * | pCallbackFns = NULL,
 |  | const void ** | pCallbackDataArray = NULL
 | ) |  | [static]
virtual Error StopCapture ( ) [virtual]

Stops isochronous image transfer and cleans up all associated resources.

If an image callback function (specified in the StartCapture() call) is currently executing, StopCapture() will not return until after the callback has completed.

See also:
StartCapture()
RetrieveBuffer()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error ValidateFormat7Settings | ( | const Format7ImageSettings * | pImageSettings,
 |  | bool * | pSettingsAreValid,
 |  | Format7PacketInfo * | pPacketInfo
 | ) |  | [virtual]

Validates Format7ImageSettings structure and returns valid packet size information if the image settings are valid.

The current image settings are cached while validation is taking place. The cached settings are restored when validation is complete.

Parameters:
pImageSettings | Structure containing the image settings.
pSettingsAreValid | Whether the settings are valid.
pPacketInfo | Packet size information that can be used to determine a valid packet size.
See also:
GetFormat7Info()
GetFormat7Configuration()
SetFormat7Configuration()
Returns:
An Error indicating the success or failure of the function.
virtual Error WaitForBufferEvent | ( | Image * | pImage,
 |  | unsigned int | eventNumber
 | ) |  | [virtual]

Retrieves the next image event containing the next part of the image.

Parameters:
pImage | Pointer to Image object to store image data.
eventNumber | The event number to wait for.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error WriteRegister | ( | unsigned int | address,
 |  | unsigned int | value,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Write to the specified register on the camera.

Parameters:
address | DCAM address to be written to.
value | The value to be written.
broadcast | Whether the action should be broadcast.
See also:
ReadRegister()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error WriteRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | const unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Write to the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to write to.
addressLow | Bottom 32 bits of the 48 bits absolute address to write to.
pBuffer | Array containing data to be written.
length | Size of array, in quadlets.
See also:
ReadRegisterBlock()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

The documentation for this class was generated from the following file:
  • Camera.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: CameraBase Class Reference

  • FlyCapture2
  • CameraBase
Public Member Functions | Protected Attributes
CameraBase Class Reference

The CameraBase class is an abstract base class that defines a general interface to a camera. More...

Inheritance diagram for CameraBase:
[legend]

List of all members.

Public Member Functions

CameraBase ()
Default constructor.
virtual | ~CameraBase ()
Default destructor.

Protected Attributes

CameraData * | m_pCameraData

Connection and Image Retrieval

These functions deal with connections and image retrieval from the camera.

virtual Error | Connect (PGRGuid *pGuid=NULL)=0
Connects the camera object to the camera specified by the GUID.
virtual Error | Disconnect ()=0
Disconnects the camera object from the camera.
virtual bool | IsConnected ()=0
Checks if the camera object is connected to a physical camera specified by a GUID.
virtual Error | SetCallback (ImageEventCallback callbackFn, const void *pCallbackData=NULL)=0
Sets the callback data to be used on completion of image transfer.
virtual Error | StartCapture (ImageEventCallback callbackFn=NULL, const void *pCallbackData=NULL)=0
Starts isochronous image capture.
virtual Error | RetrieveBuffer (Image *pImage)=0
Retrieves the the next image object containing the next image.
virtual Error | StopCapture ()=0
Stops isochronous image transfer and cleans up all associated resources.
virtual Error | WaitForBufferEvent (Image *pImage, unsigned int eventNumber)=0
Retrieves the next image event containing the next part of the image.
virtual Error | SetUserBuffers (unsigned char *const pMemBuffers, int size, int numBuffers)=0
Specify user allocated buffers to use as image data buffers.
virtual Error | GetConfiguration (FC2Config *pConfig)=0
Get the configuration associated with the camera object.
virtual Error | SetConfiguration (const FC2Config *pConfig)=0
Set the configuration associated with the camera object.
static Error | StartSyncCapture (unsigned int numCameras, const CameraBase **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL)
Starts isochronous image capture on multiple cameras.

Information and Properties

These functions deal with information and properties can be retrieved from the camera.

virtual Error | GetCameraInfo (CameraInfo *pCameraInfo)=0
Retrieves information from the camera such as serial number, model name and other camera information.
virtual Error | GetPropertyInfo (PropertyInfo *pPropInfo)=0
Retrieves information about the specified camera property.
virtual Error | GetProperty (Property *pProp)=0
Reads the settings for the specified property from the camera.
virtual Error | SetProperty (const Property *pProp, bool broadcast=false)=0
Writes the settings for the specified property to the camera.

General Purpose Input / Output

These functions deal with general GPIO pin control on the camera.

virtual Error | GetGPIOPinDirection (unsigned int pin, unsigned int *pDirection)=0
Get the GPIO pin direction for the specified pin.
virtual Error | SetGPIOPinDirection (unsigned int pin, unsigned int direction, bool broadcast=false)=0
Set the GPIO pin direction for the specified pin.

Trigger

These functions deal with trigger control on the camera.

virtual Error | GetTriggerModeInfo (TriggerModeInfo *pTriggerModeInfo)=0
Retrieve trigger information from the camera.
virtual Error | GetTriggerMode (TriggerMode *pTriggerMode)=0
Retrieve current trigger settings from the camera.
virtual Error | SetTriggerMode (const TriggerMode *pTriggerMode, bool broadcast=false)=0
Set the specified trigger settings to the camera.
virtual Error | FireSoftwareTrigger (bool broadcast=false)=0
Fire the software trigger according to the DCAM specifications.
virtual Error | GetTriggerDelayInfo (TriggerDelayInfo *pTriggerDelayInfo)=0
Retrieve trigger delay information from the camera.
virtual Error | GetTriggerDelay (TriggerDelay *pTriggerDelay)=0
Retrieve current trigger delay settings from the camera.
virtual Error | SetTriggerDelay (const TriggerDelay *pTriggerDelay, bool broadcast=false)=0
Set the specified trigger delay settings to the camera.

Strobe

These functions deal with strobe control on the camera.

virtual Error | GetStrobeInfo (StrobeInfo *pStrobeInfo)=0
Retrieve strobe information from the camera.
virtual Error | GetStrobe (StrobeControl *pStrobeControl)=0
Retrieve current strobe settings from the camera.
virtual Error | SetStrobe (const StrobeControl *pStrobeControl, bool broadcast=false)=0
Set current strobe settings to the camera.

Look Up Table

These functions deal with Look Up Table control on the camera.

virtual Error | GetLUTInfo (LUTData *pData)=0
Query if LUT support is available on the camera.
virtual Error | GetLUTBankInfo (unsigned int bank, bool *pReadSupported, bool *pWriteSupported)=0
Query the read/write status of a single LUT bank.
virtual Error | GetActiveLUTBank (unsigned int *pActiveBank)=0
Get the LUT bank that is currently being used.
virtual Error | SetActiveLUTBank (unsigned int activeBank)=0
Set the LUT bank that will be used.
virtual Error | EnableLUT (bool on)=0
Enable or disable LUT functionality on the camera.
virtual Error | GetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, unsigned int *pEntries)=0
Get the LUT channel settings from the camera.
virtual Error | SetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, const unsigned int *pEntries)=0
Set the LUT channel settings to the camera.

Memory Channels

These functions deal with memory channel control on the camera.

virtual Error | GetMemoryChannel (unsigned int *pCurrentChannel)=0
Retrieve the current memory channel from the camera.
virtual Error | SaveToMemoryChannel (unsigned int channel)=0
Save the current settings to the specfied current memory channel.
virtual Error | RestoreFromMemoryChannel (unsigned int channel)=0
Restore the specfied current memory channel.
virtual Error | GetMemoryChannelInfo (unsigned int *pNumChannels)=0
Query the camera for memory channel support.

Embedded Image Information

These functions deal with embedded image information control on the camera.

virtual Error | GetEmbeddedImageInfo (EmbeddedImageInfo *pInfo)=0
Get the current status of the embedded image information register, as well as the availability of each embedded property.
virtual Error | SetEmbeddedImageInfo (EmbeddedImageInfo *pInfo)=0
Sets the on/off values of the embedded image information structure to the camera.

Register Operation

These functions deal with register operation on the camera.

virtual Error | WriteRegister (unsigned int address, unsigned int value, bool broadcast=false)=0
Write to the specified register on the camera.
virtual Error | ReadRegister (unsigned int address, unsigned int *pValue)=0
Read the specified register from the camera.
virtual Error | WriteRegisterBlock (unsigned short addressHigh, unsigned int addressLow, const unsigned int *pBuffer, unsigned int length)=0
Write to the specified register block on the camera.
virtual Error | ReadRegisterBlock (unsigned short addressHigh, unsigned int addressLow, unsigned int *pBuffer, unsigned int length)=0
Read from the specified register block on the camera.
virtual Error | GetCycleTime (TimeStamp *timeStamp)=0
Returns a Timestamp struct containing 1394 CYCLE_TIME information.
virtual Error | GetStats (CameraStats *pStats)=0
virtual Error | ResetStats ()=0
virtual Error | RegisterEvent (EventOptions *pOpts)=0
virtual Error | DeregisterEvent (EventOptions *pOpts)=0
virtual Error | RegisterAllEvents (EventOptions *pOpts)=0
virtual Error | DeregisterAllEvents (void)=0
static const char * | GetRegisterString (unsigned int registerVal)
Returns a text representation of the register value.

Detailed Description

The CameraBase class is an abstract base class that defines a general interface to a camera.

Constructor & Destructor Documentation

CameraBase ( ) [inline]

Default constructor.

virtual ~CameraBase ( ) [inline, virtual]

Default destructor.

Member Function Documentation

virtual Error Connect ( PGRGuid * pGuid = NULL ) [pure virtual]

Connects the camera object to the camera specified by the GUID.

If the guid is omitted or set to NULL, the connection will be made to the first camera detected on the PC (i.e. index = 0).

Parameters:
pGuid The unique identifier for a specific camera on the PC.
See also:
BusManager::GetCameraFromIndex()
BusManager::GetCameraFromSerialNumber()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error DeregisterAllEvents ( void ) [pure virtual]

Implemented in GigECamera, and Camera.

virtual Error DeregisterEvent ( EventOptions * pOpts ) [pure virtual]

Implemented in GigECamera, and Camera.

virtual Error Disconnect ( ) [pure virtual]

Disconnects the camera object from the camera.

This allows another physical camera specified by a GUID to be connected to the camera object.

See also:
Connect()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error EnableLUT ( bool on ) [pure virtual]

Enable or disable LUT functionality on the camera.

Parameters:
on Whether to enable or disable LUT.
See also:
GetLUTInfo()
GetLUTChannel()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error FireSoftwareTrigger ( bool broadcast = false ) [pure virtual]

Fire the software trigger according to the DCAM specifications.

Parameters:
broadcast Whether the action should be broadcast.
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetActiveLUTBank ( unsigned int * pActiveBank ) [pure virtual]

Get the LUT bank that is currently being used.

For cameras with PGR LUT, the active bank is always 0.

Parameters:
pActiveBank The currently active bank.
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetCameraInfo ( CameraInfo * pCameraInfo ) [pure virtual]

Retrieves information from the camera such as serial number, model name and other camera information.

Parameters:
pCameraInfo Pointer to the camera information structure to be filled.
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetConfiguration ( FC2Config * pConfig ) [pure virtual]

Get the configuration associated with the camera object.

Parameters:
pConfig Pointer to the configuration structure to be filled.
See also:
SetConfiguration()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetCycleTime ( TimeStamp * timeStamp ) [pure virtual]

Returns a Timestamp struct containing 1394 CYCLE_TIME information.

Parameters:
registerVal The register value to query.
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetEmbeddedImageInfo ( EmbeddedImageInfo * pInfo ) [pure virtual]

Get the current status of the embedded image information register, as well as the availability of each embedded property.

Parameters:
pInfo Structure to be filled.
See also:
SetEmbeddedImageInfo()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int * | pDirection
 | ) |  | [pure virtual]

Get the GPIO pin direction for the specified pin.

This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
pDirection | Direction of the pin. 0 for input, 1 for output.
See also:
SetGPIOPinDirection()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetLUTBankInfo | ( | unsigned int | bank,
 |  | bool * | pReadSupported,
 |  | bool * | pWriteSupported
 | ) |  | [pure virtual]

Query the read/write status of a single LUT bank.

Parameters:
bank | The bank to query.
pReadSupported | Whether reading from the bank is supported.
pWriteSupported | Whether writing to the bank is supported.
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | unsigned int * | pEntries
 | ) |  | [pure virtual]

Get the LUT channel settings from the camera.

Parameters:
bank | Bank to retrieve.
channel | Channel to retrieve.
sizeEntries | Number of entries in LUT table to read.
pEntries | Array to store LUT entries.
See also:
GetLUTInfo()
EnableLUT()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetLUTInfo ( LUTData * pData ) [pure virtual]

Query if LUT support is available on the camera.

Note that some cameras may report support for the LUT and return an inputBitDepth of 0. In these cases use log2(numEntries) for the inputBitDepth.

Parameters:
pData The LUT structure to be filled.
See also:
EnableLUT()
GetLUTChannel()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetMemoryChannel ( unsigned int * pCurrentChannel ) [pure virtual]

Retrieve the current memory channel from the camera.

Parameters:
pCurrentChannel Current memory channel.
See also:
SaveToMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetMemoryChannelInfo ( unsigned int * pNumChannels ) [pure virtual]

Query the camera for memory channel support.

If the number of channels is 0, then memory channel support is not available.

Parameters:
pNumChannels Number of memory channels supported.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
RestoreFromMemoryChannel()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetProperty ( Property * pProp ) [pure virtual]

Reads the settings for the specified property from the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. If auto is on, the integer and abs values returned may not be consistent with each other.

Parameters:
pProp Pointer to the Property structure to be filled.
See also:
GetPropertyInfo()
SetProperty()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetPropertyInfo ( PropertyInfo * pPropInfo ) [pure virtual]

Retrieves information about the specified camera property.

The property type must be specified in the PropertyInfo structure passed into the function in order for the function to succeed.

Parameters:
pPropInfo Pointer to the PropertyInfo structure to be filled.
See also:
GetProperty()
SetProperty()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

static const char* GetRegisterString ( unsigned int registerVal ) [static]

Returns a text representation of the register value.

Parameters:
registerVal The register value to query.
Returns:
The text representation of the register.

Reimplemented in GigECamera, Camera, and GCCamera.

virtual Error GetStats ( CameraStats * pStats ) [pure virtual]

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetStrobe ( StrobeControl * pStrobeControl ) [pure virtual]

Retrieve current strobe settings from the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
pStrobeControl Structure to receive strobe settings.
See also:
GetStrobeInfo()
SetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetStrobeInfo ( StrobeInfo * pStrobeInfo ) [pure virtual]

Retrieve strobe information from the camera.

Parameters:
pStrobeInfo Structure to receive strobe information.
See also:
GetStrobe()
SetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetTriggerDelay ( TriggerDelay * pTriggerDelay ) [pure virtual]

Retrieve current trigger delay settings from the camera.

Parameters:
pTriggerDelay Structure to receive trigger delay settings.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetTriggerDelayInfo ( TriggerDelayInfo * pTriggerDelayInfo ) [pure virtual]

Retrieve trigger delay information from the camera.

Parameters:
pTriggerDelayInfo Structure to receive trigger delay information.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetTriggerMode ( TriggerMode * pTriggerMode ) [pure virtual]

Retrieve current trigger settings from the camera.

Parameters:
pTriggerMode Structure to receive trigger mode settings.
See also:
GetTriggerModeInfo()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error GetTriggerModeInfo ( TriggerModeInfo * pTriggerModeInfo ) [pure virtual]

Retrieve trigger information from the camera.

Parameters:
pTriggerModeInfo Structure to receive trigger information.
See also:
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual bool IsConnected ( ) [pure virtual]

Checks if the camera object is connected to a physical camera specified by a GUID.

See also:
Connect()
Disconnect()
Returns:
Whether Connect() was called on the camera object.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error ReadRegister | ( | unsigned int | address,
 |  | unsigned int * | pValue
 | ) |  | [pure virtual]

Read the specified register from the camera.

Parameters:
address | DCAM address to be read from.
pValue | The value that is read.
See also:
WriteRegister()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error ReadRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [pure virtual]

Read from the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to read from.
addressLow | Bottom 32 bits of the 48 bits absolute address to read from.
pBuffer | Array to store read data.
length | Size of array, in quadlets.
See also:
WriteRegisterBlock()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error RegisterAllEvents ( EventOptions * pOpts ) [pure virtual]

Implemented in GigECamera, and Camera.

virtual Error RegisterEvent ( EventOptions * pOpts ) [pure virtual]

Implemented in GigECamera, and Camera.

virtual Error ResetStats ( ) [pure virtual]

Implemented in GigECamera, Camera, and GCCamera.

virtual Error RestoreFromMemoryChannel ( unsigned int channel ) [pure virtual]

Restore the specfied current memory channel.

Parameters:
channel Memory channel to restore from.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error RetrieveBuffer ( Image * pImage ) [pure virtual]

Retrieves the the next image object containing the next image.

If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been retrieved by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be retrieved. Note that for the BUFFER_FRAMES case, if retrieval does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image retrieval.

Parameters:
pImage Pointer to Image object to store image data.
See also:
StartCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SaveToMemoryChannel ( unsigned int channel ) [pure virtual]

Save the current settings to the specfied current memory channel.

Parameters:
channel Memory channel to save to.
See also:
GetMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetActiveLUTBank ( unsigned int activeBank ) [pure virtual]

Set the LUT bank that will be used.

Parameters:
activeBank The bank to be set as active.
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetCallback | ( | ImageEventCallback | callbackFn,
 |  | const void * | pCallbackData = NULL
 | ) |  | [pure virtual]

Sets the callback data to be used on completion of image transfer.

To clear the current stored callback data, pass in NULL for both arguments.

Parameters:
callbackFn | A function to be called when a new image is received.
pCallbackData | A pointer to data that can be passed to the callback function.
See also:
StartCapture()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetConfiguration ( const FC2Config * pConfig ) [pure virtual]

Set the configuration associated with the camera object.

Parameters:
pConfig Pointer to the configuration structure to be used.
See also:
GetConfiguration()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetEmbeddedImageInfo ( EmbeddedImageInfo * pInfo ) [pure virtual]

Sets the on/off values of the embedded image information structure to the camera.

Parameters:
pInfo Structure to be used.
See also:
GetEmbeddedImageInfo()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int | direction,
 |  | bool | broadcast = false
 | ) |  | [pure virtual]

Set the GPIO pin direction for the specified pin.

This is useful if there is a need to set the pin into an input pin (i.e. to read the voltage) off the pin without setting it as a trigger source. This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
direction | Direction of the pin. 0 for input, 1 for output.
broadcast | Whether the action should be broadcast.
See also:
GetGPIOPinDirection()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | const unsigned int * | pEntries
 | ) |  | [pure virtual]

Set the LUT channel settings to the camera.

Parameters:
bank | Bank to set.
channel | Channel to set.
sizeEntries | Number of entries in LUT table to write. This must be the same size as numEntries returned by GetLutInfo().
pEntries | Array containing LUT entries to write.
See also:
GetLUTInfo()
EnableLUT()
GetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetProperty | ( | const Property * | pProp,
 |  | bool | broadcast = false
 | ) |  | [pure virtual]

Writes the settings for the specified property to the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. The absControl flag controls whether the absolute or integer value is written to the camera. Use GetPropertyInfo() to query which options are available for a specific property.

Parameters:
pProp | Pointer to the Property structure to be used.
broadcast | Whether the action should be broadcast.
See also:
GetPropertyInfo()
GetProperty()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetStrobe | ( | const StrobeControl * | pStrobeControl,
 |  | bool | broadcast = false
 | ) |  | [pure virtual]

Set current strobe settings to the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
pStrobeControl | Structure providing strobe settings.
broadcast | Whether the action should be broadcast.
See also:
GetStrobeInfo()
GetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetTriggerDelay | ( | const TriggerDelay * | pTriggerDelay,
 |  | bool | broadcast = false
 | ) |  | [pure virtual]

Set the specified trigger delay settings to the camera.

Parameters:
pTriggerDelay | Structure providing trigger delay settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetTriggerMode | ( | const TriggerMode * | pTriggerMode,
 |  | bool | broadcast = false
 | ) |  | [pure virtual]

Set the specified trigger settings to the camera.

Parameters:
pTriggerMode | Structure providing trigger mode settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error SetUserBuffers | ( | unsigned char *const | pMemBuffers,
 |  | int | size,
 |  | int | numBuffers
 | ) |  | [pure virtual]

Specify user allocated buffers to use as image data buffers.

To prevent image tearing, the size of each buffer should be equal to ((unsigned int)(bufferSize + packetSize - 1)/packetSize) * packetSize. The total size should be (size * numBuffers) or larger. The packet Size that should be used differs between interfaces: Firewire: Use the Format7 packet size. Usb2: First round to Format7 packet size then round to 512 bytes. Usb3: Use a packet size of 1024 bytes. GigE: No need to do any rounding on GigE

Parameters:
pMemBuffers | Pointer to memory buffers to be written to.
size | The size of each buffer (in bytes).
numBuffers | Number of buffers in the array.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error StartCapture | ( | ImageEventCallback | callbackFn = NULL,
 |  | const void * | pCallbackData = NULL
 | ) |  | [pure virtual]

Starts isochronous image capture.

It will use either the current video mode or the most recently set video mode of the camera. The optional callback function parameter is called on completion of image transfer. When a callback function is specified, the grab mode will determine how images are delivered. If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been delivered by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be delivered. Note that for the BUFFER_FRAMES case, if delivery does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image delivery Alternatively, the callback parameter can be set to NULL and RetrieveBuffer() can be called as a blocking call to get the image data.

Parameters:
callbackFn | A function to be called when a new image is received.
pCallbackData | A pointer to data that can be passed to the callback function.
See also:
RetrieveBuffer()
StartSyncCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

static Error StartSyncCapture | ( | unsigned int | numCameras,
 |  | const CameraBase ** | ppCameras,
 |  | const ImageEventCallback * | pCallbackFns = NULL,
 |  | const void ** | pCallbackDataArray = NULL
 | ) |  | [static]

Starts isochronous image capture on multiple cameras.

On each frame, the time stamps across the cameras are aligned which means the frames are synchronized. Note that the cameras must be synchronized by external means in order for this function to work. This means that the cameras should either be on the same bus, hardware synchronized (e.g. through triggering) or Multisync is running. This function is only used with firewire cameras.

Parameters:
numCameras | Number of Camera objects in the ppCameras array.
ppCameras | Array of pointers to Camera objects containing the cameras to be started and synchronized.
pCallbackFns | Array of callback functions for each camera.
pCallbackDataArray | Array of callback data pointers.
See also:
RetrieveBuffer()
StartCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.
virtual Error StopCapture ( ) [pure virtual]

Stops isochronous image transfer and cleans up all associated resources.

If an image callback function (specified in the StartCapture() call) is currently executing, StopCapture() will not return until after the callback has completed.

See also:
StartCapture()
RetrieveBuffer()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error WaitForBufferEvent | ( | Image * | pImage,
 |  | unsigned int | eventNumber
 | ) |  | [pure virtual]

Retrieves the next image event containing the next part of the image.

Parameters:
pImage | Pointer to Image object to store image data.
eventNumber | The event number to wait for.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error WriteRegister | ( | unsigned int | address,
 |  | unsigned int | value,
 |  | bool | broadcast = false
 | ) |  | [pure virtual]

Write to the specified register on the camera.

Parameters:
address | DCAM address to be written to.
value | The value to be written.
broadcast | Whether the action should be broadcast.
See also:
ReadRegister()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

virtual Error WriteRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | const unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [pure virtual]

Write to the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to write to.
addressLow | Bottom 32 bits of the 48 bits absolute address to write to.
pBuffer | Array containing data to be written.
length | Size of array, in quadlets.
See also:
ReadRegisterBlock()
Returns:
An Error indicating the success or failure of the function.

Implemented in GigECamera, Camera, and GCCamera.

Member Data Documentation

CameraData* m_pCameraData [protected]
The documentation for this class was generated from the following file:
  • CameraBase.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: CameraControlDlg Class Reference

  • FlyCapture2
  • CameraControlDlg
Public Member Functions
CameraControlDlg Class Reference

The CameraControlDlg object represents a dialog that provides a graphical interface to a specified camera. More...

List of all members.

Public Member Functions

CameraControlDlg ()
Default constructor.
~CameraControlDlg ()
Default destructor.
void | Connect (CameraBase *pCamera)
Connect dialog to a camera.
void | Disconnect ()
Disconnect a connected camera from the dialog.
void | Show ()
Show the dialog.
void | Show (void *pParent)
Show the dialog.
void | ShowModal ()
Show the modal dialog.
void | ShowModal (void *pParent)
Show the modal dialog.
void | Hide ()
Hide the dialog.
bool | IsVisible ()
Get the visibility of the dialog.
void | SetTitle (const char *title)
Change the title of the window.

Detailed Description

The CameraControlDlg object represents a dialog that provides a graphical interface to a specified camera.

Constructor & Destructor Documentation

CameraControlDlg ( )

Default constructor.

~CameraControlDlg ( )

Default destructor.

Member Function Documentation

void Connect ( CameraBase * pCamera )

Connect dialog to a camera.

Parameters:
pCamera Camera object to connect the dialog to.
void Disconnect ( )

Disconnect a connected camera from the dialog.

void Hide ( )

Hide the dialog.

bool IsVisible ( )

Get the visibility of the dialog.

Returns:
Whether the dialog is visible.
void SetTitle ( const char * title )

Change the title of the window.

This has to be called after calling Connect().

Parameters:
title Null-terminated string representing the title.
void Show ( )

Show the dialog.

void Show ( void * pParent )

Show the dialog.

void ShowModal ( )

Show the modal dialog.

void ShowModal ( void * pParent )

Show the modal dialog.

The documentation for this class was generated from the following file:
  • FlyCapture2GUI.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: CameraInfo Struct Reference

  • FlyCapture2
  • CameraInfo
Public Member Functions | Public Attributes
CameraInfo Struct Reference
Structures

Camera information. More...

Collaboration diagram for CameraInfo:
[legend]

List of all members.

Public Member Functions

CameraInfo ()

Public Attributes

unsigned int | serialNumber
Device serial number.
InterfaceType interfaceType
Interface type.
DriverType driverType
Driver type.
bool | isColorCamera
Flag indicating if this is a color camera.
char | modelName [sk_maxStringLength]
Device model name.
char | vendorName [sk_maxStringLength]
Device vendor name.
char | sensorInfo [sk_maxStringLength]
String detailing the sensor information.
char | sensorResolution [sk_maxStringLength]
String providing the sensor resolution.
char | driverName [sk_maxStringLength]
Driver name of driver being used.
char | firmwareVersion [sk_maxStringLength]
Firmware version of camera.
char | firmwareBuildTime [sk_maxStringLength]
Firmware build time.
BusSpeed maximumBusSpeed
Maximum bus speed.
BayerTileFormat bayerTileFormat
Bayer tile format.
unsigned short | busNumber
Bus number, set to 0 for GigE and USB cameras.
unsigned short | nodeNumber
ieee1394 Node number, set to 0 for GigE and USB cameras
PCIeBusSpeed pcieBusSpeed
PCIe Bus Speed, set to PCIE_BUSSPEED_UNKNOWN for unsupported drivers.
unsigned int | reserved [16]
Reserved for future use.
IIDC specific information
unsigned int | iidcVer
DCAM version.
ConfigROM configROM
Configuration ROM data.
GigE specific information
unsigned int | gigEMajorVersion
GigE Vision version.
unsigned int | gigEMinorVersion
GigE Vision minor version.
char | userDefinedName [sk_maxStringLength]
User defined name.
char | xmlURL1 [sk_maxStringLength]
XML URL 1.
char | xmlURL2 [sk_maxStringLength]
XML URL 2.
MACAddress macAddress
MAC address.
IPAddress ipAddress
IP address.
IPAddress subnetMask
Subnet mask.
IPAddress defaultGateway
Default gateway.
unsigned int | ccpStatus
Status/Content of CCP register.
unsigned int | applicationIPAddress
Local Application IP Address.
unsigned int | applicationPort
Local Application port.

Detailed Description

Camera information.

Constructor & Destructor Documentation

CameraInfo ( ) [inline]

Member Data Documentation

unsigned int applicationIPAddress

Local Application IP Address.

unsigned int applicationPort

Local Application port.

BayerTileFormat bayerTileFormat

Bayer tile format.

unsigned short busNumber

Bus number, set to 0 for GigE and USB cameras.

unsigned int ccpStatus

Status/Content of CCP register.

ConfigROM configROM

Configuration ROM data.

IPAddress defaultGateway

Default gateway.

char driverName[sk_maxStringLength]

Driver name of driver being used.

DriverType driverType

Driver type.

char firmwareBuildTime[sk_maxStringLength]

Firmware build time.

char firmwareVersion[sk_maxStringLength]

Firmware version of camera.

unsigned int gigEMajorVersion

GigE Vision version.

unsigned int gigEMinorVersion

GigE Vision minor version.

unsigned int iidcVer

DCAM version.

InterfaceType interfaceType

Interface type.

IPAddress ipAddress

IP address.

bool isColorCamera

Flag indicating if this is a color camera.

MACAddress macAddress

MAC address.

BusSpeed maximumBusSpeed

Maximum bus speed.

char modelName[sk_maxStringLength]

Device model name.

unsigned short nodeNumber

ieee1394 Node number, set to 0 for GigE and USB cameras

PCIeBusSpeed pcieBusSpeed

PCIe Bus Speed, set to PCIE_BUSSPEED_UNKNOWN for unsupported drivers.

unsigned int reserved[16]

Reserved for future use.

char sensorInfo[sk_maxStringLength]

String detailing the sensor information.

char sensorResolution[sk_maxStringLength]

String providing the sensor resolution.

unsigned int serialNumber

Device serial number.

IPAddress subnetMask

Subnet mask.

char userDefinedName[sk_maxStringLength]

User defined name.

char vendorName[sk_maxStringLength]

Device vendor name.

char xmlURL1[sk_maxStringLength]

XML URL 1.

char xmlURL2[sk_maxStringLength]

XML URL 2.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: CameraSelectionDlg Class Reference

  • FlyCapture2
  • CameraSelectionDlg
Public Member Functions
CameraSelectionDlg Class Reference

The CameraSelectionDlg object represents a dialog that provides a graphical interface that lists the number of cameras available to the library. More...

List of all members.

Public Member Functions

CameraSelectionDlg ()
Default constructor.
~CameraSelectionDlg ()
Default destructor.
void | ShowModal (bool *pOk, PGRGuid *pGuid, unsigned int *pSize)
Show the CameraSelectionDlg.
void | SetTitle (const char *title)
Set the window title.

Detailed Description

The CameraSelectionDlg object represents a dialog that provides a graphical interface that lists the number of cameras available to the library.

Any GigE cameras that were connected prior to creating a CameraSelectionDlg will lose CCP after the creation. Consider creating a CameraSelectionDlg prior to connecting any GigE cameras or calling connect on any outstanding GigE camera.

Constructor & Destructor Documentation

CameraSelectionDlg ( )

Default constructor.

~CameraSelectionDlg ( )

Default destructor.

Member Function Documentation

void SetTitle ( const char * title )

Set the window title.

Parameters:
title Null-terminated string representing the title.
void ShowModal | ( | bool * | pOk,
 |  | PGRGuid * | pGuid,
 |  | unsigned int * | pSize
 | ) |  |

Show the CameraSelectionDlg.

Parameters:
pOk | Whether Ok (true) or Cancel (false) was clicked.
pGuid | Array of PGRGuids containing the selected cameras.
pSize | Size of PGRGuid array.
The documentation for this class was generated from the following file:
  • FlyCapture2GUI.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: CameraStats Struct Reference

  • FlyCapture2
  • CameraStats
Public Member Functions | Public Attributes
CameraStats Struct Reference
Structures

Camera diagnostic information. More...

Collaboration diagram for CameraStats:
[legend]

List of all members.

Public Member Functions

CameraStats ()

Public Attributes

unsigned int | imageDropped
unsigned int | imageCorrupt
unsigned int | imageXmitFailed
unsigned int | imageDriverDropped
unsigned int | regReadFailed
unsigned int | regWriteFailed
unsigned int | portErrors
bool | cameraPowerUp
float | cameraVoltages [8]
unsigned int | numVoltages
The number of voltage registers available.
float | cameraCurrents [8]
unsigned int | numCurrents
The number of current registers available.
unsigned int | temperature
unsigned int | timeSinceInitialization
unsigned int | timeSinceBusReset
TimeStamp timeStamp
unsigned int | numResendPacketsRequested
unsigned int | numResendPacketsReceived
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Camera diagnostic information.

Constructor & Destructor Documentation

CameraStats ( ) [inline]

Member Data Documentation

float cameraCurrents[8]
bool cameraPowerUp
float cameraVoltages[8]
unsigned int imageCorrupt
unsigned int imageDriverDropped
unsigned int imageDropped
unsigned int imageXmitFailed
unsigned int numCurrents

The number of current registers available.

0: the values in cameraCurrents[] are invalid.

unsigned int numResendPacketsReceived
unsigned int numResendPacketsRequested
unsigned int numVoltages

The number of voltage registers available.

0: the values in cameraVoltages[] are invalid.

unsigned int portErrors
unsigned int regReadFailed
unsigned int regWriteFailed
unsigned int reserved[16]

Reserved for future use.

unsigned int temperature
unsigned int timeSinceBusReset
unsigned int timeSinceInitialization
TimeStamp timeStamp
The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: ConfigROM Struct Reference

  • FlyCapture2
  • ConfigROM
Public Member Functions | Public Attributes
ConfigROM Struct Reference
Structures

Camera configuration ROM. More...

List of all members.

Public Member Functions

ConfigROM ()

Public Attributes

unsigned int | nodeVendorId
Vendor ID of a node.
unsigned int | chipIdHi
Chip ID (high part).
unsigned int | chipIdLo
Chip ID (low part).
unsigned int | unitSpecId
Unit Spec ID, usually 0xa02d.
unsigned int | unitSWVer
Unit software version.
unsigned int | unitSubSWVer
Unit sub software version.
unsigned int | vendorUniqueInfo_0
Vendor unique info 0.
unsigned int | vendorUniqueInfo_1
Vendor unique info 1.
unsigned int | vendorUniqueInfo_2
Vendor unique info 2.
unsigned int | vendorUniqueInfo_3
Vendor unique info 3.
char | pszKeyword [sk_maxStringLength]
Keyword.
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Camera configuration ROM.

Constructor & Destructor Documentation

ConfigROM ( ) [inline]

Member Data Documentation

unsigned int chipIdHi

Chip ID (high part).

unsigned int chipIdLo

Chip ID (low part).

unsigned int nodeVendorId

Vendor ID of a node.

char pszKeyword[sk_maxStringLength]

Keyword.

unsigned int reserved[16]

Reserved for future use.

unsigned int unitSpecId

Unit Spec ID, usually 0xa02d.

unsigned int unitSubSWVer

Unit sub software version.

unsigned int unitSWVer

Unit software version.

unsigned int vendorUniqueInfo_0

Vendor unique info 0.

unsigned int vendorUniqueInfo_1

Vendor unique info 1.

unsigned int vendorUniqueInfo_2

Vendor unique info 2.

unsigned int vendorUniqueInfo_3

Vendor unique info 3.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: EmbeddedImageInfo Struct Reference

  • FlyCapture2
  • EmbeddedImageInfo
Public Attributes
EmbeddedImageInfo Struct Reference
Structures

Properties of the possible embedded image information. More...

Collaboration diagram for EmbeddedImageInfo:
[legend]

List of all members.

Public Attributes

EmbeddedImageInfoProperty timestamp
EmbeddedImageInfoProperty gain
EmbeddedImageInfoProperty shutter
EmbeddedImageInfoProperty brightness
EmbeddedImageInfoProperty exposure
EmbeddedImageInfoProperty whiteBalance
EmbeddedImageInfoProperty frameCounter
EmbeddedImageInfoProperty strobePattern
EmbeddedImageInfoProperty GPIOPinState
EmbeddedImageInfoProperty ROIPosition

Detailed Description

Properties of the possible embedded image information.

Member Data Documentation

EmbeddedImageInfoProperty brightness
EmbeddedImageInfoProperty exposure
EmbeddedImageInfoProperty frameCounter
EmbeddedImageInfoProperty gain
EmbeddedImageInfoProperty GPIOPinState
EmbeddedImageInfoProperty ROIPosition
EmbeddedImageInfoProperty shutter
EmbeddedImageInfoProperty strobePattern
EmbeddedImageInfoProperty timestamp
EmbeddedImageInfoProperty whiteBalance
The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: EmbeddedImageInfoProperty Struct Reference

  • FlyCapture2
  • EmbeddedImageInfoProperty
Public Member Functions | Public Attributes
EmbeddedImageInfoProperty Struct Reference
Structures

Properties of a single embedded image info property. More...

List of all members.

Public Member Functions

EmbeddedImageInfoProperty ()

Public Attributes

bool | available
Whether this property is available.
bool | onOff
Whether this property is on or off.

Detailed Description

Properties of a single embedded image info property.

Constructor & Destructor Documentation

EmbeddedImageInfoProperty ( ) [inline]

Member Data Documentation

bool available

Whether this property is available.

bool onOff

Whether this property is on or off.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Error Class Reference

  • FlyCapture2
  • Error
Public Member Functions | Friends
Error Class Reference

The Error object represents an error that is returned from the library. More...

List of all members.

Public Member Functions

Error ()
Default constructor.
Error (const Error &error)
Copy constructor.
virtual | ~Error ()
Default destructor.
virtual Error & | operator= (const Error &error)
Assignment operator.
virtual bool | operator== (const Error &error) const
Equality operator.
virtual bool | operator== (const ErrorType &errorType) const
Equality operator.
virtual bool | operator!= (const Error &error) const
Inequality operator.
virtual bool | operator!= (const ErrorType &errorType) const
Inequality operator.
virtual ErrorType | GetType () const
Retrieve the ErrorType of the error.
virtual const char * | GetDescription () const
Retrieve the top level description of the error that occurred.
virtual unsigned int | GetLine () const
Retrieve the line number where the error originated.
virtual const char * | GetFilename () const
Retrieve the source filename where the error originated.
virtual Error | GetCause () const
Get the error which caused this error.
virtual const char * | GetBuildDate () const
Retrieve the build date of the file where the error originated.
virtual const char * | CollectSupportInformation () const
Retrieve the support information.
virtual void | PrintErrorTrace () const
Print a formatted log trace to stderr.

Friends

class | InternalError

Detailed Description

The Error object represents an error that is returned from the library.

Overloaded operators allow comparisons against other Error objects or the ErrorType enumeration.

Constructor & Destructor Documentation

Error ( )

Default constructor.

Error ( const Error & error )

Copy constructor.

virtual ~Error ( ) [virtual]

Default destructor.

Member Function Documentation

virtual const char* CollectSupportInformation ( ) const [virtual]

Retrieve the support information.

It is not implemented in this release.

Returns:
A string containing support information.
virtual const char* GetBuildDate ( ) const [virtual]

Retrieve the build date of the file where the error originated.

Returns:
A string with the build date and time.
virtual Error GetCause ( ) const [virtual]

Get the error which caused this error.

Returns:
An error object representing the cause of this error.
virtual const char* GetDescription ( ) const [virtual]

Retrieve the top level description of the error that occurred.

Returns:
A string with the error description.
virtual const char* GetFilename ( ) const [virtual]

Retrieve the source filename where the error originated.

Returns:
A string with the file name.
virtual unsigned int GetLine ( ) const [virtual]

Retrieve the line number where the error originated.

Returns:
The line number.
virtual ErrorType GetType ( ) const [virtual]

Retrieve the ErrorType of the error.

Returns:
The ErrorType of the error.
virtual bool operator!= ( const Error & error ) const [virtual]

Inequality operator.

virtual bool operator!= ( const ErrorType & errorType ) const [virtual]

Inequality operator.

This overloaded operator compares the ErrorType of the Error against the specified ErrorType.

virtual Error& operator= ( const Error & error ) [virtual]

Assignment operator.

virtual bool operator== ( const Error & error ) const [virtual]

Equality operator.

virtual bool operator== ( const ErrorType & errorType ) const [virtual]

Equality operator.

This overloaded operator compares the ErrorType of the Error against the specified ErrorType.

virtual void PrintErrorTrace ( ) const [virtual]

Print a formatted log trace to stderr.

Friends And Related Function Documentation

friend class InternalError [friend]
The documentation for this class was generated from the following file:
  • Error.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: EventCallbackData Struct Reference

  • FlyCapture2
  • EventCallbackData
Public Attributes
EventCallbackData Struct Reference
Image saving structures.

List of all members.

Public Attributes

void * | EventUserData
Pointer to the user-supplied data struct.
size_t | EventUserDataSize
Size of the user data data supplied to the RegisterEvent() function.
const char * | EventName
The event name used to register the event.
long long unsigned | EventID
The device register which EventName maps to.
long long unsigned | EventTimestamp
Timestamp indicated the time (as reported by the camera) at which the camera exposure operation completed.
void * | EventData
A pointer to additional data pertaining to the event which just trigger the callback function.
size_t | EventDataSize
The size of the structure pointed to by EventData.

Member Data Documentation

void* EventData

A pointer to additional data pertaining to the event which just trigger the callback function.

The data may be of difference sizes or may not even be allocated, depending on the type of event which triggered the callback.

size_t EventDataSize

The size of the structure pointed to by EventData.

This value should be checked, especially if there are events which can trigger variable- length event data to be returned to the user when the callback function is issued.

long long unsigned EventID

The device register which EventName maps to.

Provides an alternate means of indexing into different event types.

const char* EventName

The event name used to register the event.

Provided so the user knows which event triggered the callback.

long long unsigned EventTimestamp

Timestamp indicated the time (as reported by the camera) at which the camera exposure operation completed.

This can be compared with image stimestamps if there is a need to map event timestamps to specific images, if applicable.

void* EventUserData

Pointer to the user-supplied data struct.

size_t EventUserDataSize

Size of the user data data supplied to the RegisterEvent() function.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: EventOptions Struct Reference

  • FlyCapture2
  • EventOptions
Public Attributes
EventOptions Struct Reference
Image saving structures.

Options for enabling device event registration. More...

List of all members.

Public Attributes

CameraEventCallback EventCallbackFcn
Callback function pointer.
const char * | EventName
Event name to register.
const void * | EventUserData
Pointer to callback data to be passed to the callback function.
size_t | EventUserDataSize
Size of the underlying struct passed as eventCallbackData for sanity checks.

Detailed Description

Options for enabling device event registration.

Member Data Documentation

CameraEventCallback EventCallbackFcn

Callback function pointer.

const char* EventName

Event name to register.

const void* EventUserData

Pointer to callback data to be passed to the callback function.

size_t EventUserDataSize

Size of the underlying struct passed as eventCallbackData for sanity checks.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FC2Config Struct Reference

  • FlyCapture2
  • FC2Config
Public Member Functions | Public Attributes
FC2Config Struct Reference
Structures

Configuration for a camera. More...

List of all members.

Public Member Functions

FC2Config ()

Public Attributes

unsigned int | numBuffers
Number of buffers used by the FlyCapture2 library to grab images.
unsigned int | numImageNotifications
Number of notifications per image.
unsigned int | minNumImageNotifications
Minimum number of notifications needed for the current image settings on the camera.
int | grabTimeout
Time in milliseconds that RetrieveBuffer() and WaitForBufferEvent() will wait for an image before timing out and returning.
GrabMode grabMode
Grab mode for the camera.
bool | highPerformanceRetrieveBuffer
This parameter enables RetrieveBuffer to run in high performance mode.
BusSpeed isochBusSpeed
Isochronous bus speed.
BusSpeed asyncBusSpeed
Asynchronous bus speed.
BandwidthAllocation bandwidthAllocation
Bandwidth allocation flag that tells the camera the bandwidth allocation strategy to employ.
unsigned int | registerTimeoutRetries
Number of retries to perform when a register read/write timeout is received by the library.
unsigned int | registerTimeout
Register read/write timeout value, in microseconds.
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Configuration for a camera.

These options are options that are generally should be set before starting isochronous transfer.

Constructor & Destructor Documentation

FC2Config ( ) [inline]

Member Data Documentation

BusSpeed asyncBusSpeed

Asynchronous bus speed.

BandwidthAllocation bandwidthAllocation

Bandwidth allocation flag that tells the camera the bandwidth allocation strategy to employ.

GrabMode grabMode

Grab mode for the camera.

The default is DROP_FRAMES.

int grabTimeout

Time in milliseconds that RetrieveBuffer() and WaitForBufferEvent() will wait for an image before timing out and returning.

bool highPerformanceRetrieveBuffer

This parameter enables RetrieveBuffer to run in high performance mode.

This means that any interaction with the camera, other then grabbing the image is disabled. Currently Retrieve buffer reads registers on the camera to determine which embedded image information settings have been enabled, and it reads what the bayer tile is currently set to. When High Performance mode is on, these reads are disabled. This means that any changes to the Bayer Tile or to the Embedded image info after StartCapture() will not be tracked when made using direct register writes. If the corresponding SetEmbededImageInfo() and GetEmbededImageInfo() calls are used then the changes will be appropriately reflected. This also means that changes to embedded image info from other processes will not be updated either.

BusSpeed isochBusSpeed

Isochronous bus speed.

unsigned int minNumImageNotifications

Minimum number of notifications needed for the current image settings on the camera.

Read-only value.

unsigned int numBuffers

Number of buffers used by the FlyCapture2 library to grab images.

unsigned int numImageNotifications

Number of notifications per image.

This value should only be set after the image settings to be used is set to the camera. The default number of notifications is 1.

There are 4 general scenarios:

  • 1 notification - End of image
  • 2 notifications - After first packet and end of image
  • 3 notifications - After first packet, middle of image, end of image
  • x notifications - After first packet, (x -2) spread evenly, end of image

Specifying zero for the number of notifications will be ignored (the current value will not be modified).

Note that the event numbers start at 0. Ex. when 3 notifications are used, the three events will be 0, 1 and 2.

unsigned int registerTimeout

Register read/write timeout value, in microseconds.

The default value is dependent on the interface type.

unsigned int registerTimeoutRetries

Number of retries to perform when a register read/write timeout is received by the library.

The default value is 0.

unsigned int reserved[16]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FC2Version Struct Reference

  • FlyCapture2
  • FC2Version
Public Attributes
FC2Version Struct Reference
Structures

The current version of the library. More...

List of all members.

Public Attributes

unsigned int | major
Major version number.
unsigned int | minor
Minor version number.
unsigned int | type
Type version number.
unsigned int | build
Build version number.

Detailed Description

The current version of the library.

Member Data Documentation

unsigned int build

Build version number.

unsigned int major

Major version number.

unsigned int minor

Minor version number.

unsigned int type

Type version number.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FlyCapture3ApiGuiWrapper Class Reference

  • FlyCap3CameraControl
  • FlyCapture3ApiGuiWrapper
Public Member Functions
FlyCapture3ApiGuiWrapper Class Reference

List of all members.

Public Member Functions

WRAPPER_API | FlyCapture3ApiGuiWrapper (void)
WRAPPER_API | ~FlyCapture3ApiGuiWrapper (void)
WRAPPER_API void | ConnectGUILibrary (FlyCapture2::GCCamera &camera)
WRAPPER_API void | DisconnectGUILibrary ()
WRAPPER_API void | ShowPropertyGridDialog ()
WRAPPER_API void | ShowCameraSelectionDialog ()
WRAPPER_API int | GetNumDialogs ()
WRAPPER_API std::list
< std::string > 		GetDialogNameList ()
WRAPPER_API void | ShowDialogByName (std::string dialogName)
WRAPPER_API void | ShowDialogByIndex (int index)
WRAPPER_API int | GetNumOfControls ()
WRAPPER_API std::list
< std::string > 		GetControlNameList ()

Constructor & Destructor Documentation

WRAPPER_API FlyCapture3ApiGuiWrapper ( void )
WRAPPER_API ~FlyCapture3ApiGuiWrapper ( void )

Member Function Documentation

WRAPPER_API void ConnectGUILibrary ( FlyCapture2::GCCamera & camera )
WRAPPER_API void DisconnectGUILibrary ( )
WRAPPER_API std::list<std::string> GetControlNameList ( )
WRAPPER_API std::list<std::string> GetDialogNameList ( )
WRAPPER_API int GetNumDialogs ( )
WRAPPER_API int GetNumOfControls ( )
WRAPPER_API void ShowCameraSelectionDialog ( )
WRAPPER_API void ShowDialogByIndex ( int index )
WRAPPER_API void ShowDialogByName ( std::string dialogName )
WRAPPER_API void ShowPropertyGridDialog ( )
The documentation for this class was generated from the following file:
  • FlyCapture3ApiGuiWrapper.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Format7ImageSettings Struct Reference

  • FlyCapture2
  • Format7ImageSettings
Public Member Functions | Public Attributes
Format7ImageSettings Struct Reference
Structures | IIDC specific structures

Format 7 image settings. More...

List of all members.

Public Member Functions

Format7ImageSettings ()

Public Attributes

Mode mode
Format 7 mode.
unsigned int | offsetX
Horizontal image offset.
unsigned int | offsetY
Vertical image offset.
unsigned int | width
Width of image.
unsigned int | height
Height of image.
PixelFormat pixelFormat
Pixel format of image.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

Format 7 image settings.

Constructor & Destructor Documentation

Format7ImageSettings ( ) [inline]

Member Data Documentation

unsigned int height

Height of image.

Mode mode

Format 7 mode.

unsigned int offsetX

Horizontal image offset.

unsigned int offsetY

Vertical image offset.

PixelFormat pixelFormat

Pixel format of image.

unsigned int reserved[8]

Reserved for future use.

unsigned int width

Width of image.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Format7Info Struct Reference

  • FlyCapture2
  • Format7Info
Public Member Functions | Public Attributes
Format7Info Struct Reference
IIDC specific structures

Format 7 information for a single mode. More...

List of all members.

Public Member Functions

Format7Info ()

Public Attributes

Mode mode
Format 7 mode.
unsigned int | maxWidth
Maximum image width.
unsigned int | maxHeight
Maximum image height.
unsigned int | offsetHStepSize
Horizontal step size for the offset.
unsigned int | offsetVStepSize
Vertical step size for the offset.
unsigned int | imageHStepSize
Horizontal step size for the image.
unsigned int | imageVStepSize
Vertical step size for the image.
unsigned int | pixelFormatBitField
Supported pixel formats in a bit field.
unsigned int | vendorPixelFormatBitField
Vendor unique pixel formats in a bit field.
unsigned int | packetSize
Current packet size in bytes.
unsigned int | minPacketSize
Minimum packet size in bytes for current mode.
unsigned int | maxPacketSize
Maximum packet size in bytes for current mode.
float | percentage
Current packet size as a percentage of maximum packet size.
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Format 7 information for a single mode.

Constructor & Destructor Documentation

Format7Info ( ) [inline]

Member Data Documentation

unsigned int imageHStepSize

Horizontal step size for the image.

unsigned int imageVStepSize

Vertical step size for the image.

unsigned int maxHeight

Maximum image height.

unsigned int maxPacketSize

Maximum packet size in bytes for current mode.

unsigned int maxWidth

Maximum image width.

unsigned int minPacketSize

Minimum packet size in bytes for current mode.

Mode mode

Format 7 mode.

unsigned int offsetHStepSize

Horizontal step size for the offset.

unsigned int offsetVStepSize

Vertical step size for the offset.

unsigned int packetSize

Current packet size in bytes.

float percentage

Current packet size as a percentage of maximum packet size.

unsigned int pixelFormatBitField

Supported pixel formats in a bit field.

unsigned int reserved[16]

Reserved for future use.

unsigned int vendorPixelFormatBitField

Vendor unique pixel formats in a bit field.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Format7PacketInfo Struct Reference

  • FlyCapture2
  • Format7PacketInfo
Public Member Functions | Public Attributes
Format7PacketInfo Struct Reference
IIDC specific structures

Format 7 packet information. More...

List of all members.

Public Member Functions

Format7PacketInfo ()

Public Attributes

unsigned int | recommendedBytesPerPacket
Recommended bytes per packet.
unsigned int | maxBytesPerPacket
Maximum bytes per packet.
unsigned int | unitBytesPerPacket
Minimum bytes per packet.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

Format 7 packet information.

Constructor & Destructor Documentation

Format7PacketInfo ( ) [inline]

Member Data Documentation

unsigned int maxBytesPerPacket

Maximum bytes per packet.

unsigned int recommendedBytesPerPacket

Recommended bytes per packet.

unsigned int reserved[8]

Reserved for future use.

unsigned int unitBytesPerPacket

Minimum bytes per packet.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GCCamera Class Reference

  • FlyCapture2
  • GCCamera
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes
GCCamera Class Reference
Inheritance diagram for GCCamera:
[legend]
Collaboration diagram for GCCamera:
[legend]

List of all members.

Public Member Functions

GCCamera (void)
virtual | ~GCCamera (void)
::GenApi::INodeMap * | GetNodeMap ()
Error | SetCamera (CameraBase *camera)
Error | SetCamera (CameraBase *camera, const char *filepath=NULL)
std::string | GCCamera::GetXML ()
virtual Error | WriteGVCPRegister (unsigned int address, unsigned int value, bool broadcast=false)
virtual Error | ReadGVCPRegister (unsigned int address, unsigned int *pValue)
virtual Error | WriteGVCPRegisterBlock (unsigned int address, const unsigned int *pBuffer, unsigned int length)
virtual Error | ReadGVCPRegisterBlock (unsigned int address, unsigned int *pBuffer, unsigned int length)
virtual Error | WriteGVCPMemory (unsigned int address, const unsigned char *pBuffer, unsigned int length)
virtual Error | ReadGVCPMemory (unsigned int address, unsigned char *pBuffer, unsigned int length)
virtual Error | Connect (PGRGuid *pGuid=NULL)
The following functions are inherited from CameraBase.
Error | Connect (PGRGuid *pGuid=NULL, const char *filepath=NULL)
virtual Error | Disconnect ()
Disconnects the camera object from the camera.
virtual bool | IsConnected ()
Checks if the camera object is connected to a physical camera specified by a GUID.
virtual Error | SetCallback (ImageEventCallback callbackFn, const void *pCallbackData=NULL)
Sets the callback data to be used on completion of image transfer.
virtual Error | StartCapture (ImageEventCallback callbackFn=NULL, const void *pCallbackData=NULL)
Starts isochronous image capture.
virtual Error | RetrieveBuffer (Image *pImage)
Retrieves the the next image object containing the next image.
virtual Error | StopCapture ()
Stops isochronous image transfer and cleans up all associated resources.
virtual Error | WaitForBufferEvent (Image *pImage, unsigned int eventNumber)
Retrieves the next image event containing the next part of the image.
virtual Error | SetUserBuffers (unsigned char *const pMemBuffers, int size, int numBuffers)
Specify user allocated buffers to use as image data buffers.
virtual Error | GetConfiguration (FC2Config *pConfig)
Get the configuration associated with the camera object.
virtual Error | SetConfiguration (const FC2Config *pConfig)
Set the configuration associated with the camera object.
virtual Error | GetCameraInfo (CameraInfo *pCameraInfo)
Retrieves information from the camera such as serial number, model name and other camera information.
virtual Error | GetPropertyInfo (PropertyInfo *pPropInfo)
Retrieves information about the specified camera property.
virtual Error | GetProperty (Property *pProp)
Reads the settings for the specified property from the camera.
virtual Error | SetProperty (const Property *pProp, bool broadcast=false)
Writes the settings for the specified property to the camera.
virtual Error | GetGPIOPinDirection (unsigned int pin, unsigned int *pDirection)
Get the GPIO pin direction for the specified pin.
virtual Error | SetGPIOPinDirection (unsigned int pin, unsigned int direction, bool broadcast=false)
Set the GPIO pin direction for the specified pin.
virtual Error | GetTriggerModeInfo (TriggerModeInfo *pTriggerModeInfo)
Retrieve trigger information from the camera.
virtual Error | GetTriggerMode (TriggerMode *pTriggerMode)
Retrieve current trigger settings from the camera.
virtual Error | SetTriggerMode (const TriggerMode *pTriggerMode, bool broadcast=false)
Set the specified trigger settings to the camera.
virtual Error | FireSoftwareTrigger (bool broadcast=false)
Fire the software trigger according to the DCAM specifications.
virtual Error | GetTriggerDelayInfo (TriggerDelayInfo *pTriggerDelayInfo)
Retrieve trigger delay information from the camera.
virtual Error | GetTriggerDelay (TriggerDelay *pTriggerDelay)
Retrieve current trigger delay settings from the camera.
virtual Error | SetTriggerDelay (const TriggerDelay *pTriggerDelay, bool broadcast=false)
Set the specified trigger delay settings to the camera.
virtual Error | GetStrobeInfo (StrobeInfo *pStrobeInfo)
Retrieve strobe information from the camera.
virtual Error | GetStrobe (StrobeControl *pStrobeControl)
Retrieve current strobe settings from the camera.
virtual Error | SetStrobe (const StrobeControl *pStrobeControl, bool broadcast=false)
Set current strobe settings to the camera.
virtual Error | GetLUTInfo (LUTData *pData)
Query if LUT support is available on the camera.
virtual Error | GetLUTBankInfo (unsigned int bank, bool *pReadSupported, bool *pWriteSupported)
Query the read/write status of a single LUT bank.
virtual Error | GetActiveLUTBank (unsigned int *pActiveBank)
Get the LUT bank that is currently being used.
virtual Error | SetActiveLUTBank (unsigned int activeBank)
Set the LUT bank that will be used.
virtual Error | EnableLUT (bool on)
Enable or disable LUT functionality on the camera.
virtual Error | GetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, unsigned int *pEntries)
Get the LUT channel settings from the camera.
virtual Error | SetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, const unsigned int *pEntries)
Set the LUT channel settings to the camera.
virtual Error | GetMemoryChannel (unsigned int *pCurrentChannel)
Retrieve the current memory channel from the camera.
virtual Error | SaveToMemoryChannel (unsigned int channel)
Save the current settings to the specfied current memory channel.
virtual Error | RestoreFromMemoryChannel (unsigned int channel)
Restore the specfied current memory channel.
virtual Error | GetMemoryChannelInfo (unsigned int *pNumChannels)
Query the camera for memory channel support.
virtual Error | GetEmbeddedImageInfo (EmbeddedImageInfo *pInfo)
Get the current status of the embedded image information register, as well as the availability of each embedded property.
virtual Error | SetEmbeddedImageInfo (EmbeddedImageInfo *pInfo)
Sets the on/off values of the embedded image information structure to the camera.
virtual Error | WriteRegister (unsigned int address, unsigned int value, bool broadcast=false)
Write to the specified register on the camera.
virtual Error | ReadRegister (unsigned int address, unsigned int *pValue)
Read the specified register from the camera.
virtual Error | WriteRegisterBlock (unsigned short addressHigh, unsigned int addressLow, const unsigned int *pBuffer, unsigned int length)
Write to the specified register block on the camera.
virtual Error | ReadRegisterBlock (unsigned short addressHigh, unsigned int addressLow, unsigned int *pBuffer, unsigned int length)
Read from the specified register block on the camera.
Error | GetCycleTime (TimeStamp *timeStamp)
Returns a Timestamp struct containing 1394 CYCLE_TIME information.
InterfaceType GetInterfaceType ()
virtual Error | GetStats (CameraStats *pStats)
virtual Error | ResetStats ()

Static Public Member Functions

static Error | StartSyncCapture (unsigned int numCameras, const GigECamera **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL)
static const char * | GetRegisterString (unsigned int registerVal)
Returns a text representation of the register value.

Protected Member Functions

void | TestGainNode ()

Protected Attributes

BusManager m_busMgr

Constructor & Destructor Documentation

GCCamera ( void )
virtual ~GCCamera ( void ) [virtual]

Member Function Documentation

virtual Error Connect ( PGRGuid * pGuid = NULL ) [virtual]

The following functions are inherited from CameraBase.

See CameraBase.h for further information.

Implements CameraBase.

Error Connect | ( | PGRGuid * | pGuid = NULL,
 |  | const char * | filepath = NULL
 | ) |  |
virtual Error Disconnect ( ) [virtual]

Disconnects the camera object from the camera.

This allows another physical camera specified by a GUID to be connected to the camera object.

See also:
Connect()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error EnableLUT ( bool on ) [virtual]

Enable or disable LUT functionality on the camera.

Parameters:
on Whether to enable or disable LUT.
See also:
GetLUTInfo()
GetLUTChannel()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error FireSoftwareTrigger ( bool broadcast = false ) [virtual]

Fire the software trigger according to the DCAM specifications.

Parameters:
broadcast Whether the action should be broadcast.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

std::string GCCamera::GetXML ( )
virtual Error GetActiveLUTBank ( unsigned int * pActiveBank ) [virtual]

Get the LUT bank that is currently being used.

For cameras with PGR LUT, the active bank is always 0.

Parameters:
pActiveBank The currently active bank.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetCameraInfo ( CameraInfo * pCameraInfo ) [virtual]

Retrieves information from the camera such as serial number, model name and other camera information.

Parameters:
pCameraInfo Pointer to the camera information structure to be filled.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetConfiguration ( FC2Config * pConfig ) [virtual]

Get the configuration associated with the camera object.

Parameters:
pConfig Pointer to the configuration structure to be filled.
See also:
SetConfiguration()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

Error GetCycleTime ( TimeStamp * timeStamp ) [virtual]

Returns a Timestamp struct containing 1394 CYCLE_TIME information.

Parameters:
registerVal The register value to query.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetEmbeddedImageInfo ( EmbeddedImageInfo * pInfo ) [virtual]

Get the current status of the embedded image information register, as well as the availability of each embedded property.

Parameters:
pInfo Structure to be filled.
See also:
SetEmbeddedImageInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int * | pDirection
 | ) |  | [virtual]

Get the GPIO pin direction for the specified pin.

This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
pDirection | Direction of the pin. 0 for input, 1 for output.
See also:
SetGPIOPinDirection()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

InterfaceType GetInterfaceType ( )
virtual Error GetLUTBankInfo | ( | unsigned int | bank,
 |  | bool * | pReadSupported,
 |  | bool * | pWriteSupported
 | ) |  | [virtual]

Query the read/write status of a single LUT bank.

Parameters:
bank | The bank to query.
pReadSupported | Whether reading from the bank is supported.
pWriteSupported | Whether writing to the bank is supported.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | unsigned int * | pEntries
 | ) |  | [virtual]

Get the LUT channel settings from the camera.

Parameters:
bank | Bank to retrieve.
channel | Channel to retrieve.
sizeEntries | Number of entries in LUT table to read.
pEntries | Array to store LUT entries.
See also:
GetLUTInfo()
EnableLUT()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetLUTInfo ( LUTData * pData ) [virtual]

Query if LUT support is available on the camera.

Note that some cameras may report support for the LUT and return an inputBitDepth of 0. In these cases use log2(numEntries) for the inputBitDepth.

Parameters:
pData The LUT structure to be filled.
See also:
EnableLUT()
GetLUTChannel()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetMemoryChannel ( unsigned int * pCurrentChannel ) [virtual]

Retrieve the current memory channel from the camera.

Parameters:
pCurrentChannel Current memory channel.
See also:
SaveToMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetMemoryChannelInfo ( unsigned int * pNumChannels ) [virtual]

Query the camera for memory channel support.

If the number of channels is 0, then memory channel support is not available.

Parameters:
pNumChannels Number of memory channels supported.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
RestoreFromMemoryChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

::GenApi::INodeMap* GetNodeMap ( )
virtual Error GetProperty ( Property * pProp ) [virtual]

Reads the settings for the specified property from the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. If auto is on, the integer and abs values returned may not be consistent with each other.

Parameters:
pProp Pointer to the Property structure to be filled.
See also:
GetPropertyInfo()
SetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetPropertyInfo ( PropertyInfo * pPropInfo ) [virtual]

Retrieves information about the specified camera property.

The property type must be specified in the PropertyInfo structure passed into the function in order for the function to succeed.

Parameters:
pPropInfo Pointer to the PropertyInfo structure to be filled.
See also:
GetProperty()
SetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

static const char* GetRegisterString ( unsigned int registerVal ) [static]

Returns a text representation of the register value.

Parameters:
registerVal The register value to query.
Returns:
The text representation of the register.

Reimplemented from CameraBase.

virtual Error GetStats ( CameraStats * pStats ) [virtual]

Implements CameraBase.

virtual Error GetStrobe ( StrobeControl * pStrobeControl ) [virtual]

Retrieve current strobe settings from the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
pStrobeControl Structure to receive strobe settings.
See also:
GetStrobeInfo()
SetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetStrobeInfo ( StrobeInfo * pStrobeInfo ) [virtual]

Retrieve strobe information from the camera.

Parameters:
pStrobeInfo Structure to receive strobe information.
See also:
GetStrobe()
SetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerDelay ( TriggerDelay * pTriggerDelay ) [virtual]

Retrieve current trigger delay settings from the camera.

Parameters:
pTriggerDelay Structure to receive trigger delay settings.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerDelayInfo ( TriggerDelayInfo * pTriggerDelayInfo ) [virtual]

Retrieve trigger delay information from the camera.

Parameters:
pTriggerDelayInfo Structure to receive trigger delay information.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerMode ( TriggerMode * pTriggerMode ) [virtual]

Retrieve current trigger settings from the camera.

Parameters:
pTriggerMode Structure to receive trigger mode settings.
See also:
GetTriggerModeInfo()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerModeInfo ( TriggerModeInfo * pTriggerModeInfo ) [virtual]

Retrieve trigger information from the camera.

Parameters:
pTriggerModeInfo Structure to receive trigger information.
See also:
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual bool IsConnected ( ) [virtual]

Checks if the camera object is connected to a physical camera specified by a GUID.

See also:
Connect()
Disconnect()
Returns:
Whether Connect() was called on the camera object.

Implements CameraBase.

virtual Error ReadGVCPMemory | ( | unsigned int | address,
 |  | unsigned char * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]
virtual Error ReadGVCPRegister | ( | unsigned int | address,
 |  | unsigned int * | pValue
 | ) |  | [virtual]
virtual Error ReadGVCPRegisterBlock | ( | unsigned int | address,
 |  | unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]
virtual Error ReadRegister | ( | unsigned int | address,
 |  | unsigned int * | pValue
 | ) |  | [virtual]

Read the specified register from the camera.

Parameters:
address | DCAM address to be read from.
pValue | The value that is read.
See also:
WriteRegister()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error ReadRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Read from the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to read from.
addressLow | Bottom 32 bits of the 48 bits absolute address to read from.
pBuffer | Array to store read data.
length | Size of array, in quadlets.
See also:
WriteRegisterBlock()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error ResetStats ( ) [virtual]

Implements CameraBase.

virtual Error RestoreFromMemoryChannel ( unsigned int channel ) [virtual]

Restore the specfied current memory channel.

Parameters:
channel Memory channel to restore from.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error RetrieveBuffer ( Image * pImage ) [virtual]

Retrieves the the next image object containing the next image.

If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been retrieved by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be retrieved. Note that for the BUFFER_FRAMES case, if retrieval does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image retrieval.

Parameters:
pImage Pointer to Image object to store image data.
See also:
StartCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SaveToMemoryChannel ( unsigned int channel ) [virtual]

Save the current settings to the specfied current memory channel.

Parameters:
channel Memory channel to save to.
See also:
GetMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetActiveLUTBank ( unsigned int activeBank ) [virtual]

Set the LUT bank that will be used.

Parameters:
activeBank The bank to be set as active.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetCallback | ( | ImageEventCallback | callbackFn,
 |  | const void * | pCallbackData = NULL
 | ) |  | [virtual]

Sets the callback data to be used on completion of image transfer.

To clear the current stored callback data, pass in NULL for both arguments.

Parameters:
callbackFn | A function to be called when a new image is received.
pCallbackData | A pointer to data that can be passed to the callback function.
See also:
StartCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

Error SetCamera ( CameraBase * camera )
Error SetCamera | ( | CameraBase * | camera,
 |  | const char * | filepath = NULL
 | ) |  |
virtual Error SetConfiguration ( const FC2Config * pConfig ) [virtual]

Set the configuration associated with the camera object.

Parameters:
pConfig Pointer to the configuration structure to be used.
See also:
GetConfiguration()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetEmbeddedImageInfo ( EmbeddedImageInfo * pInfo ) [virtual]

Sets the on/off values of the embedded image information structure to the camera.

Parameters:
pInfo Structure to be used.
See also:
GetEmbeddedImageInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int | direction,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the GPIO pin direction for the specified pin.

This is useful if there is a need to set the pin into an input pin (i.e. to read the voltage) off the pin without setting it as a trigger source. This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
direction | Direction of the pin. 0 for input, 1 for output.
broadcast | Whether the action should be broadcast.
See also:
GetGPIOPinDirection()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | const unsigned int * | pEntries
 | ) |  | [virtual]

Set the LUT channel settings to the camera.

Parameters:
bank | Bank to set.
channel | Channel to set.
sizeEntries | Number of entries in LUT table to write. This must be the same size as numEntries returned by GetLutInfo().
pEntries | Array containing LUT entries to write.
See also:
GetLUTInfo()
EnableLUT()
GetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetProperty | ( | const Property * | pProp,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Writes the settings for the specified property to the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. The absControl flag controls whether the absolute or integer value is written to the camera. Use GetPropertyInfo() to query which options are available for a specific property.

Parameters:
pProp | Pointer to the Property structure to be used.
broadcast | Whether the action should be broadcast.
See also:
GetPropertyInfo()
GetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetStrobe | ( | const StrobeControl * | pStrobeControl,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set current strobe settings to the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
pStrobeControl | Structure providing strobe settings.
broadcast | Whether the action should be broadcast.
See also:
GetStrobeInfo()
GetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetTriggerDelay | ( | const TriggerDelay * | pTriggerDelay,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the specified trigger delay settings to the camera.

Parameters:
pTriggerDelay | Structure providing trigger delay settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetTriggerMode | ( | const TriggerMode * | pTriggerMode,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the specified trigger settings to the camera.

Parameters:
pTriggerMode | Structure providing trigger mode settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetUserBuffers | ( | unsigned char *const | pMemBuffers,
 |  | int | size,
 |  | int | numBuffers
 | ) |  | [virtual]

Specify user allocated buffers to use as image data buffers.

To prevent image tearing, the size of each buffer should be equal to ((unsigned int)(bufferSize + packetSize - 1)/packetSize) * packetSize. The total size should be (size * numBuffers) or larger. The packet Size that should be used differs between interfaces: Firewire: Use the Format7 packet size. Usb2: First round to Format7 packet size then round to 512 bytes. Usb3: Use a packet size of 1024 bytes. GigE: No need to do any rounding on GigE

Parameters:
pMemBuffers | Pointer to memory buffers to be written to.
size | The size of each buffer (in bytes).
numBuffers | Number of buffers in the array.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error StartCapture | ( | ImageEventCallback | callbackFn = NULL,
 |  | const void * | pCallbackData = NULL
 | ) |  | [virtual]

Starts isochronous image capture.

It will use either the current video mode or the most recently set video mode of the camera. The optional callback function parameter is called on completion of image transfer. When a callback function is specified, the grab mode will determine how images are delivered. If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been delivered by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be delivered. Note that for the BUFFER_FRAMES case, if delivery does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image delivery Alternatively, the callback parameter can be set to NULL and RetrieveBuffer() can be called as a blocking call to get the image data.

Parameters:
callbackFn | A function to be called when a new image is received.
pCallbackData | A pointer to data that can be passed to the callback function.
See also:
RetrieveBuffer()
StartSyncCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

static Error StartSyncCapture | ( | unsigned int | numCameras,
 |  | const GigECamera ** | ppCameras,
 |  | const ImageEventCallback * | pCallbackFns = NULL,
 |  | const void ** | pCallbackDataArray = NULL
 | ) |  | [static]
virtual Error StopCapture ( ) [virtual]

Stops isochronous image transfer and cleans up all associated resources.

If an image callback function (specified in the StartCapture() call) is currently executing, StopCapture() will not return until after the callback has completed.

See also:
StartCapture()
RetrieveBuffer()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

void TestGainNode ( ) [protected]
virtual Error WaitForBufferEvent | ( | Image * | pImage,
 |  | unsigned int | eventNumber
 | ) |  | [virtual]

Retrieves the next image event containing the next part of the image.

Parameters:
pImage | Pointer to Image object to store image data.
eventNumber | The event number to wait for.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error WriteGVCPMemory | ( | unsigned int | address,
 |  | const unsigned char * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]
virtual Error WriteGVCPRegister | ( | unsigned int | address,
 |  | unsigned int | value,
 |  | bool | broadcast = false
 | ) |  | [virtual]
virtual Error WriteGVCPRegisterBlock | ( | unsigned int | address,
 |  | const unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]
virtual Error WriteRegister | ( | unsigned int | address,
 |  | unsigned int | value,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Write to the specified register on the camera.

Parameters:
address | DCAM address to be written to.
value | The value to be written.
broadcast | Whether the action should be broadcast.
See also:
ReadRegister()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error WriteRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | const unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Write to the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to write to.
addressLow | Bottom 32 bits of the 48 bits absolute address to write to.
pBuffer | Array containing data to be written.
length | Size of array, in quadlets.
See also:
ReadRegisterBlock()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

Member Data Documentation

BusManager m_busMgr [protected]
The documentation for this class was generated from the following file:
  • GCCamera.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigECamera Class Reference

  • FlyCapture2
  • GigECamera
Public Member Functions | Static Public Member Functions
GigECamera Class Reference

The GigECamera object represents a physical Gigabit Ethernet camera. More...

Inheritance diagram for GigECamera:
[legend]
Collaboration diagram for GigECamera:
[legend]

List of all members.

Public Member Functions

GigECamera ()
Default constructor.
virtual | ~GigECamera ()
Default destructor.
virtual Error | Connect (PGRGuid *pGuid=NULL)
The following functions are inherited from CameraBase.
virtual Error | Disconnect ()
Disconnects the camera object from the camera.
virtual bool | IsConnected ()
Checks if the camera object is connected to a physical camera specified by a GUID.
virtual Error | SetCallback (ImageEventCallback callbackFn, const void *pCallbackData=NULL)
Sets the callback data to be used on completion of image transfer.
virtual Error | StartCapture (ImageEventCallback callbackFn=NULL, const void *pCallbackData=NULL)
Starts isochronous image capture.
virtual Error | RetrieveBuffer (Image *pImage)
Retrieves the the next image object containing the next image.
virtual Error | StopCapture ()
Stops isochronous image transfer and cleans up all associated resources.
virtual Error | WaitForBufferEvent (Image *pImage, unsigned int eventNumber)
Retrieves the next image event containing the next part of the image.
virtual Error | SetUserBuffers (unsigned char *const pMemBuffers, int size, int numBuffers)
Specify user allocated buffers to use as image data buffers.
virtual Error | GetConfiguration (FC2Config *pConfig)
Get the configuration associated with the camera object.
virtual Error | SetConfiguration (const FC2Config *pConfig)
Set the configuration associated with the camera object.
virtual Error | GetCameraInfo (CameraInfo *pCameraInfo)
Retrieves information from the camera such as serial number, model name and other camera information.
virtual Error | GetPropertyInfo (PropertyInfo *pPropInfo)
Retrieves information about the specified camera property.
virtual Error | GetProperty (Property *pProp)
Reads the settings for the specified property from the camera.
virtual Error | SetProperty (const Property *pProp, bool broadcast=false)
Writes the settings for the specified property to the camera.
virtual Error | GetGPIOPinDirection (unsigned int pin, unsigned int *pDirection)
Get the GPIO pin direction for the specified pin.
virtual Error | SetGPIOPinDirection (unsigned int pin, unsigned int direction, bool broadcast=false)
Set the GPIO pin direction for the specified pin.
virtual Error | GetTriggerModeInfo (TriggerModeInfo *pTriggerModeInfo)
Retrieve trigger information from the camera.
virtual Error | GetTriggerMode (TriggerMode *pTriggerMode)
Retrieve current trigger settings from the camera.
virtual Error | SetTriggerMode (const TriggerMode *pTriggerMode, bool broadcast=false)
Set the specified trigger settings to the camera.
virtual Error | FireSoftwareTrigger (bool broadcast=false)
Fire the software trigger according to the DCAM specifications.
virtual Error | GetTriggerDelayInfo (TriggerDelayInfo *pTriggerDelayInfo)
Retrieve trigger delay information from the camera.
virtual Error | GetTriggerDelay (TriggerDelay *pTriggerDelay)
Retrieve current trigger delay settings from the camera.
virtual Error | SetTriggerDelay (const TriggerDelay *pTriggerDelay, bool broadcast=false)
Set the specified trigger delay settings to the camera.
virtual Error | GetStrobeInfo (StrobeInfo *pStrobeInfo)
Retrieve strobe information from the camera.
virtual Error | GetStrobe (StrobeControl *pStrobeControl)
Retrieve current strobe settings from the camera.
virtual Error | SetStrobe (const StrobeControl *pStrobeControl, bool broadcast=false)
Set current strobe settings to the camera.
virtual Error | GetLUTInfo (LUTData *pData)
Query if LUT support is available on the camera.
virtual Error | GetLUTBankInfo (unsigned int bank, bool *pReadSupported, bool *pWriteSupported)
Query the read/write status of a single LUT bank.
virtual Error | GetActiveLUTBank (unsigned int *pActiveBank)
Get the LUT bank that is currently being used.
virtual Error | SetActiveLUTBank (unsigned int activeBank)
Set the LUT bank that will be used.
virtual Error | EnableLUT (bool on)
Enable or disable LUT functionality on the camera.
virtual Error | GetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, unsigned int *pEntries)
Get the LUT channel settings from the camera.
virtual Error | SetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, const unsigned int *pEntries)
Set the LUT channel settings to the camera.
virtual Error | GetMemoryChannel (unsigned int *pCurrentChannel)
Retrieve the current memory channel from the camera.
virtual Error | SaveToMemoryChannel (unsigned int channel)
Save the current settings to the specfied current memory channel.
virtual Error | RestoreFromMemoryChannel (unsigned int channel)
Restore the specfied current memory channel.
virtual Error | GetMemoryChannelInfo (unsigned int *pNumChannels)
Query the camera for memory channel support.
virtual Error | GetEmbeddedImageInfo (EmbeddedImageInfo *pInfo)
Get the current status of the embedded image information register, as well as the availability of each embedded property.
virtual Error | SetEmbeddedImageInfo (EmbeddedImageInfo *pInfo)
Sets the on/off values of the embedded image information structure to the camera.
virtual Error | WriteRegister (unsigned int address, unsigned int value, bool broadcast=false)
Write to the specified register on the camera.
virtual Error | ReadRegister (unsigned int address, unsigned int *pValue)
Read the specified register from the camera.
virtual Error | WriteRegisterBlock (unsigned short addressHigh, unsigned int addressLow, const unsigned int *pBuffer, unsigned int length)
Write to the specified register block on the camera.
virtual Error | ReadRegisterBlock (unsigned short addressHigh, unsigned int addressLow, unsigned int *pBuffer, unsigned int length)
Read from the specified register block on the camera.
Error | GetCycleTime (TimeStamp *timeStamp)
Returns a Timestamp struct containing 1394 CYCLE_TIME information.
virtual Error | GetStats (CameraStats *pStats)
virtual Error | ResetStats ()
virtual Error | RegisterEvent (EventOptions *pOpts)
virtual Error | DeregisterEvent (EventOptions *pOpts)
virtual Error | RegisterAllEvents (EventOptions *pOpts)
virtual Error | DeregisterAllEvents (void)

Static Public Member Functions

static Error | StartSyncCapture (unsigned int numCameras, const GigECamera **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL)
StartSyncCapture() with GigE Cameras is not supported.
static const char * | GetRegisterString (unsigned int registerVal)
Returns a text representation of the register value.

GVCP Register Operation

These functions deal with GVCP register operation on the camera.

virtual Error | WriteGVCPRegister (unsigned int address, unsigned int value, bool broadcast=false)
Write a GVCP register.
virtual Error | ReadGVCPRegister (unsigned int address, unsigned int *pValue)
Read a GVCP register.
virtual Error | WriteGVCPRegisterBlock (unsigned int address, const unsigned int *pBuffer, unsigned int length)
Write a GVCP register block.
virtual Error | ReadGVCPRegisterBlock (unsigned int address, unsigned int *pBuffer, unsigned int length)
Read a GVCP register block.
virtual Error | WriteGVCPMemory (unsigned int address, const unsigned char *pBuffer, unsigned int length)
Write a GVCP Memory block.
virtual Error | ReadGVCPMemory (unsigned int address, unsigned char *pBuffer, unsigned int length)
Read a GVCP memory block.

GigE property manipulation

These functions deal with GigE properties.

virtual Error | GetGigEProperty (GigEProperty *pGigEProp)
Get the specified GigEProperty.
virtual Error | SetGigEProperty (const GigEProperty *pGigEProp)
Set the specified GigEProperty.
virtual Error | DiscoverGigEPacketSize (unsigned int *packetSize)
Discover the largest packet size that works for the network link between the PC and the camera.

GigE image settings

These functions deal with GigE image setting.

virtual Error | QueryGigEImagingMode (Mode mode, bool *isSupported)
Check if the particular imaging mode is supported by the camera.
virtual Error | GetGigEImagingMode (Mode *mode)
Get the current imaging mode on the camera.
virtual Error | SetGigEImagingMode (Mode mode)
Set the current imaging mode to the camera.
virtual Error | GetGigEImageSettingsInfo (GigEImageSettingsInfo *pInfo)
Get information about the image settings possible on the camera.
virtual Error | GetGigEImageSettings (GigEImageSettings *pImageSettings)
Get the current image settings on the camera.
virtual Error | SetGigEImageSettings (const GigEImageSettings *pImageSettings)
Set the image settings specified to the camera.

GigE image binning settings

These functions deal with GigE image binning settings.

virtual Error | GetGigEImageBinningSettings (unsigned int *horzBinnningValue, unsigned int *vertBinnningValue)
Get the current binning settings on the camera.
virtual Error | SetGigEImageBinningSettings (unsigned int horzBinnningValue, unsigned int vertBinnningValue)
Set the specified binning values to the camera.

GigE image stream configuration

These functions deal with GigE image stream configuration.

virtual Error | GetNumStreamChannels (unsigned int *numChannels)
Get the number of stream channels present on the camera.
virtual Error | GetGigEStreamChannelInfo (unsigned int channel, GigEStreamChannel *pChannel)
Get the stream channel information for the specified channel.
virtual Error | SetGigEStreamChannelInfo (unsigned int channel, GigEStreamChannel *pChannel)
Set the stream channel information for the specified channel.
virtual Error | GetGigEConfig (GigEConfig *pGigEConfig)
Get the current gige config on the camera.
virtual Error | SetGigEConfig (const GigEConfig *pGigEConfig)
Set the gige config specified to the camera.

Detailed Description

The GigECamera object represents a physical Gigabit Ethernet camera.

The object must first be connected to using Connect() before any other operations can proceed.

Please see Camera.h for basic functions that this class inherits from.

Constructor & Destructor Documentation

GigECamera ( )

Default constructor.

virtual ~GigECamera ( ) [virtual]

Default destructor.

Member Function Documentation

virtual Error Connect ( PGRGuid * pGuid = NULL ) [virtual]

The following functions are inherited from CameraBase.

See CameraBase.h for further information.

Implements CameraBase.

virtual Error DeregisterAllEvents ( void ) [virtual]

Implements CameraBase.

virtual Error DeregisterEvent ( EventOptions * pOpts ) [virtual]

Implements CameraBase.

virtual Error Disconnect ( ) [virtual]

Disconnects the camera object from the camera.

This allows another physical camera specified by a GUID to be connected to the camera object.

See also:
Connect()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error DiscoverGigEPacketSize ( unsigned int * packetSize ) [virtual]

Discover the largest packet size that works for the network link between the PC and the camera.

This is useful in cases where there may be multiple links between the PC and the camera and there is a possiblity of a component not supporting the recommended jumbo frame packet size of 9000.

Parameters:
packetSize The maximum packet size supported by the link.
Returns:
An Error indicating the success or failure of the function.
virtual Error EnableLUT ( bool on ) [virtual]

Enable or disable LUT functionality on the camera.

Parameters:
on Whether to enable or disable LUT.
See also:
GetLUTInfo()
GetLUTChannel()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error FireSoftwareTrigger ( bool broadcast = false ) [virtual]

Fire the software trigger according to the DCAM specifications.

Parameters:
broadcast Whether the action should be broadcast.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetActiveLUTBank ( unsigned int * pActiveBank ) [virtual]

Get the LUT bank that is currently being used.

For cameras with PGR LUT, the active bank is always 0.

Parameters:
pActiveBank The currently active bank.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetCameraInfo ( CameraInfo * pCameraInfo ) [virtual]

Retrieves information from the camera such as serial number, model name and other camera information.

Parameters:
pCameraInfo Pointer to the camera information structure to be filled.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetConfiguration ( FC2Config * pConfig ) [virtual]

Get the configuration associated with the camera object.

Parameters:
pConfig Pointer to the configuration structure to be filled.
See also:
SetConfiguration()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

Error GetCycleTime ( TimeStamp * timeStamp ) [virtual]

Returns a Timestamp struct containing 1394 CYCLE_TIME information.

Parameters:
registerVal The register value to query.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetEmbeddedImageInfo ( EmbeddedImageInfo * pInfo ) [virtual]

Get the current status of the embedded image information register, as well as the availability of each embedded property.

Parameters:
pInfo Structure to be filled.
See also:
SetEmbeddedImageInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetGigEConfig ( GigEConfig * pGigEConfig ) [virtual]

Get the current gige config on the camera.

Parameters:
pGigEConfig Current configuration on camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetGigEImageBinningSettings | ( | unsigned int * | horzBinnningValue,
 |  | unsigned int * | vertBinnningValue
 | ) |  | [virtual]

Get the current binning settings on the camera.

Parameters:
horzBinnningValue | Current horizontal binning value.
vertBinnningValue | Current vertical binning value.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetGigEImageSettings ( GigEImageSettings * pImageSettings ) [virtual]

Get the current image settings on the camera.

Parameters:
pImageSettings Current image settings on camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetGigEImageSettingsInfo ( GigEImageSettingsInfo * pInfo ) [virtual]

Get information about the image settings possible on the camera.

Parameters:
pInfo Image settings information.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetGigEImagingMode ( Mode * mode ) [virtual]

Get the current imaging mode on the camera.

Parameters:
mode Current imaging mode on the camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetGigEProperty ( GigEProperty * pGigEProp ) [virtual]

Get the specified GigEProperty.

The GigEPropertyType field must be set in order for this function to succeed.

Parameters:
pGigEProp The GigE property to get.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetGigEStreamChannelInfo | ( | unsigned int | channel,
 |  | GigEStreamChannel * | pChannel
 | ) |  | [virtual]

Get the stream channel information for the specified channel.

Parameters:
channel | Channel number to use.
pChannel | Stream channel information for the specified channel.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int * | pDirection
 | ) |  | [virtual]

Get the GPIO pin direction for the specified pin.

This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
pDirection | Direction of the pin. 0 for input, 1 for output.
See also:
SetGPIOPinDirection()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetLUTBankInfo | ( | unsigned int | bank,
 |  | bool * | pReadSupported,
 |  | bool * | pWriteSupported
 | ) |  | [virtual]

Query the read/write status of a single LUT bank.

Parameters:
bank | The bank to query.
pReadSupported | Whether reading from the bank is supported.
pWriteSupported | Whether writing to the bank is supported.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | unsigned int * | pEntries
 | ) |  | [virtual]

Get the LUT channel settings from the camera.

Parameters:
bank | Bank to retrieve.
channel | Channel to retrieve.
sizeEntries | Number of entries in LUT table to read.
pEntries | Array to store LUT entries.
See also:
GetLUTInfo()
EnableLUT()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetLUTInfo ( LUTData * pData ) [virtual]

Query if LUT support is available on the camera.

Note that some cameras may report support for the LUT and return an inputBitDepth of 0. In these cases use log2(numEntries) for the inputBitDepth.

Parameters:
pData The LUT structure to be filled.
See also:
EnableLUT()
GetLUTChannel()
SetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetMemoryChannel ( unsigned int * pCurrentChannel ) [virtual]

Retrieve the current memory channel from the camera.

Parameters:
pCurrentChannel Current memory channel.
See also:
SaveToMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetMemoryChannelInfo ( unsigned int * pNumChannels ) [virtual]

Query the camera for memory channel support.

If the number of channels is 0, then memory channel support is not available.

Parameters:
pNumChannels Number of memory channels supported.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
RestoreFromMemoryChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetNumStreamChannels ( unsigned int * numChannels ) [virtual]

Get the number of stream channels present on the camera.

Parameters:
numChannels Number of stream channels present.
Returns:
An Error indicating the success or failure of the function.
virtual Error GetProperty ( Property * pProp ) [virtual]

Reads the settings for the specified property from the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. If auto is on, the integer and abs values returned may not be consistent with each other.

Parameters:
pProp Pointer to the Property structure to be filled.
See also:
GetPropertyInfo()
SetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetPropertyInfo ( PropertyInfo * pPropInfo ) [virtual]

Retrieves information about the specified camera property.

The property type must be specified in the PropertyInfo structure passed into the function in order for the function to succeed.

Parameters:
pPropInfo Pointer to the PropertyInfo structure to be filled.
See also:
GetProperty()
SetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

static const char* GetRegisterString ( unsigned int registerVal ) [static]

Returns a text representation of the register value.

Parameters:
registerVal The register value to query.
Returns:
The text representation of the register.

Reimplemented from CameraBase.

virtual Error GetStats ( CameraStats * pStats ) [virtual]

Implements CameraBase.

virtual Error GetStrobe ( StrobeControl * pStrobeControl ) [virtual]

Retrieve current strobe settings from the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
pStrobeControl Structure to receive strobe settings.
See also:
GetStrobeInfo()
SetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetStrobeInfo ( StrobeInfo * pStrobeInfo ) [virtual]

Retrieve strobe information from the camera.

Parameters:
pStrobeInfo Structure to receive strobe information.
See also:
GetStrobe()
SetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerDelay ( TriggerDelay * pTriggerDelay ) [virtual]

Retrieve current trigger delay settings from the camera.

Parameters:
pTriggerDelay Structure to receive trigger delay settings.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerDelayInfo ( TriggerDelayInfo * pTriggerDelayInfo ) [virtual]

Retrieve trigger delay information from the camera.

Parameters:
pTriggerDelayInfo Structure to receive trigger delay information.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerMode ( TriggerMode * pTriggerMode ) [virtual]

Retrieve current trigger settings from the camera.

Parameters:
pTriggerMode Structure to receive trigger mode settings.
See also:
GetTriggerModeInfo()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error GetTriggerModeInfo ( TriggerModeInfo * pTriggerModeInfo ) [virtual]

Retrieve trigger information from the camera.

Parameters:
pTriggerModeInfo Structure to receive trigger information.
See also:
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual bool IsConnected ( ) [virtual]

Checks if the camera object is connected to a physical camera specified by a GUID.

See also:
Connect()
Disconnect()
Returns:
Whether Connect() was called on the camera object.

Implements CameraBase.

virtual Error QueryGigEImagingMode | ( | Mode | mode,
 |  | bool * | isSupported
 | ) |  | [virtual]

Check if the particular imaging mode is supported by the camera.

Parameters:
mode | The mode to check.
isSupported | Whether the mode is supported.
Returns:
An Error indicating the success or failure of the function.
virtual Error ReadGVCPMemory | ( | unsigned int | address,
 |  | unsigned char * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Read a GVCP memory block.

Parameters:
address | GVCP address to be read from.
pBuffer | Array for data to be read into.
length | Size of array, in quadlets.
Returns:
An Error indicating the success or failure of the function.
virtual Error ReadGVCPRegister | ( | unsigned int | address,
 |  | unsigned int * | pValue
 | ) |  | [virtual]

Read a GVCP register.

Parameters:
address | GVCP address to be read from.
pValue | The value that is read.
Returns:
An Error indicating the success or failure of the function.
virtual Error ReadGVCPRegisterBlock | ( | unsigned int | address,
 |  | unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Read a GVCP register block.

Parameters:
address | GVCP address to be read from.
pBuffer | Array for data to be read into.
length | Size of array, in quadlets.
Returns:
An Error indicating the success or failure of the function.
virtual Error ReadRegister | ( | unsigned int | address,
 |  | unsigned int * | pValue
 | ) |  | [virtual]

Read the specified register from the camera.

Parameters:
address | DCAM address to be read from.
pValue | The value that is read.
See also:
WriteRegister()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error ReadRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Read from the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to read from.
addressLow | Bottom 32 bits of the 48 bits absolute address to read from.
pBuffer | Array to store read data.
length | Size of array, in quadlets.
See also:
WriteRegisterBlock()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error RegisterAllEvents ( EventOptions * pOpts ) [virtual]

Implements CameraBase.

virtual Error RegisterEvent ( EventOptions * pOpts ) [virtual]

Implements CameraBase.

virtual Error ResetStats ( ) [virtual]

Implements CameraBase.

virtual Error RestoreFromMemoryChannel ( unsigned int channel ) [virtual]

Restore the specfied current memory channel.

Parameters:
channel Memory channel to restore from.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error RetrieveBuffer ( Image * pImage ) [virtual]

Retrieves the the next image object containing the next image.

If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been retrieved by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be retrieved. Note that for the BUFFER_FRAMES case, if retrieval does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image retrieval.

Parameters:
pImage Pointer to Image object to store image data.
See also:
StartCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SaveToMemoryChannel ( unsigned int channel ) [virtual]

Save the current settings to the specfied current memory channel.

Parameters:
channel Memory channel to save to.
See also:
GetMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetActiveLUTBank ( unsigned int activeBank ) [virtual]

Set the LUT bank that will be used.

Parameters:
activeBank The bank to be set as active.
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetCallback | ( | ImageEventCallback | callbackFn,
 |  | const void * | pCallbackData = NULL
 | ) |  | [virtual]

Sets the callback data to be used on completion of image transfer.

To clear the current stored callback data, pass in NULL for both arguments.

Parameters:
callbackFn | A function to be called when a new image is received.
pCallbackData | A pointer to data that can be passed to the callback function.
See also:
StartCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetConfiguration ( const FC2Config * pConfig ) [virtual]

Set the configuration associated with the camera object.

Parameters:
pConfig Pointer to the configuration structure to be used.
See also:
GetConfiguration()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetEmbeddedImageInfo ( EmbeddedImageInfo * pInfo ) [virtual]

Sets the on/off values of the embedded image information structure to the camera.

Parameters:
pInfo Structure to be used.
See also:
GetEmbeddedImageInfo()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetGigEConfig ( const GigEConfig * pGigEConfig ) [virtual]

Set the gige config specified to the camera.

Parameters:
pGigEConfig configuration to set to camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error SetGigEImageBinningSettings | ( | unsigned int | horzBinnningValue,
 |  | unsigned int | vertBinnningValue
 | ) |  | [virtual]

Set the specified binning values to the camera.

It is recommended that GetGigEImageSettingsInfo() be called after this function succeeds to retrieve the new image settings information for the new binning mode.

Parameters:
horzBinnningValue | Horizontal binning value.
vertBinnningValue | Vertical binning value.
Returns:
An Error indicating the success or failure of the function.
virtual Error SetGigEImageSettings ( const GigEImageSettings * pImageSettings ) [virtual]

Set the image settings specified to the camera.

Parameters:
pImageSettings Image settings to set to camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error SetGigEImagingMode ( Mode mode ) [virtual]

Set the current imaging mode to the camera.

This should only be done when the camera is not streaming images.

Parameters:
mode Imaging mode to set to the camera.
Returns:
An Error indicating the success or failure of the function.
virtual Error SetGigEProperty ( const GigEProperty * pGigEProp ) [virtual]

Set the specified GigEProperty.

The GigEPropertyType field must be set in order for this function to succeed.

Parameters:
pGigEProp The GigE property to set.
Returns:
An Error indicating the success or failure of the function.
virtual Error SetGigEStreamChannelInfo | ( | unsigned int | channel,
 |  | GigEStreamChannel * | pChannel
 | ) |  | [virtual]

Set the stream channel information for the specified channel.

Note that the source UDP port of the stream channel is read-only.

Parameters:
channel | Channel number to use.
pChannel | Stream channel information to use for the specified channel.
Returns:
An Error indicating the success or failure of the function.
virtual Error SetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int | direction,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the GPIO pin direction for the specified pin.

This is useful if there is a need to set the pin into an input pin (i.e. to read the voltage) off the pin without setting it as a trigger source. This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
direction | Direction of the pin. 0 for input, 1 for output.
broadcast | Whether the action should be broadcast.
See also:
GetGPIOPinDirection()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | const unsigned int * | pEntries
 | ) |  | [virtual]

Set the LUT channel settings to the camera.

Parameters:
bank | Bank to set.
channel | Channel to set.
sizeEntries | Number of entries in LUT table to write. This must be the same size as numEntries returned by GetLutInfo().
pEntries | Array containing LUT entries to write.
See also:
GetLUTInfo()
EnableLUT()
GetLUTChannel()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetProperty | ( | const Property * | pProp,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Writes the settings for the specified property to the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. The absControl flag controls whether the absolute or integer value is written to the camera. Use GetPropertyInfo() to query which options are available for a specific property.

Parameters:
pProp | Pointer to the Property structure to be used.
broadcast | Whether the action should be broadcast.
See also:
GetPropertyInfo()
GetProperty()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetStrobe | ( | const StrobeControl * | pStrobeControl,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set current strobe settings to the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
pStrobeControl | Structure providing strobe settings.
broadcast | Whether the action should be broadcast.
See also:
GetStrobeInfo()
GetStrobe()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetTriggerDelay | ( | const TriggerDelay * | pTriggerDelay,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the specified trigger delay settings to the camera.

Parameters:
pTriggerDelay | Structure providing trigger delay settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetTriggerMode | ( | const TriggerMode * | pTriggerMode,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Set the specified trigger settings to the camera.

Parameters:
pTriggerMode | Structure providing trigger mode settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
SetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error SetUserBuffers | ( | unsigned char *const | pMemBuffers,
 |  | int | size,
 |  | int | numBuffers
 | ) |  | [virtual]

Specify user allocated buffers to use as image data buffers.

To prevent image tearing, the size of each buffer should be equal to ((unsigned int)(bufferSize + packetSize - 1)/packetSize) * packetSize. The total size should be (size * numBuffers) or larger. The packet Size that should be used differs between interfaces: Firewire: Use the Format7 packet size. Usb2: First round to Format7 packet size then round to 512 bytes. Usb3: Use a packet size of 1024 bytes. GigE: No need to do any rounding on GigE

Parameters:
pMemBuffers | Pointer to memory buffers to be written to.
size | The size of each buffer (in bytes).
numBuffers | Number of buffers in the array.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error StartCapture | ( | ImageEventCallback | callbackFn = NULL,
 |  | const void * | pCallbackData = NULL
 | ) |  | [virtual]

Starts isochronous image capture.

It will use either the current video mode or the most recently set video mode of the camera. The optional callback function parameter is called on completion of image transfer. When a callback function is specified, the grab mode will determine how images are delivered. If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been delivered by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be delivered. Note that for the BUFFER_FRAMES case, if delivery does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image delivery Alternatively, the callback parameter can be set to NULL and RetrieveBuffer() can be called as a blocking call to get the image data.

Parameters:
callbackFn | A function to be called when a new image is received.
pCallbackData | A pointer to data that can be passed to the callback function.
See also:
RetrieveBuffer()
StartSyncCapture()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

static Error StartSyncCapture | ( | unsigned int | numCameras,
 |  | const GigECamera ** | ppCameras,
 |  | const ImageEventCallback * | pCallbackFns = NULL,
 |  | const void ** | pCallbackDataArray = NULL
 | ) |  | [static]

StartSyncCapture() with GigE Cameras is not supported.

This function has been deprecated and will be removed in a future version of FlyCapture.

virtual Error StopCapture ( ) [virtual]

Stops isochronous image transfer and cleans up all associated resources.

If an image callback function (specified in the StartCapture() call) is currently executing, StopCapture() will not return until after the callback has completed.

See also:
StartCapture()
RetrieveBuffer()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error WaitForBufferEvent | ( | Image * | pImage,
 |  | unsigned int | eventNumber
 | ) |  | [virtual]

Retrieves the next image event containing the next part of the image.

Parameters:
pImage | Pointer to Image object to store image data.
eventNumber | The event number to wait for.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error WriteGVCPMemory | ( | unsigned int | address,
 |  | const unsigned char * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Write a GVCP Memory block.

Parameters:
address | GVCP address to be write to.
pBuffer | Array containing data to be written in increments.
length | Size of array, in quadlets.
Returns:
An Error indicating the success or failure of the function.
virtual Error WriteGVCPRegister | ( | unsigned int | address,
 |  | unsigned int | value,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Write a GVCP register.

Parameters:
address | GVCP address to be written to.
value | The value to be written.
broadcast | Whether the action should be broadcast.
Returns:
An Error indicating the success or failure of the function.
virtual Error WriteGVCPRegisterBlock | ( | unsigned int | address,
 |  | const unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Write a GVCP register block.

Parameters:
address | GVCP address to be write to.
pBuffer | Array containing data to be written.
length | Size of array, in quadlets.
Returns:
An Error indicating the success or failure of the function.
virtual Error WriteRegister | ( | unsigned int | address,
 |  | unsigned int | value,
 |  | bool | broadcast = false
 | ) |  | [virtual]

Write to the specified register on the camera.

Parameters:
address | DCAM address to be written to.
value | The value to be written.
broadcast | Whether the action should be broadcast.
See also:
ReadRegister()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

virtual Error WriteRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | const unsigned int * | pBuffer,
 |  | unsigned int | length
 | ) |  | [virtual]

Write to the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to write to.
addressLow | Bottom 32 bits of the 48 bits absolute address to write to.
pBuffer | Array containing data to be written.
length | Size of array, in quadlets.
See also:
ReadRegisterBlock()
Returns:
An Error indicating the success or failure of the function.

Implements CameraBase.

The documentation for this class was generated from the following file:
  • GigECamera.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigEConfig Struct Reference

  • FlyCapture2
  • GigEConfig
Public Member Functions | Public Attributes
GigEConfig Struct Reference
GigE specific structures

Configuration for a GigE camera. More...

List of all members.

Public Member Functions

GigEConfig ()

Public Attributes

bool | enablePacketResend
Turn on/off packet resend functionality.
unsigned int | registerTimeoutRetries
Number of retries to perform when a register read/write timeout is received by the library.
unsigned int | registerTimeout
Register read/write timeout value, in microseconds.

Detailed Description

Configuration for a GigE camera.

These options are options that are generally should be set before starting isochronous transfer.

Constructor & Destructor Documentation

GigEConfig ( ) [inline]

Member Data Documentation

bool enablePacketResend

Turn on/off packet resend functionality.

unsigned int registerTimeout

Register read/write timeout value, in microseconds.

The default value is dependent on the interface type.

unsigned int registerTimeoutRetries

Number of retries to perform when a register read/write timeout is received by the library.

The default value is 0.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigEImageSettings Struct Reference

  • FlyCapture2
  • GigEImageSettings
Public Member Functions | Public Attributes
GigEImageSettings Struct Reference
GigE specific structures

Image settings for a GigE camera. More...

List of all members.

Public Member Functions

GigEImageSettings ()

Public Attributes

unsigned int | offsetX
Horizontal image offset.
unsigned int | offsetY
Vertical image offset.
unsigned int | width
Width of image.
unsigned int | height
Height of image.
PixelFormat pixelFormat
Pixel format of image.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

Image settings for a GigE camera.

Constructor & Destructor Documentation

GigEImageSettings ( ) [inline]

Member Data Documentation

unsigned int height

Height of image.

unsigned int offsetX

Horizontal image offset.

unsigned int offsetY

Vertical image offset.

PixelFormat pixelFormat

Pixel format of image.

unsigned int reserved[8]

Reserved for future use.

unsigned int width

Width of image.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigEImageSettingsInfo Struct Reference

  • FlyCapture2
  • GigEImageSettingsInfo
Public Member Functions | Public Attributes
GigEImageSettingsInfo Struct Reference
GigE specific structures

Format 7 information for a single mode. More...

List of all members.

Public Member Functions

GigEImageSettingsInfo ()

Public Attributes

unsigned int | maxWidth
Maximum image width.
unsigned int | maxHeight
Maximum image height.
unsigned int | offsetHStepSize
Horizontal step size for the offset.
unsigned int | offsetVStepSize
Vertical step size for the offset.
unsigned int | imageHStepSize
Horizontal step size for the image.
unsigned int | imageVStepSize
Vertical step size for the image.
unsigned int | pixelFormatBitField
Supported pixel formats in a bit field.
unsigned int | vendorPixelFormatBitField
Vendor unique pixel formats in a bit field.
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Format 7 information for a single mode.

Constructor & Destructor Documentation

GigEImageSettingsInfo ( ) [inline]

Member Data Documentation

unsigned int imageHStepSize

Horizontal step size for the image.

unsigned int imageVStepSize

Vertical step size for the image.

unsigned int maxHeight

Maximum image height.

unsigned int maxWidth

Maximum image width.

unsigned int offsetHStepSize

Horizontal step size for the offset.

unsigned int offsetVStepSize

Vertical step size for the offset.

unsigned int pixelFormatBitField

Supported pixel formats in a bit field.

unsigned int reserved[16]

Reserved for future use.

unsigned int vendorPixelFormatBitField

Vendor unique pixel formats in a bit field.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigEProperty Struct Reference

  • FlyCapture2
  • GigEProperty
Public Attributes
GigEProperty Struct Reference
GigE specific structures

A GigE property. More...

List of all members.

Public Attributes

GigEPropertyType propType
The type of property.
bool | isReadable
Whether the property is readable.
bool | isWritable
Whether the property is writable.
unsigned int | min
Minimum value.
unsigned int | max
Maximum value.
unsigned int | value
Current value.

Detailed Description

A GigE property.

Member Data Documentation

bool isReadable

Whether the property is readable.

If this is false, then no other value in this structure is valid.

bool isWritable

Whether the property is writable.

unsigned int max

Maximum value.

unsigned int min

Minimum value.

GigEPropertyType propType

The type of property.

unsigned int value

Current value.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigEStreamChannel Struct Reference

  • FlyCapture2
  • GigEStreamChannel
Public Member Functions | Public Attributes
GigEStreamChannel Struct Reference
GigE specific structures

Information about a single GigE stream channel. More...

Collaboration diagram for GigEStreamChannel:
[legend]

List of all members.

Public Member Functions

GigEStreamChannel ()

Public Attributes

unsigned int | networkInterfaceIndex
Network interface index used (or to use).
unsigned int | hostPort
Host port on the PC where the camera will send the data stream.
bool | doNotFragment
Disable IP fragmentation of packets.
unsigned int | packetSize
Packet size, in bytes.
unsigned int | interPacketDelay
Inter packet delay, in timestamp counter units.
IPAddress destinationIpAddress
Destination IP address.
unsigned int | sourcePort
Source UDP port of the stream channel.

Detailed Description

Information about a single GigE stream channel.

Constructor & Destructor Documentation

GigEStreamChannel ( ) [inline]

Member Data Documentation

IPAddress destinationIpAddress

Destination IP address.

It can be a multicast or unicast address.

bool doNotFragment

Disable IP fragmentation of packets.

unsigned int hostPort

Host port on the PC where the camera will send the data stream.

unsigned int interPacketDelay

Inter packet delay, in timestamp counter units.

unsigned int networkInterfaceIndex

Network interface index used (or to use).

unsigned int packetSize

Packet size, in bytes.

unsigned int sourcePort

Source UDP port of the stream channel.

Read only.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: H264Option Struct Reference

  • FlyCapture2
  • H264Option
Public Member Functions | Public Attributes
H264Option Struct Reference
Image saving structures.

Options for saving H264 files. More...

List of all members.

Public Member Functions

H264Option ()

Public Attributes

float | frameRate
Frame rate of the stream.
unsigned int | width
Width of source image.
unsigned int | height
Height of source image.
unsigned int | bitrate
Bitrate to encode at.
unsigned int | reserved [256]
Reserved for future use.

Detailed Description

Options for saving H264 files.

Constructor & Destructor Documentation

H264Option ( ) [inline]

Member Data Documentation

unsigned int bitrate

Bitrate to encode at.

float frameRate

Frame rate of the stream.

unsigned int height

Height of source image.

unsigned int reserved[256]

Reserved for future use.

unsigned int width

Width of source image.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Image Class Reference

  • FlyCapture2
  • Image
Public Member Functions | Static Public Member Functions | Friends
Image Class Reference

The Image class is used to retrieve images from a camera, convert between multiple pixel formats and save images to disk. More...

List of all members.

Public Member Functions

Image ()
Default constructor.
Image (unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, PixelFormat format, BayerTileFormat bayerFormat=NONE)
Construct an Image object with the specified arguments.
Image (unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, unsigned int receivedDataSize, PixelFormat format, BayerTileFormat bayerFormat=NONE)
Construct an Image object with the specified arguments.
Image (unsigned char *pData, unsigned int dataSize)
Construct an Image object with the specified arguments.
Image (unsigned int rows, unsigned int cols, PixelFormat format, BayerTileFormat bayerFormat=NONE)
Construct an Image object with the specified arguments.
Image (const Image &image)
Copy constructor.
virtual | ~Image ()
Default destructor.
virtual Image & | operator= (const Image &image)
Assignment operator.
virtual unsigned char * | operator[] (unsigned int index)
Indexing operator.
virtual unsigned char * | operator() (unsigned int row, unsigned int col)
Indexing operator.
virtual Error | DeepCopy (const Image *pImage)
Perform a deep copy of the Image.
virtual Error | SetDimensions (unsigned int rows, unsigned int cols, unsigned int stride, PixelFormat pixelFormat, BayerTileFormat bayerFormat)
Sets the dimensions of the image object.
virtual Error | SetData (const unsigned char *pData, unsigned int dataSize)
Set the data of the Image object.
virtual Error | SetBlockId (const unsigned int blockId)
Set the block id of the Image object.
virtual unsigned int | GetBlockId ()
get the block id of the Image object.
virtual PixelFormat | GetPixelFormat () const
Get the current pixel format.
virtual ColorProcessingAlgorithm | GetColorProcessing () const
Get the current color processing algorithm.
virtual Error | SetColorProcessing (ColorProcessingAlgorithm colorProc)
Set the color processing algorithm.
virtual unsigned int | GetCols () const
Get the number of columns in the image.
virtual unsigned int | GetRows () const
Get the number of rows in the image.
virtual unsigned int | GetStride () const
Get the stride in the image.
virtual unsigned int | GetBitsPerPixel () const
Get the bits per pixel of the image.
virtual BayerTileFormat | GetBayerTileFormat () const
Get the Bayer tile format of the image.
virtual unsigned int | GetDataSize () const
Get the size of the buffer associated with the image, in bytes.
virtual unsigned int | GetReceivedDataSize () const
Get the size of the compressed data, in bytes.
virtual void | GetDimensions (unsigned int *pRows, unsigned int *pCols=NULL, unsigned int *pStride=NULL, PixelFormat *pPixelFormat=NULL, BayerTileFormat *pBayerFormat=NULL) const
Get the image dimensions associated with the image.
virtual unsigned char * | GetData ()
Get a pointer to the data associated with the image.
virtual unsigned char *const | GetData () const
virtual ImageMetadata | GetMetadata () const
Get the metadata associated with the image.
virtual Error | CalculateStatistics (ImageStatistics *pStatistics)
Calculate statistics associated with the image.
virtual TimeStamp | GetTimeStamp () const
Get the timestamp data associated with the image.
virtual Error | Save (const char *pFilename, ImageFileFormat format=FROM_FILE_EXT)
Save the image to the specified file name with the file format specified.
virtual Error | Save (const char *pFilename, PNGOption *pOption)
Save the image to the specified file name with the options specified.
virtual Error | Save (const char *pFilename, PPMOption *pOption)
Save the image to the specified file name with the options specified.
virtual Error | Save (const char *pFilename, PGMOption *pOption)
Save the image to the specified file name with the options specified.
virtual Error | Save (const char *pFilename, TIFFOption *pOption)
Save the image to the specified file name with the options specified.
virtual Error | Save (const char *pFilename, JPEGOption *pOption)
Save the image to the specified file name with the options specified.
virtual Error | Save (const char *pFilename, JPG2Option *pOption)
Save the image to the specified file name with the options specified.
virtual Error | Save (const char *pFilename, BMPOption *pOption)
Save the image to the specified file name with the options specified.
virtual Error | Convert (PixelFormat format, Image *pDestImage) const
Converts the current image buffer to the specified output format and stores the result in the specified image.
virtual Error | Convert (Image *pDestImage) const
Converts the current image buffer to the specified output format and stores the result in the specified image.
virtual Error | ReleaseBuffer ()
Release the buffer associated with the Image.

Static Public Member Functions

static Error | SetDefaultColorProcessing (ColorProcessingAlgorithm defaultMethod)
Set the default color processing algorithm.
static ColorProcessingAlgorithm | GetDefaultColorProcessing ()
Get the default color processing algorithm.
static Error | SetDefaultOutputFormat (PixelFormat format)
Set the default output pixel format.
static PixelFormat | GetDefaultOutputFormat ()
Get the default output pixel format.
static unsigned int | DetermineBitsPerPixel (PixelFormat format)
Calculate the bits per pixel for the specified pixel format.

Friends

class | Iso

Detailed Description

The Image class is used to retrieve images from a camera, convert between multiple pixel formats and save images to disk.

Operations on Image objects are not guaranteed to be thread safe. It is recommended that operations on Image objects be protected by thread synchronization constructs such as mutexes.

Constructor & Destructor Documentation

Image ( )

Default constructor.

Image | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | unsigned int | stride,
 |  | unsigned char * | pData,
 |  | unsigned int | dataSize,
 |  | PixelFormat | format,
 |  | BayerTileFormat | bayerFormat = NONE
 | ) |  |

Construct an Image object with the specified arguments.

Ownership of the image buffer is not transferred to the Image object. It is the user's responsibility to delete the buffer when it is no longer in use.

Parameters:
rows | Rows in the image.
cols | Columns in the image.
stride | Stride of the image buffer.
pData | Pointer to the image buffer.
dataSize | Size of the image buffer.
format | Pixel format.
bayerFormat | Format of the Bayer tiled raw image.
Image | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | unsigned int | stride,
 |  | unsigned char * | pData,
 |  | unsigned int | dataSize,
 |  | unsigned int | receivedDataSize,
 |  | PixelFormat | format,
 |  | BayerTileFormat | bayerFormat = NONE
 | ) |  |

Construct an Image object with the specified arguments.

Ownership of the image buffer is not transferred to the Image object. It is the user's responsibility to delete the buffer when it is no longer in use.

Parameters:
rows | Rows in the image.
cols | Columns in the image.
stride | Stride of the image buffer.
pData | Pointer to the image buffer.
dataSize | Size of the image buffer.
receivedDataSize | Actual size of data.
format | Pixel format.
bayerFormat | Format of the Bayer tiled raw image.
Image | ( | unsigned char * | pData,
 |  | unsigned int | dataSize
 | ) |  |

Construct an Image object with the specified arguments.

Ownership of the image buffer is not transferred to the Image object. It is the user's responsibility to delete the buffer when it is no longer in use.

Parameters:
pData | Pointer to the image buffer.
dataSize | Size of the image buffer.
Image | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | PixelFormat | format,
 |  | BayerTileFormat | bayerFormat = NONE
 | ) |  |

Construct an Image object with the specified arguments.

Parameters:
rows | Rows in the image.
cols | Columns in the image.
format | Pixel format.
bayerFormat | Format of the Bayer tiled raw image.
Image ( const Image & image )

Copy constructor.

Both images will point to the same image buffer internally.

virtual ~Image ( ) [virtual]

Default destructor.

The internal image buffer will be released if there are no other Image objects holding a reference to it. This will also allow the buffer to be requeued internally.

Member Function Documentation

virtual Error CalculateStatistics ( ImageStatistics * pStatistics ) [virtual]

Calculate statistics associated with the image.

In order to collect statistics for a particular channel, the enabled flag for the channel must be set to true. Statistics can only be collected for images in Mono8, Mono16, RGB, RGBU, BGR and BGRU.

Parameters:
pStatistics The ImageStatistics object to hold the statistics.
Returns:
An Error indicating the success or failure of the function.
virtual Error Convert | ( | PixelFormat | format,
 |  | Image * | pDestImage
 | ) |  | const [virtual]

Converts the current image buffer to the specified output format and stores the result in the specified image.

The destination image does not need to be configured in any way before the call is made.

Parameters:
format | Output format of the converted image.
pDestImage | Destination image.
Returns:
An Error indicating the success or failure of the function.
virtual Error Convert ( Image * pDestImage ) const [virtual]

Converts the current image buffer to the specified output format and stores the result in the specified image.

The destination image does not need to be configured in anyway before the call is made.

Parameters:
pDestImage Destination image.
Returns:
An Error indicating the success or failure of the function.
virtual Error DeepCopy ( const Image * pImage ) [virtual]

Perform a deep copy of the Image.

After this operation, the image contents and member variables will be the same. The Images will not share a buffer. The Image's current buffer will not be released.

Parameters:
pImage The Image to copy the data from.
Returns:
An Error indicating the success or failure of the function.
static unsigned int DetermineBitsPerPixel ( PixelFormat format ) [static]

Calculate the bits per pixel for the specified pixel format.

Parameters:
format The pixel format.
Returns:
The bits per pixel.
virtual BayerTileFormat GetBayerTileFormat ( ) const [virtual]

Get the Bayer tile format of the image.

Returns:
The Bayer tile format.
virtual unsigned int GetBitsPerPixel ( ) const [virtual]

Get the bits per pixel of the image.

Returns:
The bits per pixel.
virtual unsigned int GetBlockId ( ) [virtual]

get the block id of the Image object.

Returns:
The blockId assigned to the image.
virtual ColorProcessingAlgorithm GetColorProcessing ( ) const [virtual]

Get the current color processing algorithm.

See also:
SetColorProcessing()
Returns:
The current color processing algorithm.
virtual unsigned int GetCols ( ) const [virtual]

Get the number of columns in the image.

Returns:
The number of columns.
virtual unsigned char* GetData ( ) [virtual]

Get a pointer to the data associated with the image.

This function is considered unsafe. The pointer returned could be invalidated if the buffer is resized or released. The pointer may also be invalidated if the Image object is passed to Camera::RetrieveBuffer(). It is recommended that a Image::DeepCopy() be performed if a seperate copy of the Image data is required for further processing.

Returns:
A pointer to the image data.
virtual unsigned char* const GetData ( ) const [virtual]
virtual unsigned int GetDataSize ( ) const [virtual]

Get the size of the buffer associated with the image, in bytes.

Returns:
The size of the buffer, in bytes.
static ColorProcessingAlgorithm GetDefaultColorProcessing ( ) [static]

Get the default color processing algorithm.

See also:
SetDefaultColorProcessing()
Returns:
The default color processing algorithm.
static PixelFormat GetDefaultOutputFormat ( ) [static]

Get the default output pixel format.

See also:
SetDefaultOutputFormat()
Returns:
The default pixel format.
virtual void GetDimensions | ( | unsigned int * | pRows,
 |  | unsigned int * | pCols = NULL,
 |  | unsigned int * | pStride = NULL,
 |  | PixelFormat * | pPixelFormat = NULL,
 |  | BayerTileFormat * | pBayerFormat = NULL
 | ) |  | const [virtual]

Get the image dimensions associated with the image.

Parameters:
pRows | Number of rows.
pCols | Number of columns.
pStride | The stride.
pPixelFormat | Pixel format.
pBayerFormat | Bayer tile format.
virtual ImageMetadata GetMetadata ( ) const [virtual]

Get the metadata associated with the image.

This includes embedded image information.

Returns:
Metadata associated with the image.
virtual PixelFormat GetPixelFormat ( ) const [virtual]

Get the current pixel format.

Returns:
The current pixel format.
virtual unsigned int GetReceivedDataSize ( ) const [virtual]

Get the size of the compressed data, in bytes.

A compressed image will have a maximum size equal to GetDataSize(), but may actually contain less data, depending on the compression level. For uncompressed images, a value smaller than the data size may indicate lost data.

Returns:
The size of the compressed data, in bytes. 0 when camera not sending compressed data.
virtual unsigned int GetRows ( ) const [virtual]

Get the number of rows in the image.

Returns:
The number of rows.
virtual unsigned int GetStride ( ) const [virtual]

Get the stride in the image.

Returns:
The stride (The number of bytes between rows of the image).
virtual TimeStamp GetTimeStamp ( ) const [virtual]

Get the timestamp data associated with the image.

Returns:
Timestamp data associated with the image.
virtual unsigned char* operator() | ( | unsigned int | row,
 |  | unsigned int | col
 | ) |  | [virtual]

Indexing operator.

Parameters:
row | The row of the pixel to return.
col | The column of the pixel to return.
Returns:
The address of the specified byte from the image data.
virtual Image& operator= ( const Image & image ) [virtual]

Assignment operator.

Both images will point to the same image buffer internally. If the Image already has a buffer attached to it, it will will be released.

Parameters:
image The image to copy from.
virtual unsigned char* operator[] ( unsigned int index ) [virtual]

Indexing operator.

Parameters:
index The index of the byte to return.
Returns:
The address of the specified byte from the image data.
virtual Error ReleaseBuffer ( ) [virtual]

Release the buffer associated with the Image.

If no buffer is associated, the function does nothing.

Returns:
An Error indicating the success or failure of the function.
virtual Error Save | ( | const char * | pFilename,
 |  | ImageFileFormat | format = FROM_FILE_EXT
 | ) |  | [virtual]

Save the image to the specified file name with the file format specified.

Parameters:
pFilename | Filename to save image with.
format | File format to save in.
Returns:
An Error indicating the success or failure of the function.
virtual Error Save | ( | const char * | pFilename,
 |  | PNGOption * | pOption
 | ) |  | [virtual]

Save the image to the specified file name with the options specified.

Parameters:
pFilename | Filename to save image with.
pOption | Options to use while saving image.
Returns:
An Error indicating the success or failure of the function.
virtual Error Save | ( | const char * | pFilename,
 |  | PPMOption * | pOption
 | ) |  | [virtual]

Save the image to the specified file name with the options specified.

Parameters:
pFilename | Filename to save image with.
pOption | Options to use while saving image.
Returns:
An Error indicating the success or failure of the function.
virtual Error Save | ( | const char * | pFilename,
 |  | PGMOption * | pOption
 | ) |  | [virtual]

Save the image to the specified file name with the options specified.

Parameters:
pFilename | Filename to save image with.
pOption | Options to use while saving image.
Returns:
An Error indicating the success or failure of the function.
virtual Error Save | ( | const char * | pFilename,
 |  | TIFFOption * | pOption
 | ) |  | [virtual]

Save the image to the specified file name with the options specified.

Parameters:
pFilename | Filename to save image with.
pOption | Options to use while saving image.
Returns:
An Error indicating the success or failure of the function.
virtual Error Save | ( | const char * | pFilename,
 |  | JPEGOption * | pOption
 | ) |  | [virtual]

Save the image to the specified file name with the options specified.

Parameters:
pFilename | Filename to save image with.
pOption | Options to use while saving image.
Returns:
An Error indicating the success or failure of the function.
virtual Error Save | ( | const char * | pFilename,
 |  | JPG2Option * | pOption
 | ) |  | [virtual]

Save the image to the specified file name with the options specified.

Parameters:
pFilename | Filename to save image with.
pOption | Options to use while saving image.
Returns:
An Error indicating the success or failure of the function.
virtual Error Save | ( | const char * | pFilename,
 |  | BMPOption * | pOption
 | ) |  | [virtual]

Save the image to the specified file name with the options specified.

Parameters:
pFilename | Filename to save image with.
pOption | Options to use while saving image.
Returns:
An Error indicating the success or failure of the function.
virtual Error SetBlockId ( const unsigned int blockId ) [virtual]

Set the block id of the Image object.

Parameters:
blockId The blockId to assign to the image.
virtual Error SetColorProcessing ( ColorProcessingAlgorithm colorProc ) [virtual]

Set the color processing algorithm.

This should be set on the input Image object.

Parameters:
colorProc The color processing algorithm to use.
See also:
GetColorProcessing()
Returns:
An Error indicating the success or failure of the function.
virtual Error SetData | ( | const unsigned char * | pData,
 |  | unsigned int | dataSize
 | ) |  | [virtual]

Set the data of the Image object.

Ownership of the image buffer is not transferred to the Image object. It is the user's responsibility to delete the buffer when it is no longer in use.

Parameters:
pData | Pointer to the image buffer.
dataSize | Size of the image buffer.
static Error SetDefaultColorProcessing ( ColorProcessingAlgorithm defaultMethod ) [static]

Set the default color processing algorithm.

This method will be used for any image with the DEFAULT algorithm set. The method used is determined at the time of the Convert() call, therefore the most recent execution of this function will take precedence. The default setting is shared within the current process.

Parameters:
defaultMethod The color processing algorithm to set.
See also:
GetDefaultColorProcessing()
Returns:
An Error indicating the success or failure of the function.
static Error SetDefaultOutputFormat ( PixelFormat format ) [static]

Set the default output pixel format.

This format will be used for any call to Convert() that does not specify an output format. The format used will be determined at the time of the Convert() call, therefore the most recent execution of this function will take precedence. The default is shared within the current process.

Parameters:
format The output pixel format to set.
See also:
GetDefaultOutputFormat()
Returns:
The default color processing algorithm.
virtual Error SetDimensions | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | unsigned int | stride,
 |  | PixelFormat | pixelFormat,
 |  | BayerTileFormat | bayerFormat
 | ) |  | [virtual]

Sets the dimensions of the image object.

Parameters:
rows | Number of rows to set.
cols | Number of cols to set.
stride | Stride to set.
pixelFormat | Pixel format to set.
bayerFormat | Bayer tile format to set.
See also:
GetDimensions()
Returns:
An Error indicating the success or failure of the function.

Friends And Related Function Documentation

friend class Iso [friend]
The documentation for this class was generated from the following file:
  • Image.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: ImageMetadata Struct Reference

  • FlyCapture2
  • ImageMetadata
Public Member Functions | Public Attributes
ImageMetadata Struct Reference
Structures

Metadata related to an image. More...

List of all members.

Public Member Functions

ImageMetadata ()

Public Attributes

unsigned int | embeddedTimeStamp
Embedded timestamp.
unsigned int | embeddedGain
Embedded gain.
unsigned int | embeddedShutter
Embedded shutter.
unsigned int | embeddedBrightness
Embedded brightness.
unsigned int | embeddedExposure
Embedded exposure.
unsigned int | embeddedWhiteBalance
Embedded white balance.
unsigned int | embeddedFrameCounter
Embedded frame counter.
unsigned int | embeddedStrobePattern
Embedded strobe pattern.
unsigned int | embeddedGPIOPinState
Embedded GPIO pin state.
unsigned int | embeddedROIPosition
Embedded ROI position.
unsigned int | reserved [31]
Reserved for future use.

Detailed Description

Metadata related to an image.

Constructor & Destructor Documentation

ImageMetadata ( ) [inline]

Member Data Documentation

unsigned int embeddedBrightness

Embedded brightness.

unsigned int embeddedExposure

Embedded exposure.

unsigned int embeddedFrameCounter

Embedded frame counter.

unsigned int embeddedGain

Embedded gain.

unsigned int embeddedGPIOPinState

Embedded GPIO pin state.

unsigned int embeddedROIPosition

Embedded ROI position.

unsigned int embeddedShutter

Embedded shutter.

unsigned int embeddedStrobePattern

Embedded strobe pattern.

unsigned int embeddedTimeStamp

Embedded timestamp.

unsigned int embeddedWhiteBalance

Embedded white balance.

unsigned int reserved[31]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: ImageStatistics Class Reference

  • FlyCapture2
  • ImageStatistics
Public Types | Public Member Functions | Friends
ImageStatistics Class Reference

The ImageStatistics object represents image statistics for an image. More...

List of all members.

Public Types

enum StatisticsChannel {
GREY,
RED,
GREEN,
BLUE,
HUE,
SATURATION,
LIGHTNESS,
NUM_STATISTICS_CHANNELS
}
Channels that allow statistics to be calculated. More...

Public Member Functions

ImageStatistics ()
Default constructor.
virtual | ~ImageStatistics ()
Default destructor.
ImageStatistics (const ImageStatistics &other)
Copy constructor.
ImageStatistics & | operator= (const ImageStatistics &other)
Assignment operator.
Error EnableAll ()
Enable all channels.
Error DisableAll ()
Disable all channels.
Error EnableGreyOnly ()
Enable only the grey channel.
Error EnableRGBOnly ()
Enable only the RGB channels.
Error EnableHSLOnly ()
Enable only the HSL channels.
Error | GetChannelStatus (StatisticsChannel channel, bool *pEnabled) const
Get the status of a statistics channel.
Error | SetChannelStatus (StatisticsChannel channel, bool enabled)
Set the status of a statistics channel.
Error | GetRange (StatisticsChannel channel, unsigned int *pMin, unsigned int *pMax) const
Get the range of a statistics channel.
Error | GetPixelValueRange (StatisticsChannel channel, unsigned int *pPixelValueMin, unsigned int *pPixelValueMax) const
Get the range of a statistics channel.
Error | GetNumPixelValues (StatisticsChannel channel, unsigned int *pNumPixelValues) const
Get the number of unique pixel values in the image.
Error | GetMean (StatisticsChannel channel, float *pPixelValueMean) const
Get the mean of the image.
Error | GetHistogram (StatisticsChannel channel, int **ppHistogram) const
Get the histogram for the image.
Error | GetStatistics (StatisticsChannel channel, unsigned int *pRangeMin=NULL, unsigned int *pRangeMax=NULL, unsigned int *pPixelValueMin=NULL, unsigned int *pPixelValueMax=NULL, unsigned int *pNumPixelValues=NULL, float *pPixelValueMean=NULL, int **ppHistogram=NULL) const
Get all statistics for the image.

Friends

class | ImageStatsCalculator

Detailed Description

The ImageStatistics object represents image statistics for an image.

Member Enumeration Documentation

enum StatisticsChannel

Channels that allow statistics to be calculated.

Enumerator:
GREY
RED
GREEN
BLUE
HUE
SATURATION
LIGHTNESS
NUM_STATISTICS_CHANNELS

Constructor & Destructor Documentation

ImageStatistics ( )

Default constructor.

virtual ~ImageStatistics ( ) [virtual]

Default destructor.

ImageStatistics ( const ImageStatistics & other )

Copy constructor.

Member Function Documentation

Error DisableAll ( )

Disable all channels.

Returns:
An Error indicating the success or failure of the function.
Error EnableAll ( )

Enable all channels.

Returns:
An Error indicating the success or failure of the function.
Error EnableGreyOnly ( )

Enable only the grey channel.

Returns:
An Error indicating the success or failure of the function.
Error EnableHSLOnly ( )

Enable only the HSL channels.

Returns:
An Error indicating the success or failure of the function.
Error EnableRGBOnly ( )

Enable only the RGB channels.

Returns:
An Error indicating the success or failure of the function.
Error GetChannelStatus | ( | StatisticsChannel | channel,
 |  | bool * | pEnabled
 | ) |  | const

Get the status of a statistics channel.

Parameters:
channel | The statistics channel.
pEnabled | Whether the channel is enabled.
See also:
SetChannelStatus()
Returns:
An Error indicating the success or failure of the function.
Error GetHistogram | ( | StatisticsChannel | channel,
 |  | int ** | ppHistogram
 | ) |  | const

Get the histogram for the image.

Parameters:
channel | The statistics channel.
ppHistogram | Pointer to an array containing the histogram.
Returns:
An Error indicating the success or failure of the function.
Error GetMean | ( | StatisticsChannel | channel,
 |  | float * | pPixelValueMean
 | ) |  | const

Get the mean of the image.

Parameters:
channel | The statistics channel.
pPixelValueMean | The mean of the image.
Returns:
An Error indicating the success or failure of the function.
Error GetNumPixelValues | ( | StatisticsChannel | channel,
 |  | unsigned int * | pNumPixelValues
 | ) |  | const

Get the number of unique pixel values in the image.

Parameters:
channel | The statistics channel.
pNumPixelValues | The number of unique pixel values.
Returns:
An Error indicating the success or failure of the function.
Error GetPixelValueRange | ( | StatisticsChannel | channel,
 |  | unsigned int * | pPixelValueMin,
 |  | unsigned int * | pPixelValueMax
 | ) |  | const

Get the range of a statistics channel.

The values returned are the maximum values recorded for all pixels in the image.

Parameters:
channel | The statistics channel.
pPixelValueMin | The minimum pixel value.
pPixelValueMax | The maximum pixel value.
Returns:
An Error indicating the success or failure of the function.
Error GetRange | ( | StatisticsChannel | channel,
 |  | unsigned int * | pMin,
 |  | unsigned int * | pMax
 | ) |  | const

Get the range of a statistics channel.

The values returned are the maximum possible values for any given pixel in the image. This is generally 0-255 for 8 bit images, and 0-65535 for 16 bit images.

Parameters:
channel | The statistics channel.
pMin | The minimum possible value.
pMax | The maximum possible value.
Returns:
An Error indicating the success or failure of the function.
Error GetStatistics | ( | StatisticsChannel | channel,
 |  | unsigned int * | pRangeMin = NULL,
 |  | unsigned int * | pRangeMax = NULL,
 |  | unsigned int * | pPixelValueMin = NULL,
 |  | unsigned int * | pPixelValueMax = NULL,
 |  | unsigned int * | pNumPixelValues = NULL,
 |  | float * | pPixelValueMean = NULL,
 |  | int ** | ppHistogram = NULL
 | ) |  | const

Get all statistics for the image.

Parameters:
channel | The statistics channel.
pRangeMin | The minimum possible value.
pRangeMax | The maximum possible value.
pPixelValueMin | The minimum pixel value.
pPixelValueMax | The maximum pixel value.
pNumPixelValues | The number of unique pixel values.
pPixelValueMean | The mean of the image.
ppHistogram | Pointer to an array containing the histogram.
Returns:
An Error indicating the success or failure of the function.
ImageStatistics& operator= ( const ImageStatistics & other )

Assignment operator.

Parameters:
other The ImageStatistics object to copy from.
Error SetChannelStatus | ( | StatisticsChannel | channel,
 |  | bool | enabled
 | ) |  |

Set the status of a statistics channel.

Parameters:
channel | The statistics channel.
enabled | Whether the channel should be enabled.
See also:
GetChannelStatus()
Returns:
An Error indicating the success or failure of the function.

Friends And Related Function Documentation

friend class ImageStatsCalculator [friend]
The documentation for this class was generated from the following file:
  • ImageStatistics.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Internal Class Reference

  • FlyCapture2
  • Internal
Static Public Member Functions
Internal Class Reference

List of all members.

Static Public Member Functions

static void * GetInternal (unsigned int index)

Member Function Documentation

static void* GetInternal ( unsigned int index ) [static]
The documentation for this class was generated from the following file:
  • Internal.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: IPAddress Struct Reference

  • FlyCapture2
  • IPAddress
Public Member Functions | Public Attributes
IPAddress Struct Reference
Structures | GigE specific structures

IPv4 address. More...

List of all members.

Public Member Functions

IPAddress ()
IPAddress (unsigned int ipAddressVal)
bool | operator== (const IPAddress &address) const
Equality operator.
bool | operator!= (const IPAddress &address)
Inequality operator.

Public Attributes

unsigned char | octets [4]

Detailed Description

IPv4 address.

Constructor & Destructor Documentation

IPAddress ( ) [inline]
IPAddress ( unsigned int ipAddressVal ) [inline]

Member Function Documentation

bool operator!= ( const IPAddress & address ) [inline]

Inequality operator.

bool operator== ( const IPAddress & address ) const [inline]

Equality operator.

Member Data Documentation

unsigned char octets[4]
The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: JPEGOption Struct Reference

  • FlyCapture2
  • JPEGOption
Public Member Functions | Public Attributes
JPEGOption Struct Reference
Image saving structures.

Options for saving JPEG image. More...

List of all members.

Public Member Functions

JPEGOption ()

Public Attributes

bool | progressive
Whether to save as a progressive JPEG file.
unsigned int | quality
JPEG image quality in range (0-100).
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Options for saving JPEG image.

Constructor & Destructor Documentation

JPEGOption ( ) [inline]

Member Data Documentation

bool progressive

Whether to save as a progressive JPEG file.

unsigned int quality

JPEG image quality in range (0-100).

  • 100 - Superb quality.
  • 75 - Good quality.
  • 50 - Normal quality.
  • 10 - Poor quality.
unsigned int reserved[16]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: JPG2Option Struct Reference

  • FlyCapture2
  • JPG2Option
Public Member Functions | Public Attributes
JPG2Option Struct Reference
Image saving structures.

Options for saving JPEG2000 image. More...

List of all members.

Public Member Functions

JPG2Option ()

Public Attributes

unsigned int | quality
JPEG saving quality in range (1-512).
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Options for saving JPEG2000 image.

Constructor & Destructor Documentation

JPG2Option ( ) [inline]

Member Data Documentation

unsigned int quality

JPEG saving quality in range (1-512).

unsigned int reserved[16]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: LUTData Struct Reference

  • FlyCapture2
  • LUTData
Public Member Functions | Public Attributes
LUTData Struct Reference
Structures

Information about the camera's look up table. More...

List of all members.

Public Member Functions

LUTData ()

Public Attributes

bool | supported
Flag indicating if LUT is supported.
bool | enabled
Flag indicating if LUT is enabled.
unsigned int | numBanks
The number of LUT banks available (Always 1 for PGR LUT).
unsigned int | numChannels
The number of LUT channels per bank available.
unsigned int | inputBitDepth
The input bit depth of the LUT.
unsigned int | outputBitDepth
The output bit depth of the LUT.
unsigned int | numEntries
The number of entries in the LUT.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

Information about the camera's look up table.

Constructor & Destructor Documentation

LUTData ( ) [inline]

Member Data Documentation

bool enabled

Flag indicating if LUT is enabled.

unsigned int inputBitDepth

The input bit depth of the LUT.

unsigned int numBanks

The number of LUT banks available (Always 1 for PGR LUT).

unsigned int numChannels

The number of LUT channels per bank available.

unsigned int numEntries

The number of entries in the LUT.

unsigned int outputBitDepth

The output bit depth of the LUT.

unsigned int reserved[8]

Reserved for future use.

bool supported

Flag indicating if LUT is supported.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: MACAddress Struct Reference

  • FlyCapture2
  • MACAddress
Public Member Functions | Public Attributes
MACAddress Struct Reference
GigE specific structures

MAC address. More...

List of all members.

Public Member Functions

MACAddress ()
MACAddress (unsigned int macAddressValHigh, unsigned int macAddressValLow)
bool | operator== (const MACAddress &address) const
Equality operator.
bool | operator!= (const MACAddress &address)
Inequality operator.

Public Attributes

unsigned char | octets [6]

Detailed Description

MAC address.

Constructor & Destructor Documentation

MACAddress ( ) [inline]
MACAddress | ( | unsigned int | macAddressValHigh,
 |  | unsigned int | macAddressValLow
 | ) |  | [inline]

Member Function Documentation

bool operator!= ( const MACAddress & address ) [inline]

Inequality operator.

bool operator== ( const MACAddress & address ) const [inline]

Equality operator.

Member Data Documentation

unsigned char octets[6]
The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: MJPGOption Struct Reference

  • FlyCapture2
  • MJPGOption
Public Member Functions | Public Attributes
MJPGOption Struct Reference
Image saving structures.

Options for saving MJPG files. More...

List of all members.

Public Member Functions

MJPGOption ()

Public Attributes

float | frameRate
Frame rate of the stream.
unsigned int | quality
Image quality (1-100)
unsigned int | reserved [256]

Detailed Description

Options for saving MJPG files.

Constructor & Destructor Documentation

MJPGOption ( ) [inline]

Member Data Documentation

float frameRate

Frame rate of the stream.

unsigned int quality

Image quality (1-100)

unsigned int reserved[256]
The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: NodeMap Class Reference

  • FlyCapture2
  • NodeMap
Public Member Functions
NodeMap Class Reference

List of all members.

Public Member Functions

NodeMap (GenApi::CNodeMapRef *ref)
virtual | ~NodeMap (void)
GenICam::gcstring | _GetDeviceName ()
Get device name.
void | _Poll (int64_t ElapsedTime)
Fires nodes which have a polling time.
void | _GetNodes (NodeList_t &Nodes)
Retrieves all nodes in the node map.
INode * | _GetNode (const GenICam::gcstring &key)
Retrieves the node from the central map by name.
void | _InvalidateNodes () const
Invalidates all nodes.

Constructor & Destructor Documentation

NodeMap ( GenApi::CNodeMapRef * ref )
virtual ~NodeMap ( void ) [virtual]

Member Function Documentation

GenICam::gcstring _GetDeviceName ( )

Get device name.

INode* _GetNode ( const GenICam::gcstring & key )

Retrieves the node from the central map by name.

void _GetNodes ( NodeList_t & Nodes )

Retrieves all nodes in the node map.

void _InvalidateNodes ( ) const

Invalidates all nodes.

void _Poll ( int64_t ElapsedTime )

Fires nodes which have a polling time.

The documentation for this class was generated from the following file:
  • NodeMap.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: PGMOption Struct Reference

  • FlyCapture2
  • PGMOption
Public Member Functions | Public Attributes
PGMOption Struct Reference
Image saving structures.

Options for saving PGM images. More...

List of all members.

Public Member Functions

PGMOption ()

Public Attributes

bool | binaryFile
Whether to save the PPM as a binary file.
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Options for saving PGM images.

Constructor & Destructor Documentation

PGMOption ( ) [inline]

Member Data Documentation

bool binaryFile

Whether to save the PPM as a binary file.

unsigned int reserved[16]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: PGRGuid Class Reference

  • FlyCapture2
  • PGRGuid
Public Member Functions | Public Attributes
PGRGuid Class Reference
Structures

A GUID to the camera. More...

List of all members.

Public Member Functions

PGRGuid ()
Constructor.
bool | operator== (const PGRGuid &guid) const
Equality operator.
bool | operator!= (const PGRGuid &guid)
Inequality operator.

Public Attributes

unsigned int | value [4]

Detailed Description

A GUID to the camera.

It is used to uniquely identify a camera.

Constructor & Destructor Documentation

PGRGuid ( ) [inline]

Constructor.

Member Function Documentation

bool operator!= ( const PGRGuid & guid ) [inline]

Inequality operator.

bool operator== ( const PGRGuid & guid ) const [inline]

Equality operator.

Member Data Documentation

unsigned int value[4]
The documentation for this class was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: PNGOption Struct Reference

  • FlyCapture2
  • PNGOption
Public Member Functions | Public Attributes
PNGOption Struct Reference
Structures | Image saving structures.

Options for saving PNG images. More...

List of all members.

Public Member Functions

PNGOption ()

Public Attributes

bool | interlaced
Whether to save the PNG as interlaced.
unsigned int | compressionLevel
Compression level (0-9).
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Options for saving PNG images.

Constructor & Destructor Documentation

PNGOption ( ) [inline]

Member Data Documentation

unsigned int compressionLevel

Compression level (0-9).

0 is no compression, 9 is best compression.

bool interlaced

Whether to save the PNG as interlaced.

unsigned int reserved[16]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: PPMOption Struct Reference

  • FlyCapture2
  • PPMOption
Public Member Functions | Public Attributes
PPMOption Struct Reference
Image saving structures.

Options for saving PPM images. More...

List of all members.

Public Member Functions

PPMOption ()

Public Attributes

bool | binaryFile
Whether to save the PPM as a binary file.
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Options for saving PPM images.

Constructor & Destructor Documentation

PPMOption ( ) [inline]

Member Data Documentation

bool binaryFile

Whether to save the PPM as a binary file.

unsigned int reserved[16]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Property Struct Reference

  • FlyCapture2
  • Property
Public Member Functions | Public Attributes
Property Struct Reference
Structures

A specific camera property. More...

List of all members.

Public Member Functions

Property ()
Property (PropertyType propType)

Public Attributes

PropertyType type
Property info type.
bool | present
Flag indicating if the property is present.
bool | absControl
Flag controlling absolute mode (real world units) or non-absolute mode (camera internal units).
bool | onePush
Flag controlling one push.
bool | onOff
Flag controlling on/off.
bool | autoManualMode
Flag controlling auto.
unsigned int | valueA
Value A (integer).
unsigned int | valueB
Value B (integer).
float | absValue
Floating point value.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

A specific camera property.

For example, to set the gain to 12dB, set the following values:

  • type - GAIN
  • absControl - true
  • onePush - false
  • onOff - true
  • autoManualMode - false
  • absValue - 12.0

Constructor & Destructor Documentation

Property ( ) [inline]
Property ( PropertyType propType ) [inline]

Member Data Documentation

bool absControl

Flag controlling absolute mode (real world units) or non-absolute mode (camera internal units).

float absValue

Floating point value.

Used to configure properties in absolute mode.

bool autoManualMode

Flag controlling auto.

bool onePush

Flag controlling one push.

bool onOff

Flag controlling on/off.

bool present

Flag indicating if the property is present.

unsigned int reserved[8]

Reserved for future use.

PropertyType type

Property info type.

unsigned int valueA

Value A (integer).

Used to configure properties in non-absolute mode.

unsigned int valueB

Value B (integer).

For white balance, value B applies to the blue value and value A applies to the red value.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: PropertyInfo Struct Reference

  • FlyCapture2
  • PropertyInfo
Public Member Functions | Public Attributes
PropertyInfo Struct Reference
Structures

Information about a specific camera property. More...

List of all members.

Public Member Functions

PropertyInfo ()
PropertyInfo (PropertyType propType)

Public Attributes

PropertyType type
Property info type.
bool | present
Flag indicating if the property is present.
bool | autoSupported
Flag indicating if auto is supported.
bool | manualSupported
Flag indicating if manual is supported.
bool | onOffSupported
Flag indicating if on/off is supported.
bool | onePushSupported
Flag indicating if one push is supported.
bool | absValSupported
Flag indicating if absolute mode is supported.
bool | readOutSupported
Flag indicating if property value can be read out.
unsigned int | min
Minimum value (as an integer).
unsigned int | max
Maximum value (as an integer).
float | absMin
Minimum value (as a floating point value).
float | absMax
Maximum value (as a floating point value).
char | pUnits [sk_maxStringLength]
Textual description of units.
char | pUnitAbbr [sk_maxStringLength]
Abbreviated textual description of units.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

Information about a specific camera property.

This structure is also also used as the TriggerDelayInfo structure.

Constructor & Destructor Documentation

PropertyInfo ( ) [inline]
PropertyInfo ( PropertyType propType ) [inline]

Member Data Documentation

float absMax

Maximum value (as a floating point value).

float absMin

Minimum value (as a floating point value).

bool absValSupported

Flag indicating if absolute mode is supported.

bool autoSupported

Flag indicating if auto is supported.

bool manualSupported

Flag indicating if manual is supported.

unsigned int max

Maximum value (as an integer).

unsigned int min

Minimum value (as an integer).

bool onePushSupported

Flag indicating if one push is supported.

bool onOffSupported

Flag indicating if on/off is supported.

bool present

Flag indicating if the property is present.

char pUnitAbbr[sk_maxStringLength]

Abbreviated textual description of units.

char pUnits[sk_maxStringLength]

Textual description of units.

bool readOutSupported

Flag indicating if property value can be read out.

unsigned int reserved[8]

Reserved for future use.

PropertyType type

Property info type.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: StrobeControl Struct Reference

  • FlyCapture2
  • StrobeControl
Public Member Functions | Public Attributes
StrobeControl Struct Reference
Structures

A camera strobe. More...

List of all members.

Public Member Functions

StrobeControl ()

Public Attributes

unsigned int | source
Source value.
bool | onOff
Flag controlling on/off.
unsigned int | polarity
Signal polarity.
float | delay
Signal delay (in ms).
float | duration
Signal duration (in ms).
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

A camera strobe.

Constructor & Destructor Documentation

StrobeControl ( ) [inline]

Member Data Documentation

float delay

Signal delay (in ms).

float duration

Signal duration (in ms).

bool onOff

Flag controlling on/off.

unsigned int polarity

Signal polarity.

unsigned int reserved[8]

Reserved for future use.

unsigned int source

Source value.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: StrobeInfo Struct Reference

  • FlyCapture2
  • StrobeInfo
Public Member Functions | Public Attributes
StrobeInfo Struct Reference
Structures

A camera strobe property. More...

List of all members.

Public Member Functions

StrobeInfo ()

Public Attributes

unsigned int | source
Source value.
bool | present
Presence of strobe.
bool | readOutSupported
Flag indicating if strobe value can be read out.
bool | onOffSupported
Flag indicating if on/off is supported.
bool | polaritySupported
Flag indicating if polarity is supported.
float | minValue
Minimum value.
float | maxValue
Maximum value.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

A camera strobe property.

Constructor & Destructor Documentation

StrobeInfo ( ) [inline]

Member Data Documentation

float maxValue

Maximum value.

float minValue

Minimum value.

bool onOffSupported

Flag indicating if on/off is supported.

bool polaritySupported

Flag indicating if polarity is supported.

bool present

Presence of strobe.

bool readOutSupported

Flag indicating if strobe value can be read out.

unsigned int reserved[8]

Reserved for future use.

unsigned int source

Source value.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: SyncManager Class Reference

  • MultiSyncLibrary
  • SyncManager
Public Member Functions
SyncManager Class Reference

List of all members.

Public Member Functions

MULTISYNCLIBRARY_API | SyncManager ()
MULTISYNCLIBRARY_API | ~SyncManager ()
MULTISYNCLIBRARY_API PGRSyncError | Start ()
MULTISYNCLIBRARY_API PGRSyncError | Stop ()
MULTISYNCLIBRARY_API PGRSyncError | RescanMasterTimingBus ()
MULTISYNCLIBRARY_API PGRSyncMessage | GetSyncStatus ()
MULTISYNCLIBRARY_API double | GetTimeSinceSynced ()
MULTISYNCLIBRARY_API bool | IsTimingBusConnected ()
MULTISYNCLIBRARY_API bool | EnableCrossPCSynchronization ()
MULTISYNCLIBRARY_API bool | DisableCrossPCSynchronization ()
MULTISYNCLIBRARY_API bool | QueryCrossPCSynchronizationSetting ()

Constructor & Destructor Documentation

MULTISYNCLIBRARY_API SyncManager ( )
MULTISYNCLIBRARY_API ~SyncManager ( )

Member Function Documentation

MULTISYNCLIBRARY_API bool DisableCrossPCSynchronization ( )
MULTISYNCLIBRARY_API bool EnableCrossPCSynchronization ( )
MULTISYNCLIBRARY_API PGRSyncMessage GetSyncStatus ( )
MULTISYNCLIBRARY_API double GetTimeSinceSynced ( )
MULTISYNCLIBRARY_API bool IsTimingBusConnected ( )
MULTISYNCLIBRARY_API bool QueryCrossPCSynchronizationSetting ( )
MULTISYNCLIBRARY_API PGRSyncError RescanMasterTimingBus ( )
MULTISYNCLIBRARY_API PGRSyncError Start ( )
MULTISYNCLIBRARY_API PGRSyncError Stop ( )
The documentation for this class was generated from the following file:
  • MultiSyncLibraryDefs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: SystemInfo Struct Reference

  • FlyCapture2
  • SystemInfo
Public Attributes
SystemInfo Struct Reference

Description of the system. More...

List of all members.

Public Attributes

OSType osType
Operating system type as described by OSType.
char | osDescription [sk_maxStringLength]
Detailed description of the operating system.
ByteOrder byteOrder
Byte order of the system.
size_t | sysMemSize
Amount of memory available on the system.
char | cpuDescription [sk_maxStringLength]
Detailed description of the CPU.
size_t | numCpuCores
Number of cores on all CPUs on the system.
char | driverList [sk_maxStringLength]
List of drivers used.
char | libraryList [sk_maxStringLength]
List of libraries used.
char | gpuDescription [sk_maxStringLength]
Detailed description of the GPU.
size_t | screenWidth
Screen resolution width in pixels.
size_t | screenHeight
Screen resolution height in pixels.
unsigned int | reserved [16]
Reserved for future use.

Detailed Description

Description of the system.

Member Data Documentation

ByteOrder byteOrder

Byte order of the system.

char cpuDescription[sk_maxStringLength]

Detailed description of the CPU.

char driverList[sk_maxStringLength]

List of drivers used.

char gpuDescription[sk_maxStringLength]

Detailed description of the GPU.

char libraryList[sk_maxStringLength]

List of libraries used.

size_t numCpuCores

Number of cores on all CPUs on the system.

char osDescription[sk_maxStringLength]

Detailed description of the operating system.

OSType osType

Operating system type as described by OSType.

unsigned int reserved[16]

Reserved for future use.

size_t screenHeight

Screen resolution height in pixels.

size_t screenWidth

Screen resolution width in pixels.

size_t sysMemSize

Amount of memory available on the system.

The documentation for this struct was generated from the following file:
  • Utilities.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: TIFFOption Struct Reference

  • FlyCapture2
  • TIFFOption
Public Types | Public Member Functions | Public Attributes
TIFFOption Struct Reference
Image saving structures.

Options for saving TIFF images. More...

List of all members.

Public Types

enum CompressionMethod {
NONE = 1,
PACKBITS,
DEFLATE,
ADOBE_DEFLATE,
CCITTFAX3,
CCITTFAX4,
LZW,
JPEG
}

Public Member Functions

TIFFOption ()

Public Attributes

CompressionMethod compression
Compression method to use for encoding TIFF images.
unsigned int reserved [16]
Reserved for future use.

Detailed Description

Options for saving TIFF images.

Member Enumeration Documentation

enum CompressionMethod
Enumerator:
NONE

Save without any compression.

PACKBITS

Save using PACKBITS compression.

DEFLATE

Save using DEFLATE compression (ZLIB compression).

ADOBE_DEFLATE

Save using ADOBE DEFLATE compression.

CCITTFAX3

Save using CCITT Group 3 fax encoding.

This is only valid for 1-bit images only. Default to LZW for other bit depths.

CCITTFAX4

Save using CCITT Group 4 fax encoding.

This is only valid for 1-bit images only. Default to LZW for other bit depths.

LZW

Save using LZW compression.

JPEG

Save using JPEG compression.

This is only valid for 8-bit greyscale and 24-bit only. Default to LZW for other bit depths.

Constructor & Destructor Documentation

TIFFOption ( ) [inline]

Member Data Documentation

CompressionMethod compression

Compression method to use for encoding TIFF images.

unsigned int reserved[16]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: TimeStamp Struct Reference

  • FlyCapture2
  • TimeStamp
Public Member Functions | Public Attributes
TimeStamp Struct Reference
Structures

Timestamp information. More...

List of all members.

Public Member Functions

TimeStamp ()

Public Attributes

long long | seconds
Seconds.
unsigned int | microSeconds
Microseconds.
unsigned int | cycleSeconds
1394 cycle time seconds.
unsigned int | cycleCount
1394 cycle time count.
unsigned int | cycleOffset
1394 cycle time offset.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

Timestamp information.

Constructor & Destructor Documentation

TimeStamp ( ) [inline]

Member Data Documentation

unsigned int cycleCount

1394 cycle time count.

unsigned int cycleOffset

1394 cycle time offset.

unsigned int cycleSeconds

1394 cycle time seconds.

unsigned int microSeconds

Microseconds.

unsigned int reserved[8]

Reserved for future use.

long long seconds

Seconds.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: TopologyNode Class Reference

  • FlyCapture2
  • TopologyNode
Public Types | Public Member Functions
TopologyNode Class Reference

The TopologyNode class contains topology information that can be used to generate a tree structure of all cameras and devices connected to a computer. More...

List of all members.

Public Types

enum PortType {
NOT_CONNECTED = 1,
CONNECTED_TO_PARENT,
CONNECTED_TO_CHILD
}
Possible states of a port on a node. More...
enum NodeType {
COMPUTER,
BUS,
CAMERA,
NODE
}
Type of node. More...

Public Member Functions

TopologyNode ()
Default constructor.
TopologyNode (PGRGuid guid, int deviceId, NodeType nodeType, InterfaceType interfaceType)
Constructor.
virtual | ~TopologyNode ()
Default destructor.
TopologyNode (const TopologyNode &other)
Copy constructor.
virtual TopologyNode & | operator= (const TopologyNode &other)
Assignment operator.
virtual PGRGuid | GetGuid ()
Get the PGRGuid associated with the node.
virtual int | GetDeviceId ()
Get the device ID associated with the node.
virtual NodeType | GetNodeType ()
Get the node type associated with the node.
virtual InterfaceType | GetInterfaceType ()
Get the interface type associated with the node.
virtual unsigned int | GetNumChildren ()
Get the number of child nodes.
virtual TopologyNode | GetChild (unsigned int position)
Get child node located at the specified position.
virtual void | AddChild (TopologyNode childNode)
Add the specified TopologyNode as a child of the node.
virtual unsigned int | GetNumPorts ()
Get the number of ports.
virtual PortType | GetPortType (unsigned int position)
Get type of port located at the specified position.
virtual void | AddPortType (PortType childPort)
Add the specified PortType as a port of the node.
virtual bool | AssignGuidToNode (PGRGuid guid, int deviceId)
Assign a PGRGuid and device ID to the node.
virtual bool | AssignGuidToNode (PGRGuid guid, int deviceId, NodeType nodeType)
Assign a PGRGuid, device ID and nodeType to the node.

Detailed Description

The TopologyNode class contains topology information that can be used to generate a tree structure of all cameras and devices connected to a computer.

Member Enumeration Documentation

enum NodeType

Type of node.

Enumerator:
COMPUTER
BUS
CAMERA
NODE
enum PortType

Possible states of a port on a node.

Enumerator:
NOT_CONNECTED
CONNECTED_TO_PARENT
CONNECTED_TO_CHILD

Constructor & Destructor Documentation

TopologyNode ( )

Default constructor.

TopologyNode | ( | PGRGuid | guid,
 |  | int | deviceId,
 |  | NodeType | nodeType,
 |  | InterfaceType | interfaceType
 | ) |  |

Constructor.

Parameters:
guid | The PGRGuid of the node (if applicable).
deviceId | Device ID of the node.
nodeType | Type of the node.
interfaceType | Interface type of the node.
virtual ~TopologyNode ( ) [virtual]

Default destructor.

TopologyNode ( const TopologyNode & other )

Copy constructor.

Member Function Documentation

virtual void AddChild ( TopologyNode childNode ) [virtual]

Add the specified TopologyNode as a child of the node.

Parameters:
childNode The TopologyNode to add.
virtual void AddPortType ( PortType childPort ) [virtual]

Add the specified PortType as a port of the node.

Parameters:
childPort The port to add.
virtual bool AssignGuidToNode | ( | PGRGuid | guid,
 |  | int | deviceId
 | ) |  | [virtual]

Assign a PGRGuid and device ID to the node.

Parameters:
guid | PGRGuid to be assigned.
deviceId | Device ID to be assigned.
Returns:
Whether the data was successfully set to the node.
virtual bool AssignGuidToNode | ( | PGRGuid | guid,
 |  | int | deviceId,
 |  | NodeType | nodeType
 | ) |  | [virtual]

Assign a PGRGuid, device ID and nodeType to the node.

Parameters:
guid | PGRGuid to be assigned.
deviceId | Device ID to be assigned.
nodeType | NodeType to be assigned
Returns:
Whether the data was successfully set to the node.
virtual TopologyNode GetChild ( unsigned int position ) [virtual]

Get child node located at the specified position.

Parameters:
position Position of the node.
Returns:
TopologyNode at the specified position.
virtual int GetDeviceId ( ) [virtual]

Get the device ID associated with the node.

Returns:
Device ID of the node.
virtual PGRGuid GetGuid ( ) [virtual]

Get the PGRGuid associated with the node.

Returns:
PGRGuid of the node.
virtual InterfaceType GetInterfaceType ( ) [virtual]

Get the interface type associated with the node.

Returns:
Interface type of the node.
virtual NodeType GetNodeType ( ) [virtual]

Get the node type associated with the node.

Returns:
Node type of the node.
virtual unsigned int GetNumChildren ( ) [virtual]

Get the number of child nodes.

Returns:
Number of child nodes.
virtual unsigned int GetNumPorts ( ) [virtual]

Get the number of ports.

Returns:
Number of ports.
virtual PortType GetPortType ( unsigned int position ) [virtual]

Get type of port located at the specified position.

Parameters:
position Position of the port.
Returns:
PortType at the specified position.
virtual TopologyNode& operator= ( const TopologyNode & other ) [virtual]

Assignment operator.

Parameters:
other The TopologyNode to copy from.
The documentation for this class was generated from the following file:
  • TopologyNode.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: TriggerMode Struct Reference

  • FlyCapture2
  • TriggerMode
Public Member Functions | Public Attributes
TriggerMode Struct Reference
Structures

A camera trigger. More...

List of all members.

Public Member Functions

TriggerMode ()

Public Attributes

bool | onOff
Flag controlling on/off.
unsigned int | polarity
Polarity value.
unsigned int | source
Source value.
unsigned int | mode
Mode value.
unsigned int | parameter
Parameter value.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

A camera trigger.

Constructor & Destructor Documentation

TriggerMode ( ) [inline]

Member Data Documentation

unsigned int mode

Mode value.

bool onOff

Flag controlling on/off.

unsigned int parameter

Parameter value.

unsigned int polarity

Polarity value.

unsigned int reserved[8]

Reserved for future use.

unsigned int source

Source value.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: TriggerModeInfo Struct Reference

  • FlyCapture2
  • TriggerModeInfo
Public Member Functions | Public Attributes
TriggerModeInfo Struct Reference
Structures

Information about a camera trigger property. More...

List of all members.

Public Member Functions

TriggerModeInfo ()

Public Attributes

bool | present
Presence of trigger mode.
bool | readOutSupported
Flag indicating if trigger value can be read out.
bool | onOffSupported
Flag indicating if on/off is supported.
bool | polaritySupported
Flag indicating if polarity is supported.
bool | valueReadable
Flag indicating if the value is readable.
unsigned int | sourceMask
Source mask.
bool | softwareTriggerSupported
Flag indicating if software trigger is supported.
unsigned int | modeMask
Mode mask.
unsigned int | reserved [8]
Reserved for future use.

Detailed Description

Information about a camera trigger property.

Constructor & Destructor Documentation

TriggerModeInfo ( ) [inline]

Member Data Documentation

unsigned int modeMask

Mode mask.

bool onOffSupported

Flag indicating if on/off is supported.

bool polaritySupported

Flag indicating if polarity is supported.

bool present

Presence of trigger mode.

bool readOutSupported

Flag indicating if trigger value can be read out.

unsigned int reserved[8]

Reserved for future use.

bool softwareTriggerSupported

Flag indicating if software trigger is supported.

unsigned int sourceMask

Source mask.

bool valueReadable

Flag indicating if the value is readable.

The documentation for this struct was generated from the following file:
  • FlyCapture2Defs.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Utilities Class Reference

  • FlyCapture2
  • Utilities
Static Public Member Functions
Utilities Class Reference

The Utility class is generally used to query for general system information such as operating system, available memory etc. More...

List of all members.

Static Public Member Functions

static Error | CheckDriver (const PGRGuid *guid)
Check for driver compatibility for the given camera guid.
static Error | GetDriverDeviceName (const PGRGuid *guid, std::string &deviceName)
Get the driver's name for a device.
static Error | GetSystemInfo (SystemInfo *pSystemInfo)
Get system information.
static Error | GetLibraryVersion (FC2Version *pVersion)
Get library version.
static Error | LaunchBrowser (const char *pAddress)
Launch a URL in the system default browser.
static Error | LaunchHelp (const char *pFileName)
Open a CHM file in the system default CHM viewer.
static Error | LaunchCommand (const char *pCommand)
Execute a command in the terminal.
static Error | LaunchCommandAsync (const char *pCommand, AsyncCommandCallback pCallback, void *pUserData)
Execute a command in the terminal.

Detailed Description

The Utility class is generally used to query for general system information such as operating system, available memory etc.

It can also be used to launch browsers, CHM viewers or terminal commands.

Member Function Documentation

static Error CheckDriver ( const PGRGuid * guid ) [static]

Check for driver compatibility for the given camera guid.

Parameters:
guid Pointer to the guid of the device to check.
Returns:
PGR_NO_ERROR if the library is compatible with the currently loaded driver, otherwise an error indicating the type of failure.
static Error GetDriverDeviceName | ( | const PGRGuid * | guid,
 |  | std::string & | deviceName
 | ) |  | [static]

Get the driver's name for a device.

Parameters:
guid | Pointer to the guid of the device to check.
deviceName | The device name will be returned in this string
Returns:
An Error indicating the success or failure of the function.
static Error GetLibraryVersion ( FC2Version * pVersion ) [static]

Get library version.

Parameters:
pVersion Structure to receive the library version.
Returns:
An Error indicating the success or failure of the function.
static Error GetSystemInfo ( SystemInfo * pSystemInfo ) [static]

Get system information.

Parameters:
pSystemInfo Structure to receive system information.
Returns:
An Error indicating the success or failure of the function.
static Error LaunchBrowser ( const char * pAddress ) [static]

Launch a URL in the system default browser.

Parameters:
pAddress URL to open in browser.
Returns:
An Error indicating the success or failure of the function.
static Error LaunchCommand ( const char * pCommand ) [static]

Execute a command in the terminal.

This is a blocking call that will return when the command completes.

Parameters:
pCommand Command to execute.
See also:
LaunchCommandAsync()
Returns:
An Error indicating the success or failure of the function.
static Error LaunchCommandAsync | ( | const char * | pCommand,
 |  | AsyncCommandCallback | pCallback,
 |  | void * | pUserData
 | ) |  | [static]

Execute a command in the terminal.

This is a non-blocking call that will return immediately. The return value of the command can be retrieved in the callback.

Parameters:
pCommand | Command to execute.
pCallback | Callback to fire when command is complete.
pUserData | Data pointer to pass to callback.
See also:
LaunchCommand()
Returns:
An Error indicating the success or failure of the function.
static Error LaunchHelp ( const char * pFileName ) [static]

Open a CHM file in the system default CHM viewer.

Parameters:
pFileName Filename of CHM file to open.
Returns:
An Error indicating the success or failure of the function.
The documentation for this class was generated from the following file:
  • Utilities.h
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Index

Class Index
A | B | C | E | F | G | H | I | J | L | M | N | P | S | T | U
A
EmbeddedImageInfoProperty (FlyCapture2) GigEImageSettingsInfo (FlyCapture2)
M
StrobeInfo (FlyCapture2)
Error (FlyCapture2) GigEProperty (FlyCapture2) SyncManager (MultiSyncLibrary)
AVIOption (FlyCapture2) EventCallbackData (FlyCapture2) GigEStreamChannel (FlyCapture2) MACAddress (FlyCapture2) SystemInfo (FlyCapture2)
AVIRecorder (FlyCapture2) EventOptions (FlyCapture2)
H
MJPGOption (FlyCapture2)
T
B
F
N
H264Option (FlyCapture2) TIFFOption (FlyCapture2)
BMPOption (FlyCapture2) FC2Config (FlyCapture2)
I
NodeMap (FlyCapture2) TimeStamp (FlyCapture2)
BusManager (FlyCapture2) FC2Version (FlyCapture2)
P
TopologyNode (FlyCapture2)
C
FlyCapture3ApiGuiWrapper (FlyCap3CameraControl) Image (FlyCapture2) TriggerMode (FlyCapture2)
Format7ImageSettings (FlyCapture2) ImageMetadata (FlyCapture2) PGMOption (FlyCapture2) TriggerModeInfo (FlyCapture2)
Camera (FlyCapture2) Format7Info (FlyCapture2) ImageStatistics (FlyCapture2) PGRGuid (FlyCapture2)
U
CameraBase (FlyCapture2) Format7PacketInfo (FlyCapture2) Internal (FlyCapture2) PNGOption (FlyCapture2)
CameraControlDlg (FlyCapture2)
G
IPAddress (FlyCapture2) PPMOption (FlyCapture2) Utilities (FlyCapture2)
CameraInfo (FlyCapture2)
J
Property (FlyCapture2)
CameraSelectionDlg (FlyCapture2) GCCamera (FlyCapture2) PropertyInfo (FlyCapture2)
CameraStats (FlyCapture2) GigECamera (FlyCapture2) JPEGOption (FlyCapture2)
S
ConfigROM (FlyCapture2) GigEConfig (FlyCapture2) JPG2Option (FlyCapture2)
E
GigEImageSettings (FlyCapture2)
L
StrobeControl (FlyCapture2)
EmbeddedImageInfo (FlyCapture2) LUTData (FlyCapture2)
A | B | C | E | F | G | H | I | J | L | M | N | P | S | T | U
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • AVIOption
  • AVIRecorder
  • BMPOption
  • BusManager
  • CameraBase
    • Camera
    • GCCamera
    • GigECamera
  • CameraControlDlg
  • CameraInfo
  • CameraSelectionDlg
  • CameraStats
  • ConfigROM
  • EmbeddedImageInfo
  • EmbeddedImageInfoProperty
  • Error
  • EventCallbackData
  • EventOptions
  • FC2Config
  • FC2Version
  • FlyCapture3ApiGuiWrapper
  • Format7ImageSettings
  • Format7Info
  • Format7PacketInfo
  • GigEConfig
  • GigEImageSettings
  • GigEImageSettingsInfo
  • GigEProperty
  • GigEStreamChannel
  • H264Option
  • Image
  • ImageMetadata
  • ImageStatistics
  • Internal
  • IPAddress
  • JPEGOption
  • JPG2Option
  • LUTData
  • MACAddress
  • MJPGOption
  • NodeMap
  • PGMOption
  • PGRGuid
  • PNGOption
  • PPMOption
  • Property
  • PropertyInfo
  • StrobeControl
  • StrobeInfo
  • SyncManager
  • SystemInfo
  • TIFFOption
  • TimeStamp
  • TopologyNode
  • TriggerMode
  • TriggerModeInfo
  • Utilities
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _GetDeviceName() : NodeMap
  • _GetNode() : NodeMap
  • _GetNodes() : NodeMap
  • _InvalidateNodes() : NodeMap
  • _Poll() : NodeMap
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
FlyCap3CameraControl
FlyCapture2
MultiSyncLibrary
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FlyCap3CameraControl Namespace Reference

  • Namespace List
  • Namespace Members
Classes
FlyCap3CameraControl Namespace Reference

Classes

class FlyCapture3ApiGuiWrapper
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FlyCapture2 Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Variables
FlyCapture2 Namespace Reference

Classes

class | AVIRecorder
The AVIRecorder class provides the functionality for the user to record images to an AVI file. More...
class | BusManager
The BusManager class provides the functionality for the user to get an PGRGuid for a desired camera or device easily. More...
class | Camera
The Camera object represents a physical camera that uses the IIDC register set. More...
class | CameraBase
The CameraBase class is an abstract base class that defines a general interface to a camera. More...
class | Error
The Error object represents an error that is returned from the library. More...
struct | FC2Version
The current version of the library. More...
class | PGRGuid
A GUID to the camera. More...
struct | IPAddress
IPv4 address. More...
struct | MACAddress
MAC address. More...
struct | GigEProperty
A GigE property. More...
struct | GigEStreamChannel
Information about a single GigE stream channel. More...
struct | GigEConfig
Configuration for a GigE camera. More...
struct | GigEImageSettingsInfo
Format 7 information for a single mode. More...
struct | GigEImageSettings
Image settings for a GigE camera. More...
struct | Format7ImageSettings
Format 7 image settings. More...
struct | Format7Info
Format 7 information for a single mode. More...
struct | Format7PacketInfo
Format 7 packet information. More...
struct | FC2Config
Configuration for a camera. More...
struct | PropertyInfo
Information about a specific camera property. More...
struct | Property
A specific camera property. More...
struct | TriggerModeInfo
Information about a camera trigger property. More...
struct | TriggerMode
A camera trigger. More...
struct | StrobeInfo
A camera strobe property. More...
struct | StrobeControl
A camera strobe. More...
struct | TimeStamp
Timestamp information. More...
struct | ConfigROM
Camera configuration ROM. More...
struct | CameraInfo
Camera information. More...
struct | EmbeddedImageInfoProperty
Properties of a single embedded image info property. More...
struct | EmbeddedImageInfo
Properties of the possible embedded image information. More...
struct | ImageMetadata
Metadata related to an image. More...
struct | LUTData
Information about the camera's look up table. More...
struct | CameraStats
Camera diagnostic information. More...
struct | PNGOption
Options for saving PNG images. More...
struct | PPMOption
Options for saving PPM images. More...
struct | PGMOption
Options for saving PGM images. More...
struct | TIFFOption
Options for saving TIFF images. More...
struct | JPEGOption
Options for saving JPEG image. More...
struct | JPG2Option
Options for saving JPEG2000 image. More...
struct | BMPOption
Options for saving Bitmap image. More...
struct | MJPGOption
Options for saving MJPG files. More...
struct | H264Option
Options for saving H264 files. More...
struct | AVIOption
Options for saving AVI files. More...
struct | EventOptions
Options for enabling device event registration. More...
struct | EventCallbackData
class | CameraControlDlg
The CameraControlDlg object represents a dialog that provides a graphical interface to a specified camera. More...
class | CameraSelectionDlg
The CameraSelectionDlg object represents a dialog that provides a graphical interface that lists the number of cameras available to the library. More...
class | GCCamera
class | GigECamera
The GigECamera object represents a physical Gigabit Ethernet camera. More...
class | Image
The Image class is used to retrieve images from a camera, convert between multiple pixel formats and save images to disk. More...
class | ImageStatistics
The ImageStatistics object represents image statistics for an image. More...
class | Internal
class | NodeMap
class | TopologyNode
The TopologyNode class contains topology information that can be used to generate a tree structure of all cameras and devices connected to a computer. More...
struct | SystemInfo
Description of the system. More...
class | Utilities
The Utility class is generally used to query for general system information such as operating system, available memory etc. More...

Typedefs

typedef void(* | BusEventCallback )(void *pParameter, unsigned int serialNumber)
Bus event callback function prototype.
typedef void * | CallbackHandle
Handle that is returned when registering a callback.
typedef void(* | ImageEventCallback )(class Image *pImage, const void *pCallbackData)
Image event callback function prototype.
typedef PropertyInfo | TriggerDelayInfo
The TriggerDelayInfo structure is identical to PropertyInfo.
typedef Property | TriggerDelay
The TriggerDelay structure is identical to Property.
typedef void(* | CameraEventCallback )(void *data)
typedef void(* | AsyncCommandCallback )(class Error retError, void *pUserData)
Async command callback function prototype.

Enumerations

enum ErrorType {
PGRERROR_UNDEFINED = -1,
PGRERROR_OK,
PGRERROR_FAILED,
PGRERROR_NOT_IMPLEMENTED,
PGRERROR_FAILED_BUS_MASTER_CONNECTION,
PGRERROR_NOT_CONNECTED,
PGRERROR_INIT_FAILED,
PGRERROR_NOT_INTITIALIZED,
PGRERROR_INVALID_PARAMETER,
PGRERROR_INVALID_SETTINGS,
PGRERROR_INVALID_BUS_MANAGER,
PGRERROR_MEMORY_ALLOCATION_FAILED,
PGRERROR_LOW_LEVEL_FAILURE,
PGRERROR_NOT_FOUND,
PGRERROR_FAILED_GUID,
PGRERROR_INVALID_PACKET_SIZE,
PGRERROR_INVALID_MODE,
PGRERROR_NOT_IN_FORMAT7,
PGRERROR_NOT_SUPPORTED,
PGRERROR_TIMEOUT,
PGRERROR_BUS_MASTER_FAILED,
PGRERROR_INVALID_GENERATION,
PGRERROR_LUT_FAILED,
PGRERROR_IIDC_FAILED,
PGRERROR_STROBE_FAILED,
PGRERROR_TRIGGER_FAILED,
PGRERROR_PROPERTY_FAILED,
PGRERROR_PROPERTY_NOT_PRESENT,
PGRERROR_REGISTER_FAILED,
PGRERROR_READ_REGISTER_FAILED,
PGRERROR_WRITE_REGISTER_FAILED,
PGRERROR_ISOCH_FAILED,
PGRERROR_ISOCH_ALREADY_STARTED,
PGRERROR_ISOCH_NOT_STARTED,
PGRERROR_ISOCH_START_FAILED,
PGRERROR_ISOCH_RETRIEVE_BUFFER_FAILED,
PGRERROR_ISOCH_STOP_FAILED,
PGRERROR_ISOCH_SYNC_FAILED,
PGRERROR_ISOCH_BANDWIDTH_EXCEEDED,
PGRERROR_IMAGE_CONVERSION_FAILED,
PGRERROR_IMAGE_LIBRARY_FAILURE,
PGRERROR_BUFFER_TOO_SMALL,
PGRERROR_IMAGE_CONSISTENCY_ERROR,
PGRERROR_INCOMPATIBLE_DRIVER,
PGRERROR_FORCE_32BITS = FULL_32BIT_VALUE
}
The error types returned by functions. More...
enum BusCallbackType {
BUS_RESET,
ARRIVAL,
REMOVAL,
CALLBACK_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
The type of bus callback to register a callback function for. More...
enum GrabMode {
DROP_FRAMES,
BUFFER_FRAMES,
UNSPECIFIED_GRAB_MODE,
GRAB_MODE_FORCE_32BITS = FULL_32BIT_VALUE
}
The grab strategy employed during image transfer. More...
enum GrabTimeout {
TIMEOUT_NONE = 0,
TIMEOUT_INFINITE = -1,
TIMEOUT_UNSPECIFIED = -2,
GRAB_TIMEOUT_FORCE_32BITS = FULL_32BIT_VALUE
}
Timeout options for grabbing images. More...
enum BandwidthAllocation {
BANDWIDTH_ALLOCATION_OFF = 0,
BANDWIDTH_ALLOCATION_ON = 1,
BANDWIDTH_ALLOCATION_UNSUPPORTED = 2,
BANDWIDTH_ALLOCATION_UNSPECIFIED = 3,
BANDWIDTH_ALLOCATION_FORCE_32BITS = FULL_32BIT_VALUE
}
Bandwidth allocation options for 1394 devices. More...
enum InterfaceType {
INTERFACE_IEEE1394,
INTERFACE_USB2,
INTERFACE_USB3,
INTERFACE_GIGE,
INTERFACE_UNKNOWN,
INTERFACE_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
Interfaces that a camera may use to communicate with a host. More...
enum PropertyType {
BRIGHTNESS,
AUTO_EXPOSURE,
SHARPNESS,
WHITE_BALANCE,
HUE,
SATURATION,
GAMMA,
IRIS,
FOCUS,
ZOOM,
PAN,
TILT,
SHUTTER,
GAIN,
TRIGGER_MODE,
TRIGGER_DELAY,
FRAME_RATE,
TEMPERATURE,
UNSPECIFIED_PROPERTY_TYPE,
PROPERTY_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
Camera properties. More...
enum FrameRate {
FRAMERATE_1_875,
FRAMERATE_3_75,
FRAMERATE_7_5,
FRAMERATE_15,
FRAMERATE_30,
FRAMERATE_60,
FRAMERATE_120,
FRAMERATE_240,
FRAMERATE_FORMAT7,
NUM_FRAMERATES,
FRAMERATE_FORCE_32BITS = FULL_32BIT_VALUE
}
Frame rates in frames per second. More...
enum VideoMode {
VIDEOMODE_160x120YUV444,
VIDEOMODE_320x240YUV422,
VIDEOMODE_640x480YUV411,
VIDEOMODE_640x480YUV422,
VIDEOMODE_640x480RGB,
VIDEOMODE_640x480Y8,
VIDEOMODE_640x480Y16,
VIDEOMODE_800x600YUV422,
VIDEOMODE_800x600RGB,
VIDEOMODE_800x600Y8,
VIDEOMODE_800x600Y16,
VIDEOMODE_1024x768YUV422,
VIDEOMODE_1024x768RGB,
VIDEOMODE_1024x768Y8,
VIDEOMODE_1024x768Y16,
VIDEOMODE_1280x960YUV422,
VIDEOMODE_1280x960RGB,
VIDEOMODE_1280x960Y8,
VIDEOMODE_1280x960Y16,
VIDEOMODE_1600x1200YUV422,
VIDEOMODE_1600x1200RGB,
VIDEOMODE_1600x1200Y8,
VIDEOMODE_1600x1200Y16,
VIDEOMODE_FORMAT7,
NUM_VIDEOMODES,
VIDEOMODE_FORCE_32BITS = FULL_32BIT_VALUE
}
DCAM video modes. More...
enum Mode {
MODE_0 = 0,
MODE_1,
MODE_2,
MODE_3,
MODE_4,
MODE_5,
MODE_6,
MODE_7,
MODE_8,
MODE_9,
MODE_10,
MODE_11,
MODE_12,
MODE_13,
MODE_14,
MODE_15,
MODE_16,
MODE_17,
MODE_18,
MODE_19,
MODE_20,
MODE_21,
MODE_22,
MODE_23,
MODE_24,
MODE_25,
MODE_26,
MODE_27,
MODE_28,
MODE_29,
MODE_30,
MODE_31,
NUM_MODES,
MODE_FORCE_32BITS = FULL_32BIT_VALUE
}
Camera modes for DCAM formats as well as Format7. More...
enum PixelFormat {
PIXEL_FORMAT_MONO8 = 0x80000000,
PIXEL_FORMAT_411YUV8 = 0x40000000,
PIXEL_FORMAT_422YUV8 = 0x20000000,
PIXEL_FORMAT_444YUV8 = 0x10000000,
PIXEL_FORMAT_RGB8 = 0x08000000,
PIXEL_FORMAT_MONO16 = 0x04000000,
PIXEL_FORMAT_RGB16 = 0x02000000,
PIXEL_FORMAT_S_MONO16 = 0x01000000,
PIXEL_FORMAT_S_RGB16 = 0x00800000,
PIXEL_FORMAT_RAW8 = 0x00400000,
PIXEL_FORMAT_RAW16 = 0x00200000,
PIXEL_FORMAT_MONO12 = 0x00100000,
PIXEL_FORMAT_RAW12 = 0x00080000,
PIXEL_FORMAT_BGR = 0x80000008,
PIXEL_FORMAT_BGRU = 0x40000008,
PIXEL_FORMAT_RGB = PIXEL_FORMAT_RGB8,
PIXEL_FORMAT_RGBU = 0x40000002,
PIXEL_FORMAT_BGR16 = 0x02000001,
PIXEL_FORMAT_BGRU16 = 0x02000002,
PIXEL_FORMAT_422YUV8_JPEG = 0x40000001,
NUM_PIXEL_FORMATS = 20,
UNSPECIFIED_PIXEL_FORMAT = 0
}
Pixel formats available for Format7 modes. More...
enum BusSpeed {
BUSSPEED_S100,
BUSSPEED_S200,
BUSSPEED_S400,
BUSSPEED_S480,
BUSSPEED_S800,
BUSSPEED_S1600,
BUSSPEED_S3200,
BUSSPEED_S5000,
BUSSPEED_10BASE_T,
BUSSPEED_100BASE_T,
BUSSPEED_1000BASE_T,
BUSSPEED_10000BASE_T,
BUSSPEED_S_FASTEST,
BUSSPEED_ANY,
BUSSPEED_SPEED_UNKNOWN = -1,
BUSSPEED_FORCE_32BITS = FULL_32BIT_VALUE
}
Bus speeds. More...
enum PCIeBusSpeed {
PCIE_BUSSPEED_2_5,
PCIE_BUSSPEED_5_0,
PCIE_BUSSPEED_UNKNOWN = -1,
PCIE_BUSSPEED_FORCE_32BITS = FULL_32BIT_VALUE
}
enum DriverType {
DRIVER_1394_CAM,
DRIVER_1394_PRO,
DRIVER_1394_JUJU,
DRIVER_1394_VIDEO1394,
DRIVER_1394_RAW1394,
DRIVER_USB_NONE,
DRIVER_USB_CAM,
DRIVER_USB3_PRO,
DRIVER_GIGE_NONE,
DRIVER_GIGE_FILTER,
DRIVER_GIGE_PRO,
DRIVER_GIGE_LWF,
DRIVER_UNKNOWN = -1,
DRIVER_FORCE_32BITS = FULL_32BIT_VALUE
}
Types of low level drivers that flycapture uses. More...
enum ColorProcessingAlgorithm {
DEFAULT,
NO_COLOR_PROCESSING,
NEAREST_NEIGHBOR,
EDGE_SENSING,
HQ_LINEAR,
RIGOROUS,
IPP,
DIRECTIONAL_FILTER,
WEIGHTED_DIRECTIONAL_FILTER,
COLOR_PROCESSING_ALGORITHM_FORCE_32BITS = FULL_32BIT_VALUE
}
Color processing algorithms. More...
enum BayerTileFormat {
NONE,
RGGB,
GRBG,
GBRG,
BGGR,
BT_FORCE_32BITS = FULL_32BIT_VALUE
}
Bayer tile formats. More...
enum ImageFileFormat {
FROM_FILE_EXT = -1,
PGM,
PPM,
BMP,
JPEG,
JPEG2000,
TIFF,
PNG,
RAW,
IMAGE_FILE_FORMAT_FORCE_32BITS = FULL_32BIT_VALUE
}
File formats to be used for saving images to disk. More...
enum GigEPropertyType {
HEARTBEAT,
HEARTBEAT_TIMEOUT,
PACKET_SIZE,
PACKET_DELAY
}
Possible properties that can be queried from the camera. More...
enum OSType {
WINDOWS_X86,
WINDOWS_X64,
LINUX_X86,
LINUX_X64,
MAC,
UNKNOWN_OS,
OSTYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
Possible operating systems. More...
enum ByteOrder {
BYTE_ORDER_LITTLE_ENDIAN,
BYTE_ORDER_BIG_ENDIAN,
BYTE_ORDER_FORCE_32BITS = FULL_32BIT_VALUE
}
Possible byte orders. More...

Variables

static const unsigned int | sk_maxStringLength = 512
The maximum length that is allocated for a string.
static const unsigned int | sk_maxNumPorts = 32
The maximum number of ports one device can have.

Typedef Documentation

typedef void(* AsyncCommandCallback)(class Error retError, void *pUserData)

Async command callback function prototype.

Defines the syntax of the async command function that is passed into LaunchCommandAsync().

typedef void(* BusEventCallback)(void *pParameter, unsigned int serialNumber)

Bus event callback function prototype.

Defines the syntax of the callback function that is passed into RegisterCallback() and UnregisterCallback(). It is recommended that minimal handling be performed in this callback as it will block internal processing of bus events until it returns.

typedef void* CallbackHandle

Handle that is returned when registering a callback.

It is required when unregistering the callback.

typedef void(* ImageEventCallback)(class Image *pImage, const void *pCallbackData)

Image event callback function prototype.

Defines the syntax of the image callback function that is passed into StartCapture(). It is possible for this function to be called simultaneously. Therefore, users must make sure that code in the callback is thread safe.

Enumeration Type Documentation

enum ByteOrder

Possible byte orders.

Enumerator:
BYTE_ORDER_LITTLE_ENDIAN
BYTE_ORDER_BIG_ENDIAN
BYTE_ORDER_FORCE_32BITS
enum OSType

Possible operating systems.

Enumerator:
WINDOWS_X86

All Windows 32-bit variants.

WINDOWS_X64

All Windows 64-bit variants.

LINUX_X86

All Linux 32-bit variants.

LINUX_X64

All Linux 32-bit variants.

MAC

Mac OSX.

UNKNOWN_OS

Unknown operating system.

OSTYPE_FORCE_32BITS
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: MultiSyncLibrary Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations
MultiSyncLibrary Namespace Reference

Classes

class SyncManager

Enumerations

enum PGRSyncError {
PGRSyncError_OK = 0,
PGRSyncError_FAILED,
PGRSyncError_ALREADY_STARTED,
PGRSyncError_ALREADY_STOPPED,
PGRSyncError_CAMERA_NOT_FOUND,
PGRSyncError_UNKNOWN_ERROR
}
enum PGRSyncMessage {
PGRSyncMessage_OK = 0,
PGRSyncMessage_STARTED,
PGRSyncMessage_STOPPED,
PGRSyncMessage_SYNCING,
PGRSyncMessage_NOMASTER,
PGRSyncMessage_THREAD_ERROR,
PGRSyncMessage_DEVICE_ERROR,
PGRSyncMessage_NOT_ENOUGH_DEVICES,
PGRSyncMessage_BUS_RESET,
PGRSyncMessage_NOT_INITIALIZED,
PGRSyncMessage_UNKNOWN_ERROR
}

Enumeration Type Documentation

enum PGRSyncError
Enumerator:
PGRSyncError_OK
PGRSyncError_FAILED
PGRSyncError_ALREADY_STARTED
PGRSyncError_ALREADY_STOPPED
PGRSyncError_CAMERA_NOT_FOUND
PGRSyncError_UNKNOWN_ERROR
enum PGRSyncMessage
Enumerator:
PGRSyncMessage_OK
PGRSyncMessage_STARTED
PGRSyncMessage_STOPPED
PGRSyncMessage_SYNCING
PGRSyncMessage_NOMASTER
PGRSyncMessage_THREAD_ERROR
PGRSyncMessage_DEVICE_ERROR
PGRSyncMessage_NOT_ENOUGH_DEVICES
PGRSyncMessage_BUS_RESET
PGRSyncMessage_NOT_INITIALIZED
PGRSyncMessage_UNKNOWN_ERROR
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • ARRIVAL : FlyCapture2
  • AsyncCommandCallback : FlyCapture2
  • AUTO_EXPOSURE : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
AVIRecorder.h
BusManager.h
Camera.h
CameraBase.h
Error.h
FlyCapture2.h
FlyCapture2Defs.h
FlyCapture2GUI.h
FlyCapture2Platform.h
FlyCapture3ApiGuiWrapper.h
GCCamera.h
GigECamera.h
Image.h
ImageStatistics.h
Internal.h
MultiSyncLibrary.h
MultiSyncLibraryDefs.h
MultiSyncLibraryPlatform.h
NodeMap.h
TopologyNode.h
Utilities.h
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: AVIRecorder.h File Reference

  • File List
  • File Members
Classes | Namespaces
AVIRecorder.h File Reference

Classes

class | AVIRecorder
The AVIRecorder class provides the functionality for the user to record images to an AVI file. More...

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: BusManager.h File Reference

  • File List
  • File Members
Classes | Namespaces | Typedefs
BusManager.h File Reference

Classes

class | BusManager
The BusManager class provides the functionality for the user to get an PGRGuid for a desired camera or device easily. More...

Namespaces

namespace | FlyCapture2

Typedefs

typedef void(* | BusEventCallback )(void *pParameter, unsigned int serialNumber)
Bus event callback function prototype.
typedef void * | CallbackHandle
Handle that is returned when registering a callback.
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Camera.h File Reference

  • File List
  • File Members
Classes | Namespaces
Camera.h File Reference

Classes

class | Camera
The Camera object represents a physical camera that uses the IIDC register set. More...

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: CameraBase.h File Reference

  • File List
  • File Members
Classes | Namespaces | Typedefs
CameraBase.h File Reference

Classes

class | CameraBase
The CameraBase class is an abstract base class that defines a general interface to a camera. More...

Namespaces

namespace | FlyCapture2

Typedefs

typedef void(* | ImageEventCallback )(class Image *pImage, const void *pCallbackData)
Image event callback function prototype.
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Error.h File Reference

  • File List
  • File Members
Classes | Namespaces
Error.h File Reference

Classes

class | Error
The Error object represents an error that is returned from the library. More...

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FlyCapture2.h File Reference

  • File List
  • File Members
FlyCapture2.h File Reference
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FlyCapture2Defs.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines | Typedefs | Enumerations | Variables
FlyCapture2Defs.h File Reference

Classes

struct | FC2Version
The current version of the library. More...
class | PGRGuid
A GUID to the camera. More...
struct | IPAddress
IPv4 address. More...
struct | MACAddress
MAC address. More...
struct | GigEProperty
A GigE property. More...
struct | GigEStreamChannel
Information about a single GigE stream channel. More...
struct | GigEConfig
Configuration for a GigE camera. More...
struct | GigEImageSettingsInfo
Format 7 information for a single mode. More...
struct | GigEImageSettings
Image settings for a GigE camera. More...
struct | Format7ImageSettings
Format 7 image settings. More...
struct | Format7Info
Format 7 information for a single mode. More...
struct | Format7PacketInfo
Format 7 packet information. More...
struct | FC2Config
Configuration for a camera. More...
struct | PropertyInfo
Information about a specific camera property. More...
struct | Property
A specific camera property. More...
struct | TriggerModeInfo
Information about a camera trigger property. More...
struct | TriggerMode
A camera trigger. More...
struct | StrobeInfo
A camera strobe property. More...
struct | StrobeControl
A camera strobe. More...
struct | TimeStamp
Timestamp information. More...
struct | ConfigROM
Camera configuration ROM. More...
struct | CameraInfo
Camera information. More...
struct | EmbeddedImageInfoProperty
Properties of a single embedded image info property. More...
struct | EmbeddedImageInfo
Properties of the possible embedded image information. More...
struct | ImageMetadata
Metadata related to an image. More...
struct | LUTData
Information about the camera's look up table. More...
struct | CameraStats
Camera diagnostic information. More...
struct | PNGOption
Options for saving PNG images. More...
struct | PPMOption
Options for saving PPM images. More...
struct | PGMOption
Options for saving PGM images. More...
struct | TIFFOption
Options for saving TIFF images. More...
struct | JPEGOption
Options for saving JPEG image. More...
struct | JPG2Option
Options for saving JPEG2000 image. More...
struct | BMPOption
Options for saving Bitmap image. More...
struct | MJPGOption
Options for saving MJPG files. More...
struct | H264Option
Options for saving H264 files. More...
struct | AVIOption
Options for saving AVI files. More...
struct | EventOptions
Options for enabling device event registration. More...
struct | EventCallbackData

Namespaces

namespace | FlyCapture2

Defines

#define | NULL 0
#define | FULL_32BIT_VALUE 0x7FFFFFFF

Typedefs

typedef PropertyInfo | TriggerDelayInfo
The TriggerDelayInfo structure is identical to PropertyInfo.
typedef Property | TriggerDelay
The TriggerDelay structure is identical to Property.
typedef void(* | CameraEventCallback )(void *data)

Enumerations

enum ErrorType {
PGRERROR_UNDEFINED = -1,
PGRERROR_OK,
PGRERROR_FAILED,
PGRERROR_NOT_IMPLEMENTED,
PGRERROR_FAILED_BUS_MASTER_CONNECTION,
PGRERROR_NOT_CONNECTED,
PGRERROR_INIT_FAILED,
PGRERROR_NOT_INTITIALIZED,
PGRERROR_INVALID_PARAMETER,
PGRERROR_INVALID_SETTINGS,
PGRERROR_INVALID_BUS_MANAGER,
PGRERROR_MEMORY_ALLOCATION_FAILED,
PGRERROR_LOW_LEVEL_FAILURE,
PGRERROR_NOT_FOUND,
PGRERROR_FAILED_GUID,
PGRERROR_INVALID_PACKET_SIZE,
PGRERROR_INVALID_MODE,
PGRERROR_NOT_IN_FORMAT7,
PGRERROR_NOT_SUPPORTED,
PGRERROR_TIMEOUT,
PGRERROR_BUS_MASTER_FAILED,
PGRERROR_INVALID_GENERATION,
PGRERROR_LUT_FAILED,
PGRERROR_IIDC_FAILED,
PGRERROR_STROBE_FAILED,
PGRERROR_TRIGGER_FAILED,
PGRERROR_PROPERTY_FAILED,
PGRERROR_PROPERTY_NOT_PRESENT,
PGRERROR_REGISTER_FAILED,
PGRERROR_READ_REGISTER_FAILED,
PGRERROR_WRITE_REGISTER_FAILED,
PGRERROR_ISOCH_FAILED,
PGRERROR_ISOCH_ALREADY_STARTED,
PGRERROR_ISOCH_NOT_STARTED,
PGRERROR_ISOCH_START_FAILED,
PGRERROR_ISOCH_RETRIEVE_BUFFER_FAILED,
PGRERROR_ISOCH_STOP_FAILED,
PGRERROR_ISOCH_SYNC_FAILED,
PGRERROR_ISOCH_BANDWIDTH_EXCEEDED,
PGRERROR_IMAGE_CONVERSION_FAILED,
PGRERROR_IMAGE_LIBRARY_FAILURE,
PGRERROR_BUFFER_TOO_SMALL,
PGRERROR_IMAGE_CONSISTENCY_ERROR,
PGRERROR_INCOMPATIBLE_DRIVER,
PGRERROR_FORCE_32BITS = FULL_32BIT_VALUE
}
The error types returned by functions. More...
enum BusCallbackType {
BUS_RESET,
ARRIVAL,
REMOVAL,
CALLBACK_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
The type of bus callback to register a callback function for. More...
enum GrabMode {
DROP_FRAMES,
BUFFER_FRAMES,
UNSPECIFIED_GRAB_MODE,
GRAB_MODE_FORCE_32BITS = FULL_32BIT_VALUE
}
The grab strategy employed during image transfer. More...
enum GrabTimeout {
TIMEOUT_NONE = 0,
TIMEOUT_INFINITE = -1,
TIMEOUT_UNSPECIFIED = -2,
GRAB_TIMEOUT_FORCE_32BITS = FULL_32BIT_VALUE
}
Timeout options for grabbing images. More...
enum BandwidthAllocation {
BANDWIDTH_ALLOCATION_OFF = 0,
BANDWIDTH_ALLOCATION_ON = 1,
BANDWIDTH_ALLOCATION_UNSUPPORTED = 2,
BANDWIDTH_ALLOCATION_UNSPECIFIED = 3,
BANDWIDTH_ALLOCATION_FORCE_32BITS = FULL_32BIT_VALUE
}
Bandwidth allocation options for 1394 devices. More...
enum InterfaceType {
INTERFACE_IEEE1394,
INTERFACE_USB2,
INTERFACE_USB3,
INTERFACE_GIGE,
INTERFACE_UNKNOWN,
INTERFACE_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
Interfaces that a camera may use to communicate with a host. More...
enum PropertyType {
BRIGHTNESS,
AUTO_EXPOSURE,
SHARPNESS,
WHITE_BALANCE,
HUE,
SATURATION,
GAMMA,
IRIS,
FOCUS,
ZOOM,
PAN,
TILT,
SHUTTER,
GAIN,
TRIGGER_MODE,
TRIGGER_DELAY,
FRAME_RATE,
TEMPERATURE,
UNSPECIFIED_PROPERTY_TYPE,
PROPERTY_TYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
Camera properties. More...
enum FrameRate {
FRAMERATE_1_875,
FRAMERATE_3_75,
FRAMERATE_7_5,
FRAMERATE_15,
FRAMERATE_30,
FRAMERATE_60,
FRAMERATE_120,
FRAMERATE_240,
FRAMERATE_FORMAT7,
NUM_FRAMERATES,
FRAMERATE_FORCE_32BITS = FULL_32BIT_VALUE
}
Frame rates in frames per second. More...
enum VideoMode {
VIDEOMODE_160x120YUV444,
VIDEOMODE_320x240YUV422,
VIDEOMODE_640x480YUV411,
VIDEOMODE_640x480YUV422,
VIDEOMODE_640x480RGB,
VIDEOMODE_640x480Y8,
VIDEOMODE_640x480Y16,
VIDEOMODE_800x600YUV422,
VIDEOMODE_800x600RGB,
VIDEOMODE_800x600Y8,
VIDEOMODE_800x600Y16,
VIDEOMODE_1024x768YUV422,
VIDEOMODE_1024x768RGB,
VIDEOMODE_1024x768Y8,
VIDEOMODE_1024x768Y16,
VIDEOMODE_1280x960YUV422,
VIDEOMODE_1280x960RGB,
VIDEOMODE_1280x960Y8,
VIDEOMODE_1280x960Y16,
VIDEOMODE_1600x1200YUV422,
VIDEOMODE_1600x1200RGB,
VIDEOMODE_1600x1200Y8,
VIDEOMODE_1600x1200Y16,
VIDEOMODE_FORMAT7,
NUM_VIDEOMODES,
VIDEOMODE_FORCE_32BITS = FULL_32BIT_VALUE
}
DCAM video modes. More...
enum Mode {
MODE_0 = 0,
MODE_1,
MODE_2,
MODE_3,
MODE_4,
MODE_5,
MODE_6,
MODE_7,
MODE_8,
MODE_9,
MODE_10,
MODE_11,
MODE_12,
MODE_13,
MODE_14,
MODE_15,
MODE_16,
MODE_17,
MODE_18,
MODE_19,
MODE_20,
MODE_21,
MODE_22,
MODE_23,
MODE_24,
MODE_25,
MODE_26,
MODE_27,
MODE_28,
MODE_29,
MODE_30,
MODE_31,
NUM_MODES,
MODE_FORCE_32BITS = FULL_32BIT_VALUE
}
Camera modes for DCAM formats as well as Format7. More...
enum PixelFormat {
PIXEL_FORMAT_MONO8 = 0x80000000,
PIXEL_FORMAT_411YUV8 = 0x40000000,
PIXEL_FORMAT_422YUV8 = 0x20000000,
PIXEL_FORMAT_444YUV8 = 0x10000000,
PIXEL_FORMAT_RGB8 = 0x08000000,
PIXEL_FORMAT_MONO16 = 0x04000000,
PIXEL_FORMAT_RGB16 = 0x02000000,
PIXEL_FORMAT_S_MONO16 = 0x01000000,
PIXEL_FORMAT_S_RGB16 = 0x00800000,
PIXEL_FORMAT_RAW8 = 0x00400000,
PIXEL_FORMAT_RAW16 = 0x00200000,
PIXEL_FORMAT_MONO12 = 0x00100000,
PIXEL_FORMAT_RAW12 = 0x00080000,
PIXEL_FORMAT_BGR = 0x80000008,
PIXEL_FORMAT_BGRU = 0x40000008,
PIXEL_FORMAT_RGB = PIXEL_FORMAT_RGB8,
PIXEL_FORMAT_RGBU = 0x40000002,
PIXEL_FORMAT_BGR16 = 0x02000001,
PIXEL_FORMAT_BGRU16 = 0x02000002,
PIXEL_FORMAT_422YUV8_JPEG = 0x40000001,
NUM_PIXEL_FORMATS = 20,
UNSPECIFIED_PIXEL_FORMAT = 0
}
Pixel formats available for Format7 modes. More...
enum BusSpeed {
BUSSPEED_S100,
BUSSPEED_S200,
BUSSPEED_S400,
BUSSPEED_S480,
BUSSPEED_S800,
BUSSPEED_S1600,
BUSSPEED_S3200,
BUSSPEED_S5000,
BUSSPEED_10BASE_T,
BUSSPEED_100BASE_T,
BUSSPEED_1000BASE_T,
BUSSPEED_10000BASE_T,
BUSSPEED_S_FASTEST,
BUSSPEED_ANY,
BUSSPEED_SPEED_UNKNOWN = -1,
BUSSPEED_FORCE_32BITS = FULL_32BIT_VALUE
}
Bus speeds. More...
enum PCIeBusSpeed {
PCIE_BUSSPEED_2_5,
PCIE_BUSSPEED_5_0,
PCIE_BUSSPEED_UNKNOWN = -1,
PCIE_BUSSPEED_FORCE_32BITS = FULL_32BIT_VALUE
}
enum DriverType {
DRIVER_1394_CAM,
DRIVER_1394_PRO,
DRIVER_1394_JUJU,
DRIVER_1394_VIDEO1394,
DRIVER_1394_RAW1394,
DRIVER_USB_NONE,
DRIVER_USB_CAM,
DRIVER_USB3_PRO,
DRIVER_GIGE_NONE,
DRIVER_GIGE_FILTER,
DRIVER_GIGE_PRO,
DRIVER_GIGE_LWF,
DRIVER_UNKNOWN = -1,
DRIVER_FORCE_32BITS = FULL_32BIT_VALUE
}
Types of low level drivers that flycapture uses. More...
enum ColorProcessingAlgorithm {
DEFAULT,
NO_COLOR_PROCESSING,
NEAREST_NEIGHBOR,
EDGE_SENSING,
HQ_LINEAR,
RIGOROUS,
IPP,
DIRECTIONAL_FILTER,
WEIGHTED_DIRECTIONAL_FILTER,
COLOR_PROCESSING_ALGORITHM_FORCE_32BITS = FULL_32BIT_VALUE
}
Color processing algorithms. More...
enum BayerTileFormat {
NONE,
RGGB,
GRBG,
GBRG,
BGGR,
BT_FORCE_32BITS = FULL_32BIT_VALUE
}
Bayer tile formats. More...
enum ImageFileFormat {
FROM_FILE_EXT = -1,
PGM,
PPM,
BMP,
JPEG,
JPEG2000,
TIFF,
PNG,
RAW,
IMAGE_FILE_FORMAT_FORCE_32BITS = FULL_32BIT_VALUE
}
File formats to be used for saving images to disk. More...
enum GigEPropertyType {
HEARTBEAT,
HEARTBEAT_TIMEOUT,
PACKET_SIZE,
PACKET_DELAY
}
Possible properties that can be queried from the camera. More...

Variables

static const unsigned int | sk_maxStringLength = 512
The maximum length that is allocated for a string.
static const unsigned int | sk_maxNumPorts = 32
The maximum number of ports one device can have.

Define Documentation

#define FULL_32BIT_VALUE 0x7FFFFFFF
#define NULL 0
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FlyCapture2GUI.h File Reference

  • File List
  • File Members
Classes | Namespaces
FlyCapture2GUI.h File Reference

Classes

class | CameraControlDlg
The CameraControlDlg object represents a dialog that provides a graphical interface to a specified camera. More...
class | CameraSelectionDlg
The CameraSelectionDlg object represents a dialog that provides a graphical interface that lists the number of cameras available to the library. More...

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FlyCapture2Platform.h File Reference

  • File List
  • File Members
Defines
FlyCapture2Platform.h File Reference

Defines

#define | FLYCAPTURE2_API __attribute__ ((visibility ("default")))
#define | FLYCAPTURE2_LOCAL __attribute__ ((visibility ("hidden")))

Define Documentation

#define FLYCAPTURE2_API __attribute__ ((visibility ("default")))
#define FLYCAPTURE2_LOCAL __attribute__ ((visibility ("hidden")))
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: FlyCapture3ApiGuiWrapper.h File Reference

  • File List
  • File Members
Classes | Namespaces | Defines
FlyCapture3ApiGuiWrapper.h File Reference

Classes

class | FlyCapture3ApiGuiWrapper

Namespaces

namespace | FlyCapture2
namespace | FlyCap3CameraControl

Defines

#define | WRAPPER_API __declspec(dllimport)

Define Documentation

#define WRAPPER_API __declspec(dllimport)
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GCCamera.h File Reference

  • File List
  • File Members
Classes | Namespaces
GCCamera.h File Reference

Classes

class | GCCamera

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: GigECamera.h File Reference

  • File List
  • File Members
Classes | Namespaces
GigECamera.h File Reference

Classes

class | GigECamera
The GigECamera object represents a physical Gigabit Ethernet camera. More...

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Image.h File Reference

  • File List
  • File Members
Classes | Namespaces
Image.h File Reference

Classes

class | Image
The Image class is used to retrieve images from a camera, convert between multiple pixel formats and save images to disk. More...

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: ImageStatistics.h File Reference

  • File List
  • File Members
Classes | Namespaces
ImageStatistics.h File Reference

Classes

class | ImageStatistics
The ImageStatistics object represents image statistics for an image. More...

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Internal.h File Reference

  • File List
  • File Members
Classes | Namespaces
Internal.h File Reference

Classes

class | Internal

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: MultiSyncLibrary.h File Reference

  • File List
  • File Members
MultiSyncLibrary.h File Reference
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: MultiSyncLibraryDefs.h File Reference

  • File List
  • File Members
Classes | Namespaces | Enumerations
MultiSyncLibraryDefs.h File Reference

Classes

class | SyncManager

Namespaces

namespace | MultiSyncLibrary

Enumerations

enum PGRSyncError {
PGRSyncError_OK = 0,
PGRSyncError_FAILED,
PGRSyncError_ALREADY_STARTED,
PGRSyncError_ALREADY_STOPPED,
PGRSyncError_CAMERA_NOT_FOUND,
PGRSyncError_UNKNOWN_ERROR
}
enum PGRSyncMessage {
PGRSyncMessage_OK = 0,
PGRSyncMessage_STARTED,
PGRSyncMessage_STOPPED,
PGRSyncMessage_SYNCING,
PGRSyncMessage_NOMASTER,
PGRSyncMessage_THREAD_ERROR,
PGRSyncMessage_DEVICE_ERROR,
PGRSyncMessage_NOT_ENOUGH_DEVICES,
PGRSyncMessage_BUS_RESET,
PGRSyncMessage_NOT_INITIALIZED,
PGRSyncMessage_UNKNOWN_ERROR
}
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: MultiSyncLibraryPlatform.h File Reference

  • File List
  • File Members
Defines
MultiSyncLibraryPlatform.h File Reference

Defines

#define | MULTISYNCLIBRARY_API __attribute__ ((visibility ("default")))
#define | MULTISYNCLIBRARY_LOCAL __attribute__ ((visibility ("hidden")))

Define Documentation

#define MULTISYNCLIBRARY_API __attribute__ ((visibility ("default")))
#define MULTISYNCLIBRARY_LOCAL __attribute__ ((visibility ("hidden")))
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: NodeMap.h File Reference

  • File List
  • File Members
Classes | Namespaces
NodeMap.h File Reference

Classes

class | NodeMap

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: TopologyNode.h File Reference

  • File List
  • File Members
Classes | Namespaces
TopologyNode.h File Reference

Classes

class | TopologyNode
The TopologyNode class contains topology information that can be used to generate a tree structure of all cameras and devices connected to a computer. More...

Namespaces

namespace | FlyCapture2
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Utilities.h File Reference

  • File List
  • File Members
Classes | Namespaces | Typedefs | Enumerations
Utilities.h File Reference

Classes

struct | SystemInfo
Description of the system. More...
class | Utilities
The Utility class is generally used to query for general system information such as operating system, available memory etc. More...

Namespaces

namespace | FlyCapture2

Typedefs

typedef void(* | AsyncCommandCallback )(class Error retError, void *pUserData)
Async command callback function prototype.

Enumerations

enum OSType {
WINDOWS_X86,
WINDOWS_X64,
LINUX_X86,
LINUX_X64,
MAC,
UNKNOWN_OS,
OSTYPE_FORCE_32BITS = FULL_32BIT_VALUE
}
Possible operating systems. More...
enum ByteOrder {
BYTE_ORDER_LITTLE_ENDIAN,
BYTE_ORDER_BIG_ENDIAN,
BYTE_ORDER_FORCE_32BITS = FULL_32BIT_VALUE
}
Possible byte orders. More...
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: File Members

  • File List
  • File Members
  • All
  • Defines
Here is a list of all file members with links to the files they belong to:
  • FLYCAPTURE2_API : FlyCapture2Platform.h
  • FLYCAPTURE2_LOCAL : FlyCapture2Platform.h
  • FULL_32BIT_VALUE : FlyCapture2Defs.h
  • MULTISYNCLIBRARY_API : MultiSyncLibraryPlatform.h
  • MULTISYNCLIBRARY_LOCAL : MultiSyncLibraryPlatform.h
  • NULL : FlyCapture2Defs.h
  • WRAPPER_API : FlyCapture3ApiGuiWrapper.h
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Licensing.dox File Reference

  • File List
  • File Members
Licensing.dox File Reference
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCap3CameraControl
  • FlyCapture3ApiGuiWrapper
FlyCapture3ApiGuiWrapper Member List
This is the complete list of members for FlyCapture3ApiGuiWrapper, including all inherited members.
ConnectGUILibrary(FlyCapture2::GCCamera &camera) | FlyCapture3ApiGuiWrapper
DisconnectGUILibrary() | FlyCapture3ApiGuiWrapper
FlyCapture3ApiGuiWrapper(void) | FlyCapture3ApiGuiWrapper
GetControlNameList() | FlyCapture3ApiGuiWrapper
GetDialogNameList() | FlyCapture3ApiGuiWrapper
GetNumDialogs() | FlyCapture3ApiGuiWrapper
GetNumOfControls() | FlyCapture3ApiGuiWrapper
ShowCameraSelectionDialog() | FlyCapture3ApiGuiWrapper
ShowDialogByIndex(int index) | FlyCapture3ApiGuiWrapper
ShowDialogByName(std::string dialogName) | FlyCapture3ApiGuiWrapper
ShowPropertyGridDialog() | FlyCapture3ApiGuiWrapper
~FlyCapture3ApiGuiWrapper(void) | FlyCapture3ApiGuiWrapper
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • AVIRecorder
AVIRecorder Member List
This is the complete list of members for AVIRecorder, including all inherited members.
AVIAppend(Image *pImage) | AVIRecorder | [virtual]
AVIClose() | AVIRecorder | [virtual]
AVIOpen(const char *pFileName, AVIOption *pOption) | AVIRecorder | [virtual]
AVIOpen(const char *pFileName, MJPGOption *pOption) | AVIRecorder | [virtual]
AVIOpen(const char *pFileName, H264Option *pOption) | AVIRecorder | [virtual]
AVIRecorder() | AVIRecorder |
SetMaximumAVISize(unsigned int size) | AVIRecorder | [virtual]
~AVIRecorder() | AVIRecorder | [virtual]
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • BusManager
BusManager Member List
This is the complete list of members for BusManager, including all inherited members.
BusManager() | BusManager |
DiscoverGigECameras(CameraInfo *gigECameras, unsigned int *arraySize) | BusManager | [static]
FireBusReset(PGRGuid *pGuid) | BusManager | [virtual]
ForceAllIPAddressesAutomatically() | BusManager | [static]
ForceAllIPAddressesAutomatically(unsigned int serialNumber) | BusManager | [static]
ForceIPAddressToCamera(MACAddress macAddress, IPAddress ipAddress, IPAddress subnetMask, IPAddress defaultGateway) | BusManager | [static]
GetCameraFromIndex(unsigned int index, PGRGuid *pGuid) | BusManager | [virtual]
GetCameraFromIPAddress(IPAddress ipAddress, PGRGuid *pGuid) | BusManager | [virtual]
GetCameraFromSerialNumber(unsigned int serialNumber, PGRGuid *pGuid) | BusManager | [virtual]
GetCameraSerialNumberFromIndex(unsigned int index, unsigned int *pSerialNumber) | BusManager | [virtual]
GetDeviceFromIndex(unsigned int index, PGRGuid *pGuid) | BusManager | [virtual]
GetInterfaceTypeFromGuid(PGRGuid *pGuid, InterfaceType *pInterfaceType) | BusManager | [virtual]
GetNumOfCameras(unsigned int *pNumCameras) | BusManager | [virtual]
GetNumOfDevices(unsigned int *pNumDevices) | BusManager | [virtual]
GetTopology(TopologyNode *pNode) | BusManager | [virtual]
GetUsbLinkInfo(PGRGuid guid, unsigned int *pValue) | BusManager | [virtual]
GetUsbPortStatus(PGRGuid guid, unsigned int *pValue) | BusManager | [virtual]
IsCameraControlable(PGRGuid *pGuid, bool *pControlable) | BusManager |
ReadPhyRegister(PGRGuid guid, unsigned int page, unsigned int port, unsigned int address, unsigned int *pValue) | BusManager | [virtual]
RegisterCallback(BusEventCallback busEventCallback, BusCallbackType callbackType, void *pParameter, CallbackHandle *pCallbackHandle) | BusManager | [virtual]
RescanBus() | BusManager | [virtual]
UnregisterCallback(CallbackHandle callbackHandle) | BusManager | [virtual]
WritePhyRegister(PGRGuid guid, unsigned int page, unsigned int port, unsigned int address, unsigned int value) | BusManager | [virtual]
~BusManager() | BusManager | [virtual]
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Camera
Camera Member List
This is the complete list of members for Camera, including all inherited members.
Camera() | Camera |
CameraBase() | CameraBase | [inline]
Connect(PGRGuid *pGuid=NULL) | Camera | [virtual]
DeregisterAllEvents(void) | Camera | [virtual]
DeregisterEvent(EventOptions *pOpts) | Camera | [virtual]
Disconnect() | Camera | [virtual]
EnableLUT(bool on) | Camera | [virtual]
FireSoftwareTrigger(bool broadcast=false) | Camera | [virtual]
GetActiveLUTBank(unsigned int *pActiveBank) | Camera | [virtual]
GetCameraInfo(CameraInfo *pCameraInfo) | Camera | [virtual]
GetConfiguration(FC2Config *pConfig) | Camera | [virtual]
GetCycleTime(TimeStamp *timeStamp) | Camera | [virtual]
GetEmbeddedImageInfo(EmbeddedImageInfo *pInfo) | Camera | [virtual]
GetFormat7Configuration(Format7ImageSettings *pImageSettings, unsigned int *pPacketSize, float *pPercentage) | Camera | [virtual]
GetFormat7Info(Format7Info *pInfo, bool *pSupported) | Camera | [virtual]
GetGPIOPinDirection(unsigned int pin, unsigned int *pDirection) | Camera | [virtual]
GetLUTBankInfo(unsigned int bank, bool *pReadSupported, bool *pWriteSupported) | Camera | [virtual]
GetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, unsigned int *pEntries) | Camera | [virtual]
GetLUTInfo(LUTData *pData) | Camera | [virtual]
GetMemoryChannel(unsigned int *pCurrentChannel) | Camera | [virtual]
GetMemoryChannelInfo(unsigned int *pNumChannels) | Camera | [virtual]
GetProperty(Property *pProp) | Camera | [virtual]
GetPropertyInfo(PropertyInfo *pPropInfo) | Camera | [virtual]
GetRegisterString(unsigned int registerVal) | Camera | [static]
GetStats(CameraStats *pStats) | Camera | [virtual]
GetStrobe(StrobeControl *pStrobeControl) | Camera | [virtual]
GetStrobeInfo(StrobeInfo *pStrobeInfo) | Camera | [virtual]
GetTriggerDelay(TriggerDelay *pTriggerDelay) | Camera | [virtual]
GetTriggerDelayInfo(TriggerDelayInfo *pTriggerDelayInfo) | Camera | [virtual]
GetTriggerMode(TriggerMode *pTriggerMode) | Camera | [virtual]
GetTriggerModeInfo(TriggerModeInfo *pTriggerModeInfo) | Camera | [virtual]
GetVideoModeAndFrameRate(VideoMode *pVideoMode, FrameRate *pFrameRate) | Camera | [virtual]
GetVideoModeAndFrameRateInfo(VideoMode videoMode, FrameRate frameRate, bool *pSupported) | Camera | [virtual]
IsConnected() | Camera | [virtual]
m_pCameraData | CameraBase | [protected]
ReadRegister(unsigned int address, unsigned int *pValue) | Camera | [virtual]
ReadRegisterBlock(unsigned short addressHigh, unsigned int addressLow, unsigned int *pBuffer, unsigned int length) | Camera | [virtual]
RegisterAllEvents(EventOptions *pOpts) | Camera | [virtual]
RegisterEvent(EventOptions *pOpts) | Camera | [virtual]
ResetStats() | Camera | [virtual]
RestoreFromMemoryChannel(unsigned int channel) | Camera | [virtual]
RetrieveBuffer(Image *pImage) | Camera | [virtual]
SaveToMemoryChannel(unsigned int channel) | Camera | [virtual]
SetActiveLUTBank(unsigned int activeBank) | Camera | [virtual]
SetCallback(ImageEventCallback callbackFn, const void *pCallbackData=NULL) | Camera | [virtual]
SetConfiguration(const FC2Config *pConfig) | Camera | [virtual]
SetEmbeddedImageInfo(EmbeddedImageInfo *pInfo) | Camera | [virtual]
SetFormat7Configuration(const Format7ImageSettings *pImageSettings, unsigned int packetSize) | Camera | [virtual]
SetFormat7Configuration(const Format7ImageSettings *pImageSettings, float percentSpeed) | Camera | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction, bool broadcast=false) | Camera | [virtual]
SetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, const unsigned int *pEntries) | Camera | [virtual]
SetProperty(const Property *pProp, bool broadcast=false) | Camera | [virtual]
SetStrobe(const StrobeControl *pStrobeControl, bool broadcast=false) | Camera | [virtual]
SetTriggerDelay(const TriggerDelay *pTriggerDelay, bool broadcast=false) | Camera | [virtual]
SetTriggerMode(const TriggerMode *pTriggerMode, bool broadcast=false) | Camera | [virtual]
SetUserBuffers(unsigned char *const pMemBuffers, int size, int numBuffers) | Camera | [virtual]
SetVideoModeAndFrameRate(VideoMode videoMode, FrameRate frameRate) | Camera | [virtual]
StartCapture(ImageEventCallback callbackFn=NULL, const void *pCallbackData=NULL) | Camera | [virtual]
StartSyncCapture(unsigned int numCameras, const Camera **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL) | Camera | [static]
FlyCapture2::CameraBase::StartSyncCapture(unsigned int numCameras, const CameraBase **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL) | CameraBase | [static]
StopCapture() | Camera | [virtual]
ValidateFormat7Settings(const Format7ImageSettings *pImageSettings, bool *pSettingsAreValid, Format7PacketInfo *pPacketInfo) | Camera | [virtual]
WaitForBufferEvent(Image *pImage, unsigned int eventNumber) | Camera | [virtual]
WriteRegister(unsigned int address, unsigned int value, bool broadcast=false) | Camera | [virtual]
WriteRegisterBlock(unsigned short addressHigh, unsigned int addressLow, const unsigned int *pBuffer, unsigned int length) | Camera | [virtual]
~Camera() | Camera | [virtual]
~CameraBase() | CameraBase | [inline, virtual]
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • CameraBase
CameraBase Member List
This is the complete list of members for CameraBase, including all inherited members.
CameraBase() | CameraBase | [inline]
Connect(PGRGuid *pGuid=NULL)=0 | CameraBase | [pure virtual]
DeregisterAllEvents(void)=0 | CameraBase | [pure virtual]
DeregisterEvent(EventOptions *pOpts)=0 | CameraBase | [pure virtual]
Disconnect()=0 | CameraBase | [pure virtual]
EnableLUT(bool on)=0 | CameraBase | [pure virtual]
FireSoftwareTrigger(bool broadcast=false)=0 | CameraBase | [pure virtual]
GetActiveLUTBank(unsigned int *pActiveBank)=0 | CameraBase | [pure virtual]
GetCameraInfo(CameraInfo *pCameraInfo)=0 | CameraBase | [pure virtual]
GetConfiguration(FC2Config *pConfig)=0 | CameraBase | [pure virtual]
GetCycleTime(TimeStamp *timeStamp)=0 | CameraBase | [pure virtual]
GetEmbeddedImageInfo(EmbeddedImageInfo *pInfo)=0 | CameraBase | [pure virtual]
GetGPIOPinDirection(unsigned int pin, unsigned int *pDirection)=0 | CameraBase | [pure virtual]
GetLUTBankInfo(unsigned int bank, bool *pReadSupported, bool *pWriteSupported)=0 | CameraBase | [pure virtual]
GetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, unsigned int *pEntries)=0 | CameraBase | [pure virtual]
GetLUTInfo(LUTData *pData)=0 | CameraBase | [pure virtual]
GetMemoryChannel(unsigned int *pCurrentChannel)=0 | CameraBase | [pure virtual]
GetMemoryChannelInfo(unsigned int *pNumChannels)=0 | CameraBase | [pure virtual]
GetProperty(Property *pProp)=0 | CameraBase | [pure virtual]
GetPropertyInfo(PropertyInfo *pPropInfo)=0 | CameraBase | [pure virtual]
GetRegisterString(unsigned int registerVal) | CameraBase | [static]
GetStats(CameraStats *pStats)=0 | CameraBase | [pure virtual]
GetStrobe(StrobeControl *pStrobeControl)=0 | CameraBase | [pure virtual]
GetStrobeInfo(StrobeInfo *pStrobeInfo)=0 | CameraBase | [pure virtual]
GetTriggerDelay(TriggerDelay *pTriggerDelay)=0 | CameraBase | [pure virtual]
GetTriggerDelayInfo(TriggerDelayInfo *pTriggerDelayInfo)=0 | CameraBase | [pure virtual]
GetTriggerMode(TriggerMode *pTriggerMode)=0 | CameraBase | [pure virtual]
GetTriggerModeInfo(TriggerModeInfo *pTriggerModeInfo)=0 | CameraBase | [pure virtual]
IsConnected()=0 | CameraBase | [pure virtual]
m_pCameraData | CameraBase | [protected]
ReadRegister(unsigned int address, unsigned int *pValue)=0 | CameraBase | [pure virtual]
ReadRegisterBlock(unsigned short addressHigh, unsigned int addressLow, unsigned int *pBuffer, unsigned int length)=0 | CameraBase | [pure virtual]
RegisterAllEvents(EventOptions *pOpts)=0 | CameraBase | [pure virtual]
RegisterEvent(EventOptions *pOpts)=0 | CameraBase | [pure virtual]
ResetStats()=0 | CameraBase | [pure virtual]
RestoreFromMemoryChannel(unsigned int channel)=0 | CameraBase | [pure virtual]
RetrieveBuffer(Image *pImage)=0 | CameraBase | [pure virtual]
SaveToMemoryChannel(unsigned int channel)=0 | CameraBase | [pure virtual]
SetActiveLUTBank(unsigned int activeBank)=0 | CameraBase | [pure virtual]
SetCallback(ImageEventCallback callbackFn, const void *pCallbackData=NULL)=0 | CameraBase | [pure virtual]
SetConfiguration(const FC2Config *pConfig)=0 | CameraBase | [pure virtual]
SetEmbeddedImageInfo(EmbeddedImageInfo *pInfo)=0 | CameraBase | [pure virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction, bool broadcast=false)=0 | CameraBase | [pure virtual]
SetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, const unsigned int *pEntries)=0 | CameraBase | [pure virtual]
SetProperty(const Property *pProp, bool broadcast=false)=0 | CameraBase | [pure virtual]
SetStrobe(const StrobeControl *pStrobeControl, bool broadcast=false)=0 | CameraBase | [pure virtual]
SetTriggerDelay(const TriggerDelay *pTriggerDelay, bool broadcast=false)=0 | CameraBase | [pure virtual]
SetTriggerMode(const TriggerMode *pTriggerMode, bool broadcast=false)=0 | CameraBase | [pure virtual]
SetUserBuffers(unsigned char *const pMemBuffers, int size, int numBuffers)=0 | CameraBase | [pure virtual]
StartCapture(ImageEventCallback callbackFn=NULL, const void *pCallbackData=NULL)=0 | CameraBase | [pure virtual]
StartSyncCapture(unsigned int numCameras, const CameraBase **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL) | CameraBase | [static]
StopCapture()=0 | CameraBase | [pure virtual]
WaitForBufferEvent(Image *pImage, unsigned int eventNumber)=0 | CameraBase | [pure virtual]
WriteRegister(unsigned int address, unsigned int value, bool broadcast=false)=0 | CameraBase | [pure virtual]
WriteRegisterBlock(unsigned short addressHigh, unsigned int addressLow, const unsigned int *pBuffer, unsigned int length)=0 | CameraBase | [pure virtual]
~CameraBase() | CameraBase | [inline, virtual]
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • CameraControlDlg
CameraControlDlg Member List
This is the complete list of members for CameraControlDlg, including all inherited members.
CameraControlDlg() | CameraControlDlg
Connect(CameraBase *pCamera) | CameraControlDlg
Disconnect() | CameraControlDlg
Hide() | CameraControlDlg
IsVisible() | CameraControlDlg
SetTitle(const char *title) | CameraControlDlg
Show() | CameraControlDlg
Show(void *pParent) | CameraControlDlg
ShowModal() | CameraControlDlg
ShowModal(void *pParent) | CameraControlDlg
~CameraControlDlg() | CameraControlDlg
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • CameraSelectionDlg
CameraSelectionDlg Member List
This is the complete list of members for CameraSelectionDlg, including all inherited members.
CameraSelectionDlg() | CameraSelectionDlg
SetTitle(const char *title) | CameraSelectionDlg
ShowModal(bool *pOk, PGRGuid *pGuid, unsigned int *pSize) | CameraSelectionDlg
~CameraSelectionDlg() | CameraSelectionDlg
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Error
Error Member List
This is the complete list of members for Error, including all inherited members.
CollectSupportInformation() const | Error | [virtual]
Error() | Error |
Error(const Error &error) | Error |
GetBuildDate() const | Error | [virtual]
GetCause() const | Error | [virtual]
GetDescription() const | Error | [virtual]
GetFilename() const | Error | [virtual]
GetLine() const | Error | [virtual]
GetType() const | Error | [virtual]
InternalError class | Error | [friend]
operator!=(const Error &error) const | Error | [virtual]
operator!=(const ErrorType &errorType) const | Error | [virtual]
operator=(const Error &error) | Error | [virtual]
operator==(const Error &error) const | Error | [virtual]
operator==(const ErrorType &errorType) const | Error | [virtual]
PrintErrorTrace() const | Error | [virtual]
~Error() | Error | [virtual]
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • GCCamera
GCCamera Member List
This is the complete list of members for GCCamera, including all inherited members.
CameraBase() | CameraBase | [inline]
Connect(PGRGuid *pGuid=NULL) | GCCamera | [virtual]
Connect(PGRGuid *pGuid=NULL, const char *filepath=NULL) | GCCamera |
DeregisterAllEvents(void)=0 | CameraBase | [pure virtual]
DeregisterEvent(EventOptions *pOpts)=0 | CameraBase | [pure virtual]
Disconnect() | GCCamera | [virtual]
EnableLUT(bool on) | GCCamera | [virtual]
FireSoftwareTrigger(bool broadcast=false) | GCCamera | [virtual]
GCCamera(void) | GCCamera |
GCCamera::GetXML() | GCCamera |
GetActiveLUTBank(unsigned int *pActiveBank) | GCCamera | [virtual]
GetCameraInfo(CameraInfo *pCameraInfo) | GCCamera | [virtual]
GetConfiguration(FC2Config *pConfig) | GCCamera | [virtual]
GetCycleTime(TimeStamp *timeStamp) | GCCamera | [virtual]
GetEmbeddedImageInfo(EmbeddedImageInfo *pInfo) | GCCamera | [virtual]
GetGPIOPinDirection(unsigned int pin, unsigned int *pDirection) | GCCamera | [virtual]
GetInterfaceType() | GCCamera |
GetLUTBankInfo(unsigned int bank, bool *pReadSupported, bool *pWriteSupported) | GCCamera | [virtual]
GetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, unsigned int *pEntries) | GCCamera | [virtual]
GetLUTInfo(LUTData *pData) | GCCamera | [virtual]
GetMemoryChannel(unsigned int *pCurrentChannel) | GCCamera | [virtual]
GetMemoryChannelInfo(unsigned int *pNumChannels) | GCCamera | [virtual]
GetNodeMap() | GCCamera |
GetProperty(Property *pProp) | GCCamera | [virtual]
GetPropertyInfo(PropertyInfo *pPropInfo) | GCCamera | [virtual]
GetRegisterString(unsigned int registerVal) | GCCamera | [static]
GetStats(CameraStats *pStats) | GCCamera | [virtual]
GetStrobe(StrobeControl *pStrobeControl) | GCCamera | [virtual]
GetStrobeInfo(StrobeInfo *pStrobeInfo) | GCCamera | [virtual]
GetTriggerDelay(TriggerDelay *pTriggerDelay) | GCCamera | [virtual]
GetTriggerDelayInfo(TriggerDelayInfo *pTriggerDelayInfo) | GCCamera | [virtual]
GetTriggerMode(TriggerMode *pTriggerMode) | GCCamera | [virtual]
GetTriggerModeInfo(TriggerModeInfo *pTriggerModeInfo) | GCCamera | [virtual]
IsConnected() | GCCamera | [virtual]
m_busMgr | GCCamera | [protected]
m_pCameraData | CameraBase | [protected]
ReadGVCPMemory(unsigned int address, unsigned char *pBuffer, unsigned int length) | GCCamera | [virtual]
ReadGVCPRegister(unsigned int address, unsigned int *pValue) | GCCamera | [virtual]
ReadGVCPRegisterBlock(unsigned int address, unsigned int *pBuffer, unsigned int length) | GCCamera | [virtual]
ReadRegister(unsigned int address, unsigned int *pValue) | GCCamera | [virtual]
ReadRegisterBlock(unsigned short addressHigh, unsigned int addressLow, unsigned int *pBuffer, unsigned int length) | GCCamera | [virtual]
RegisterAllEvents(EventOptions *pOpts)=0 | CameraBase | [pure virtual]
RegisterEvent(EventOptions *pOpts)=0 | CameraBase | [pure virtual]
ResetStats() | GCCamera | [virtual]
RestoreFromMemoryChannel(unsigned int channel) | GCCamera | [virtual]
RetrieveBuffer(Image *pImage) | GCCamera | [virtual]
SaveToMemoryChannel(unsigned int channel) | GCCamera | [virtual]
SetActiveLUTBank(unsigned int activeBank) | GCCamera | [virtual]
SetCallback(ImageEventCallback callbackFn, const void *pCallbackData=NULL) | GCCamera | [virtual]
SetCamera(CameraBase *camera) | GCCamera |
SetCamera(CameraBase *camera, const char *filepath=NULL) | GCCamera |
SetConfiguration(const FC2Config *pConfig) | GCCamera | [virtual]
SetEmbeddedImageInfo(EmbeddedImageInfo *pInfo) | GCCamera | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction, bool broadcast=false) | GCCamera | [virtual]
SetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, const unsigned int *pEntries) | GCCamera | [virtual]
SetProperty(const Property *pProp, bool broadcast=false) | GCCamera | [virtual]
SetStrobe(const StrobeControl *pStrobeControl, bool broadcast=false) | GCCamera | [virtual]
SetTriggerDelay(const TriggerDelay *pTriggerDelay, bool broadcast=false) | GCCamera | [virtual]
SetTriggerMode(const TriggerMode *pTriggerMode, bool broadcast=false) | GCCamera | [virtual]
SetUserBuffers(unsigned char *const pMemBuffers, int size, int numBuffers) | GCCamera | [virtual]
StartCapture(ImageEventCallback callbackFn=NULL, const void *pCallbackData=NULL) | GCCamera | [virtual]
StartSyncCapture(unsigned int numCameras, const GigECamera **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL) | GCCamera | [static]
FlyCapture2::CameraBase::StartSyncCapture(unsigned int numCameras, const CameraBase **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL) | CameraBase | [static]
StopCapture() | GCCamera | [virtual]
TestGainNode() | GCCamera | [protected]
WaitForBufferEvent(Image *pImage, unsigned int eventNumber) | GCCamera | [virtual]
WriteGVCPMemory(unsigned int address, const unsigned char *pBuffer, unsigned int length) | GCCamera | [virtual]
WriteGVCPRegister(unsigned int address, unsigned int value, bool broadcast=false) | GCCamera | [virtual]
WriteGVCPRegisterBlock(unsigned int address, const unsigned int *pBuffer, unsigned int length) | GCCamera | [virtual]
WriteRegister(unsigned int address, unsigned int value, bool broadcast=false) | GCCamera | [virtual]
WriteRegisterBlock(unsigned short addressHigh, unsigned int addressLow, const unsigned int *pBuffer, unsigned int length) | GCCamera | [virtual]
~CameraBase() | CameraBase | [inline, virtual]
~GCCamera(void) | GCCamera | [virtual]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • GigECamera
GigECamera Member List
This is the complete list of members for GigECamera, including all inherited members.
CameraBase() | CameraBase | [inline]
Connect(PGRGuid *pGuid=NULL) | GigECamera | [virtual]
DeregisterAllEvents(void) | GigECamera | [virtual]
DeregisterEvent(EventOptions *pOpts) | GigECamera | [virtual]
Disconnect() | GigECamera | [virtual]
DiscoverGigEPacketSize(unsigned int *packetSize) | GigECamera | [virtual]
EnableLUT(bool on) | GigECamera | [virtual]
FireSoftwareTrigger(bool broadcast=false) | GigECamera | [virtual]
GetActiveLUTBank(unsigned int *pActiveBank) | GigECamera | [virtual]
GetCameraInfo(CameraInfo *pCameraInfo) | GigECamera | [virtual]
GetConfiguration(FC2Config *pConfig) | GigECamera | [virtual]
GetCycleTime(TimeStamp *timeStamp) | GigECamera | [virtual]
GetEmbeddedImageInfo(EmbeddedImageInfo *pInfo) | GigECamera | [virtual]
GetGigEConfig(GigEConfig *pGigEConfig) | GigECamera | [virtual]
GetGigEImageBinningSettings(unsigned int *horzBinnningValue, unsigned int *vertBinnningValue) | GigECamera | [virtual]
GetGigEImageSettings(GigEImageSettings *pImageSettings) | GigECamera | [virtual]
GetGigEImageSettingsInfo(GigEImageSettingsInfo *pInfo) | GigECamera | [virtual]
GetGigEImagingMode(Mode *mode) | GigECamera | [virtual]
GetGigEProperty(GigEProperty *pGigEProp) | GigECamera | [virtual]
GetGigEStreamChannelInfo(unsigned int channel, GigEStreamChannel *pChannel) | GigECamera | [virtual]
GetGPIOPinDirection(unsigned int pin, unsigned int *pDirection) | GigECamera | [virtual]
GetLUTBankInfo(unsigned int bank, bool *pReadSupported, bool *pWriteSupported) | GigECamera | [virtual]
GetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, unsigned int *pEntries) | GigECamera | [virtual]
GetLUTInfo(LUTData *pData) | GigECamera | [virtual]
GetMemoryChannel(unsigned int *pCurrentChannel) | GigECamera | [virtual]
GetMemoryChannelInfo(unsigned int *pNumChannels) | GigECamera | [virtual]
GetNumStreamChannels(unsigned int *numChannels) | GigECamera | [virtual]
GetProperty(Property *pProp) | GigECamera | [virtual]
GetPropertyInfo(PropertyInfo *pPropInfo) | GigECamera | [virtual]
GetRegisterString(unsigned int registerVal) | GigECamera | [static]
GetStats(CameraStats *pStats) | GigECamera | [virtual]
GetStrobe(StrobeControl *pStrobeControl) | GigECamera | [virtual]
GetStrobeInfo(StrobeInfo *pStrobeInfo) | GigECamera | [virtual]
GetTriggerDelay(TriggerDelay *pTriggerDelay) | GigECamera | [virtual]
GetTriggerDelayInfo(TriggerDelayInfo *pTriggerDelayInfo) | GigECamera | [virtual]
GetTriggerMode(TriggerMode *pTriggerMode) | GigECamera | [virtual]
GetTriggerModeInfo(TriggerModeInfo *pTriggerModeInfo) | GigECamera | [virtual]
GigECamera() | GigECamera |
IsConnected() | GigECamera | [virtual]
m_pCameraData | CameraBase | [protected]
QueryGigEImagingMode(Mode mode, bool *isSupported) | GigECamera | [virtual]
ReadGVCPMemory(unsigned int address, unsigned char *pBuffer, unsigned int length) | GigECamera | [virtual]
ReadGVCPRegister(unsigned int address, unsigned int *pValue) | GigECamera | [virtual]
ReadGVCPRegisterBlock(unsigned int address, unsigned int *pBuffer, unsigned int length) | GigECamera | [virtual]
ReadRegister(unsigned int address, unsigned int *pValue) | GigECamera | [virtual]
ReadRegisterBlock(unsigned short addressHigh, unsigned int addressLow, unsigned int *pBuffer, unsigned int length) | GigECamera | [virtual]
RegisterAllEvents(EventOptions *pOpts) | GigECamera | [virtual]
RegisterEvent(EventOptions *pOpts) | GigECamera | [virtual]
ResetStats() | GigECamera | [virtual]
RestoreFromMemoryChannel(unsigned int channel) | GigECamera | [virtual]
RetrieveBuffer(Image *pImage) | GigECamera | [virtual]
SaveToMemoryChannel(unsigned int channel) | GigECamera | [virtual]
SetActiveLUTBank(unsigned int activeBank) | GigECamera | [virtual]
SetCallback(ImageEventCallback callbackFn, const void *pCallbackData=NULL) | GigECamera | [virtual]
SetConfiguration(const FC2Config *pConfig) | GigECamera | [virtual]
SetEmbeddedImageInfo(EmbeddedImageInfo *pInfo) | GigECamera | [virtual]
SetGigEConfig(const GigEConfig *pGigEConfig) | GigECamera | [virtual]
SetGigEImageBinningSettings(unsigned int horzBinnningValue, unsigned int vertBinnningValue) | GigECamera | [virtual]
SetGigEImageSettings(const GigEImageSettings *pImageSettings) | GigECamera | [virtual]
SetGigEImagingMode(Mode mode) | GigECamera | [virtual]
SetGigEProperty(const GigEProperty *pGigEProp) | GigECamera | [virtual]
SetGigEStreamChannelInfo(unsigned int channel, GigEStreamChannel *pChannel) | GigECamera | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction, bool broadcast=false) | GigECamera | [virtual]
SetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, const unsigned int *pEntries) | GigECamera | [virtual]
SetProperty(const Property *pProp, bool broadcast=false) | GigECamera | [virtual]
SetStrobe(const StrobeControl *pStrobeControl, bool broadcast=false) | GigECamera | [virtual]
SetTriggerDelay(const TriggerDelay *pTriggerDelay, bool broadcast=false) | GigECamera | [virtual]
SetTriggerMode(const TriggerMode *pTriggerMode, bool broadcast=false) | GigECamera | [virtual]
SetUserBuffers(unsigned char *const pMemBuffers, int size, int numBuffers) | GigECamera | [virtual]
StartCapture(ImageEventCallback callbackFn=NULL, const void *pCallbackData=NULL) | GigECamera | [virtual]
StartSyncCapture(unsigned int numCameras, const GigECamera **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL) | GigECamera | [static]
FlyCapture2::CameraBase::StartSyncCapture(unsigned int numCameras, const CameraBase **ppCameras, const ImageEventCallback *pCallbackFns=NULL, const void **pCallbackDataArray=NULL) | CameraBase | [static]
StopCapture() | GigECamera | [virtual]
WaitForBufferEvent(Image *pImage, unsigned int eventNumber) | GigECamera | [virtual]
WriteGVCPMemory(unsigned int address, const unsigned char *pBuffer, unsigned int length) | GigECamera | [virtual]
WriteGVCPRegister(unsigned int address, unsigned int value, bool broadcast=false) | GigECamera | [virtual]
WriteGVCPRegisterBlock(unsigned int address, const unsigned int *pBuffer, unsigned int length) | GigECamera | [virtual]
WriteRegister(unsigned int address, unsigned int value, bool broadcast=false) | GigECamera | [virtual]
WriteRegisterBlock(unsigned short addressHigh, unsigned int addressLow, const unsigned int *pBuffer, unsigned int length) | GigECamera | [virtual]
~CameraBase() | CameraBase | [inline, virtual]
~GigECamera() | GigECamera | [virtual]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Image
Image Member List
This is the complete list of members for Image, including all inherited members.
CalculateStatistics(ImageStatistics *pStatistics) | Image | [virtual]
Convert(PixelFormat format, Image *pDestImage) const | Image | [virtual]
Convert(Image *pDestImage) const | Image | [virtual]
DeepCopy(const Image *pImage) | Image | [virtual]
DetermineBitsPerPixel(PixelFormat format) | Image | [static]
GetBayerTileFormat() const | Image | [virtual]
GetBitsPerPixel() const | Image | [virtual]
GetBlockId() | Image | [virtual]
GetColorProcessing() const | Image | [virtual]
GetCols() const | Image | [virtual]
GetData() | Image | [virtual]
GetData() const | Image | [virtual]
GetDataSize() const | Image | [virtual]
GetDefaultColorProcessing() | Image | [static]
GetDefaultOutputFormat() | Image | [static]
GetDimensions(unsigned int *pRows, unsigned int *pCols=NULL, unsigned int *pStride=NULL, PixelFormat *pPixelFormat=NULL, BayerTileFormat *pBayerFormat=NULL) const | Image | [virtual]
GetMetadata() const | Image | [virtual]
GetPixelFormat() const | Image | [virtual]
GetReceivedDataSize() const | Image | [virtual]
GetRows() const | Image | [virtual]
GetStride() const | Image | [virtual]
GetTimeStamp() const | Image | [virtual]
Image() | Image |
Image(unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, PixelFormat format, BayerTileFormat bayerFormat=NONE) | Image |
Image(unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, unsigned int receivedDataSize, PixelFormat format, BayerTileFormat bayerFormat=NONE) | Image |
Image(unsigned char *pData, unsigned int dataSize) | Image |
Image(unsigned int rows, unsigned int cols, PixelFormat format, BayerTileFormat bayerFormat=NONE) | Image |
Image(const Image &image) | Image |
Iso class | Image | [friend]
operator()(unsigned int row, unsigned int col) | Image | [virtual]
operator=(const Image &image) | Image | [virtual]
operator[](unsigned int index) | Image | [virtual]
ReleaseBuffer() | Image | [virtual]
Save(const char *pFilename, ImageFileFormat format=FROM_FILE_EXT) | Image | [virtual]
Save(const char *pFilename, PNGOption *pOption) | Image | [virtual]
Save(const char *pFilename, PPMOption *pOption) | Image | [virtual]
Save(const char *pFilename, PGMOption *pOption) | Image | [virtual]
Save(const char *pFilename, TIFFOption *pOption) | Image | [virtual]
Save(const char *pFilename, JPEGOption *pOption) | Image | [virtual]
Save(const char *pFilename, JPG2Option *pOption) | Image | [virtual]
Save(const char *pFilename, BMPOption *pOption) | Image | [virtual]
SetBlockId(const unsigned int blockId) | Image | [virtual]
SetColorProcessing(ColorProcessingAlgorithm colorProc) | Image | [virtual]
SetData(const unsigned char *pData, unsigned int dataSize) | Image | [virtual]
SetDefaultColorProcessing(ColorProcessingAlgorithm defaultMethod) | Image | [static]
SetDefaultOutputFormat(PixelFormat format) | Image | [static]
SetDimensions(unsigned int rows, unsigned int cols, unsigned int stride, PixelFormat pixelFormat, BayerTileFormat bayerFormat) | Image | [virtual]
~Image() | Image | [virtual]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • ImageStatistics
ImageStatistics Member List
This is the complete list of members for ImageStatistics, including all inherited members.
BLUE enum value | ImageStatistics |
DisableAll() | ImageStatistics |
EnableAll() | ImageStatistics |
EnableGreyOnly() | ImageStatistics |
EnableHSLOnly() | ImageStatistics |
EnableRGBOnly() | ImageStatistics |
GetChannelStatus(StatisticsChannel channel, bool *pEnabled) const | ImageStatistics |
GetHistogram(StatisticsChannel channel, int **ppHistogram) const | ImageStatistics |
GetMean(StatisticsChannel channel, float *pPixelValueMean) const | ImageStatistics |
GetNumPixelValues(StatisticsChannel channel, unsigned int *pNumPixelValues) const | ImageStatistics |
GetPixelValueRange(StatisticsChannel channel, unsigned int *pPixelValueMin, unsigned int *pPixelValueMax) const | ImageStatistics |
GetRange(StatisticsChannel channel, unsigned int *pMin, unsigned int *pMax) const | ImageStatistics |
GetStatistics(StatisticsChannel channel, unsigned int *pRangeMin=NULL, unsigned int *pRangeMax=NULL, unsigned int *pPixelValueMin=NULL, unsigned int *pPixelValueMax=NULL, unsigned int *pNumPixelValues=NULL, float *pPixelValueMean=NULL, int **ppHistogram=NULL) const | ImageStatistics |
GREEN enum value | ImageStatistics |
GREY enum value | ImageStatistics |
HUE enum value | ImageStatistics |
ImageStatistics() | ImageStatistics |
ImageStatistics(const ImageStatistics &other) | ImageStatistics |
ImageStatsCalculator class | ImageStatistics | [friend]
LIGHTNESS enum value | ImageStatistics |
NUM_STATISTICS_CHANNELS enum value | ImageStatistics |
operator=(const ImageStatistics &other) | ImageStatistics |
RED enum value | ImageStatistics |
SATURATION enum value | ImageStatistics |
SetChannelStatus(StatisticsChannel channel, bool enabled) | ImageStatistics |
StatisticsChannel enum name | ImageStatistics |
~ImageStatistics() | ImageStatistics | [virtual]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Internal
Internal Member List
This is the complete list of members for Internal, including all inherited members.
GetInternal(unsigned int index) Internal [static]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • NodeMap
NodeMap Member List
This is the complete list of members for NodeMap, including all inherited members.
_GetDeviceName() | NodeMap |
_GetNode(const GenICam::gcstring &key) | NodeMap |
_GetNodes(NodeList_t &Nodes) | NodeMap |
_InvalidateNodes() const | NodeMap |
_Poll(int64_t ElapsedTime) | NodeMap |
NodeMap(GenApi::CNodeMapRef *ref) | NodeMap |
~NodeMap(void) | NodeMap | [virtual]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • PGRGuid
PGRGuid Member List
This is the complete list of members for PGRGuid, including all inherited members.
operator!=(const PGRGuid &guid) | PGRGuid | [inline]
operator==(const PGRGuid &guid) const | PGRGuid | [inline]
PGRGuid() | PGRGuid | [inline]
value | PGRGuid |
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • TopologyNode
TopologyNode Member List
This is the complete list of members for TopologyNode, including all inherited members.
AddChild(TopologyNode childNode) | TopologyNode | [virtual]
AddPortType(PortType childPort) | TopologyNode | [virtual]
AssignGuidToNode(PGRGuid guid, int deviceId) | TopologyNode | [virtual]
AssignGuidToNode(PGRGuid guid, int deviceId, NodeType nodeType) | TopologyNode | [virtual]
BUS enum value | TopologyNode |
CAMERA enum value | TopologyNode |
COMPUTER enum value | TopologyNode |
CONNECTED_TO_CHILD enum value | TopologyNode |
CONNECTED_TO_PARENT enum value | TopologyNode |
GetChild(unsigned int position) | TopologyNode | [virtual]
GetDeviceId() | TopologyNode | [virtual]
GetGuid() | TopologyNode | [virtual]
GetInterfaceType() | TopologyNode | [virtual]
GetNodeType() | TopologyNode | [virtual]
GetNumChildren() | TopologyNode | [virtual]
GetNumPorts() | TopologyNode | [virtual]
GetPortType(unsigned int position) | TopologyNode | [virtual]
NODE enum value | TopologyNode |
NodeType enum name | TopologyNode |
NOT_CONNECTED enum value | TopologyNode |
operator=(const TopologyNode &other) | TopologyNode | [virtual]
PortType enum name | TopologyNode |
TopologyNode() | TopologyNode |
TopologyNode(PGRGuid guid, int deviceId, NodeType nodeType, InterfaceType interfaceType) | TopologyNode |
TopologyNode(const TopologyNode &other) | TopologyNode |
~TopologyNode() | TopologyNode | [virtual]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Utilities
Utilities Member List
This is the complete list of members for Utilities, including all inherited members.
CheckDriver(const PGRGuid *guid) | Utilities | [static]
GetDriverDeviceName(const PGRGuid *guid, std::string &deviceName) | Utilities | [static]
GetLibraryVersion(FC2Version *pVersion) | Utilities | [static]
GetSystemInfo(SystemInfo *pSystemInfo) | Utilities | [static]
LaunchBrowser(const char *pAddress) | Utilities | [static]
LaunchCommand(const char *pCommand) | Utilities | [static]
LaunchCommandAsync(const char *pCommand, AsyncCommandCallback pCallback, void *pUserData) | Utilities | [static]
LaunchHelp(const char *pFileName) | Utilities | [static]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • MultiSyncLibrary
  • SyncManager
SyncManager Member List
This is the complete list of members for SyncManager, including all inherited members.
DisableCrossPCSynchronization() | SyncManager
EnableCrossPCSynchronization() | SyncManager
GetSyncStatus() | SyncManager
GetTimeSinceSynced() | SyncManager
IsTimingBusConnected() | SyncManager
QueryCrossPCSynchronizationSetting() | SyncManager
RescanMasterTimingBus() | SyncManager
Start() | SyncManager
Stop() | SyncManager
SyncManager() | SyncManager
~SyncManager() | SyncManager
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • JPEG : TIFFOption
  • JPEGOption() : JPEGOption
  • JPG2Option() : JPG2Option
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • LaunchBrowser() : Utilities
  • LaunchCommand() : Utilities
  • LaunchCommandAsync() : Utilities
  • LaunchHelp() : Utilities
  • libraryList : SystemInfo
  • LIGHTNESS : ImageStatistics
  • LUTData() : LUTData
  • LZW : TIFFOption
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • m_busMgr : GCCamera
  • m_pCameraData : CameraBase
  • MACAddress() : MACAddress
  • macAddress : CameraInfo
  • major : FC2Version
  • manualSupported : PropertyInfo
  • max : GigEProperty , PropertyInfo
  • maxBytesPerPacket : Format7PacketInfo
  • maxHeight : GigEImageSettingsInfo , Format7Info
  • maximumBusSpeed : CameraInfo
  • maxPacketSize : Format7Info
  • maxValue : StrobeInfo
  • maxWidth : GigEImageSettingsInfo , Format7Info
  • microSeconds : TimeStamp
  • min : PropertyInfo , GigEProperty
  • minNumImageNotifications : FC2Config
  • minor : FC2Version
  • minPacketSize : Format7Info
  • minValue : StrobeInfo
  • MJPGOption() : MJPGOption
  • mode : Format7Info , Format7ImageSettings , TriggerMode
  • modelName : CameraInfo
  • modeMask : TriggerModeInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • networkInterfaceIndex : GigEStreamChannel
  • NODE : TopologyNode
  • NodeMap() : NodeMap
  • nodeNumber : CameraInfo
  • NodeType : TopologyNode
  • nodeVendorId : ConfigROM
  • NONE : TIFFOption
  • NOT_CONNECTED : TopologyNode
  • NUM_STATISTICS_CHANNELS : ImageStatistics
  • numBanks : LUTData
  • numBuffers : FC2Config
  • numChannels : LUTData
  • numCpuCores : SystemInfo
  • numCurrents : CameraStats
  • numEntries : LUTData
  • numImageNotifications : FC2Config
  • numResendPacketsReceived : CameraStats
  • numResendPacketsRequested : CameraStats
  • numVoltages : CameraStats
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • octets : IPAddress , MACAddress
  • offsetHStepSize : Format7Info , GigEImageSettingsInfo
  • offsetVStepSize : GigEImageSettingsInfo , Format7Info
  • offsetX : Format7ImageSettings , GigEImageSettings
  • offsetY : GigEImageSettings , Format7ImageSettings
  • onePush : Property
  • onePushSupported : PropertyInfo
  • onOff : EmbeddedImageInfoProperty , Property , TriggerMode , StrobeControl
  • onOffSupported : PropertyInfo , TriggerModeInfo , StrobeInfo
  • operator!=() : IPAddress , Error , PGRGuid , MACAddress
  • operator()() : Image
  • operator=() : TopologyNode , Image , Error , ImageStatistics
  • operator==() : MACAddress , Error , IPAddress , Error , PGRGuid
  • operator[]() : Image
  • osDescription : SystemInfo
  • osType : SystemInfo
  • outputBitDepth : LUTData
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~AVIRecorder() : AVIRecorder
  • ~BusManager() : BusManager
  • ~Camera() : Camera
  • ~CameraBase() : CameraBase
  • ~CameraControlDlg() : CameraControlDlg
  • ~CameraSelectionDlg() : CameraSelectionDlg
  • ~Error() : Error
  • ~FlyCapture3ApiGuiWrapper() : FlyCapture3ApiGuiWrapper
  • ~GCCamera() : GCCamera
  • ~GigECamera() : GigECamera
  • ~Image() : Image
  • ~ImageStatistics() : ImageStatistics
  • ~NodeMap() : NodeMap
  • ~SyncManager() : SyncManager
  • ~TopologyNode() : TopologyNode
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • absControl : Property
  • absMax : PropertyInfo
  • absMin : PropertyInfo
  • absValSupported : PropertyInfo
  • absValue : Property
  • AddChild() : TopologyNode
  • AddPortType() : TopologyNode
  • ADOBE_DEFLATE : TIFFOption
  • applicationIPAddress : CameraInfo
  • applicationPort : CameraInfo
  • AssignGuidToNode() : TopologyNode
  • asyncBusSpeed : FC2Config
  • autoManualMode : Property
  • autoSupported : PropertyInfo
  • available : EmbeddedImageInfoProperty
  • AVIAppend() : AVIRecorder
  • AVIClose() : AVIRecorder
  • AVIOpen() : AVIRecorder
  • AVIOption() : AVIOption
  • AVIRecorder() : AVIRecorder
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • bandwidthAllocation : FC2Config
  • bayerTileFormat : CameraInfo
  • binaryFile : PGMOption , PPMOption
  • bitrate : H264Option
  • BLUE : ImageStatistics
  • BMPOption() : BMPOption
  • brightness : EmbeddedImageInfo
  • build : FC2Version
  • BUS : TopologyNode
  • BusManager() : BusManager
  • busNumber : CameraInfo
  • byteOrder : SystemInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • CalculateStatistics() : Image
  • Camera() : Camera
  • CAMERA : TopologyNode
  • CameraBase() : CameraBase
  • CameraControlDlg() : CameraControlDlg
  • cameraCurrents : CameraStats
  • CameraInfo() : CameraInfo
  • cameraPowerUp : CameraStats
  • CameraSelectionDlg() : CameraSelectionDlg
  • CameraStats() : CameraStats
  • cameraVoltages : CameraStats
  • CCITTFAX3 : TIFFOption
  • CCITTFAX4 : TIFFOption
  • ccpStatus : CameraInfo
  • CheckDriver() : Utilities
  • chipIdHi : ConfigROM
  • chipIdLo : ConfigROM
  • CollectSupportInformation() : Error
  • compression : TIFFOption
  • compressionLevel : PNGOption
  • CompressionMethod : TIFFOption
  • COMPUTER : TopologyNode
  • ConfigROM() : ConfigROM
  • configROM : CameraInfo
  • Connect() : GigECamera , GCCamera , Camera , CameraBase , CameraControlDlg
  • CONNECTED_TO_CHILD : TopologyNode
  • CONNECTED_TO_PARENT : TopologyNode
  • ConnectGUILibrary() : FlyCapture3ApiGuiWrapper
  • Convert() : Image
  • cpuDescription : SystemInfo
  • cycleCount : TimeStamp
  • cycleOffset : TimeStamp
  • cycleSeconds : TimeStamp
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • DeepCopy() : Image
  • defaultGateway : CameraInfo
  • DEFLATE : TIFFOption
  • delay : StrobeControl
  • DeregisterAllEvents() : Camera , CameraBase , GigECamera
  • DeregisterEvent() : Camera , CameraBase , GigECamera
  • destinationIpAddress : GigEStreamChannel
  • DetermineBitsPerPixel() : Image
  • DisableAll() : ImageStatistics
  • DisableCrossPCSynchronization() : SyncManager
  • Disconnect() : CameraBase , CameraControlDlg , GCCamera , GigECamera , Camera
  • DisconnectGUILibrary() : FlyCapture3ApiGuiWrapper
  • DiscoverGigECameras() : BusManager
  • DiscoverGigEPacketSize() : GigECamera
  • doNotFragment : GigEStreamChannel
  • driverList : SystemInfo
  • driverName : CameraInfo
  • driverType : CameraInfo
  • duration : StrobeControl
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • embeddedBrightness : ImageMetadata
  • embeddedExposure : ImageMetadata
  • embeddedFrameCounter : ImageMetadata
  • embeddedGain : ImageMetadata
  • embeddedGPIOPinState : ImageMetadata
  • EmbeddedImageInfoProperty() : EmbeddedImageInfoProperty
  • embeddedROIPosition : ImageMetadata
  • embeddedShutter : ImageMetadata
  • embeddedStrobePattern : ImageMetadata
  • embeddedTimeStamp : ImageMetadata
  • embeddedWhiteBalance : ImageMetadata
  • EnableAll() : ImageStatistics
  • EnableCrossPCSynchronization() : SyncManager
  • enabled : LUTData
  • EnableGreyOnly() : ImageStatistics
  • EnableHSLOnly() : ImageStatistics
  • EnableLUT() : Camera , CameraBase , GCCamera , GigECamera
  • enablePacketResend : GigEConfig
  • EnableRGBOnly() : ImageStatistics
  • Error() : Error
  • EventCallbackFcn : EventOptions
  • EventData : EventCallbackData
  • EventDataSize : EventCallbackData
  • EventID : EventCallbackData
  • EventName : EventCallbackData , EventOptions
  • EventTimestamp : EventCallbackData
  • EventUserData : EventOptions , EventCallbackData
  • EventUserDataSize : EventOptions , EventCallbackData
  • exposure : EmbeddedImageInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • FC2Config() : FC2Config
  • FireBusReset() : BusManager
  • FireSoftwareTrigger() : CameraBase , GCCamera , Camera , GigECamera
  • firmwareBuildTime : CameraInfo
  • firmwareVersion : CameraInfo
  • FlyCapture3ApiGuiWrapper() : FlyCapture3ApiGuiWrapper
  • ForceAllIPAddressesAutomatically() : BusManager
  • ForceIPAddressToCamera() : BusManager
  • Format7ImageSettings() : Format7ImageSettings
  • Format7Info() : Format7Info
  • Format7PacketInfo() : Format7PacketInfo
  • frameCounter : EmbeddedImageInfo
  • frameRate : MJPGOption , H264Option , AVIOption
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • gain : EmbeddedImageInfo
  • GCCamera() : GCCamera
  • GCCamera::GetXML() : GCCamera
  • GetActiveLUTBank() : Camera , CameraBase , GCCamera , GigECamera
  • GetBayerTileFormat() : Image
  • GetBitsPerPixel() : Image
  • GetBlockId() : Image
  • GetBuildDate() : Error
  • GetCameraFromIndex() : BusManager
  • GetCameraFromIPAddress() : BusManager
  • GetCameraFromSerialNumber() : BusManager
  • GetCameraInfo() : CameraBase , GCCamera , GigECamera , Camera
  • GetCameraSerialNumberFromIndex() : BusManager
  • GetCause() : Error
  • GetChannelStatus() : ImageStatistics
  • GetChild() : TopologyNode
  • GetColorProcessing() : Image
  • GetCols() : Image
  • GetConfiguration() : Camera , CameraBase , GCCamera , GigECamera
  • GetControlNameList() : FlyCapture3ApiGuiWrapper
  • GetCycleTime() : GCCamera , GigECamera , Camera , CameraBase
  • GetData() : Image
  • GetDataSize() : Image
  • GetDefaultColorProcessing() : Image
  • GetDefaultOutputFormat() : Image
  • GetDescription() : Error
  • GetDeviceFromIndex() : BusManager
  • GetDeviceId() : TopologyNode
  • GetDialogNameList() : FlyCapture3ApiGuiWrapper
  • GetDimensions() : Image
  • GetDriverDeviceName() : Utilities
  • GetEmbeddedImageInfo() : Camera , CameraBase , GCCamera , GigECamera
  • GetFilename() : Error
  • GetFormat7Configuration() : Camera
  • GetFormat7Info() : Camera
  • GetGigEConfig() : GigECamera
  • GetGigEImageBinningSettings() : GigECamera
  • GetGigEImageSettings() : GigECamera
  • GetGigEImageSettingsInfo() : GigECamera
  • GetGigEImagingMode() : GigECamera
  • GetGigEProperty() : GigECamera
  • GetGigEStreamChannelInfo() : GigECamera
  • GetGPIOPinDirection() : Camera , CameraBase , GCCamera , GigECamera
  • GetGuid() : TopologyNode
  • GetHistogram() : ImageStatistics
  • GetInterfaceType() : GCCamera , TopologyNode
  • GetInterfaceTypeFromGuid() : BusManager
  • GetInternal() : Internal
  • GetLibraryVersion() : Utilities
  • GetLine() : Error
  • GetLUTBankInfo() : Camera , CameraBase , GCCamera , GigECamera
  • GetLUTChannel() : Camera , CameraBase , GCCamera , GigECamera
  • GetLUTInfo() : Camera , CameraBase , GCCamera , GigECamera
  • GetMean() : ImageStatistics
  • GetMemoryChannel() : Camera , CameraBase , GCCamera , GigECamera
  • GetMemoryChannelInfo() : GigECamera , Camera , CameraBase , GCCamera
  • GetMetadata() : Image
  • GetNodeMap() : GCCamera
  • GetNodeType() : TopologyNode
  • GetNumChildren() : TopologyNode
  • GetNumDialogs() : FlyCapture3ApiGuiWrapper
  • GetNumOfCameras() : BusManager
  • GetNumOfControls() : FlyCapture3ApiGuiWrapper
  • GetNumOfDevices() : BusManager
  • GetNumPixelValues() : ImageStatistics
  • GetNumPorts() : TopologyNode
  • GetNumStreamChannels() : GigECamera
  • GetPixelFormat() : Image
  • GetPixelValueRange() : ImageStatistics
  • GetPortType() : TopologyNode
  • GetProperty() : CameraBase , Camera , GCCamera , GigECamera
  • GetPropertyInfo() : CameraBase , Camera , GCCamera , GigECamera
  • GetRange() : ImageStatistics
  • GetReceivedDataSize() : Image
  • GetRegisterString() : GigECamera , Camera , GCCamera , CameraBase
  • GetRows() : Image
  • GetStatistics() : ImageStatistics
  • GetStats() : CameraBase , GigECamera , Camera , GCCamera
  • GetStride() : Image
  • GetStrobe() : CameraBase , GCCamera , GigECamera , Camera
  • GetStrobeInfo() : CameraBase , Camera , GCCamera , GigECamera
  • GetSyncStatus() : SyncManager
  • GetSystemInfo() : Utilities
  • GetTimeSinceSynced() : SyncManager
  • GetTimeStamp() : Image
  • GetTopology() : BusManager
  • GetTriggerDelay() : Camera , CameraBase , GCCamera , GigECamera
  • GetTriggerDelayInfo() : GCCamera , Camera , CameraBase , GigECamera
  • GetTriggerMode() : Camera , GigECamera , CameraBase , GCCamera
  • GetTriggerModeInfo() : CameraBase , GCCamera , GigECamera , Camera
  • GetType() : Error
  • GetUsbLinkInfo() : BusManager
  • GetUsbPortStatus() : BusManager
  • GetVideoModeAndFrameRate() : Camera
  • GetVideoModeAndFrameRateInfo() : Camera
  • GigECamera() : GigECamera
  • GigEConfig() : GigEConfig
  • GigEImageSettings() : GigEImageSettings
  • GigEImageSettingsInfo() : GigEImageSettingsInfo
  • gigEMajorVersion : CameraInfo
  • gigEMinorVersion : CameraInfo
  • GigEStreamChannel() : GigEStreamChannel
  • GPIOPinState : EmbeddedImageInfo
  • gpuDescription : SystemInfo
  • grabMode : FC2Config
  • grabTimeout : FC2Config
  • GREEN : ImageStatistics
  • GREY : ImageStatistics
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • H264Option() : H264Option
  • height : GigEImageSettings , H264Option , Format7ImageSettings
  • Hide() : CameraControlDlg
  • highPerformanceRetrieveBuffer : FC2Config
  • hostPort : GigEStreamChannel
  • HUE : ImageStatistics
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • iidcVer : CameraInfo
  • Image() : Image
  • imageCorrupt : CameraStats
  • imageDriverDropped : CameraStats
  • imageDropped : CameraStats
  • imageHStepSize : GigEImageSettingsInfo , Format7Info
  • ImageMetadata() : ImageMetadata
  • ImageStatistics() : ImageStatistics
  • ImageStatsCalculator : ImageStatistics
  • imageVStepSize : GigEImageSettingsInfo , Format7Info
  • imageXmitFailed : CameraStats
  • indexedColor_8bit : BMPOption
  • inputBitDepth : LUTData
  • interfaceType : CameraInfo
  • interlaced : PNGOption
  • InternalError : Error
  • interPacketDelay : GigEStreamChannel
  • IPAddress() : IPAddress
  • ipAddress : CameraInfo
  • IPAddress() : IPAddress
  • IsCameraControlable() : BusManager
  • isColorCamera : CameraInfo
  • IsConnected() : Camera , CameraBase , GCCamera , GigECamera
  • Iso : Image
  • isochBusSpeed : FC2Config
  • isReadable : GigEProperty
  • IsTimingBusConnected() : SyncManager
  • IsVisible() : CameraControlDlg
  • isWritable : GigEProperty
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • PACKBITS : TIFFOption
  • packetSize : GigEStreamChannel , Format7Info
  • parameter : TriggerMode
  • pcieBusSpeed : CameraInfo
  • percentage : Format7Info
  • PGMOption() : PGMOption
  • PGRGuid() : PGRGuid
  • pixelFormat : GigEImageSettings , Format7ImageSettings
  • pixelFormatBitField : GigEImageSettingsInfo , Format7Info
  • PNGOption() : PNGOption
  • polarity : TriggerMode , StrobeControl
  • polaritySupported : TriggerModeInfo , StrobeInfo
  • portErrors : CameraStats
  • PortType : TopologyNode
  • PPMOption() : PPMOption
  • present : PropertyInfo , Property , StrobeInfo , TriggerModeInfo
  • PrintErrorTrace() : Error
  • progressive : JPEGOption
  • Property() : Property
  • PropertyInfo() : PropertyInfo
  • propType : GigEProperty
  • pszKeyword : ConfigROM
  • pUnitAbbr : PropertyInfo
  • pUnits : PropertyInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • quality : JPEGOption , JPG2Option , MJPGOption
  • QueryCrossPCSynchronizationSetting() : SyncManager
  • QueryGigEImagingMode() : GigECamera
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • ReadGVCPMemory() : GCCamera , GigECamera
  • ReadGVCPRegister() : GigECamera , GCCamera
  • ReadGVCPRegisterBlock() : GCCamera , GigECamera
  • readOutSupported : TriggerModeInfo , StrobeInfo , PropertyInfo
  • ReadPhyRegister() : BusManager
  • ReadRegister() : Camera , CameraBase , GCCamera , GigECamera
  • ReadRegisterBlock() : CameraBase , GCCamera , GigECamera , Camera
  • recommendedBytesPerPacket : Format7PacketInfo
  • RED : ImageStatistics
  • RegisterAllEvents() : Camera , CameraBase , GigECamera
  • RegisterCallback() : BusManager
  • RegisterEvent() : Camera , CameraBase , GigECamera
  • registerTimeout : GigEConfig , FC2Config
  • registerTimeoutRetries : GigEConfig , FC2Config
  • regReadFailed : CameraStats
  • regWriteFailed : CameraStats
  • ReleaseBuffer() : Image
  • RescanBus() : BusManager
  • RescanMasterTimingBus() : SyncManager
  • reserved : PropertyInfo , TriggerModeInfo , StrobeInfo , H264Option , Format7ImageSettings , GigEImageSettings , AVIOption , PGMOption , GigEImageSettingsInfo , SystemInfo , BMPOption , Format7Info , Format7PacketInfo , JPG2Option , TIFFOption , FC2Config , CameraStats , ImageMetadata , ConfigROM , JPEGOption , Property , TriggerMode , MJPGOption , StrobeControl , TimeStamp , PNGOption , LUTData , PPMOption , CameraInfo
  • ResetStats() : GigECamera , Camera , GCCamera , CameraBase
  • RestoreFromMemoryChannel() : CameraBase , GigECamera , Camera , GCCamera
  • RetrieveBuffer() : GCCamera , CameraBase , Camera , GigECamera
  • ROIPosition : EmbeddedImageInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SATURATION : ImageStatistics
  • Save() : Image
  • SaveToMemoryChannel() : Camera , CameraBase , GCCamera , GigECamera
  • screenHeight : SystemInfo
  • screenWidth : SystemInfo
  • seconds : TimeStamp
  • sensorInfo : CameraInfo
  • sensorResolution : CameraInfo
  • serialNumber : CameraInfo
  • SetActiveLUTBank() : Camera , CameraBase , GCCamera , GigECamera
  • SetBlockId() : Image
  • SetCallback() : Camera , CameraBase , GCCamera , GigECamera
  • SetCamera() : GCCamera
  • SetChannelStatus() : ImageStatistics
  • SetColorProcessing() : Image
  • SetConfiguration() : Camera , CameraBase , GCCamera , GigECamera
  • SetData() : Image
  • SetDefaultColorProcessing() : Image
  • SetDefaultOutputFormat() : Image
  • SetDimensions() : Image
  • SetEmbeddedImageInfo() : Camera , CameraBase , GCCamera , GigECamera
  • SetFormat7Configuration() : Camera
  • SetGigEConfig() : GigECamera
  • SetGigEImageBinningSettings() : GigECamera
  • SetGigEImageSettings() : GigECamera
  • SetGigEImagingMode() : GigECamera
  • SetGigEProperty() : GigECamera
  • SetGigEStreamChannelInfo() : GigECamera
  • SetGPIOPinDirection() : Camera , CameraBase , GCCamera , GigECamera
  • SetLUTChannel() : Camera , CameraBase , GCCamera , GigECamera
  • SetMaximumAVISize() : AVIRecorder
  • SetProperty() : GCCamera , GigECamera , Camera , CameraBase
  • SetStrobe() : Camera , CameraBase , GCCamera , GigECamera
  • SetTitle() : CameraControlDlg , CameraSelectionDlg
  • SetTriggerDelay() : Camera , CameraBase , GCCamera , GigECamera
  • SetTriggerMode() : Camera , CameraBase , GCCamera , GigECamera
  • SetUserBuffers() : GigECamera , Camera , CameraBase , GCCamera
  • SetVideoModeAndFrameRate() : Camera
  • Show() : CameraControlDlg
  • ShowCameraSelectionDialog() : FlyCapture3ApiGuiWrapper
  • ShowDialogByIndex() : FlyCapture3ApiGuiWrapper
  • ShowDialogByName() : FlyCapture3ApiGuiWrapper
  • ShowModal() : CameraControlDlg , CameraSelectionDlg
  • ShowPropertyGridDialog() : FlyCapture3ApiGuiWrapper
  • shutter : EmbeddedImageInfo
  • softwareTriggerSupported : TriggerModeInfo
  • source : StrobeControl , TriggerMode , StrobeInfo
  • sourceMask : TriggerModeInfo
  • sourcePort : GigEStreamChannel
  • Start() : SyncManager
  • StartCapture() : Camera , GCCamera , GigECamera , CameraBase
  • StartSyncCapture() : CameraBase , GCCamera , GigECamera , Camera
  • StatisticsChannel : ImageStatistics
  • Stop() : SyncManager
  • StopCapture() : GigECamera , CameraBase , GCCamera , Camera
  • StrobeControl() : StrobeControl
  • StrobeInfo() : StrobeInfo
  • strobePattern : EmbeddedImageInfo
  • subnetMask : CameraInfo
  • supported : LUTData
  • SyncManager() : SyncManager
  • sysMemSize : SystemInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • temperature : CameraStats
  • TestGainNode() : GCCamera
  • TIFFOption() : TIFFOption
  • timeSinceBusReset : CameraStats
  • timeSinceInitialization : CameraStats
  • timeStamp : CameraStats
  • TimeStamp() : TimeStamp
  • timestamp : EmbeddedImageInfo
  • TopologyNode() : TopologyNode
  • TriggerMode() : TriggerMode
  • TriggerModeInfo() : TriggerModeInfo
  • type : Property , FC2Version , PropertyInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • unitBytesPerPacket : Format7PacketInfo
  • unitSpecId : ConfigROM
  • unitSubSWVer : ConfigROM
  • unitSWVer : ConfigROM
  • UnregisterCallback() : BusManager
  • userDefinedName : CameraInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • ValidateFormat7Settings() : Camera
  • value : PGRGuid , GigEProperty
  • valueA : Property
  • valueB : Property
  • valueReadable : TriggerModeInfo
  • vendorName : CameraInfo
  • vendorPixelFormatBitField : GigEImageSettingsInfo , Format7Info
  • vendorUniqueInfo_0 : ConfigROM
  • vendorUniqueInfo_1 : ConfigROM
  • vendorUniqueInfo_2 : ConfigROM
  • vendorUniqueInfo_3 : ConfigROM
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitForBufferEvent() : Camera , CameraBase , GigECamera , GCCamera
  • whiteBalance : EmbeddedImageInfo
  • width : H264Option , GigEImageSettings , Format7ImageSettings
  • WriteGVCPMemory() : GCCamera , GigECamera
  • WriteGVCPRegister() : GCCamera , GigECamera
  • WriteGVCPRegisterBlock() : GCCamera , GigECamera
  • WritePhyRegister() : BusManager
  • WriteRegister() : GCCamera , GigECamera , Camera , CameraBase
  • WriteRegisterBlock() : Camera , GCCamera , GigECamera , CameraBase
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- x -

  • xmlURL1 : CameraInfo
  • xmlURL2 : CameraInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • CompressionMethod : TIFFOption
  • NodeType : TopologyNode
  • PortType : TopologyNode
  • StatisticsChannel : ImageStatistics
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Enumerator

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • ADOBE_DEFLATE : TIFFOption
  • BLUE : ImageStatistics
  • BUS : TopologyNode
  • CAMERA : TopologyNode
  • CCITTFAX3 : TIFFOption
  • CCITTFAX4 : TIFFOption
  • COMPUTER : TopologyNode
  • CONNECTED_TO_CHILD : TopologyNode
  • CONNECTED_TO_PARENT : TopologyNode
  • DEFLATE : TIFFOption
  • GREEN : ImageStatistics
  • GREY : ImageStatistics
  • HUE : ImageStatistics
  • JPEG : TIFFOption
  • LIGHTNESS : ImageStatistics
  • LZW : TIFFOption
  • NODE : TopologyNode
  • NONE : TIFFOption
  • NOT_CONNECTED : TopologyNode
  • NUM_STATISTICS_CHANNELS : ImageStatistics
  • PACKBITS : TIFFOption
  • RED : ImageStatistics
  • SATURATION : ImageStatistics
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- _ -

  • _GetDeviceName() : NodeMap
  • _GetNode() : NodeMap
  • _GetNodes() : NodeMap
  • _InvalidateNodes() : NodeMap
  • _Poll() : NodeMap
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- j -

  • JPEGOption() : JPEGOption
  • JPG2Option() : JPG2Option
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • LaunchBrowser() : Utilities
  • LaunchCommand() : Utilities
  • LaunchCommandAsync() : Utilities
  • LaunchHelp() : Utilities
  • LUTData() : LUTData
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • MACAddress() : MACAddress
  • MJPGOption() : MJPGOption
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- n -

  • NodeMap() : NodeMap
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • operator!=() : Error , IPAddress , MACAddress , PGRGuid
  • operator()() : Image
  • operator=() : Image , ImageStatistics , TopologyNode , Error
  • operator==() : Error , IPAddress , MACAddress , Error , PGRGuid
  • operator[]() : Image
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~AVIRecorder() : AVIRecorder
  • ~BusManager() : BusManager
  • ~Camera() : Camera
  • ~CameraBase() : CameraBase
  • ~CameraControlDlg() : CameraControlDlg
  • ~CameraSelectionDlg() : CameraSelectionDlg
  • ~Error() : Error
  • ~FlyCapture3ApiGuiWrapper() : FlyCapture3ApiGuiWrapper
  • ~GCCamera() : GCCamera
  • ~GigECamera() : GigECamera
  • ~Image() : Image
  • ~ImageStatistics() : ImageStatistics
  • ~NodeMap() : NodeMap
  • ~SyncManager() : SyncManager
  • ~TopologyNode() : TopologyNode
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • AddChild() : TopologyNode
  • AddPortType() : TopologyNode
  • AssignGuidToNode() : TopologyNode
  • AVIAppend() : AVIRecorder
  • AVIClose() : AVIRecorder
  • AVIOpen() : AVIRecorder
  • AVIOption() : AVIOption
  • AVIRecorder() : AVIRecorder
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • BMPOption() : BMPOption
  • BusManager() : BusManager
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • CalculateStatistics() : Image
  • Camera() : Camera
  • CameraBase() : CameraBase
  • CameraControlDlg() : CameraControlDlg
  • CameraInfo() : CameraInfo
  • CameraSelectionDlg() : CameraSelectionDlg
  • CameraStats() : CameraStats
  • CheckDriver() : Utilities
  • CollectSupportInformation() : Error
  • ConfigROM() : ConfigROM
  • Connect() : CameraControlDlg , GigECamera , Camera , GCCamera , CameraBase , GCCamera
  • ConnectGUILibrary() : FlyCapture3ApiGuiWrapper
  • Convert() : Image
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • DeepCopy() : Image
  • DeregisterAllEvents() : Camera , GigECamera , CameraBase
  • DeregisterEvent() : Camera , CameraBase , GigECamera
  • DetermineBitsPerPixel() : Image
  • DisableAll() : ImageStatistics
  • DisableCrossPCSynchronization() : SyncManager
  • Disconnect() : GigECamera , Camera , GCCamera , CameraBase , CameraControlDlg
  • DisconnectGUILibrary() : FlyCapture3ApiGuiWrapper
  • DiscoverGigECameras() : BusManager
  • DiscoverGigEPacketSize() : GigECamera
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • EmbeddedImageInfoProperty() : EmbeddedImageInfoProperty
  • EnableAll() : ImageStatistics
  • EnableCrossPCSynchronization() : SyncManager
  • EnableGreyOnly() : ImageStatistics
  • EnableHSLOnly() : ImageStatistics
  • EnableLUT() : GigECamera , CameraBase , GCCamera , Camera
  • EnableRGBOnly() : ImageStatistics
  • Error() : Error
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • FC2Config() : FC2Config
  • FireBusReset() : BusManager
  • FireSoftwareTrigger() : CameraBase , GCCamera , Camera , GigECamera
  • FlyCapture3ApiGuiWrapper() : FlyCapture3ApiGuiWrapper
  • ForceAllIPAddressesAutomatically() : BusManager
  • ForceIPAddressToCamera() : BusManager
  • Format7ImageSettings() : Format7ImageSettings
  • Format7Info() : Format7Info
  • Format7PacketInfo() : Format7PacketInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • GCCamera() : GCCamera
  • GCCamera::GetXML() : GCCamera
  • GetActiveLUTBank() : CameraBase , GCCamera , Camera , GigECamera
  • GetBayerTileFormat() : Image
  • GetBitsPerPixel() : Image
  • GetBlockId() : Image
  • GetBuildDate() : Error
  • GetCameraFromIndex() : BusManager
  • GetCameraFromIPAddress() : BusManager
  • GetCameraFromSerialNumber() : BusManager
  • GetCameraInfo() : GCCamera , GigECamera , Camera , CameraBase
  • GetCameraSerialNumberFromIndex() : BusManager
  • GetCause() : Error
  • GetChannelStatus() : ImageStatistics
  • GetChild() : TopologyNode
  • GetColorProcessing() : Image
  • GetCols() : Image
  • GetConfiguration() : Camera , CameraBase , GCCamera , GigECamera
  • GetControlNameList() : FlyCapture3ApiGuiWrapper
  • GetCycleTime() : GigECamera , Camera , CameraBase , GCCamera
  • GetData() : Image
  • GetDataSize() : Image
  • GetDefaultColorProcessing() : Image
  • GetDefaultOutputFormat() : Image
  • GetDescription() : Error
  • GetDeviceFromIndex() : BusManager
  • GetDeviceId() : TopologyNode
  • GetDialogNameList() : FlyCapture3ApiGuiWrapper
  • GetDimensions() : Image
  • GetDriverDeviceName() : Utilities
  • GetEmbeddedImageInfo() : Camera , CameraBase , GCCamera , GigECamera
  • GetFilename() : Error
  • GetFormat7Configuration() : Camera
  • GetFormat7Info() : Camera
  • GetGigEConfig() : GigECamera
  • GetGigEImageBinningSettings() : GigECamera
  • GetGigEImageSettings() : GigECamera
  • GetGigEImageSettingsInfo() : GigECamera
  • GetGigEImagingMode() : GigECamera
  • GetGigEProperty() : GigECamera
  • GetGigEStreamChannelInfo() : GigECamera
  • GetGPIOPinDirection() : Camera , CameraBase , GCCamera , GigECamera
  • GetGuid() : TopologyNode
  • GetHistogram() : ImageStatistics
  • GetInterfaceType() : GCCamera , TopologyNode
  • GetInterfaceTypeFromGuid() : BusManager
  • GetInternal() : Internal
  • GetLibraryVersion() : Utilities
  • GetLine() : Error
  • GetLUTBankInfo() : Camera , CameraBase , GCCamera , GigECamera
  • GetLUTChannel() : Camera , CameraBase , GCCamera , GigECamera
  • GetLUTInfo() : Camera , CameraBase , GCCamera , GigECamera
  • GetMean() : ImageStatistics
  • GetMemoryChannel() : Camera , CameraBase , GCCamera , GigECamera
  • GetMemoryChannelInfo() : Camera , CameraBase , GCCamera , GigECamera
  • GetMetadata() : Image
  • GetNodeMap() : GCCamera
  • GetNodeType() : TopologyNode
  • GetNumChildren() : TopologyNode
  • GetNumDialogs() : FlyCapture3ApiGuiWrapper
  • GetNumOfCameras() : BusManager
  • GetNumOfControls() : FlyCapture3ApiGuiWrapper
  • GetNumOfDevices() : BusManager
  • GetNumPixelValues() : ImageStatistics
  • GetNumPorts() : TopologyNode
  • GetNumStreamChannels() : GigECamera
  • GetPixelFormat() : Image
  • GetPixelValueRange() : ImageStatistics
  • GetPortType() : TopologyNode
  • GetProperty() : Camera , CameraBase , GigECamera , GCCamera
  • GetPropertyInfo() : Camera , CameraBase , GigECamera , GCCamera
  • GetRange() : ImageStatistics
  • GetReceivedDataSize() : Image
  • GetRegisterString() : GigECamera , GCCamera , CameraBase , Camera
  • GetRows() : Image
  • GetStatistics() : ImageStatistics
  • GetStats() : GCCamera , Camera , CameraBase , GigECamera
  • GetStride() : Image
  • GetStrobe() : GCCamera , GigECamera , CameraBase , Camera
  • GetStrobeInfo() : Camera , GCCamera , GigECamera , CameraBase
  • GetSyncStatus() : SyncManager
  • GetSystemInfo() : Utilities
  • GetTimeSinceSynced() : SyncManager
  • GetTimeStamp() : Image
  • GetTopology() : BusManager
  • GetTriggerDelay() : CameraBase , GCCamera , GigECamera , Camera
  • GetTriggerDelayInfo() : CameraBase , GigECamera , GCCamera , Camera
  • GetTriggerMode() : CameraBase , GCCamera , Camera , GigECamera
  • GetTriggerModeInfo() : Camera , GCCamera , CameraBase , GigECamera
  • GetType() : Error
  • GetUsbLinkInfo() : BusManager
  • GetUsbPortStatus() : BusManager
  • GetVideoModeAndFrameRate() : Camera
  • GetVideoModeAndFrameRateInfo() : Camera
  • GigECamera() : GigECamera
  • GigEConfig() : GigEConfig
  • GigEImageSettings() : GigEImageSettings
  • GigEImageSettingsInfo() : GigEImageSettingsInfo
  • GigEStreamChannel() : GigEStreamChannel
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • H264Option() : H264Option
  • Hide() : CameraControlDlg
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • Image() : Image
  • ImageMetadata() : ImageMetadata
  • ImageStatistics() : ImageStatistics
  • IPAddress() : IPAddress
  • IsCameraControlable() : BusManager
  • IsConnected() : CameraBase , GCCamera , GigECamera , Camera
  • IsTimingBusConnected() : SyncManager
  • IsVisible() : CameraControlDlg
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • PGMOption() : PGMOption
  • PGRGuid() : PGRGuid
  • PNGOption() : PNGOption
  • PPMOption() : PPMOption
  • PrintErrorTrace() : Error
  • Property() : Property
  • PropertyInfo() : PropertyInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- q -

  • QueryCrossPCSynchronizationSetting() : SyncManager
  • QueryGigEImagingMode() : GigECamera
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • ReadGVCPMemory() : GCCamera , GigECamera
  • ReadGVCPRegister() : GigECamera , GCCamera
  • ReadGVCPRegisterBlock() : GCCamera , GigECamera
  • ReadPhyRegister() : BusManager
  • ReadRegister() : Camera , CameraBase , GCCamera , GigECamera
  • ReadRegisterBlock() : Camera , CameraBase , GCCamera , GigECamera
  • RegisterAllEvents() : Camera , CameraBase , GigECamera
  • RegisterCallback() : BusManager
  • RegisterEvent() : Camera , CameraBase , GigECamera
  • ReleaseBuffer() : Image
  • RescanBus() : BusManager
  • RescanMasterTimingBus() : SyncManager
  • ResetStats() : GigECamera , GCCamera , Camera , CameraBase
  • RestoreFromMemoryChannel() : CameraBase , GCCamera , GigECamera , Camera
  • RetrieveBuffer() : Camera , GigECamera , GCCamera , CameraBase
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • Save() : Image
  • SaveToMemoryChannel() : Camera , CameraBase , GCCamera , GigECamera
  • SetActiveLUTBank() : GigECamera , Camera , CameraBase , GCCamera
  • SetBlockId() : Image
  • SetCallback() : Camera , CameraBase , GCCamera , GigECamera
  • SetCamera() : GCCamera
  • SetChannelStatus() : ImageStatistics
  • SetColorProcessing() : Image
  • SetConfiguration() : Camera , CameraBase , GCCamera , GigECamera
  • SetData() : Image
  • SetDefaultColorProcessing() : Image
  • SetDefaultOutputFormat() : Image
  • SetDimensions() : Image
  • SetEmbeddedImageInfo() : Camera , CameraBase , GCCamera , GigECamera
  • SetFormat7Configuration() : Camera
  • SetGigEConfig() : GigECamera
  • SetGigEImageBinningSettings() : GigECamera
  • SetGigEImageSettings() : GigECamera
  • SetGigEImagingMode() : GigECamera
  • SetGigEProperty() : GigECamera
  • SetGigEStreamChannelInfo() : GigECamera
  • SetGPIOPinDirection() : Camera , CameraBase , GCCamera , GigECamera
  • SetLUTChannel() : Camera , CameraBase , GCCamera , GigECamera
  • SetMaximumAVISize() : AVIRecorder
  • SetProperty() : Camera , CameraBase , GCCamera , GigECamera
  • SetStrobe() : Camera , CameraBase , GCCamera , GigECamera
  • SetTitle() : CameraSelectionDlg , CameraControlDlg
  • SetTriggerDelay() : GCCamera , Camera , CameraBase , GigECamera
  • SetTriggerMode() : Camera , CameraBase , GCCamera , GigECamera
  • SetUserBuffers() : CameraBase , GigECamera , Camera , GCCamera
  • SetVideoModeAndFrameRate() : Camera
  • Show() : CameraControlDlg
  • ShowCameraSelectionDialog() : FlyCapture3ApiGuiWrapper
  • ShowDialogByIndex() : FlyCapture3ApiGuiWrapper
  • ShowDialogByName() : FlyCapture3ApiGuiWrapper
  • ShowModal() : CameraControlDlg , CameraSelectionDlg , CameraControlDlg
  • ShowPropertyGridDialog() : FlyCapture3ApiGuiWrapper
  • Start() : SyncManager
  • StartCapture() : GCCamera , GigECamera , CameraBase , Camera
  • StartSyncCapture() : Camera , GCCamera , CameraBase , GigECamera
  • Stop() : SyncManager
  • StopCapture() : GigECamera , GCCamera , CameraBase , Camera
  • StrobeControl() : StrobeControl
  • StrobeInfo() : StrobeInfo
  • SyncManager() : SyncManager
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • TestGainNode() : GCCamera
  • TIFFOption() : TIFFOption
  • TimeStamp() : TimeStamp
  • TopologyNode() : TopologyNode
  • TriggerMode() : TriggerMode
  • TriggerModeInfo() : TriggerModeInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • UnregisterCallback() : BusManager
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • ValidateFormat7Settings() : Camera
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • WaitForBufferEvent() : Camera , CameraBase , GigECamera , GCCamera
  • WriteGVCPMemory() : GCCamera , GigECamera
  • WriteGVCPRegister() : GigECamera , GCCamera
  • WriteGVCPRegisterBlock() : GCCamera , GigECamera
  • WritePhyRegister() : BusManager
  • WriteRegister() : GCCamera , CameraBase , GigECamera , Camera
  • WriteRegisterBlock() : CameraBase , GCCamera , GigECamera , Camera
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Related Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • ImageStatsCalculator : ImageStatistics
  • InternalError : Error
  • Iso : Image
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- a -

  • absControl : Property
  • absMax : PropertyInfo
  • absMin : PropertyInfo
  • absValSupported : PropertyInfo
  • absValue : Property
  • applicationIPAddress : CameraInfo
  • applicationPort : CameraInfo
  • asyncBusSpeed : FC2Config
  • autoManualMode : Property
  • autoSupported : PropertyInfo
  • available : EmbeddedImageInfoProperty
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- l -

  • libraryList : SystemInfo
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- m -

  • m_busMgr : GCCamera
  • m_pCameraData : CameraBase
  • macAddress : CameraInfo
  • major : FC2Version
  • manualSupported : PropertyInfo
  • max : GigEProperty , PropertyInfo
  • maxBytesPerPacket : Format7PacketInfo
  • maxHeight : GigEImageSettingsInfo , Format7Info
  • maximumBusSpeed : CameraInfo
  • maxPacketSize : Format7Info
  • maxValue : StrobeInfo
  • maxWidth : GigEImageSettingsInfo , Format7Info
  • microSeconds : TimeStamp
  • min : GigEProperty , PropertyInfo
  • minNumImageNotifications : FC2Config
  • minor : FC2Version
  • minPacketSize : Format7Info
  • minValue : StrobeInfo
  • mode : Format7Info , TriggerMode , Format7ImageSettings
  • modelName : CameraInfo
  • modeMask : TriggerModeInfo
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- n -

  • networkInterfaceIndex : GigEStreamChannel
  • nodeNumber : CameraInfo
  • nodeVendorId : ConfigROM
  • numBanks : LUTData
  • numBuffers : FC2Config
  • numChannels : LUTData
  • numCpuCores : SystemInfo
  • numCurrents : CameraStats
  • numEntries : LUTData
  • numImageNotifications : FC2Config
  • numResendPacketsReceived : CameraStats
  • numResendPacketsRequested : CameraStats
  • numVoltages : CameraStats
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- o -

  • octets : IPAddress , MACAddress
  • offsetHStepSize : Format7Info , GigEImageSettingsInfo
  • offsetVStepSize : GigEImageSettingsInfo , Format7Info
  • offsetX : Format7ImageSettings , GigEImageSettings
  • offsetY : GigEImageSettings , Format7ImageSettings
  • onePush : Property
  • onePushSupported : PropertyInfo
  • onOff : EmbeddedImageInfoProperty , StrobeControl , Property , TriggerMode
  • onOffSupported : PropertyInfo , StrobeInfo , TriggerModeInfo
  • osDescription : SystemInfo
  • osType : SystemInfo
  • outputBitDepth : LUTData
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- b -

  • bandwidthAllocation : FC2Config
  • bayerTileFormat : CameraInfo
  • binaryFile : PGMOption , PPMOption
  • bitrate : H264Option
  • brightness : EmbeddedImageInfo
  • build : FC2Version
  • busNumber : CameraInfo
  • byteOrder : SystemInfo
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- c -

  • cameraCurrents : CameraStats
  • cameraPowerUp : CameraStats
  • cameraVoltages : CameraStats
  • ccpStatus : CameraInfo
  • chipIdHi : ConfigROM
  • chipIdLo : ConfigROM
  • compression : TIFFOption
  • compressionLevel : PNGOption
  • configROM : CameraInfo
  • cpuDescription : SystemInfo
  • cycleCount : TimeStamp
  • cycleOffset : TimeStamp
  • cycleSeconds : TimeStamp
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- d -

  • defaultGateway : CameraInfo
  • delay : StrobeControl
  • destinationIpAddress : GigEStreamChannel
  • doNotFragment : GigEStreamChannel
  • driverList : SystemInfo
  • driverName : CameraInfo
  • driverType : CameraInfo
  • duration : StrobeControl
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- e -

  • embeddedBrightness : ImageMetadata
  • embeddedExposure : ImageMetadata
  • embeddedFrameCounter : ImageMetadata
  • embeddedGain : ImageMetadata
  • embeddedGPIOPinState : ImageMetadata
  • embeddedROIPosition : ImageMetadata
  • embeddedShutter : ImageMetadata
  • embeddedStrobePattern : ImageMetadata
  • embeddedTimeStamp : ImageMetadata
  • embeddedWhiteBalance : ImageMetadata
  • enabled : LUTData
  • enablePacketResend : GigEConfig
  • EventCallbackFcn : EventOptions
  • EventData : EventCallbackData
  • EventDataSize : EventCallbackData
  • EventID : EventCallbackData
  • EventName : EventOptions , EventCallbackData
  • EventTimestamp : EventCallbackData
  • EventUserData : EventCallbackData , EventOptions
  • EventUserDataSize : EventCallbackData , EventOptions
  • exposure : EmbeddedImageInfo
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- f -

  • firmwareBuildTime : CameraInfo
  • firmwareVersion : CameraInfo
  • frameCounter : EmbeddedImageInfo
  • frameRate : MJPGOption , H264Option , AVIOption
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- g -

  • gain : EmbeddedImageInfo
  • gigEMajorVersion : CameraInfo
  • gigEMinorVersion : CameraInfo
  • GPIOPinState : EmbeddedImageInfo
  • gpuDescription : SystemInfo
  • grabMode : FC2Config
  • grabTimeout : FC2Config
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- h -

  • height : GigEImageSettings , Format7ImageSettings , H264Option
  • highPerformanceRetrieveBuffer : FC2Config
  • hostPort : GigEStreamChannel
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- i -

  • iidcVer : CameraInfo
  • imageCorrupt : CameraStats
  • imageDriverDropped : CameraStats
  • imageDropped : CameraStats
  • imageHStepSize : GigEImageSettingsInfo , Format7Info
  • imageVStepSize : Format7Info , GigEImageSettingsInfo
  • imageXmitFailed : CameraStats
  • indexedColor_8bit : BMPOption
  • inputBitDepth : LUTData
  • interfaceType : CameraInfo
  • interlaced : PNGOption
  • interPacketDelay : GigEStreamChannel
  • ipAddress : CameraInfo
  • isColorCamera : CameraInfo
  • isochBusSpeed : FC2Config
  • isReadable : GigEProperty
  • isWritable : GigEProperty
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- p -

  • packetSize : GigEStreamChannel , Format7Info
  • parameter : TriggerMode
  • pcieBusSpeed : CameraInfo
  • percentage : Format7Info
  • pixelFormat : GigEImageSettings , Format7ImageSettings
  • pixelFormatBitField : GigEImageSettingsInfo , Format7Info
  • polarity : TriggerMode , StrobeControl
  • polaritySupported : TriggerModeInfo , StrobeInfo
  • portErrors : CameraStats
  • present : TriggerModeInfo , Property , StrobeInfo , PropertyInfo
  • progressive : JPEGOption
  • propType : GigEProperty
  • pszKeyword : ConfigROM
  • pUnitAbbr : PropertyInfo
  • pUnits : PropertyInfo
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- q -

  • quality : JPEGOption , MJPGOption , JPG2Option
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- r -

  • readOutSupported : PropertyInfo , TriggerModeInfo , StrobeInfo
  • recommendedBytesPerPacket : Format7PacketInfo
  • registerTimeout : GigEConfig , FC2Config
  • registerTimeoutRetries : FC2Config , GigEConfig
  • regReadFailed : CameraStats
  • regWriteFailed : CameraStats
  • reserved : PGMOption , PPMOption , PNGOption , CameraStats , LUTData , ImageMetadata , CameraInfo , ConfigROM , TimeStamp , StrobeControl , StrobeInfo , TriggerMode , TriggerModeInfo , Property , PropertyInfo , BMPOption , Format7PacketInfo , Format7Info , Format7ImageSettings , GigEImageSettings , GigEImageSettingsInfo , AVIOption , H264Option , FC2Config , MJPGOption , SystemInfo , JPEGOption , TIFFOption , JPG2Option
  • ROIPosition : EmbeddedImageInfo
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- s -

  • screenHeight : SystemInfo
  • screenWidth : SystemInfo
  • seconds : TimeStamp
  • sensorInfo : CameraInfo
  • sensorResolution : CameraInfo
  • serialNumber : CameraInfo
  • shutter : EmbeddedImageInfo
  • softwareTriggerSupported : TriggerModeInfo
  • source : StrobeControl , TriggerMode , StrobeInfo
  • sourceMask : TriggerModeInfo
  • sourcePort : GigEStreamChannel
  • strobePattern : EmbeddedImageInfo
  • subnetMask : CameraInfo
  • supported : LUTData
  • sysMemSize : SystemInfo
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- t -

  • temperature : CameraStats
  • timeSinceBusReset : CameraStats
  • timeSinceInitialization : CameraStats
  • timestamp : EmbeddedImageInfo
  • timeStamp : CameraStats
  • type : Property , PropertyInfo , FC2Version
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- u -

  • unitBytesPerPacket : Format7PacketInfo
  • unitSpecId : ConfigROM
  • unitSubSWVer : ConfigROM
  • unitSWVer : ConfigROM
  • userDefinedName : CameraInfo
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- v -

  • value : PGRGuid , GigEProperty
  • valueA : Property
  • valueB : Property
  • valueReadable : TriggerModeInfo
  • vendorName : CameraInfo
  • vendorPixelFormatBitField : Format7Info , GigEImageSettingsInfo
  • vendorUniqueInfo_0 : ConfigROM
  • vendorUniqueInfo_1 : ConfigROM
  • vendorUniqueInfo_2 : ConfigROM
  • vendorUniqueInfo_3 : ConfigROM
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- w -

  • whiteBalance : EmbeddedImageInfo
  • width : H264Option , Format7ImageSettings , GigEImageSettings
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- x -

  • xmlURL1 : CameraInfo
  • xmlURL2 : CameraInfo
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: File Members

  • File List
  • File Members
  • All
  • Defines
  • FLYCAPTURE2_API : FlyCapture2Platform.h
  • FLYCAPTURE2_LOCAL : FlyCapture2Platform.h
  • FULL_32BIT_VALUE : FlyCapture2Defs.h
  • MULTISYNCLIBRARY_API : MultiSyncLibraryPlatform.h
  • MULTISYNCLIBRARY_LOCAL : MultiSyncLibraryPlatform.h
  • NULL : FlyCapture2Defs.h
  • WRAPPER_API : FlyCapture3ApiGuiWrapper.h
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Main Page

FlyCapture2 Documentation
Generated on Tue Jan 9 2018 21:57:12 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy

Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- j -

  • JPEG : FlyCapture2
  • JPEG2000 : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- l -

  • LINUX_X64 : FlyCapture2
  • LINUX_X86 : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- m -

  • MAC : FlyCapture2
  • Mode : FlyCapture2
  • MODE_0 : FlyCapture2
  • MODE_1 : FlyCapture2
  • MODE_10 : FlyCapture2
  • MODE_11 : FlyCapture2
  • MODE_12 : FlyCapture2
  • MODE_13 : FlyCapture2
  • MODE_14 : FlyCapture2
  • MODE_15 : FlyCapture2
  • MODE_16 : FlyCapture2
  • MODE_17 : FlyCapture2
  • MODE_18 : FlyCapture2
  • MODE_19 : FlyCapture2
  • MODE_2 : FlyCapture2
  • MODE_20 : FlyCapture2
  • MODE_21 : FlyCapture2
  • MODE_22 : FlyCapture2
  • MODE_23 : FlyCapture2
  • MODE_24 : FlyCapture2
  • MODE_25 : FlyCapture2
  • MODE_26 : FlyCapture2
  • MODE_27 : FlyCapture2
  • MODE_28 : FlyCapture2
  • MODE_29 : FlyCapture2
  • MODE_3 : FlyCapture2
  • MODE_30 : FlyCapture2
  • MODE_31 : FlyCapture2
  • MODE_4 : FlyCapture2
  • MODE_5 : FlyCapture2
  • MODE_6 : FlyCapture2
  • MODE_7 : FlyCapture2
  • MODE_8 : FlyCapture2
  • MODE_9 : FlyCapture2
  • MODE_FORCE_32BITS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- n -

  • NEAREST_NEIGHBOR : FlyCapture2
  • NO_COLOR_PROCESSING : FlyCapture2
  • NONE : FlyCapture2
  • NUM_FRAMERATES : FlyCapture2
  • NUM_MODES : FlyCapture2
  • NUM_PIXEL_FORMATS : FlyCapture2
  • NUM_VIDEOMODES : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- o -

  • OSType : FlyCapture2
  • OSTYPE_FORCE_32BITS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- z -

  • ZOOM : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- b -

  • BANDWIDTH_ALLOCATION_FORCE_32BITS : FlyCapture2
  • BANDWIDTH_ALLOCATION_OFF : FlyCapture2
  • BANDWIDTH_ALLOCATION_ON : FlyCapture2
  • BANDWIDTH_ALLOCATION_UNSPECIFIED : FlyCapture2
  • BANDWIDTH_ALLOCATION_UNSUPPORTED : FlyCapture2
  • BandwidthAllocation : FlyCapture2
  • BayerTileFormat : FlyCapture2
  • BGGR : FlyCapture2
  • BMP : FlyCapture2
  • BRIGHTNESS : FlyCapture2
  • BT_FORCE_32BITS : FlyCapture2
  • BUFFER_FRAMES : FlyCapture2
  • BUS_RESET : FlyCapture2
  • BusCallbackType : FlyCapture2
  • BusEventCallback : FlyCapture2
  • BusSpeed : FlyCapture2
  • BUSSPEED_10000BASE_T : FlyCapture2
  • BUSSPEED_1000BASE_T : FlyCapture2
  • BUSSPEED_100BASE_T : FlyCapture2
  • BUSSPEED_10BASE_T : FlyCapture2
  • BUSSPEED_ANY : FlyCapture2
  • BUSSPEED_FORCE_32BITS : FlyCapture2
  • BUSSPEED_S100 : FlyCapture2
  • BUSSPEED_S1600 : FlyCapture2
  • BUSSPEED_S200 : FlyCapture2
  • BUSSPEED_S3200 : FlyCapture2
  • BUSSPEED_S400 : FlyCapture2
  • BUSSPEED_S480 : FlyCapture2
  • BUSSPEED_S5000 : FlyCapture2
  • BUSSPEED_S800 : FlyCapture2
  • BUSSPEED_S_FASTEST : FlyCapture2
  • BUSSPEED_SPEED_UNKNOWN : FlyCapture2
  • BYTE_ORDER_BIG_ENDIAN : FlyCapture2
  • BYTE_ORDER_FORCE_32BITS : FlyCapture2
  • BYTE_ORDER_LITTLE_ENDIAN : FlyCapture2
  • ByteOrder : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • CALLBACK_TYPE_FORCE_32BITS : FlyCapture2
  • CallbackHandle : FlyCapture2
  • CameraEventCallback : FlyCapture2
  • COLOR_PROCESSING_ALGORITHM_FORCE_32BITS : FlyCapture2
  • ColorProcessingAlgorithm : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- d -

  • DEFAULT : FlyCapture2
  • DIRECTIONAL_FILTER : FlyCapture2
  • DRIVER_1394_CAM : FlyCapture2
  • DRIVER_1394_JUJU : FlyCapture2
  • DRIVER_1394_PRO : FlyCapture2
  • DRIVER_1394_RAW1394 : FlyCapture2
  • DRIVER_1394_VIDEO1394 : FlyCapture2
  • DRIVER_FORCE_32BITS : FlyCapture2
  • DRIVER_GIGE_FILTER : FlyCapture2
  • DRIVER_GIGE_LWF : FlyCapture2
  • DRIVER_GIGE_NONE : FlyCapture2
  • DRIVER_GIGE_PRO : FlyCapture2
  • DRIVER_UNKNOWN : FlyCapture2
  • DRIVER_USB3_PRO : FlyCapture2
  • DRIVER_USB_CAM : FlyCapture2
  • DRIVER_USB_NONE : FlyCapture2
  • DriverType : FlyCapture2
  • DROP_FRAMES : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- e -

  • EDGE_SENSING : FlyCapture2
  • ErrorType : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- f -

  • FOCUS : FlyCapture2
  • FRAME_RATE : FlyCapture2
  • FrameRate : FlyCapture2
  • FRAMERATE_120 : FlyCapture2
  • FRAMERATE_15 : FlyCapture2
  • FRAMERATE_1_875 : FlyCapture2
  • FRAMERATE_240 : FlyCapture2
  • FRAMERATE_30 : FlyCapture2
  • FRAMERATE_3_75 : FlyCapture2
  • FRAMERATE_60 : FlyCapture2
  • FRAMERATE_7_5 : FlyCapture2
  • FRAMERATE_FORCE_32BITS : FlyCapture2
  • FRAMERATE_FORMAT7 : FlyCapture2
  • FROM_FILE_EXT : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- g -

  • GAIN : FlyCapture2
  • GAMMA : FlyCapture2
  • GBRG : FlyCapture2
  • GigEPropertyType : FlyCapture2
  • GRAB_MODE_FORCE_32BITS : FlyCapture2
  • GRAB_TIMEOUT_FORCE_32BITS : FlyCapture2
  • GrabMode : FlyCapture2
  • GrabTimeout : FlyCapture2
  • GRBG : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- h -

  • HEARTBEAT : FlyCapture2
  • HEARTBEAT_TIMEOUT : FlyCapture2
  • HQ_LINEAR : FlyCapture2
  • HUE : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- i -

  • IMAGE_FILE_FORMAT_FORCE_32BITS : FlyCapture2
  • ImageEventCallback : FlyCapture2
  • ImageFileFormat : FlyCapture2
  • INTERFACE_GIGE : FlyCapture2
  • INTERFACE_IEEE1394 : FlyCapture2
  • INTERFACE_TYPE_FORCE_32BITS : FlyCapture2
  • INTERFACE_UNKNOWN : FlyCapture2
  • INTERFACE_USB2 : FlyCapture2
  • INTERFACE_USB3 : FlyCapture2
  • InterfaceType : FlyCapture2
  • IPP : FlyCapture2
  • IRIS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- p -

  • PACKET_DELAY : FlyCapture2
  • PACKET_SIZE : FlyCapture2
  • PAN : FlyCapture2
  • PCIE_BUSSPEED_2_5 : FlyCapture2
  • PCIE_BUSSPEED_5_0 : FlyCapture2
  • PCIE_BUSSPEED_FORCE_32BITS : FlyCapture2
  • PCIE_BUSSPEED_UNKNOWN : FlyCapture2
  • PCIeBusSpeed : FlyCapture2
  • PGM : FlyCapture2
  • PGRERROR_BUFFER_TOO_SMALL : FlyCapture2
  • PGRERROR_BUS_MASTER_FAILED : FlyCapture2
  • PGRERROR_FAILED : FlyCapture2
  • PGRERROR_FAILED_BUS_MASTER_CONNECTION : FlyCapture2
  • PGRERROR_FAILED_GUID : FlyCapture2
  • PGRERROR_FORCE_32BITS : FlyCapture2
  • PGRERROR_IIDC_FAILED : FlyCapture2
  • PGRERROR_IMAGE_CONSISTENCY_ERROR : FlyCapture2
  • PGRERROR_IMAGE_CONVERSION_FAILED : FlyCapture2
  • PGRERROR_IMAGE_LIBRARY_FAILURE : FlyCapture2
  • PGRERROR_INCOMPATIBLE_DRIVER : FlyCapture2
  • PGRERROR_INIT_FAILED : FlyCapture2
  • PGRERROR_INVALID_BUS_MANAGER : FlyCapture2
  • PGRERROR_INVALID_GENERATION : FlyCapture2
  • PGRERROR_INVALID_MODE : FlyCapture2
  • PGRERROR_INVALID_PACKET_SIZE : FlyCapture2
  • PGRERROR_INVALID_PARAMETER : FlyCapture2
  • PGRERROR_INVALID_SETTINGS : FlyCapture2
  • PGRERROR_ISOCH_ALREADY_STARTED : FlyCapture2
  • PGRERROR_ISOCH_BANDWIDTH_EXCEEDED : FlyCapture2
  • PGRERROR_ISOCH_FAILED : FlyCapture2
  • PGRERROR_ISOCH_NOT_STARTED : FlyCapture2
  • PGRERROR_ISOCH_RETRIEVE_BUFFER_FAILED : FlyCapture2
  • PGRERROR_ISOCH_START_FAILED : FlyCapture2
  • PGRERROR_ISOCH_STOP_FAILED : FlyCapture2
  • PGRERROR_ISOCH_SYNC_FAILED : FlyCapture2
  • PGRERROR_LOW_LEVEL_FAILURE : FlyCapture2
  • PGRERROR_LUT_FAILED : FlyCapture2
  • PGRERROR_MEMORY_ALLOCATION_FAILED : FlyCapture2
  • PGRERROR_NOT_CONNECTED : FlyCapture2
  • PGRERROR_NOT_FOUND : FlyCapture2
  • PGRERROR_NOT_IMPLEMENTED : FlyCapture2
  • PGRERROR_NOT_IN_FORMAT7 : FlyCapture2
  • PGRERROR_NOT_INTITIALIZED : FlyCapture2
  • PGRERROR_NOT_SUPPORTED : FlyCapture2
  • PGRERROR_OK : FlyCapture2
  • PGRERROR_PROPERTY_FAILED : FlyCapture2
  • PGRERROR_PROPERTY_NOT_PRESENT : FlyCapture2
  • PGRERROR_READ_REGISTER_FAILED : FlyCapture2
  • PGRERROR_REGISTER_FAILED : FlyCapture2
  • PGRERROR_STROBE_FAILED : FlyCapture2
  • PGRERROR_TIMEOUT : FlyCapture2
  • PGRERROR_TRIGGER_FAILED : FlyCapture2
  • PGRERROR_UNDEFINED : FlyCapture2
  • PGRERROR_WRITE_REGISTER_FAILED : FlyCapture2
  • PGRSyncError : MultiSyncLibrary
  • PGRSyncError_ALREADY_STARTED : MultiSyncLibrary
  • PGRSyncError_ALREADY_STOPPED : MultiSyncLibrary
  • PGRSyncError_CAMERA_NOT_FOUND : MultiSyncLibrary
  • PGRSyncError_FAILED : MultiSyncLibrary
  • PGRSyncError_OK : MultiSyncLibrary
  • PGRSyncError_UNKNOWN_ERROR : MultiSyncLibrary
  • PGRSyncMessage : MultiSyncLibrary
  • PGRSyncMessage_BUS_RESET : MultiSyncLibrary
  • PGRSyncMessage_DEVICE_ERROR : MultiSyncLibrary
  • PGRSyncMessage_NOMASTER : MultiSyncLibrary
  • PGRSyncMessage_NOT_ENOUGH_DEVICES : MultiSyncLibrary
  • PGRSyncMessage_NOT_INITIALIZED : MultiSyncLibrary
  • PGRSyncMessage_OK : MultiSyncLibrary
  • PGRSyncMessage_STARTED : MultiSyncLibrary
  • PGRSyncMessage_STOPPED : MultiSyncLibrary
  • PGRSyncMessage_SYNCING : MultiSyncLibrary
  • PGRSyncMessage_THREAD_ERROR : MultiSyncLibrary
  • PGRSyncMessage_UNKNOWN_ERROR : MultiSyncLibrary
  • PIXEL_FORMAT_411YUV8 : FlyCapture2
  • PIXEL_FORMAT_422YUV8 : FlyCapture2
  • PIXEL_FORMAT_422YUV8_JPEG : FlyCapture2
  • PIXEL_FORMAT_444YUV8 : FlyCapture2
  • PIXEL_FORMAT_BGR : FlyCapture2
  • PIXEL_FORMAT_BGR16 : FlyCapture2
  • PIXEL_FORMAT_BGRU : FlyCapture2
  • PIXEL_FORMAT_BGRU16 : FlyCapture2
  • PIXEL_FORMAT_MONO12 : FlyCapture2
  • PIXEL_FORMAT_MONO16 : FlyCapture2
  • PIXEL_FORMAT_MONO8 : FlyCapture2
  • PIXEL_FORMAT_RAW12 : FlyCapture2
  • PIXEL_FORMAT_RAW16 : FlyCapture2
  • PIXEL_FORMAT_RAW8 : FlyCapture2
  • PIXEL_FORMAT_RGB : FlyCapture2
  • PIXEL_FORMAT_RGB16 : FlyCapture2
  • PIXEL_FORMAT_RGB8 : FlyCapture2
  • PIXEL_FORMAT_RGBU : FlyCapture2
  • PIXEL_FORMAT_S_MONO16 : FlyCapture2
  • PIXEL_FORMAT_S_RGB16 : FlyCapture2
  • PixelFormat : FlyCapture2
  • PNG : FlyCapture2
  • PPM : FlyCapture2
  • PROPERTY_TYPE_FORCE_32BITS : FlyCapture2
  • PropertyType : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- r -

  • RAW : FlyCapture2
  • REMOVAL : FlyCapture2
  • RGGB : FlyCapture2
  • RIGOROUS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- s -

  • SATURATION : FlyCapture2
  • SHARPNESS : FlyCapture2
  • SHUTTER : FlyCapture2
  • sk_maxNumPorts : FlyCapture2
  • sk_maxStringLength : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- t -

  • TEMPERATURE : FlyCapture2
  • TIFF : FlyCapture2
  • TILT : FlyCapture2
  • TIMEOUT_INFINITE : FlyCapture2
  • TIMEOUT_NONE : FlyCapture2
  • TIMEOUT_UNSPECIFIED : FlyCapture2
  • TRIGGER_DELAY : FlyCapture2
  • TRIGGER_MODE : FlyCapture2
  • TriggerDelay : FlyCapture2
  • TriggerDelayInfo : FlyCapture2
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- u -

  • UNKNOWN_OS : FlyCapture2
  • UNSPECIFIED_GRAB_MODE : FlyCapture2
  • UNSPECIFIED_PIXEL_FORMAT : FlyCapture2
  • UNSPECIFIED_PROPERTY_TYPE : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- v -

  • VideoMode : FlyCapture2
  • VIDEOMODE_1024x768RGB : FlyCapture2
  • VIDEOMODE_1024x768Y16 : FlyCapture2
  • VIDEOMODE_1024x768Y8 : FlyCapture2
  • VIDEOMODE_1024x768YUV422 : FlyCapture2
  • VIDEOMODE_1280x960RGB : FlyCapture2
  • VIDEOMODE_1280x960Y16 : FlyCapture2
  • VIDEOMODE_1280x960Y8 : FlyCapture2
  • VIDEOMODE_1280x960YUV422 : FlyCapture2
  • VIDEOMODE_1600x1200RGB : FlyCapture2
  • VIDEOMODE_1600x1200Y16 : FlyCapture2
  • VIDEOMODE_1600x1200Y8 : FlyCapture2
  • VIDEOMODE_1600x1200YUV422 : FlyCapture2
  • VIDEOMODE_160x120YUV444 : FlyCapture2
  • VIDEOMODE_320x240YUV422 : FlyCapture2
  • VIDEOMODE_640x480RGB : FlyCapture2
  • VIDEOMODE_640x480Y16 : FlyCapture2
  • VIDEOMODE_640x480Y8 : FlyCapture2
  • VIDEOMODE_640x480YUV411 : FlyCapture2
  • VIDEOMODE_640x480YUV422 : FlyCapture2
  • VIDEOMODE_800x600RGB : FlyCapture2
  • VIDEOMODE_800x600Y16 : FlyCapture2
  • VIDEOMODE_800x600Y8 : FlyCapture2
  • VIDEOMODE_800x600YUV422 : FlyCapture2
  • VIDEOMODE_FORCE_32BITS : FlyCapture2
  • VIDEOMODE_FORMAT7 : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- w -

  • WEIGHTED_DIRECTIONAL_FILTER : FlyCapture2
  • WHITE_BALANCE : FlyCapture2
  • WINDOWS_X64 : FlyCapture2
  • WINDOWS_X86 : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • BandwidthAllocation : FlyCapture2
  • BayerTileFormat : FlyCapture2
  • BusCallbackType : FlyCapture2
  • BusSpeed : FlyCapture2
  • ByteOrder : FlyCapture2
  • ColorProcessingAlgorithm : FlyCapture2
  • DriverType : FlyCapture2
  • ErrorType : FlyCapture2
  • FrameRate : FlyCapture2
  • GigEPropertyType : FlyCapture2
  • GrabMode : FlyCapture2
  • GrabTimeout : FlyCapture2
  • ImageFileFormat : FlyCapture2
  • InterfaceType : FlyCapture2
  • Mode : FlyCapture2
  • OSType : FlyCapture2
  • PCIeBusSpeed : FlyCapture2
  • PGRSyncError : MultiSyncLibrary
  • PGRSyncMessage : MultiSyncLibrary
  • PixelFormat : FlyCapture2
  • PropertyType : FlyCapture2
  • VideoMode : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- a -

  • ARRIVAL : FlyCapture2
  • AUTO_EXPOSURE : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- j -

  • JPEG : FlyCapture2
  • JPEG2000 : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- l -

  • LINUX_X64 : FlyCapture2
  • LINUX_X86 : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- m -

  • MAC : FlyCapture2
  • MODE_0 : FlyCapture2
  • MODE_1 : FlyCapture2
  • MODE_10 : FlyCapture2
  • MODE_11 : FlyCapture2
  • MODE_12 : FlyCapture2
  • MODE_13 : FlyCapture2
  • MODE_14 : FlyCapture2
  • MODE_15 : FlyCapture2
  • MODE_16 : FlyCapture2
  • MODE_17 : FlyCapture2
  • MODE_18 : FlyCapture2
  • MODE_19 : FlyCapture2
  • MODE_2 : FlyCapture2
  • MODE_20 : FlyCapture2
  • MODE_21 : FlyCapture2
  • MODE_22 : FlyCapture2
  • MODE_23 : FlyCapture2
  • MODE_24 : FlyCapture2
  • MODE_25 : FlyCapture2
  • MODE_26 : FlyCapture2
  • MODE_27 : FlyCapture2
  • MODE_28 : FlyCapture2
  • MODE_29 : FlyCapture2
  • MODE_3 : FlyCapture2
  • MODE_30 : FlyCapture2
  • MODE_31 : FlyCapture2
  • MODE_4 : FlyCapture2
  • MODE_5 : FlyCapture2
  • MODE_6 : FlyCapture2
  • MODE_7 : FlyCapture2
  • MODE_8 : FlyCapture2
  • MODE_9 : FlyCapture2
  • MODE_FORCE_32BITS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- n -

  • NEAREST_NEIGHBOR : FlyCapture2
  • NO_COLOR_PROCESSING : FlyCapture2
  • NONE : FlyCapture2
  • NUM_FRAMERATES : FlyCapture2
  • NUM_MODES : FlyCapture2
  • NUM_PIXEL_FORMATS : FlyCapture2
  • NUM_VIDEOMODES : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- o -

  • OSTYPE_FORCE_32BITS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- z -

  • ZOOM : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- b -

  • BANDWIDTH_ALLOCATION_FORCE_32BITS : FlyCapture2
  • BANDWIDTH_ALLOCATION_OFF : FlyCapture2
  • BANDWIDTH_ALLOCATION_ON : FlyCapture2
  • BANDWIDTH_ALLOCATION_UNSPECIFIED : FlyCapture2
  • BANDWIDTH_ALLOCATION_UNSUPPORTED : FlyCapture2
  • BGGR : FlyCapture2
  • BMP : FlyCapture2
  • BRIGHTNESS : FlyCapture2
  • BT_FORCE_32BITS : FlyCapture2
  • BUFFER_FRAMES : FlyCapture2
  • BUS_RESET : FlyCapture2
  • BUSSPEED_10000BASE_T : FlyCapture2
  • BUSSPEED_1000BASE_T : FlyCapture2
  • BUSSPEED_100BASE_T : FlyCapture2
  • BUSSPEED_10BASE_T : FlyCapture2
  • BUSSPEED_ANY : FlyCapture2
  • BUSSPEED_FORCE_32BITS : FlyCapture2
  • BUSSPEED_S100 : FlyCapture2
  • BUSSPEED_S1600 : FlyCapture2
  • BUSSPEED_S200 : FlyCapture2
  • BUSSPEED_S3200 : FlyCapture2
  • BUSSPEED_S400 : FlyCapture2
  • BUSSPEED_S480 : FlyCapture2
  • BUSSPEED_S5000 : FlyCapture2
  • BUSSPEED_S800 : FlyCapture2
  • BUSSPEED_S_FASTEST : FlyCapture2
  • BUSSPEED_SPEED_UNKNOWN : FlyCapture2
  • BYTE_ORDER_BIG_ENDIAN : FlyCapture2
  • BYTE_ORDER_FORCE_32BITS : FlyCapture2
  • BYTE_ORDER_LITTLE_ENDIAN : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- c -

  • CALLBACK_TYPE_FORCE_32BITS : FlyCapture2
  • COLOR_PROCESSING_ALGORITHM_FORCE_32BITS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- d -

  • DEFAULT : FlyCapture2
  • DIRECTIONAL_FILTER : FlyCapture2
  • DRIVER_1394_CAM : FlyCapture2
  • DRIVER_1394_JUJU : FlyCapture2
  • DRIVER_1394_PRO : FlyCapture2
  • DRIVER_1394_RAW1394 : FlyCapture2
  • DRIVER_1394_VIDEO1394 : FlyCapture2
  • DRIVER_FORCE_32BITS : FlyCapture2
  • DRIVER_GIGE_FILTER : FlyCapture2
  • DRIVER_GIGE_LWF : FlyCapture2
  • DRIVER_GIGE_NONE : FlyCapture2
  • DRIVER_GIGE_PRO : FlyCapture2
  • DRIVER_UNKNOWN : FlyCapture2
  • DRIVER_USB3_PRO : FlyCapture2
  • DRIVER_USB_CAM : FlyCapture2
  • DRIVER_USB_NONE : FlyCapture2
  • DROP_FRAMES : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- e -

  • EDGE_SENSING : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- f -

  • FOCUS : FlyCapture2
  • FRAME_RATE : FlyCapture2
  • FRAMERATE_120 : FlyCapture2
  • FRAMERATE_15 : FlyCapture2
  • FRAMERATE_1_875 : FlyCapture2
  • FRAMERATE_240 : FlyCapture2
  • FRAMERATE_30 : FlyCapture2
  • FRAMERATE_3_75 : FlyCapture2
  • FRAMERATE_60 : FlyCapture2
  • FRAMERATE_7_5 : FlyCapture2
  • FRAMERATE_FORCE_32BITS : FlyCapture2
  • FRAMERATE_FORMAT7 : FlyCapture2
  • FROM_FILE_EXT : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- g -

  • GAIN : FlyCapture2
  • GAMMA : FlyCapture2
  • GBRG : FlyCapture2
  • GRAB_MODE_FORCE_32BITS : FlyCapture2
  • GRAB_TIMEOUT_FORCE_32BITS : FlyCapture2
  • GRBG : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- h -

  • HEARTBEAT : FlyCapture2
  • HEARTBEAT_TIMEOUT : FlyCapture2
  • HQ_LINEAR : FlyCapture2
  • HUE : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- i -

  • IMAGE_FILE_FORMAT_FORCE_32BITS : FlyCapture2
  • INTERFACE_GIGE : FlyCapture2
  • INTERFACE_IEEE1394 : FlyCapture2
  • INTERFACE_TYPE_FORCE_32BITS : FlyCapture2
  • INTERFACE_UNKNOWN : FlyCapture2
  • INTERFACE_USB2 : FlyCapture2
  • INTERFACE_USB3 : FlyCapture2
  • IPP : FlyCapture2
  • IRIS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- p -

  • PACKET_DELAY : FlyCapture2
  • PACKET_SIZE : FlyCapture2
  • PAN : FlyCapture2
  • PCIE_BUSSPEED_2_5 : FlyCapture2
  • PCIE_BUSSPEED_5_0 : FlyCapture2
  • PCIE_BUSSPEED_FORCE_32BITS : FlyCapture2
  • PCIE_BUSSPEED_UNKNOWN : FlyCapture2
  • PGM : FlyCapture2
  • PGRERROR_BUFFER_TOO_SMALL : FlyCapture2
  • PGRERROR_BUS_MASTER_FAILED : FlyCapture2
  • PGRERROR_FAILED : FlyCapture2
  • PGRERROR_FAILED_BUS_MASTER_CONNECTION : FlyCapture2
  • PGRERROR_FAILED_GUID : FlyCapture2
  • PGRERROR_FORCE_32BITS : FlyCapture2
  • PGRERROR_IIDC_FAILED : FlyCapture2
  • PGRERROR_IMAGE_CONSISTENCY_ERROR : FlyCapture2
  • PGRERROR_IMAGE_CONVERSION_FAILED : FlyCapture2
  • PGRERROR_IMAGE_LIBRARY_FAILURE : FlyCapture2
  • PGRERROR_INCOMPATIBLE_DRIVER : FlyCapture2
  • PGRERROR_INIT_FAILED : FlyCapture2
  • PGRERROR_INVALID_BUS_MANAGER : FlyCapture2
  • PGRERROR_INVALID_GENERATION : FlyCapture2
  • PGRERROR_INVALID_MODE : FlyCapture2
  • PGRERROR_INVALID_PACKET_SIZE : FlyCapture2
  • PGRERROR_INVALID_PARAMETER : FlyCapture2
  • PGRERROR_INVALID_SETTINGS : FlyCapture2
  • PGRERROR_ISOCH_ALREADY_STARTED : FlyCapture2
  • PGRERROR_ISOCH_BANDWIDTH_EXCEEDED : FlyCapture2
  • PGRERROR_ISOCH_FAILED : FlyCapture2
  • PGRERROR_ISOCH_NOT_STARTED : FlyCapture2
  • PGRERROR_ISOCH_RETRIEVE_BUFFER_FAILED : FlyCapture2
  • PGRERROR_ISOCH_START_FAILED : FlyCapture2
  • PGRERROR_ISOCH_STOP_FAILED : FlyCapture2
  • PGRERROR_ISOCH_SYNC_FAILED : FlyCapture2
  • PGRERROR_LOW_LEVEL_FAILURE : FlyCapture2
  • PGRERROR_LUT_FAILED : FlyCapture2
  • PGRERROR_MEMORY_ALLOCATION_FAILED : FlyCapture2
  • PGRERROR_NOT_CONNECTED : FlyCapture2
  • PGRERROR_NOT_FOUND : FlyCapture2
  • PGRERROR_NOT_IMPLEMENTED : FlyCapture2
  • PGRERROR_NOT_IN_FORMAT7 : FlyCapture2
  • PGRERROR_NOT_INTITIALIZED : FlyCapture2
  • PGRERROR_NOT_SUPPORTED : FlyCapture2
  • PGRERROR_OK : FlyCapture2
  • PGRERROR_PROPERTY_FAILED : FlyCapture2
  • PGRERROR_PROPERTY_NOT_PRESENT : FlyCapture2
  • PGRERROR_READ_REGISTER_FAILED : FlyCapture2
  • PGRERROR_REGISTER_FAILED : FlyCapture2
  • PGRERROR_STROBE_FAILED : FlyCapture2
  • PGRERROR_TIMEOUT : FlyCapture2
  • PGRERROR_TRIGGER_FAILED : FlyCapture2
  • PGRERROR_UNDEFINED : FlyCapture2
  • PGRERROR_WRITE_REGISTER_FAILED : FlyCapture2
  • PGRSyncError_ALREADY_STARTED : MultiSyncLibrary
  • PGRSyncError_ALREADY_STOPPED : MultiSyncLibrary
  • PGRSyncError_CAMERA_NOT_FOUND : MultiSyncLibrary
  • PGRSyncError_FAILED : MultiSyncLibrary
  • PGRSyncError_OK : MultiSyncLibrary
  • PGRSyncError_UNKNOWN_ERROR : MultiSyncLibrary
  • PGRSyncMessage_BUS_RESET : MultiSyncLibrary
  • PGRSyncMessage_DEVICE_ERROR : MultiSyncLibrary
  • PGRSyncMessage_NOMASTER : MultiSyncLibrary
  • PGRSyncMessage_NOT_ENOUGH_DEVICES : MultiSyncLibrary
  • PGRSyncMessage_NOT_INITIALIZED : MultiSyncLibrary
  • PGRSyncMessage_OK : MultiSyncLibrary
  • PGRSyncMessage_STARTED : MultiSyncLibrary
  • PGRSyncMessage_STOPPED : MultiSyncLibrary
  • PGRSyncMessage_SYNCING : MultiSyncLibrary
  • PGRSyncMessage_THREAD_ERROR : MultiSyncLibrary
  • PGRSyncMessage_UNKNOWN_ERROR : MultiSyncLibrary
  • PIXEL_FORMAT_411YUV8 : FlyCapture2
  • PIXEL_FORMAT_422YUV8 : FlyCapture2
  • PIXEL_FORMAT_422YUV8_JPEG : FlyCapture2
  • PIXEL_FORMAT_444YUV8 : FlyCapture2
  • PIXEL_FORMAT_BGR : FlyCapture2
  • PIXEL_FORMAT_BGR16 : FlyCapture2
  • PIXEL_FORMAT_BGRU : FlyCapture2
  • PIXEL_FORMAT_BGRU16 : FlyCapture2
  • PIXEL_FORMAT_MONO12 : FlyCapture2
  • PIXEL_FORMAT_MONO16 : FlyCapture2
  • PIXEL_FORMAT_MONO8 : FlyCapture2
  • PIXEL_FORMAT_RAW12 : FlyCapture2
  • PIXEL_FORMAT_RAW16 : FlyCapture2
  • PIXEL_FORMAT_RAW8 : FlyCapture2
  • PIXEL_FORMAT_RGB : FlyCapture2
  • PIXEL_FORMAT_RGB16 : FlyCapture2
  • PIXEL_FORMAT_RGB8 : FlyCapture2
  • PIXEL_FORMAT_RGBU : FlyCapture2
  • PIXEL_FORMAT_S_MONO16 : FlyCapture2
  • PIXEL_FORMAT_S_RGB16 : FlyCapture2
  • PNG : FlyCapture2
  • PPM : FlyCapture2
  • PROPERTY_TYPE_FORCE_32BITS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- r -

  • RAW : FlyCapture2
  • REMOVAL : FlyCapture2
  • RGGB : FlyCapture2
  • RIGOROUS : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- s -

  • SATURATION : FlyCapture2
  • SHARPNESS : FlyCapture2
  • SHUTTER : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- t -

  • TEMPERATURE : FlyCapture2
  • TIFF : FlyCapture2
  • TILT : FlyCapture2
  • TIMEOUT_INFINITE : FlyCapture2
  • TIMEOUT_NONE : FlyCapture2
  • TIMEOUT_UNSPECIFIED : FlyCapture2
  • TRIGGER_DELAY : FlyCapture2
  • TRIGGER_MODE : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- u -

  • UNKNOWN_OS : FlyCapture2
  • UNSPECIFIED_GRAB_MODE : FlyCapture2
  • UNSPECIFIED_PIXEL_FORMAT : FlyCapture2
  • UNSPECIFIED_PROPERTY_TYPE : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- v -

  • VIDEOMODE_1024x768RGB : FlyCapture2
  • VIDEOMODE_1024x768Y16 : FlyCapture2
  • VIDEOMODE_1024x768Y8 : FlyCapture2
  • VIDEOMODE_1024x768YUV422 : FlyCapture2
  • VIDEOMODE_1280x960RGB : FlyCapture2
  • VIDEOMODE_1280x960Y16 : FlyCapture2
  • VIDEOMODE_1280x960Y8 : FlyCapture2
  • VIDEOMODE_1280x960YUV422 : FlyCapture2
  • VIDEOMODE_1600x1200RGB : FlyCapture2
  • VIDEOMODE_1600x1200Y16 : FlyCapture2
  • VIDEOMODE_1600x1200Y8 : FlyCapture2
  • VIDEOMODE_1600x1200YUV422 : FlyCapture2
  • VIDEOMODE_160x120YUV444 : FlyCapture2
  • VIDEOMODE_320x240YUV422 : FlyCapture2
  • VIDEOMODE_640x480RGB : FlyCapture2
  • VIDEOMODE_640x480Y16 : FlyCapture2
  • VIDEOMODE_640x480Y8 : FlyCapture2
  • VIDEOMODE_640x480YUV411 : FlyCapture2
  • VIDEOMODE_640x480YUV422 : FlyCapture2
  • VIDEOMODE_800x600RGB : FlyCapture2
  • VIDEOMODE_800x600Y16 : FlyCapture2
  • VIDEOMODE_800x600Y8 : FlyCapture2
  • VIDEOMODE_800x600YUV422 : FlyCapture2
  • VIDEOMODE_FORCE_32BITS : FlyCapture2
  • VIDEOMODE_FORMAT7 : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- w -

  • WEIGHTED_DIRECTIONAL_FILTER : FlyCapture2
  • WHITE_BALANCE : FlyCapture2
  • WINDOWS_X64 : FlyCapture2
  • WINDOWS_X86 : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • AsyncCommandCallback : FlyCapture2
  • BusEventCallback : FlyCapture2
  • CallbackHandle : FlyCapture2
  • CameraEventCallback : FlyCapture2
  • ImageEventCallback : FlyCapture2
  • TriggerDelay : FlyCapture2
  • TriggerDelayInfo : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • sk_maxNumPorts : FlyCapture2
  • sk_maxStringLength : FlyCapture2
Generated on Tue Jan 9 2018 21:57:15 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • AVIOption
AVIOption Member List
This is the complete list of members for AVIOption, including all inherited members.
AVIOption() | AVIOption | [inline]
frameRate | AVIOption |
reserved | AVIOption |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • BMPOption
BMPOption Member List
This is the complete list of members for BMPOption, including all inherited members.
BMPOption() | BMPOption | [inline]
indexedColor_8bit | BMPOption |
reserved | BMPOption |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • CameraInfo
CameraInfo Member List
This is the complete list of members for CameraInfo, including all inherited members.
applicationIPAddress | CameraInfo |
applicationPort | CameraInfo |
bayerTileFormat | CameraInfo |
busNumber | CameraInfo |
CameraInfo() | CameraInfo | [inline]
ccpStatus | CameraInfo |
configROM | CameraInfo |
defaultGateway | CameraInfo |
driverName | CameraInfo |
driverType | CameraInfo |
firmwareBuildTime | CameraInfo |
firmwareVersion | CameraInfo |
gigEMajorVersion | CameraInfo |
gigEMinorVersion | CameraInfo |
iidcVer | CameraInfo |
interfaceType | CameraInfo |
ipAddress | CameraInfo |
isColorCamera | CameraInfo |
macAddress | CameraInfo |
maximumBusSpeed | CameraInfo |
modelName | CameraInfo |
nodeNumber | CameraInfo |
pcieBusSpeed | CameraInfo |
reserved | CameraInfo |
sensorInfo | CameraInfo |
sensorResolution | CameraInfo |
serialNumber | CameraInfo |
subnetMask | CameraInfo |
userDefinedName | CameraInfo |
vendorName | CameraInfo |
xmlURL1 | CameraInfo |
xmlURL2 | CameraInfo |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • CameraStats
CameraStats Member List
This is the complete list of members for CameraStats, including all inherited members.
cameraCurrents | CameraStats |
cameraPowerUp | CameraStats |
CameraStats() | CameraStats | [inline]
cameraVoltages | CameraStats |
imageCorrupt | CameraStats |
imageDriverDropped | CameraStats |
imageDropped | CameraStats |
imageXmitFailed | CameraStats |
numCurrents | CameraStats |
numResendPacketsReceived | CameraStats |
numResendPacketsRequested | CameraStats |
numVoltages | CameraStats |
portErrors | CameraStats |
regReadFailed | CameraStats |
regWriteFailed | CameraStats |
reserved | CameraStats |
temperature | CameraStats |
timeSinceBusReset | CameraStats |
timeSinceInitialization | CameraStats |
timeStamp | CameraStats |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • ConfigROM
ConfigROM Member List
This is the complete list of members for ConfigROM, including all inherited members.
chipIdHi | ConfigROM |
chipIdLo | ConfigROM |
ConfigROM() | ConfigROM | [inline]
nodeVendorId | ConfigROM |
pszKeyword | ConfigROM |
reserved | ConfigROM |
unitSpecId | ConfigROM |
unitSubSWVer | ConfigROM |
unitSWVer | ConfigROM |
vendorUniqueInfo_0 | ConfigROM |
vendorUniqueInfo_1 | ConfigROM |
vendorUniqueInfo_2 | ConfigROM |
vendorUniqueInfo_3 | ConfigROM |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • EmbeddedImageInfo
EmbeddedImageInfo Member List
This is the complete list of members for EmbeddedImageInfo, including all inherited members.
brightness | EmbeddedImageInfo
exposure | EmbeddedImageInfo
frameCounter | EmbeddedImageInfo
gain | EmbeddedImageInfo
GPIOPinState | EmbeddedImageInfo
ROIPosition | EmbeddedImageInfo
shutter | EmbeddedImageInfo
strobePattern | EmbeddedImageInfo
timestamp | EmbeddedImageInfo
whiteBalance | EmbeddedImageInfo
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • EmbeddedImageInfoProperty
EmbeddedImageInfoProperty Member List
This is the complete list of members for EmbeddedImageInfoProperty, including all inherited members.
available | EmbeddedImageInfoProperty |
EmbeddedImageInfoProperty() | EmbeddedImageInfoProperty | [inline]
onOff | EmbeddedImageInfoProperty |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • EventCallbackData
EventCallbackData Member List
This is the complete list of members for EventCallbackData, including all inherited members.
EventData | EventCallbackData
EventDataSize | EventCallbackData
EventID | EventCallbackData
EventName | EventCallbackData
EventTimestamp | EventCallbackData
EventUserData | EventCallbackData
EventUserDataSize | EventCallbackData
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • EventOptions
EventOptions Member List
This is the complete list of members for EventOptions, including all inherited members.
EventCallbackFcn | EventOptions
EventName | EventOptions
EventUserData | EventOptions
EventUserDataSize | EventOptions
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • FC2Config
FC2Config Member List
This is the complete list of members for FC2Config, including all inherited members.
asyncBusSpeed | FC2Config |
bandwidthAllocation | FC2Config |
FC2Config() | FC2Config | [inline]
grabMode | FC2Config |
grabTimeout | FC2Config |
highPerformanceRetrieveBuffer | FC2Config |
isochBusSpeed | FC2Config |
minNumImageNotifications | FC2Config |
numBuffers | FC2Config |
numImageNotifications | FC2Config |
registerTimeout | FC2Config |
registerTimeoutRetries | FC2Config |
reserved | FC2Config |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • FC2Version
FC2Version Member List
This is the complete list of members for FC2Version, including all inherited members.
build | FC2Version
major | FC2Version
minor | FC2Version
type | FC2Version
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Format7ImageSettings
Format7ImageSettings Member List
This is the complete list of members for Format7ImageSettings, including all inherited members.
Format7ImageSettings() | Format7ImageSettings | [inline]
height | Format7ImageSettings |
mode | Format7ImageSettings |
offsetX | Format7ImageSettings |
offsetY | Format7ImageSettings |
pixelFormat | Format7ImageSettings |
reserved | Format7ImageSettings |
width | Format7ImageSettings |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Format7Info
Format7Info Member List
This is the complete list of members for Format7Info, including all inherited members.
Format7Info() | Format7Info | [inline]
imageHStepSize | Format7Info |
imageVStepSize | Format7Info |
maxHeight | Format7Info |
maxPacketSize | Format7Info |
maxWidth | Format7Info |
minPacketSize | Format7Info |
mode | Format7Info |
offsetHStepSize | Format7Info |
offsetVStepSize | Format7Info |
packetSize | Format7Info |
percentage | Format7Info |
pixelFormatBitField | Format7Info |
reserved | Format7Info |
vendorPixelFormatBitField | Format7Info |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Format7PacketInfo
Format7PacketInfo Member List
This is the complete list of members for Format7PacketInfo, including all inherited members.
Format7PacketInfo() | Format7PacketInfo | [inline]
maxBytesPerPacket | Format7PacketInfo |
recommendedBytesPerPacket | Format7PacketInfo |
reserved | Format7PacketInfo |
unitBytesPerPacket | Format7PacketInfo |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • GigEConfig
GigEConfig Member List
This is the complete list of members for GigEConfig, including all inherited members.
enablePacketResend | GigEConfig |
GigEConfig() | GigEConfig | [inline]
registerTimeout | GigEConfig |
registerTimeoutRetries | GigEConfig |
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • GigEImageSettings
GigEImageSettings Member List
This is the complete list of members for GigEImageSettings, including all inherited members.
GigEImageSettings() | GigEImageSettings | [inline]
height | GigEImageSettings |
offsetX | GigEImageSettings |
offsetY | GigEImageSettings |
pixelFormat | GigEImageSettings |
reserved | GigEImageSettings |
width | GigEImageSettings |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • GigEImageSettingsInfo
GigEImageSettingsInfo Member List
This is the complete list of members for GigEImageSettingsInfo, including all inherited members.
GigEImageSettingsInfo() | GigEImageSettingsInfo | [inline]
imageHStepSize | GigEImageSettingsInfo |
imageVStepSize | GigEImageSettingsInfo |
maxHeight | GigEImageSettingsInfo |
maxWidth | GigEImageSettingsInfo |
offsetHStepSize | GigEImageSettingsInfo |
offsetVStepSize | GigEImageSettingsInfo |
pixelFormatBitField | GigEImageSettingsInfo |
reserved | GigEImageSettingsInfo |
vendorPixelFormatBitField | GigEImageSettingsInfo |
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • GigEProperty
GigEProperty Member List
This is the complete list of members for GigEProperty, including all inherited members.
isReadable | GigEProperty
isWritable | GigEProperty
max | GigEProperty
min | GigEProperty
propType | GigEProperty
value | GigEProperty
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • GigEStreamChannel
GigEStreamChannel Member List
This is the complete list of members for GigEStreamChannel, including all inherited members.
destinationIpAddress | GigEStreamChannel |
doNotFragment | GigEStreamChannel |
GigEStreamChannel() | GigEStreamChannel | [inline]
hostPort | GigEStreamChannel |
interPacketDelay | GigEStreamChannel |
networkInterfaceIndex | GigEStreamChannel |
packetSize | GigEStreamChannel |
sourcePort | GigEStreamChannel |
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • H264Option
H264Option Member List
This is the complete list of members for H264Option, including all inherited members.
bitrate | H264Option |
frameRate | H264Option |
H264Option() | H264Option | [inline]
height | H264Option |
reserved | H264Option |
width | H264Option |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • IPAddress
IPAddress Member List
This is the complete list of members for IPAddress, including all inherited members.
IPAddress() | IPAddress | [inline]
IPAddress(unsigned int ipAddressVal) | IPAddress | [inline]
octets | IPAddress |
operator!=(const IPAddress &address) | IPAddress | [inline]
operator==(const IPAddress &address) const | IPAddress | [inline]
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • ImageMetadata
ImageMetadata Member List
This is the complete list of members for ImageMetadata, including all inherited members.
embeddedBrightness | ImageMetadata |
embeddedExposure | ImageMetadata |
embeddedFrameCounter | ImageMetadata |
embeddedGain | ImageMetadata |
embeddedGPIOPinState | ImageMetadata |
embeddedROIPosition | ImageMetadata |
embeddedShutter | ImageMetadata |
embeddedStrobePattern | ImageMetadata |
embeddedTimeStamp | ImageMetadata |
embeddedWhiteBalance | ImageMetadata |
ImageMetadata() | ImageMetadata | [inline]
reserved | ImageMetadata |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • JPEGOption
JPEGOption Member List
This is the complete list of members for JPEGOption, including all inherited members.
JPEGOption() | JPEGOption | [inline]
progressive | JPEGOption |
quality | JPEGOption |
reserved | JPEGOption |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • JPG2Option
JPG2Option Member List
This is the complete list of members for JPG2Option, including all inherited members.
JPG2Option() | JPG2Option | [inline]
quality | JPG2Option |
reserved | JPG2Option |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • LUTData
LUTData Member List
This is the complete list of members for LUTData, including all inherited members.
enabled | LUTData |
inputBitDepth | LUTData |
LUTData() | LUTData | [inline]
numBanks | LUTData |
numChannels | LUTData |
numEntries | LUTData |
outputBitDepth | LUTData |
reserved | LUTData |
supported | LUTData |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • MACAddress
MACAddress Member List
This is the complete list of members for MACAddress, including all inherited members.
MACAddress() | MACAddress | [inline]
MACAddress(unsigned int macAddressValHigh, unsigned int macAddressValLow) | MACAddress | [inline]
octets | MACAddress |
operator!=(const MACAddress &address) | MACAddress | [inline]
operator==(const MACAddress &address) const | MACAddress | [inline]
Generated on Tue Jan 9 2018 21:57:13 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • MJPGOption
MJPGOption Member List
This is the complete list of members for MJPGOption, including all inherited members.
frameRate | MJPGOption |
MJPGOption() | MJPGOption | [inline]
quality | MJPGOption |
reserved | MJPGOption |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • PGMOption
PGMOption Member List
This is the complete list of members for PGMOption, including all inherited members.
binaryFile | PGMOption |
PGMOption() | PGMOption | [inline]
reserved | PGMOption |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • PNGOption
PNGOption Member List
This is the complete list of members for PNGOption, including all inherited members.
compressionLevel | PNGOption |
interlaced | PNGOption |
PNGOption() | PNGOption | [inline]
reserved | PNGOption |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • PPMOption
PPMOption Member List
This is the complete list of members for PPMOption, including all inherited members.
binaryFile | PPMOption |
PPMOption() | PPMOption | [inline]
reserved | PPMOption |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • Property
Property Member List
This is the complete list of members for Property, including all inherited members.
absControl | Property |
absValue | Property |
autoManualMode | Property |
onePush | Property |
onOff | Property |
present | Property |
Property() | Property | [inline]
Property(PropertyType propType) | Property | [inline]
reserved | Property |
type | Property |
valueA | Property |
valueB | Property |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • PropertyInfo
PropertyInfo Member List
This is the complete list of members for PropertyInfo, including all inherited members.
absMax | PropertyInfo |
absMin | PropertyInfo |
absValSupported | PropertyInfo |
autoSupported | PropertyInfo |
manualSupported | PropertyInfo |
max | PropertyInfo |
min | PropertyInfo |
onePushSupported | PropertyInfo |
onOffSupported | PropertyInfo |
present | PropertyInfo |
PropertyInfo() | PropertyInfo | [inline]
PropertyInfo(PropertyType propType) | PropertyInfo | [inline]
pUnitAbbr | PropertyInfo |
pUnits | PropertyInfo |
readOutSupported | PropertyInfo |
reserved | PropertyInfo |
type | PropertyInfo |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • StrobeControl
StrobeControl Member List
This is the complete list of members for StrobeControl, including all inherited members.
delay | StrobeControl |
duration | StrobeControl |
onOff | StrobeControl |
polarity | StrobeControl |
reserved | StrobeControl |
source | StrobeControl |
StrobeControl() | StrobeControl | [inline]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • StrobeInfo
StrobeInfo Member List
This is the complete list of members for StrobeInfo, including all inherited members.
maxValue | StrobeInfo |
minValue | StrobeInfo |
onOffSupported | StrobeInfo |
polaritySupported | StrobeInfo |
present | StrobeInfo |
readOutSupported | StrobeInfo |
reserved | StrobeInfo |
source | StrobeInfo |
StrobeInfo() | StrobeInfo | [inline]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • SystemInfo
SystemInfo Member List
This is the complete list of members for SystemInfo, including all inherited members.
byteOrder | SystemInfo
cpuDescription | SystemInfo
driverList | SystemInfo
gpuDescription | SystemInfo
libraryList | SystemInfo
numCpuCores | SystemInfo
osDescription | SystemInfo
osType | SystemInfo
reserved | SystemInfo
screenHeight | SystemInfo
screenWidth | SystemInfo
sysMemSize | SystemInfo
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • TIFFOption
TIFFOption Member List
This is the complete list of members for TIFFOption, including all inherited members.
ADOBE_DEFLATE enum value | TIFFOption |
CCITTFAX3 enum value | TIFFOption |
CCITTFAX4 enum value | TIFFOption |
compression | TIFFOption |
CompressionMethod enum name | TIFFOption |
DEFLATE enum value | TIFFOption |
JPEG enum value | TIFFOption |
LZW enum value | TIFFOption |
NONE enum value | TIFFOption |
PACKBITS enum value | TIFFOption |
reserved | TIFFOption |
TIFFOption() | TIFFOption | [inline]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • TimeStamp
TimeStamp Member List
This is the complete list of members for TimeStamp, including all inherited members.
cycleCount | TimeStamp |
cycleOffset | TimeStamp |
cycleSeconds | TimeStamp |
microSeconds | TimeStamp |
reserved | TimeStamp |
seconds | TimeStamp |
TimeStamp() | TimeStamp | [inline]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • TriggerMode
TriggerMode Member List
This is the complete list of members for TriggerMode, including all inherited members.
mode | TriggerMode |
onOff | TriggerMode |
parameter | TriggerMode |
polarity | TriggerMode |
reserved | TriggerMode |
source | TriggerMode |
TriggerMode() | TriggerMode | [inline]
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5


FlyCapture2: Member List

  • FlyCapture2
  • TriggerModeInfo
TriggerModeInfo Member List
This is the complete list of members for TriggerModeInfo, including all inherited members.
modeMask | TriggerModeInfo |
onOffSupported | TriggerModeInfo |
polaritySupported | TriggerModeInfo |
present | TriggerModeInfo |
readOutSupported | TriggerModeInfo |
reserved | TriggerModeInfo |
softwareTriggerSupported | TriggerModeInfo |
sourceMask | TriggerModeInfo |
TriggerModeInfo() | TriggerModeInfo | [inline]
valueReadable | TriggerModeInfo |
Generated on Tue Jan 9 2018 21:57:14 for FlyCapture2 by doxygen 1.7.5