FlyCapture2 Managed: Related Pages

FlyCapture2 Managed 2.12.3.2
  • Main Page
  • Related Pages
  • Modules
  • Namespaces
  • Classes
Related Pages
Here is a list of all related documentation pages:
  • Software Licensing Information
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Software Licensing Information

  • Modules
  • Namespaces
  • Classes
Software Licensing Information
License table
Component | License
FlyCapture2

Copyright © 2017 FLIR Integrated Imaging Solutions, Inc. All Rights Reserved. This software is the confidential and proprietary information of FLIR Integrated Imaging Solutions, Inc. ("Confidential Information"). You shall not disclose such Confidential Information and shall use it only in accordance with the terms of the license agreement you entered into with FLIR Integrated Imaging Solutions, Inc. (FLIR).

FLIR MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY OF THE SOFTWARE, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. FLIR SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES.

AdapterList | The Code Project Open License (CPOL) http://www.codeproject.com/info/cpol10.aspx
Boost | Boost Software License http://www.boost.org/users/license.html
FFMPEG | LGPv2.1 License https://www.ffmpeg.org/legal.html
FreeImage | FreeImage public license http://freeimage.sourceforge.net/freeimage-license.txt
GTK | LGPv2.1 License http://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt
Libusb | LGPLv2.1 License http://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt
Libraw1394

LGPLv2.0 License http://www.gnu.org/licenses/old-licenses/lgpl-2.0.txt

Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Modules

Modules
Here is a list of all modules:
  • Enumerations
  • Structures
    • Image saving structures.
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Enumerations

Enumerations
Enumerations

Enumerations

enum ErrorType {
Undefined = -1,
Ok,
Failed,
NotImplemented,
FailedBusMasterConnection,
NotConnected,
InitFailed,
NotInitialized,
InvalidParameter,
InvalidSettings,
InvalidBuManager,
MemoryAllocationFailed,
LowLevelFailure,
NotFound,
FailedGuid,
InvalidPacketSize,
InvalidMode,
NotInFormat7,
NotSupported,
Timeout,
BusMasterFailed,
InvalidGeneration,
LutFailed,
IidcFailed,
StrobeFailed,
TriggerFailed,
PropertyFailed,
PropertyNotPresent,
RegisterFailed,
ReadRegisterFailed,
WriteRegisterFailed,
IsochFailed,
IsochAlreadyStarted,
IsochNotStarted,
IsochStartFailed,
IsochRetrieveBufferFailed,
IsochStopFailed,
IsochSyncFailed,
IsochBandwidthExceeded,
ImageConversionFailed,
ImageLibraryFailure,
BufferTooSmall,
ImageConsistencyError,
IncompatibleDriver
}
The error types returned by functions. More...
enum ManagedCallbackType {
BusReset,
Arrival,
Removal
}
The type of bus callback to register a callback function for. More...
enum GrabMode {
DropFrames,
BufferFrames,
Unspecified = -2
}
The grab strategy employed during image transfer. More...
enum GrabTimeout {
None = 0,
Infinite = -1,
Unspecified = -2
}
Timeout options for grabbing images. More...
enum BandwidthAllocation {
Off = 0,
On = 1,
Unsupported = 2,
Unspecified = -2
}
Bandwidth allocation options for 1394 devices. More...
enum InterfaceType {
Ieee1394,
Usb2,
Usb3,
GigE,
Unknown = -1
}
Interfaces that a camera may use to communicate with a host. More...
enum PropertyType {
Brightness,
AutoExposure,
Sharpness,
WhiteBalance,
Hue,
Saturation,
Gamma,
Iris,
Focus,
Zoom,
Pan,
Tilt,
Shutter,
Gain,
TriggerMode,
TriggerDelay,
FrameRate,
Temperature,
Unspecified = -2
}
Camera properties. More...
enum FrameRate {
FrameRate1_875,
FrameRate3_75,
FrameRate7_5,
FrameRate15,
FrameRate30,
FrameRate60,
FrameRate120,
FrameRate240,
FrameRateFormat7,
NumberOfFrameRates
}
Frame rates in frames per second. More...
enum VideoMode {
VideoMode160x120Yuv444,
VideoMode320x240Yuv422,
VideoMode640x480Yuv411,
VideoMode640x480Yuv422,
VideoMode640x480Rgb,
VideoMode640x480Y8,
VideoMode640x480Y16,
VideoMode800x600Yuv422,
VideoMode800x600Rgb,
VideoMode800x600Y8,
VideoMode800x600Y16,
VideoMode1024x768Yuv422,
VideoMode1024x768Rgb,
VideoMode1024x768Y8,
VideoMode1024x768Y16,
VideoMode1280x960Yuv422,
VideoMode1280x960Rgb,
VideoMode1280x960Y8,
VideoMode1280x960Y16,
VideoMode1600x1200Yuv422,
VideoMode1600x1200Rgb,
VideoMode1600x1200Y8,
VideoMode1600x1200Y16,
VideoModeFormat7,
NumberOfVideoModes
}
DCAM video modes. More...
enum Mode {
Mode0 = 0,
Mode1,
Mode2,
Mode3,
Mode4,
Mode5,
Mode6,
Mode7,
Mode8,
Mode9,
Mode10,
Mode11,
Mode12,
Mode13,
Mode14,
Mode15,
Mode16,
Mode17,
Mode18,
Mode19,
Mode20,
Mode21,
Mode22,
Mode23,
Mode24,
Mode25,
Mode26,
Mode27,
Mode28,
Mode29,
Mode30,
Mode31,
NumberOfModes
}
Camera modes for DCAM formats as well as Format7. More...
enum PixelFormat {
PixelFormatMono8 = 0x80000000,
PixelFormat411Yuv8 = 0x40000000,
PixelFormat422Yuv8 = 0x20000000,
PixelFormat444Yuv8 = 0x10000000,
PixelFormatRgb8 = 0x08000000,
PixelFormatMono16 = 0x04000000,
PixelFormatRgb16 = 0x02000000,
PixelFormatSignedMono16 = 0x01000000,
PixelFormatSignedRgb16 = 0x00800000,
PixelFormatRaw8 = 0x00400000,
PixelFormatRaw16 = 0x00200000,
PixelFormatMono12 = 0x00100000,
PixelFormatRaw12 = 0x00080000,
PixelFormatBgr = 0x80000008,
PixelFormatBgru = 0x40000008,
PixelFormatRgb = PixelFormatRgb8,
PixelFormatRgbu = 0x40000002,
PixelFormatBgr16 = 0x02000001,
PixelFormatBgru16 = 0x02000002,
PixelFormat422Yuv8Jpeg = 0x40000001,
NumberOfPixelFormats = 20
}
Pixel formats available for Format7 modes. More...
enum BusSpeed {
S100,
S200,
S400,
S480,
S800,
S1600,
S3200,
S5000,
GigE_10Base_T,
GigE_100Base_T,
GigE_1000Base_T,
GigE_10000Base_T,
Fastest,
Any,
Unknown = -1
}
Bus speeds. More...
enum PCIeBusSpeed {
Speed_2_5,
Speed_5_0,
Unknown = -1
}
PCIe Bus Speeds. More...
enum DriverType {
Ieee1394_Cam,
Ieee1394_Pro,
Ieee1394_Juju,
Ieee1394_Video1394,
Ieee1394_Raw1394,
Usb_None,
Usb_Cam,
Usb3_Pro,
GigE_None,
GigE_Filter,
GigE_Pro,
GigE_Lwf,
Unknown = -1
}
Types of low level drivers that flycapture uses. More...
enum ColorProcessingAlgorithm {
Default,
NoColorProcessing,
NearestNeighbor,
EdgeSensing,
HQLinear,
Rigorous,
IPP,
Directional,
WeightedDirectional
}
Color processing algorithms. More...
enum BayerTileFormat {
None = 0,
RGGB,
GRBG,
GBRG,
BGGR
}
Bayer tile formats. More...
enum ImageFileFormat {
FromFileExtension = -1,
Pgm,
Ppm,
Bmp,
Jpeg,
Jpeg2000,
Tiff,
Png,
Raw
}
File formats to be used for saving images to disk. More...
enum GigEPropertyType {
Heartbeat,
HeartbeatTimeout,
PacketSize,
PacketDelay
}
Possible properties that can be queried from the camera. More...
enum StatisticsChannel {
Grey,
Red,
Green,
Blue,
Hue,
Saturation,
Lightness,
NumberOfStatisticsChannels
}
Channels that allow statistics to be calculated. More...
enum OSType {
WindowsX86,
WindowsX64,
LinuxX86,
LinuxX64,
Mac,
UnknownOS
}
Possible operating systems. More...
enum ByteOrder {
LittleEndian,
BigEndian
}
Possible byte orders. More...

Enumeration Type Documentation

enum BandwidthAllocation

Bandwidth allocation options for 1394 devices.

Enumerator:
Off

Do not allocate bandwidth.

On

Allocate bandwidth.

This is the default setting.

Unsupported

Bandwidth allocation is not supported by either the camera or operating system.

Unspecified

Unspecified grab mode.

Unspecified property type.

Not specified.

Unspecified timeout setting.

This leaves the current setting unchanged.

enum BayerTileFormat

Bayer tile formats.

Enumerator:
None

Non-blocking wait.

No bayer tile format.

RGGB

Red-Green-Green-Blue.

GRBG

Green-Red-Blue-Green.

GBRG

Green-Blue-Red-Green.

BGGR

Blue-Green-Green-Red.

enum BusSpeed

Bus speeds.

Enumerator:
S100

100Mbits/sec.

S200

200Mbits/sec.

S400

400Mbits/sec.

S480

480Mbits/sec.

Only for USB2 cameras.

S800

800Mbits/sec.

S1600

1600Mbits/sec.

S3200

3200Mbits/sec.

S5000

5000Mbits/sec.

Only for USB3 cameras.

GigE_10Base_T
GigE_100Base_T
GigE_1000Base_T
GigE_10000Base_T
Fastest

The fastest speed available.

Any

Any speed that is available.

Unknown

Unknown interface.

Unknown driver type.

5.0 Gb/s

Unknown bus speed.

Speed is unknown

enum ByteOrder

Possible byte orders.

Enumerator:
LittleEndian
BigEndian
enum ColorProcessingAlgorithm

Color processing algorithms.

Please refer to our knowledge base at article at http://www.ptgrey.com/support/kb/index.asp?a=4&q=33 for complete details for each algorithm.

Enumerator:
Default

Default method.

NoColorProcessing

No color processing.

NearestNeighbor

Fastest but lowest quality.

Equivalent to FLYCAPTURE_NEAREST_NEIGHBOR_FAST in FlyCapture.

EdgeSensing

Weights surrounding pixels based on localized edge orientation.

HQLinear

Similar quality to rigorous but much faster.

Rigorous

Slowest but produces the best results.

IPP

Multithreaded with similar results to edge sensing.

Directional

Best quality but much faster than rigorous.

WeightedDirectional

Weighted pixel average from different directions.

enum DriverType

Types of low level drivers that flycapture uses.

Enumerator:
Ieee1394_Cam

PGRCam.sys.

Ieee1394_Pro

PGR1394.sys.

Ieee1394_Juju

firewire_core.

Ieee1394_Video1394

video1394.

Ieee1394_Raw1394

raw1394.

Usb_None

No usb driver used just BSD stack.

(Linux only)

Usb_Cam

PGRUsbCam.sys.

Usb3_Pro

PGRXHCI.sys.

GigE_None

no gige drivers used,MS/BSD stack.

GigE_Filter

PGRGigE.sys.

GigE_Pro

PGRGigEPro.sys.

GigE_Lwf

PgrLwf.sys.

Unknown

Unknown interface.

Unknown driver type.

5.0 Gb/s

Unknown bus speed.

Speed is unknown

enum ErrorType

The error types returned by functions.

Enumerator:
Undefined

Undefined.

Ok

Function returned with no errors.

Failed

General failure.

NotImplemented

Function has not been implemented.

FailedBusMasterConnection

Could not connect to Bus Master.

NotConnected

Camera has not been connected.

InitFailed

Initialization failed.

NotInitialized

Camera has not been initialized.

InvalidParameter

Invalid parameter passed to function.

InvalidSettings

Setting set to camera is invalid.

InvalidBuManager

Invalid Bus Manager object.

MemoryAllocationFailed

Could not allocate memory.

LowLevelFailure

Low level error.

NotFound

Device not found.

FailedGuid

GUID failure.

InvalidPacketSize

Packet size set to camera is invalid.

InvalidMode

Invalid mode has been passed to function.

NotInFormat7

Error due to not being in Format7.

NotSupported

This feature is unsupported.

Timeout

Timeout error.

BusMasterFailed

Bus Master Failure.

InvalidGeneration

Generation Count Mismatch.

LutFailed

Look Up Table failure.

IidcFailed

IIDC failure.

StrobeFailed

Strobe failure.

TriggerFailed

Trigger failure.

PropertyFailed

Property failure.

PropertyNotPresent

Property is not present.

RegisterFailed

Register access failed.

ReadRegisterFailed

Register read failed.

WriteRegisterFailed

Register write failed.

IsochFailed

Isochronous failure.

IsochAlreadyStarted

Isochronous transfer has already been started.

IsochNotStarted

Isochronous transfer has not been started.

IsochStartFailed

Isochronous start failed.

IsochRetrieveBufferFailed

Isochronous retrieve buffer failed.

IsochStopFailed

Isochronous stop failed.

IsochSyncFailed

Isochronous image synchronization failed.

IsochBandwidthExceeded

Isochronous bandwidth exceeded.

ImageConversionFailed

Image conversion failed.

ImageLibraryFailure

Image library failure.

BufferTooSmall

Buffer is too small.

ImageConsistencyError

There is an image consistency error.

IncompatibleDriver

IncompatibleDriver error.

enum FrameRate

Frame rates in frames per second.

Enumerator:
FrameRate1_875

1.875 fps.

FrameRate3_75

3.75 fps.

FrameRate7_5

7.5 fps.

FrameRate15

15 fps.

FrameRate30

30 fps.

FrameRate60

60 fps.

FrameRate120

120 fps.

FrameRate240

240 fps.

FrameRateFormat7

Custom frame rate for Format7 functionality.

NumberOfFrameRates

Number of possible camera frame rates.

enum GigEPropertyType

Possible properties that can be queried from the camera.

Enumerator:
Heartbeat
HeartbeatTimeout
PacketSize
PacketDelay
enum GrabMode

The grab strategy employed during image transfer.

This type controls how images that stream off the camera accumulate in a user buffer for handling. Unlike earlier versions of the FlyCapture SDK, it is no longer necessary to explicitly start the image grabbing process before specifying an image grabbing mode.

Enumerator:
DropFrames

Grabs the newest image in the user buffer each time the RetrieveBuffer() function is called.

Older images are dropped instead of accumulating in the user buffer. Grabbing blocks if the camera has not finished transmitting the next available image. If the camera is transmitting images faster than the application can grab them, images may be dropped and only the most recent image is stored for grabbing. Note that this mode is the equivalent of flycaptureLockLatest in earlier versions of the FlyCapture SDK.

BufferFrames

Images accumulate in the user buffer, and the oldest image is grabbed for handling before being discarded.

This member can be used to guarantee that each image is seen. However, image processing time must not exceed transmission time from the camera to the buffer. Grabbing blocks if the camera has not finished transmitting the next available image. The buffer size is controlled by the numBuffers parameter in the FC2Config struct. Note that this mode is the equivalent of flycaptureLockNext in earlier versions of the FlyCapture SDK.

Unspecified

Unspecified grab mode.

Unspecified property type.

Not specified.

Unspecified timeout setting.

This leaves the current setting unchanged.

enum GrabTimeout

Timeout options for grabbing images.

Enumerator:
None

Non-blocking wait.

No bayer tile format.

Infinite

Wait indefinitely.

Unspecified

Unspecified grab mode.

Unspecified property type.

Not specified.

Unspecified timeout setting.

This leaves the current setting unchanged.

enum ImageFileFormat

File formats to be used for saving images to disk.

Enumerator:
FromFileExtension

Determine file format from file extension.

Pgm

Portable gray map.

Ppm

Portable pixmap.

Bmp

Bitmap.

Jpeg

JPEG.

Jpeg2000

JPEG 2000.

Tiff

Tagged image file format.

Png

Portable network graphics.

Raw

Raw data.

enum InterfaceType

Interfaces that a camera may use to communicate with a host.

Enumerator:
Ieee1394

IEEE-1394 (Includes 1394a and 1394b).

Usb2

USB 2.0.

Usb3

USB 3.0.

GigE

GigE.

Unknown

Unknown interface.

Unknown driver type.

5.0 Gb/s

Unknown bus speed.

Speed is unknown

enum ManagedCallbackType

The type of bus callback to register a callback function for.

Enumerator:
BusReset

Register for all bus events.

Arrival

Register for arrivals only.

Removal

Register for removals only.

enum Mode

Camera modes for DCAM formats as well as Format7.

Enumerator:
Mode0
Mode1
Mode2
Mode3
Mode4
Mode5
Mode6
Mode7
Mode8
Mode9
Mode10
Mode11
Mode12
Mode13
Mode14
Mode15
Mode16
Mode17
Mode18
Mode19
Mode20
Mode21
Mode22
Mode23
Mode24
Mode25
Mode26
Mode27
Mode28
Mode29
Mode30
Mode31
NumberOfModes
enum OSType

Possible operating systems.

Enumerator:
WindowsX86

All Windows 32-bit variants.

WindowsX64

All Windows 64-bit variants.

LinuxX86

All Linux 32-bit variants.

LinuxX64

All Linux 32-bit variants.

Mac

Mac OSX.

UnknownOS

Unknown operating system.

enum PCIeBusSpeed

PCIe Bus Speeds.

Enumerator:
Speed_2_5
Speed_5_0

2.5 Gb/s

Unknown

Unknown interface.

Unknown driver type.

5.0 Gb/s

Unknown bus speed.

Speed is unknown

enum PixelFormat

Pixel formats available for Format7 modes.

Enumerator:
PixelFormatMono8

8 bits of mono information.

PixelFormat411Yuv8

YUV 4:1:1.

PixelFormat422Yuv8

YUV 4:2:2.

PixelFormat444Yuv8

YUV 4:4:4.

PixelFormatRgb8

R = G = B = 8 bits.

PixelFormatMono16

16 bits of mono information.

PixelFormatRgb16

R = G = B = 16 bits.

PixelFormatSignedMono16

16 bits of signed mono information.

PixelFormatSignedRgb16

R = G = B = 16 bits signed.

PixelFormatRaw8

8 bit raw data output of sensor.

PixelFormatRaw16

16 bit raw data output of sensor.

PixelFormatMono12

12 bits of mono information.

PixelFormatRaw12

12 bit raw data output of sensor.

PixelFormatBgr

24 bit BGR.

PixelFormatBgru

32 bit BGRU.

PixelFormatRgb

24 bit RGB.

PixelFormatRgbu

32 bit RGBU.

PixelFormatBgr16

R = G = B = 16 bits.

PixelFormatBgru16

64 bit BGRU.

PixelFormat422Yuv8Jpeg

JPEG compressed stream.

NumberOfPixelFormats

Number of pixel formats.

enum PropertyType

Camera properties.

Not all properties may be supported, depending on the camera model.

Enumerator:
Brightness

Brightness.

AutoExposure

Auto exposure.

Sharpness

Sharpness.

WhiteBalance

White balance.

Hue

Hue.

Saturation

Saturation.

Gamma

Gamma.

Iris

Iris.

Focus

Focus.

Zoom

Zoom.

Pan

Pan.

Tilt

Tilt.

Shutter

Shutter.

Gain

Gain.

TriggerMode

Trigger mode.

TriggerDelay

Trigger delay.

FrameRate

Frame rate.

Temperature

Temperature.

Unspecified

Unspecified grab mode.

Unspecified property type.

Not specified.

Unspecified timeout setting.

This leaves the current setting unchanged.

enum StatisticsChannel

Channels that allow statistics to be calculated.

Enumerator:
Grey
Red
Green
Blue
Hue

Hue.

Saturation

Saturation.

Lightness
NumberOfStatisticsChannels
enum VideoMode

DCAM video modes.

Enumerator:
VideoMode160x120Yuv444

160x120 YUV444.

VideoMode320x240Yuv422

320x240 YUV422.

VideoMode640x480Yuv411

640x480 YUV411.

VideoMode640x480Yuv422

640x480 YUV422.

VideoMode640x480Rgb

640x480 24-bit RGB.

VideoMode640x480Y8

640x480 8-bit.

VideoMode640x480Y16

640x480 16-bit.

VideoMode800x600Yuv422

800x600 YUV422.

VideoMode800x600Rgb

800x600 RGB.

VideoMode800x600Y8

800x600 8-bit.

VideoMode800x600Y16

800x600 16-bit.

VideoMode1024x768Yuv422

1024x768 YUV422.

VideoMode1024x768Rgb

1024x768 RGB.

VideoMode1024x768Y8

1024x768 8-bit.

VideoMode1024x768Y16

1024x768 16-bit.

VideoMode1280x960Yuv422

1280x960 YUV422.

VideoMode1280x960Rgb

1280x960 RGB.

VideoMode1280x960Y8

1280x960 8-bit.

VideoMode1280x960Y16

1280x960 16-bit.

VideoMode1600x1200Yuv422

1600x1200 YUV422.

VideoMode1600x1200Rgb

1600x1200 RGB.

VideoMode1600x1200Y8

1600x1200 8-bit.

VideoMode1600x1200Y16

1600x1200 16-bit.

VideoModeFormat7

Custom video mode for Format7 functionality.

NumberOfVideoModes

Number of possible video modes.

Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Structures

Classes | Modules
Structures
Collaboration diagram for Structures:

Classes

struct | FC2Version
The current version of the library. More...
struct | GigEProperty
A GigE property. More...
struct | GigEStreamChannel
Information about a single GigE stream channel. More...
struct | GigEConfig
Configuration for a GigE camera. More...
struct | GigEImageSettingsInfo
Format 7 information for a single mode. More...
struct | GigEImageSettings
Image settings for a GigE camera. More...
struct | FC2Config
Configuration for a camera. More...
struct | CameraPropertyInfo
Information about a specific camera property. More...
struct | CameraProperty
A specific camera property. More...
struct | TriggerModeInfo
Information about a camera trigger property. More...
struct | TriggerMode
A camera trigger. More...
struct | StrobeInfo
A camera strobe property. More...
struct | StrobeControl
A camera strobe. More...
struct | Format7ImageSettings
Format 7 image settings. More...
struct | Format7Info
Format 7 information for a single mode. More...
struct | Format7PacketInfo
Format 7 packet information. More...
struct | TimeStamp
Timestamp information. More...
struct | ConfigROM
Camera configuration ROM. More...
struct | CameraInfo
Camera information. More...
struct | EmbeddedImageInfoProperty
Properties of a single embedded image info property. More...
struct | EmbeddedImageInfo
Properties of the possible embedded image information. More...
struct | ImageMetadata
Metadata related to an image. More...
struct | LutData
Information about the camera's look up table. More...
struct | CameraStats
Camera diagnostic information. More...
struct | PngOption
Options for saving PNG images. More...

Modules

Image saving structures.

These structures define various parameters used for saving images.

Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Image saving structures.

Classes
Image saving structures.
Structures

These structures define various parameters used for saving images. More...

Collaboration diagram for Image saving structures.:

Classes

struct | PngOption
Options for saving PNG images. More...
struct | PpmOption
Options for saving PPM images. More...
struct | PgmOption
Options for saving PGM images. More...
struct | TiffOption
Options for saving TIFF images. More...
struct | JpegOption
Options for saving JPEG image. More...
struct | Jpg2Option
Options for saving JPEG2000 image. More...
struct | BMPOption
Options for saving Bitmap image. More...
struct | AviOption
Options for saving AVI files. More...
struct | MJPGOption
Options for saving MJPEG files. More...
struct | H264Option
Options for saving H.264 files. More...
struct | SystemInfo
Description of the system. More...

Detailed Description

These structures define various parameters used for saving images.

Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
AviOption | Options for saving AVI files
BMPOption | Options for saving Bitmap image
CameraControlDialog | CameraControlDialog: managed wrapper of FlyCapture2::CameraControlDialog (see for details)
CameraInfo | Camera information
CameraProperty | A specific camera property
CameraPropertyInfo | Information about a specific camera property
CameraSelectionDialog | CameraControlDialog: managed wrapper of FlyCapture2::CameraSelectionDialog (see for details)
CameraStats | Camera diagnostic information
ConfigROM | Camera configuration ROM
EmbeddedImageInfo | Properties of the possible embedded image information
EmbeddedImageInfoProperty | Properties of a single embedded image info property
FC2Config | Configuration for a camera
FC2Exception | Exception that is thrown when an error is encountered
FC2Version | The current version of the library
Format7ImageSettings | Format 7 image settings
Format7Info | Format 7 information for a single mode
Format7PacketInfo | Format 7 packet information
GigEConfig | Configuration for a GigE camera
GigEImageSettings | Image settings for a GigE camera
GigEImageSettingsInfo | Format 7 information for a single mode
GigEProperty | A GigE property
GigEStreamChannel | Information about a single GigE stream channel
H264Option | Options for saving H.264 files
ImageMetadata | Metadata related to an image
JpegOption | Options for saving JPEG image
Jpg2Option | Options for saving JPEG2000 image
LutData | Information about the camera's look up table
ManagedAVIRecorder | ManagedAVIRecorder provides the functionality for the user to record images to an AVI file
ManagedBusManager | ManagedBusManager provides the functionality for the user to get an PGRGuid for a desired camera or device easily
ManagedCamera | ManagedCamera represents a physical camera that uses the IIDC register set
ManagedCameraBase | Abstract base class that represents a generic camera that defines a general interface to a camera
ManagedEventCallbackData |
ManagedEventOptions | Options for enabling device event registration
ManagedGCCamera |
ManagedGCPort |
ManagedGigECamera | The GigECamera object represents a physical Gigabit Ethernet camera
ManagedImage | The ManagedImageImage class is used to retrieve images from a camera, convert between multiple pixel formats and save images to disk
ManagedImageStatistics |
ManagedPGRGuid | Managed version of a PGRGuid
ManagedTopologyNode | Topology information that can be used to generate a tree structure of all cameras and devices connected to a computer
ManagedUtilities |
MJPGOption | Options for saving MJPEG files
NativeEventStruct |
PgmOption | Options for saving PGM images
PngOption | Options for saving PNG images
PpmOption | Options for saving PPM images
StrobeControl | A camera strobe
StrobeInfo | A camera strobe property
SystemInfo | Description of the system
TiffOption | Options for saving TIFF images
TimeStamp | Timestamp information
Translate |
TriggerMode | A camera trigger
TriggerModeInfo | Information about a camera trigger property
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: AviOption Struct Reference

  • Class Members
  • FlyCapture2Managed
  • AviOption
Public Member Functions | Properties
AviOption Struct Reference
Image saving structures.

Options for saving AVI files. More...

List of all members.

Public Member Functions

AviOption ()

Properties

float frameRate
Frame rate of the stream.

Detailed Description

Options for saving AVI files.

Constructor & Destructor Documentation

AviOption ( ) [inline]

Property Documentation

float frameRate

Frame rate of the stream.

Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: BMPOption Struct Reference

  • FlyCapture2Managed
  • BMPOption
Public Member Functions | Properties
BMPOption Struct Reference
Image saving structures.

Options for saving Bitmap image. More...

List of all members.

Public Member Functions

BMPOption ()

Properties

bool indexedColor_8bit

Detailed Description

Options for saving Bitmap image.

Constructor & Destructor Documentation

BMPOption ( ) [inline]

Property Documentation

bool indexedColor_8bit
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: CameraControlDialog Class Reference

  • FlyCapture2Managed
  • Gui
  • CameraControlDialog
Public Member Functions
CameraControlDialog Class Reference

CameraControlDialog: managed wrapper of FlyCapture2::CameraControlDialog (see for details) More...

List of all members.

Public Member Functions

CameraControlDialog ()
~CameraControlDialog ()
void | Connect (ManagedCameraBase^ camera)
void | Disconnect ()
void | Show ()
void | Hide ()
bool | IsVisible ()
void | SetTitle (System::String^ title)

Detailed Description

CameraControlDialog: managed wrapper of FlyCapture2::CameraControlDialog (see for details)

Constructor & Destructor Documentation

CameraControlDialog ( )
~CameraControlDialog ( )

Member Function Documentation

void Connect ( FlyCapture2Managed::ManagedCameraBase^ camera )
void Disconnect ( void )
void Hide ( )
bool IsVisible ( )
void SetTitle ( System::String^ title )
void Show ( )
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: CameraInfo Struct Reference

  • FlyCapture2Managed
  • CameraInfo
Properties
CameraInfo Struct Reference
Structures

Camera information. More...

List of all members.

Properties

unsigned int | serialNumber
Device serial number.
InterfaceType interfaceType
Interface type.
DriverType driverType
Driver type.
bool | isColorCamera
Flag indicating if this is a color camera.
System::String^ | modelName
Device model name.
System::String^ | vendorName
Device vendor name.
System::String^ | sensorInfo
String detailing the sensor information.
System::String^ | sensorResolution
String providing the sensor resolution.
System::String^ | driverName
Driver name of driver being used.
System::String^ | firmwareVersion
Firmware version of camera.
System::String^ | firmwareBuildTime
Firmware build time.
BusSpeed maximumBusSpeed
Maximum bus speed.
PCIeBusSpeed pcieBusSpeed
Maximum PCIe bus speed.
BayerTileFormat bayerTileFormat
Bayer tile format.
unsigned short | busNumber
Bus Number, set to 0 for USB and GigE.
unsigned short | nodeNumber
Node Number, set to 0 for USB and GigE.
IIDC specific information
unsigned int | iidcVersion
DCAM version.
ConfigROM configROM
Configuration ROM data.
GigE specific information
unsigned int | gigEMajorVersion
GigE Vision version.
unsigned int | gigEMinorVersion
GigE Vision minor version.
System::String^ | userDefinedName
User defined name.
System::String^ | xmlURL1
XML URL 1.
System::String^ | xmlURL2
XML URL 2.
System::Net::NetworkInformation::PhysicalAddress^ | macAddress
MAC address.
System::Net::IPAddress^ | ipAddress
IP address.
System::Net::IPAddress^ | subnetMask
Subnet mask.
System::Net::IPAddress^ | defaultGateway
Default gateway.
unsigned int | ccpStatus
Status/Content of CCP register.
unsigned int | applicationIPAddress
Local Application IP Address.
unsigned int | applicationPort
Local Application port.

Detailed Description

Camera information.

Property Documentation

unsigned int applicationIPAddress

Local Application IP Address.

unsigned int applicationPort

Local Application port.

BayerTileFormat bayerTileFormat

Bayer tile format.

unsigned short busNumber

Bus Number, set to 0 for USB and GigE.

unsigned int ccpStatus

Status/Content of CCP register.

ConfigROM configROM

Configuration ROM data.

System:: Net:: IPAddress^ defaultGateway

Default gateway.

System:: String^ driverName

Driver name of driver being used.

DriverType driverType

Driver type.

System:: String^ firmwareBuildTime

Firmware build time.

System:: String^ firmwareVersion

Firmware version of camera.

unsigned int gigEMajorVersion

GigE Vision version.

unsigned int gigEMinorVersion

GigE Vision minor version.

unsigned int iidcVersion

DCAM version.

InterfaceType interfaceType

Interface type.

System:: Net:: IPAddress^ ipAddress

IP address.

bool isColorCamera

Flag indicating if this is a color camera.

System:: Net:: NetworkInformation:: PhysicalAddress^ macAddress

MAC address.

BusSpeed maximumBusSpeed

Maximum bus speed.

System:: String^ modelName

Device model name.

unsigned short nodeNumber

Node Number, set to 0 for USB and GigE.

PCIeBusSpeed pcieBusSpeed

Maximum PCIe bus speed.

System:: String^ sensorInfo

String detailing the sensor information.

System:: String^ sensorResolution

String providing the sensor resolution.

unsigned int serialNumber

Device serial number.

System:: Net:: IPAddress^ subnetMask

Subnet mask.

System:: String^ userDefinedName

User defined name.

System:: String^ vendorName

Device vendor name.

System:: String^ xmlURL1

XML URL 1.

System:: String^ xmlURL2

XML URL 2.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: CameraProperty Struct Reference

  • FlyCapture2Managed
  • CameraProperty
Public Member Functions | Properties
CameraProperty Struct Reference
Structures

A specific camera property. More...

List of all members.

Public Member Functions

CameraProperty ()
CameraProperty (PropertyType type)

Properties

PropertyType type
Property info type.
bool | present
Flag indicating if the property is present.
bool | absControl
Flag controlling absolute mode.
bool | onePush
Flag controlling one push.
bool | onOff
Flag controlling on/off.
bool | autoManualMode
Flag controlling auto.
unsigned int | valueA
Value A (integer).
unsigned int | valueB
Value B (integer).
float | absValue
Floating point value.

Detailed Description

A specific camera property.

Constructor & Destructor Documentation

CameraProperty ( ) [inline]
CameraProperty ( PropertyType type ) [inline]

Property Documentation

bool absControl

Flag controlling absolute mode.

float absValue

Floating point value.

bool autoManualMode

Flag controlling auto.

bool onePush

Flag controlling one push.

bool onOff

Flag controlling on/off.

bool present

Flag indicating if the property is present.

PropertyType type

Property info type.

unsigned int valueA

Value A (integer).

unsigned int valueB

Value B (integer).

Applies only to the white balance blue value. Use Value A for the red value.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: CameraPropertyInfo Struct Reference

  • FlyCapture2Managed
  • CameraPropertyInfo
Public Member Functions | Properties
CameraPropertyInfo Struct Reference
Structures

Information about a specific camera property. More...

List of all members.

Public Member Functions

CameraPropertyInfo ()
CameraPropertyInfo (PropertyType type)

Properties

PropertyType type
Property info type.
bool | present
Flag indicating if the property is present.
bool | autoSupported
Flag indicating if auto is supported.
bool | manualSupported
Flag indicating if manual is supported.
bool | onOffSupported
Flag indicating if on/off is supported.
bool | onePushSupported
Flag indicating if one push is supported.
bool | absValSupported
Flag indicating if absolute mode is supported.
bool | readOutSupported
Flag indicating if property value can be read out.
unsigned int | min
Minimum value (as an integer).
unsigned int | max
Maximum value (as an integer).
float | absMin
Minimum value (as a floating point value).
float | absMax
Maximum value (as a floating point value).
System::String^ | units
Textual description of units.
System::String^ | unitAbbr
Abbreviated textual description of units.

Detailed Description

Information about a specific camera property.

This structure is also also used as the TriggerDelayInfo structure.

Constructor & Destructor Documentation

CameraPropertyInfo ( ) [inline]
CameraPropertyInfo ( PropertyType type ) [inline]

Property Documentation

float absMax

Maximum value (as a floating point value).

float absMin

Minimum value (as a floating point value).

bool absValSupported

Flag indicating if absolute mode is supported.

bool autoSupported

Flag indicating if auto is supported.

bool manualSupported

Flag indicating if manual is supported.

unsigned int max

Maximum value (as an integer).

unsigned int min

Minimum value (as an integer).

bool onePushSupported

Flag indicating if one push is supported.

bool onOffSupported

Flag indicating if on/off is supported.

bool present

Flag indicating if the property is present.

bool readOutSupported

Flag indicating if property value can be read out.

PropertyType type

Property info type.

System:: String^ unitAbbr

Abbreviated textual description of units.

System:: String^ units

Textual description of units.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: CameraSelectionDialog Class Reference

  • FlyCapture2Managed
  • Gui
  • CameraSelectionDialog
Public Member Functions
CameraSelectionDialog Class Reference

CameraControlDialog: managed wrapper of FlyCapture2::CameraSelectionDialog (see for details) More...

List of all members.

Public Member Functions

CameraSelectionDialog ()
~CameraSelectionDialog ()
bool | ShowModal ()
Show the CameraSelectionDlg.
array< ManagedPGRGuid^ >^ | GetSelectedCameraGuids ()
Returns the list of camera guids selected by the user while in ShowModal()
void | SetTitle (System::String^ title)
Set the window title.

Detailed Description

CameraControlDialog: managed wrapper of FlyCapture2::CameraSelectionDialog (see for details)

Constructor & Destructor Documentation

CameraSelectionDialog ( )
~CameraSelectionDialog ( )

Member Function Documentation

array< ManagedPGRGuid^ > GetSelectedCameraGuids ( )

Returns the list of camera guids selected by the user while in ShowModal()

Returns:
Array of PGRGuids identifying the selected cameras.
void SetTitle ( System::String^ title )

Set the window title.

Parameters:
pTitle Null-terminated string representing the title.
bool ShowModal ( )

Show the CameraSelectionDlg.

Returns:
Whether Ok (true) or Cancel (false) was clicked.
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: CameraStats Struct Reference

  • FlyCapture2Managed
  • CameraStats
Public Member Functions | Properties
CameraStats Struct Reference
Structures

Camera diagnostic information. More...

List of all members.

Public Member Functions

CameraStats ()

Properties

unsigned int | imageDropped
unsigned int | imageCorrupt
unsigned int | imageXmitFailed
unsigned int | imageDriverDropped
unsigned int | regReadFailed
unsigned int | regWriteFailed
unsigned int | portErrors
bool | cameraPowerUp
List< float >^ | cameraVoltages
unsigned int | numVoltages
The number of voltage registers available.
List< float >^ | cameraCurrents
unsigned int | numCurrents
The number of current registers available.
unsigned int | temperature
unsigned int | timeSinceInitialization
unsigned int | timeSinceBusReset
TimeStamp^ timeStamp
unsigned int | numResendPacketsRequested
unsigned int | numResendPacketsReceived

Detailed Description

Camera diagnostic information.

Constructor & Destructor Documentation

CameraStats ( ) [inline]

Property Documentation

List< float>^ cameraCurrents
bool cameraPowerUp
List< float>^ cameraVoltages
unsigned int imageCorrupt
unsigned int imageDriverDropped
unsigned int imageDropped
unsigned int imageXmitFailed
unsigned int numCurrents

The number of current registers available.

0: the values in cameraCurrents[] are invalid.

unsigned int numResendPacketsReceived
unsigned int numResendPacketsRequested
unsigned int numVoltages

The number of voltage registers available.

0: the values in cameraVoltages[] are invalid.

unsigned int portErrors
unsigned int regReadFailed
unsigned int regWriteFailed
unsigned int temperature
unsigned int timeSinceBusReset
unsigned int timeSinceInitialization
TimeStamp^ timeStamp
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ConfigROM Struct Reference

  • FlyCapture2Managed
  • ConfigROM
Properties
ConfigROM Struct Reference
Structures

Camera configuration ROM. More...

List of all members.

Properties

unsigned int | nodeVendorId
Vendor ID of a node.
unsigned int | chipIdHi
Chip ID (high part).
unsigned int | chipIdLo
Chip ID (low part).
unsigned int | unitSpecId
Unit Spec ID, usually 0xa02d.
unsigned int | unitSWVer
Unit software version.
unsigned int | unitSubSWVer
Unit sub software version.
unsigned int | vendorUniqueInfo0
Vendor unique info 0.
unsigned int | vendorUniqueInfo1
Vendor unique info 1.
unsigned int | vendorUniqueInfo2
Vendor unique info 2.
unsigned int | vendorUniqueInfo3
Vendor unique info 3.
System::String^ | keyword
Keyword.

Detailed Description

Camera configuration ROM.

Property Documentation

unsigned int chipIdHi

Chip ID (high part).

unsigned int chipIdLo

Chip ID (low part).

System:: String^ keyword

Keyword.

unsigned int nodeVendorId

Vendor ID of a node.

unsigned int unitSpecId

Unit Spec ID, usually 0xa02d.

unsigned int unitSubSWVer

Unit sub software version.

unsigned int unitSWVer

Unit software version.

unsigned int vendorUniqueInfo0

Vendor unique info 0.

unsigned int vendorUniqueInfo1

Vendor unique info 1.

unsigned int vendorUniqueInfo2

Vendor unique info 2.

unsigned int vendorUniqueInfo3

Vendor unique info 3.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: EmbeddedImageInfo Struct Reference

  • FlyCapture2Managed
  • EmbeddedImageInfo
Public Member Functions | Properties
EmbeddedImageInfo Struct Reference
Structures

Properties of the possible embedded image information. More...

List of all members.

Public Member Functions

EmbeddedImageInfo ()

Properties

EmbeddedImageInfoProperty^ timestamp
EmbeddedImageInfoProperty^ gain
EmbeddedImageInfoProperty^ shutter
EmbeddedImageInfoProperty^ brightness
EmbeddedImageInfoProperty^ exposure
EmbeddedImageInfoProperty^ whiteBalance
EmbeddedImageInfoProperty^ frameCounter
EmbeddedImageInfoProperty^ strobePattern
EmbeddedImageInfoProperty^ GPIOPinState
EmbeddedImageInfoProperty^ ROIPosition

Detailed Description

Properties of the possible embedded image information.

Constructor & Destructor Documentation

EmbeddedImageInfo ( ) [inline]

Property Documentation

EmbeddedImageInfoProperty^ brightness
EmbeddedImageInfoProperty^ exposure
EmbeddedImageInfoProperty^ frameCounter
EmbeddedImageInfoProperty^ gain
EmbeddedImageInfoProperty^ GPIOPinState
EmbeddedImageInfoProperty^ ROIPosition
EmbeddedImageInfoProperty^ shutter
EmbeddedImageInfoProperty^ strobePattern
EmbeddedImageInfoProperty^ timestamp
EmbeddedImageInfoProperty^ whiteBalance
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: EmbeddedImageInfoProperty Struct Reference

  • FlyCapture2Managed
  • EmbeddedImageInfoProperty
Properties
EmbeddedImageInfoProperty Struct Reference
Structures

Properties of a single embedded image info property. More...

List of all members.

Properties

bool | available
Whether this property is available.
bool | onOff
Whether this property is on or off.

Detailed Description

Properties of a single embedded image info property.

Property Documentation

bool available

Whether this property is available.

bool onOff

Whether this property is on or off.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: FC2Config Struct Reference

  • FlyCapture2Managed
  • FC2Config
Public Member Functions | Properties
FC2Config Struct Reference
Structures

Configuration for a camera. More...

List of all members.

Public Member Functions

FC2Config ()

Properties

unsigned int | numBuffers
Number of buffers used by the FlyCapture2 library to grab images.
unsigned int | numImageNotifications
Number of notifications per image.
unsigned int | minNumImageNotifications
Minimum number of notifications needed for the current image settings on the camera.
int | grabTimeout
Time in milliseconds that RetrieveBuffer() and WaitForBufferEvent() will wait for an image before timing out and returning.
GrabMode grabMode
Grab mode for the camera.
bool | highPerformanceRetrieveBuffer
This parameter enables RetrieveBuffer to run in high performance mode.
BusSpeed isochBusSpeed
Isochronous bus speed.
BusSpeed asyncBusSpeed
Asynchronous bus speed.
BandwidthAllocation bandwidthAllocation
Bandwidth allocation flag that tells the camera the bandwidth allocation strategy to employ.
unsigned int | registerTimeoutRetries
Number of retries to perform when a register read/write timeout is received by the library.
unsigned int | registerTimeout
Register read/write timeout value, in microseconds.

Detailed Description

Configuration for a camera.

These options are options that are generally should be set before starting isochronous transfer.

Constructor & Destructor Documentation

FC2Config ( ) [inline]

Property Documentation

BusSpeed asyncBusSpeed

Asynchronous bus speed.

BandwidthAllocation bandwidthAllocation

Bandwidth allocation flag that tells the camera the bandwidth allocation strategy to employ.

GrabMode grabMode

Grab mode for the camera.

The default is DROP_FRAMES.

int grabTimeout

Time in milliseconds that RetrieveBuffer() and WaitForBufferEvent() will wait for an image before timing out and returning.

bool highPerformanceRetrieveBuffer

This parameter enables RetrieveBuffer to run in high performance mode.

This means that any interaction with the camera, other then grabbing the image is disabled. Currently Retrieve buffer reads registers on the camera to determine which embedded image information settings have been enabled, and it reads what the bayer tile is currently set to. When High Performance mode is on, these reads are disabled. This means that any changes to the Bayer Tile or to the Embedded image info after StartCapture() will not be tracked when made using direct register writes. If the corresponding SetEmbededImageInfo() and GetEmbededImageInfo() calls are used then the changes will be appropriately reflected. This also means that changes to embedded image info from other processes will not be updated either.

BusSpeed isochBusSpeed

Isochronous bus speed.

unsigned int minNumImageNotifications

Minimum number of notifications needed for the current image settings on the camera.

Read-only value.

unsigned int numBuffers

Number of buffers used by the FlyCapture2 library to grab images.

unsigned int numImageNotifications

Number of notifications per image.

This value should only be set after the image settings to be used is set to the camera. The default number of notifications is 1.

There are 4 general scenarios:

  • 1 notification - End of image
  • 2 notifications - After first packet and end of image
  • 3 notifications - After first packet, middle of image, end of image
  • x notifications - After first packet, (x -2) spread evenly, end of image
unsigned int registerTimeout

Register read/write timeout value, in microseconds.

The default value is dependent on the interface type.

unsigned int registerTimeoutRetries

Number of retries to perform when a register read/write timeout is received by the library.

The default value is 0.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: FC2Exception Class Reference

  • FlyCapture2Managed
  • FC2Exception
Public Member Functions | Protected Member Functions | Package Functions | Properties
FC2Exception Class Reference

Exception that is thrown when an error is encountered. More...

List of all members.

Public Member Functions

FC2Exception ()
FC2Exception (String^ string)
FC2Exception (String^ string, Exception^ exception)
~FC2Exception ()

Protected Member Functions

FC2Exception (Runtime::Serialization::SerializationInfo^ serializationInfo, Runtime::Serialization::StreamingContext context)

Package Functions

FC2Exception (FlyCapture2::Error error)

Properties

ErrorType | Type [get]
ErrorType | CauseType [get]
String^ | NativeErrorTrace [get]

Detailed Description

Exception that is thrown when an error is encountered.

This is used instead of returning an Error object as used in the C++ interface.

Constructor & Destructor Documentation

FC2Exception ( )
FC2Exception ( String^ string )
FC2Exception | ( | String^ | string,
 |  | Exception^ | exception
 | ) |  |
~FC2Exception ( )
FC2Exception | ( | Runtime::Serialization::SerializationInfo^ | serializationInfo,
 |  | Runtime::Serialization::StreamingContext | context
 | ) |  | [protected]
FC2Exception ( FlyCapture2::Error error ) [package]

Property Documentation

ErrorType CauseType [get]
String^ NativeErrorTrace [get]
ErrorType Type [get]
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: FC2Version Struct Reference

  • FlyCapture2Managed
  • FC2Version
Properties
FC2Version Struct Reference
Structures

The current version of the library. More...

List of all members.

Properties

unsigned int | major
Major version number.
unsigned int | minor
Minor version number.
unsigned int | type
Type version number.
unsigned int | build
Build version number.

Detailed Description

The current version of the library.

Property Documentation

unsigned int build

Build version number.

unsigned int major

Major version number.

unsigned int minor

Minor version number.

unsigned int type

Type version number.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Format7ImageSettings Struct Reference

  • FlyCapture2Managed
  • Format7ImageSettings
Properties
Format7ImageSettings Struct Reference
Structures

Format 7 image settings. More...

List of all members.

Properties

Mode mode
Format 7 mode.
unsigned int | offsetX
Horizontal image offset.
unsigned int | offsetY
Vertical image offset.
unsigned int | width
Width of image.
unsigned int | height
Height of image.
PixelFormat pixelFormat
Pixel format of image.

Detailed Description

Format 7 image settings.

Property Documentation

unsigned int height

Height of image.

Mode mode

Format 7 mode.

unsigned int offsetX

Horizontal image offset.

unsigned int offsetY

Vertical image offset.

PixelFormat pixelFormat

Pixel format of image.

unsigned int width

Width of image.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Format7Info Struct Reference

  • FlyCapture2Managed
  • Format7Info
Properties
Format7Info Struct Reference
Structures

Format 7 information for a single mode. More...

List of all members.

Properties

Mode mode
Format 7 mode.
unsigned int | maxWidth
Maximum image width.
unsigned int | maxHeight
Maximum image height.
unsigned int | offsetHStepSize
Horizontal step size for the offset.
unsigned int | offsetVStepSize
Vertical step size for the offset.
unsigned int | imageHStepSize
Horizontal step size for the image.
unsigned int | imageVStepSize
Vertical step size for the image.
unsigned int | pixelFormatBitField
Supported pixel formats in a bit field.
unsigned int | vendorPixelFormatBitField
Vendor unique pixel formats in a bit field.
unsigned int | packetSize
Current packet size in bytes.
unsigned int | minPacketSize
Minimum packet size in bytes for current mode.
unsigned int | maxPacketSize
Maximum packet size in bytes for current mode.
float | percentage
Current packet size as a percentage of maximum packet size.

Detailed Description

Format 7 information for a single mode.

Property Documentation

unsigned int imageHStepSize

Horizontal step size for the image.

unsigned int imageVStepSize

Vertical step size for the image.

unsigned int maxHeight

Maximum image height.

unsigned int maxPacketSize

Maximum packet size in bytes for current mode.

unsigned int maxWidth

Maximum image width.

unsigned int minPacketSize

Minimum packet size in bytes for current mode.

Mode mode

Format 7 mode.

unsigned int offsetHStepSize

Horizontal step size for the offset.

unsigned int offsetVStepSize

Vertical step size for the offset.

unsigned int packetSize

Current packet size in bytes.

float percentage

Current packet size as a percentage of maximum packet size.

unsigned int pixelFormatBitField

Supported pixel formats in a bit field.

unsigned int vendorPixelFormatBitField

Vendor unique pixel formats in a bit field.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Format7PacketInfo Struct Reference

  • FlyCapture2Managed
  • Format7PacketInfo
Properties
Format7PacketInfo Struct Reference
Structures

Format 7 packet information. More...

List of all members.

Properties

unsigned int | recommendedBytesPerPacket
Recommended bytes per packet.
unsigned int | maxBytesPerPacket
Maximum bytes per packet.
unsigned int | unitBytesPerPacket
Minimum bytes per packet.

Detailed Description

Format 7 packet information.

Property Documentation

unsigned int maxBytesPerPacket

Maximum bytes per packet.

unsigned int recommendedBytesPerPacket

Recommended bytes per packet.

unsigned int unitBytesPerPacket

Minimum bytes per packet.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: GigEConfig Struct Reference

  • FlyCapture2Managed
  • GigEConfig
Properties
GigEConfig Struct Reference
Structures

Configuration for a GigE camera. More...

List of all members.

Properties

bool enablePacketResend
Turn on/off packet resend functionality.

Detailed Description

Configuration for a GigE camera.

These options are options that are generally should be set before starting isochronous transfer.

Property Documentation

bool enablePacketResend

Turn on/off packet resend functionality.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: GigEImageSettings Struct Reference

  • FlyCapture2Managed
  • GigEImageSettings
Properties
GigEImageSettings Struct Reference
Structures

Image settings for a GigE camera. More...

List of all members.

Properties

unsigned int | offsetX
Horizontal image offset.
unsigned int | offsetY
Vertical image offset.
unsigned int | width
Width of image.
unsigned int | height
Height of image.
PixelFormat pixelFormat
Pixel format of image.

Detailed Description

Image settings for a GigE camera.

Property Documentation

unsigned int height

Height of image.

unsigned int offsetX

Horizontal image offset.

unsigned int offsetY

Vertical image offset.

PixelFormat pixelFormat

Pixel format of image.

unsigned int width

Width of image.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: GigEImageSettingsInfo Struct Reference

  • FlyCapture2Managed
  • GigEImageSettingsInfo
Properties
GigEImageSettingsInfo Struct Reference
Structures

Format 7 information for a single mode. More...

List of all members.

Properties

unsigned int | maxWidth
Maximum image width.
unsigned int | maxHeight
Maximum image height.
unsigned int | offsetHStepSize
Horizontal step size for the offset.
unsigned int | offsetVStepSize
Vertical step size for the offset.
unsigned int | imageHStepSize
Horizontal step size for the image.
unsigned int | imageVStepSize
Vertical step size for the image.
unsigned int | pixelFormatBitField
Supported pixel formats in a bit field.
unsigned int | vendorPixelFormatBitField
Vendor unique pixel formats in a bit field.

Detailed Description

Format 7 information for a single mode.

Property Documentation

unsigned int imageHStepSize

Horizontal step size for the image.

unsigned int imageVStepSize

Vertical step size for the image.

unsigned int maxHeight

Maximum image height.

unsigned int maxWidth

Maximum image width.

unsigned int offsetHStepSize

Horizontal step size for the offset.

unsigned int offsetVStepSize

Vertical step size for the offset.

unsigned int pixelFormatBitField

Supported pixel formats in a bit field.

unsigned int vendorPixelFormatBitField

Vendor unique pixel formats in a bit field.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: GigEProperty Struct Reference

  • FlyCapture2Managed
  • GigEProperty
Properties
GigEProperty Struct Reference
Structures

A GigE property. More...

List of all members.

Properties

GigEPropertyType propType
The type of property.
bool | isReadable
Whether the property is readable.
bool | isWritable
Whether the property is writable.
unsigned int | min
Minimum value.
unsigned int | max
Maximum value.
unsigned int | value
Current value.

Detailed Description

A GigE property.

Property Documentation

bool isReadable

Whether the property is readable.

If this is false, then no other value in this structure is valid.

bool isWritable

Whether the property is writable.

unsigned int max

Maximum value.

unsigned int min

Minimum value.

GigEPropertyType propType

The type of property.

unsigned int value

Current value.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: GigEStreamChannel Struct Reference

  • FlyCapture2Managed
  • GigEStreamChannel
Properties
GigEStreamChannel Struct Reference
Structures

Information about a single GigE stream channel. More...

List of all members.

Properties

unsigned int | networkInterfaceIndex
Network interface index used (or to use).
unsigned int | hostPort
Host port on the PC where the camera will send the data stream.
bool | doNotFragment
Disable IP fragmentation of packets.
unsigned int | packetSize
Packet size, in bytes.
unsigned int | interPacketDelay
Inter packet delay, in timestamp counter units.
System::Net::IPAddress^ | destinationIpAddress
Destination IP address.
unsigned int | sourcePort
Source UDP port of the stream channel.

Detailed Description

Information about a single GigE stream channel.

Property Documentation

System:: Net:: IPAddress^ destinationIpAddress

Destination IP address.

It can be a multicast or unicast address.

bool doNotFragment

Disable IP fragmentation of packets.

unsigned int hostPort

Host port on the PC where the camera will send the data stream.

unsigned int interPacketDelay

Inter packet delay, in timestamp counter units.

unsigned int networkInterfaceIndex

Network interface index used (or to use).

unsigned int packetSize

Packet size, in bytes.

unsigned int sourcePort

Source UDP port of the stream channel.

Read only.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: H264Option Struct Reference

  • FlyCapture2Managed
  • H264Option
Public Member Functions | Properties
H264Option Struct Reference
Image saving structures.

Options for saving H.264 files. More...

List of all members.

Public Member Functions

H264Option ()

Properties

float | frameRate
Frame rate of the stream.
int | width
Width of source image.
int | height
Height of source image.
int | bitrate
Bitrate to encode at.

Detailed Description

Options for saving H.264 files.

Constructor & Destructor Documentation

H264Option ( ) [inline]

Property Documentation

int bitrate

Bitrate to encode at.

float frameRate

Frame rate of the stream.

int height

Height of source image.

int width

Width of source image.

Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ImageMetadata Struct Reference

  • FlyCapture2Managed
  • ImageMetadata
Properties
ImageMetadata Struct Reference
Structures

Metadata related to an image. More...

List of all members.

Properties

unsigned int | embeddedTimeStamp
Embedded timestamp.
unsigned int | embeddedGain
Embedded gain.
unsigned int | embeddedShutter
Embedded shutter.
unsigned int | embeddedBrightness
Embedded brightness.
unsigned int | embeddedExposure
Embedded exposure.
unsigned int | embeddedWhiteBalance
Embedded white balance.
unsigned int | embeddedFrameCounter
Embedded frame counter.
unsigned int | embeddedStrobePattern
Embedded strobe pattern.
unsigned int | embeddedGPIOPinState
Embedded GPIO pin state.
unsigned int | embeddedROIPosition
Embedded ROI position.

Detailed Description

Metadata related to an image.

Property Documentation

unsigned int embeddedBrightness

Embedded brightness.

unsigned int embeddedExposure

Embedded exposure.

unsigned int embeddedFrameCounter

Embedded frame counter.

unsigned int embeddedGain

Embedded gain.

unsigned int embeddedGPIOPinState

Embedded GPIO pin state.

unsigned int embeddedROIPosition

Embedded ROI position.

unsigned int embeddedShutter

Embedded shutter.

unsigned int embeddedStrobePattern

Embedded strobe pattern.

unsigned int embeddedTimeStamp

Embedded timestamp.

unsigned int embeddedWhiteBalance

Embedded white balance.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: JpegOption Struct Reference

  • FlyCapture2Managed
  • JpegOption
Public Member Functions | Properties
JpegOption Struct Reference
Image saving structures.

Options for saving JPEG image. More...

List of all members.

Public Member Functions

JpegOption ()

Properties

bool | progressive
Whether to save as a progressive JPEG file.
unsigned int | quality
JPEG image quality in range (0-100).

Detailed Description

Options for saving JPEG image.

Constructor & Destructor Documentation

JpegOption ( ) [inline]

Property Documentation

bool progressive

Whether to save as a progressive JPEG file.

unsigned int quality

JPEG image quality in range (0-100).

  • 100 - Superb quality.
  • 75 - Good quality.
  • 50 - Normal quality.
  • 10 - Poor quality.
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Jpg2Option Struct Reference

  • FlyCapture2Managed
  • Jpg2Option
Public Member Functions | Properties
Jpg2Option Struct Reference
Image saving structures.

Options for saving JPEG2000 image. More...

List of all members.

Public Member Functions

Jpg2Option ()

Properties

unsigned int quality
JPEG saving quality in range (1-512).

Detailed Description

Options for saving JPEG2000 image.

Constructor & Destructor Documentation

Jpg2Option ( ) [inline]

Property Documentation

unsigned int quality

JPEG saving quality in range (1-512).

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: LutData Struct Reference

  • FlyCapture2Managed
  • LutData
Properties
LutData Struct Reference
Structures

Information about the camera's look up table. More...

List of all members.

Properties

bool | supported
Flag indicating if LUT is supported.
bool | enabled
Flag indicating if LUT is enabled.
unsigned int | numBanks
The number of LUT banks available (Always 1 for PGR LUT).
unsigned int | numChannels
The number of LUT channels per bank available.
unsigned int | inputBitDepth
The input bit depth of the LUT.
unsigned int | outputBitDepth
The output bit depth of the LUT.
unsigned int | numEntries
The number of entries in the LUT.

Detailed Description

Information about the camera's look up table.

Property Documentation

bool enabled

Flag indicating if LUT is enabled.

unsigned int inputBitDepth

The input bit depth of the LUT.

unsigned int numBanks

The number of LUT banks available (Always 1 for PGR LUT).

unsigned int numChannels

The number of LUT channels per bank available.

unsigned int numEntries

The number of entries in the LUT.

unsigned int outputBitDepth

The output bit depth of the LUT.

bool supported

Flag indicating if LUT is supported.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedAVIRecorder Class Reference

  • FlyCapture2Managed
  • ManagedAVIRecorder
Public Member Functions
ManagedAVIRecorder Class Reference

ManagedAVIRecorder provides the functionality for the user to record images to an AVI file. More...

List of all members.

Public Member Functions

ManagedAVIRecorder ()
~ManagedAVIRecorder ()
void | AVIOpen (System::String^ fileName, AviOption^ option)
Open an AVI file in preparation for writing Images to disk.
void | AVIOpen (System::String^ fileName, MJPGOption^ option)
Open an MJPEG AVI file in preparation for writing Images to disk.
void | AVIOpen (System::String^ fileName, H264Option^ option)
Open an H.264 video file in preparation for writing Images to disk.
void | AVIAppend (ManagedImage^ image)
Append an image to the AVI file.
void | AVIClose ()
Close the AVI file.
void | SetMaximumAVISize (unsigned int size)
Set the maximum file size (in megabytes) of a AVI/MP4 file.

Detailed Description

ManagedAVIRecorder provides the functionality for the user to record images to an AVI file.

Constructor & Destructor Documentation

ManagedAVIRecorder ( )
~ManagedAVIRecorder ( )

Member Function Documentation

void AVIAppend ( ManagedImage^ image )

Append an image to the AVI file.

Parameters:
image The ManagedImage to append.
void AVIClose ( )

Close the AVI file.

See also:
AVIOpen()
void AVIOpen | ( | System::String^ | fileName,
 |  | AviOption^ | option
 | ) |  |

Open an AVI file in preparation for writing Images to disk.

The size of AVI files is limited to 2GB. The filenames are automatically generated using the filename specified.

Parameters:
fileName | The filename of the AVI file.
option | Options to apply to the AVI file.
See also:
SetMaximumAVISize( unsigned int size )
AVIClose()
void AVIOpen | ( | System::String^ | fileName,
 |  | MJPGOption^ | option
 | ) |  |

Open an MJPEG AVI file in preparation for writing Images to disk.

The size of AVI files is limited to 2GB. The filenames are automatically generated using the filename specified.

Parameters:
fileName | The filename of the AVI file.
option | Options to apply to the AVI file.
See also:
SetMaximumAVISize( unsigned int size )
AVIClose()
MJPGOption
void AVIOpen | ( | System::String^ | fileName,
 |  | H264Option^ | option
 | ) |  |

Open an H.264 video file in preparation for writing Images to disk.

If the file extension is not specified, MP4 will be used as the default container. Consult ffmpeg documentation for a list of supported containers.

Parameters:
pFileName | The filename of the video file.
pOption | H.264 options to apply to the video file.
See also:
AVIClose()
H264Option
void SetMaximumAVISize ( unsigned int size )

Set the maximum file size (in megabytes) of a AVI/MP4 file.

A new AVI/MP4 file is created automatically when file size limit is reached. Setting a maximum size of 0 indicates no limit on file size.

Parameters:
size The maximum AVI file size in MB.
See also:
AVIAppend( ManagedImage^ image )
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedBusManager Class Reference

  • FlyCapture2Managed
  • ManagedBusManager
Public Member Functions | Static Public Member Functions | Protected Member Functions | Static Package Functions
ManagedBusManager Class Reference

ManagedBusManager provides the functionality for the user to get an PGRGuid for a desired camera or device easily. More...

List of all members.

Public Member Functions

ManagedBusManager ()
~ManagedBusManager ()
void | FireBusReset (ManagedPGRGuid^ guid)
Fire a bus reset.
unsigned int | GetNumOfCameras ()
Gets the number of cameras attached to the PC.
ManagedPGRGuid^ | GetCameraFromIPAddress (System::Net::IPAddress^ ipAddress)
Gets the ManagedPGRGuid for a camera with the specified IPv4 address.
ManagedPGRGuid^ | GetCameraFromIndex (unsigned int index)
Gets the ManagedPGRGuid for a camera on the PC.
ManagedPGRGuid^ | GetCameraFromSerialNumber (unsigned int serialNumber)
Gets the ManagedPGRGuid for a camera on the PC.
unsigned int | GetCameraSerialNumberFromIndex (unsigned int index)
Gets the serial number of the camera with the specified index.
InterfaceType | GetInterfaceTypeFromGuid (ManagedPGRGuid^ guid)
Gets the interface type associated with a ManagedPGRGuid.
unsigned int | GetNumOfDevices ()
Gets the number of devices.
ManagedPGRGuid^ | GetDeviceFromIndex (unsigned int index)
Gets the ManagedPGRGuid for a device.
unsigned int | ReadPhyRegister (ManagedPGRGuid^ guid, unsigned int page, unsigned int port, unsigned int address)
Read a phy register on the specified device.
void | WritePhyRegister (ManagedPGRGuid^ guid, unsigned int page, unsigned int port, unsigned int address, unsigned int regVal)
Write a phy register on the specified device.
unsigned int | GetUsbLinkInfo (ManagedPGRGuid^ guid)
Read usb link info for the port that the specified device is connected to.
unsigned int | GetUsbPortStatus (ManagedPGRGuid^ guid)
Read usb port status for the port that the specified device is connected to.
ManagedTopologyNode^ GetTopology ()
Gets the topology information for the PC.
System::IntPtr | RegisterCallback (EnumCallback^ hCallbackDelegate, ManagedCallbackType callbackType, System::IntPtr parameter)
Register a callback function that will be called when the specified callback event occurs.
void | UnregisterCallback (System::IntPtr callbackHandle)
Unregister a callback function.
void | RescanBus ()
Force a rescan of the buses.
bool | IsCameraControlable (ManagedPGRGuid^ guid)
Query CCP status on camera with corresponding PGRGuid.

Static Public Member Functions

static void | ForceIPAddressToCamera (System::Net::NetworkInformation::PhysicalAddress^ macAddress, System::Net::IPAddress^ ipAddress, System::Net::IPAddress^ subnetMask, System::Net::IPAddress^ defaultGateway)
Force the camera with the specific MAC address to the specified IP address, subnet mask and default gateway.
static void | ForceAllIPAddressesAutomatically ()
Force all cameras on the network to be assigned sequential IP addresses on the same subnet as the netowrk adapters that they are connected to.
static void | ForceAllIPAddressesAutomatically (unsigned int serialNumber)
Force a specific cameras on the network to be assigned sequential IP address on the same subnet as the netowrk adapters that it is connected to.
static array< CameraInfo^ >^ | DiscoverGigECameras ()
Discover all cameras connected to the network even if they reside on a different subnet.

Protected Member Functions

!ManagedBusManager ()

Static Package Functions

static void | ConvertToNativeGuid (ManagedPGRGuid^ mgdPGRGuid, FlyCapture2::PGRGuid *pgrGuid)
Convert a ManagedPGRGuid to a native PGRGuid.
static void | ConvertToManagedGuid (FlyCapture2::PGRGuid *pgrGuid, ManagedPGRGuid^ mgdPGRGuid)
Convert a native PGRGuid to a ManagedPGRGuid.

Detailed Description

ManagedBusManager provides the functionality for the user to get an PGRGuid for a desired camera or device easily.

Once the camera or device token is found, it can then be used to connect to the camera or device through the camera class or device class. In addition, the BusManager class provides the ability to be notified when a camera or device is added or removed or some event occurs on the PC.

Constructor & Destructor Documentation

ManagedBusManager ( )
~ManagedBusManager ( )
!ManagedBusManager ( ) [protected]

Member Function Documentation

void ConvertToManagedGuid | ( | FlyCapture2::PGRGuid * | pgrGuid,
 |  | ManagedPGRGuid^ | mgdPGRGuid
 | ) |  | [inline, static, package]

Convert a native PGRGuid to a ManagedPGRGuid.

Parameters:
pgrGuid | The native PGRGuid.
mgdPGRGuid | The ManagedPGRGuid.
void ConvertToNativeGuid | ( | ManagedPGRGuid^ | mgdPGRGuid,
 |  | FlyCapture2::PGRGuid * | pgrGuid
 | ) |  | [inline, static, package]

Convert a ManagedPGRGuid to a native PGRGuid.

Parameters:
mgdPGRGuid | The ManagedPGRGuid.
pgrGuid | The native PGRGuid.
array< CameraInfo^ > DiscoverGigECameras ( ) [static]

Discover all cameras connected to the network even if they reside on a different subnet.

This is useful in situations where a GigE camera is using Persistent IP and the application's subnet is different from the device subnet. After discovering the camera, it is easy to use ForceIPAddressToCamera() to set a different IP configuration.

Returns:
Array of CameraInfo structures containing information about discovered cameras.
void FireBusReset ( ManagedPGRGuid^ guid )

Fire a bus reset.

The actual bus reset is only fired for the specified 1394 bus, but it will effectively cause a global bus reset for the library.

Parameters:
guid ManagedPGRGuid of the camera or the device to cause bus reset.
void ForceAllIPAddressesAutomatically ( ) [static]

Force all cameras on the network to be assigned sequential IP addresses on the same subnet as the netowrk adapters that they are connected to.

This is useful in situations where a GigE Vision cameras are using Persistent IP addresses and the application's subnet is different from the devices.

void ForceAllIPAddressesAutomatically ( unsigned int serialNumber ) [static]

Force a specific cameras on the network to be assigned sequential IP address on the same subnet as the netowrk adapters that it is connected to.

This is useful in situations where a GigE Vision camera is using Persistent IP addresses and the application's subnet is different from the device.

void ForceIPAddressToCamera | ( | System::Net::NetworkInformation::PhysicalAddress^ | macAddress,
 |  | System::Net::IPAddress^ | ipAddress,
 |  | System::Net::IPAddress^ | subnetMask,
 |  | System::Net::IPAddress^ | defaultGateway
 | ) |  | [static]

Force the camera with the specific MAC address to the specified IP address, subnet mask and default gateway.

This is useful in situations where a GigE Vision camera is using Persistent IP and the application's subnet is different from the device subnet.

Parameters:
macAddress | MAC address of the camera.
ipAddress | IP address to set on the camera.
subnetMask | Subnet mask to set on the camera.
defaultGateway | Default gateway to set on the camera.
ManagedPGRGuid GetCameraFromIndex ( unsigned int index )

Gets the ManagedPGRGuid for a camera on the PC.

It uniquely identifies the camera specified by the index and is used to identify the camera during a ManagedCamera::Connect() call.

Parameters:
index Zero based index of camera.
Returns:
Unique ManagedPGRGuid for the camera.
ManagedPGRGuid GetCameraFromIPAddress ( System::Net::IPAddress^ ipAddress )

Gets the ManagedPGRGuid for a camera with the specified IPv4 address.

Parameters:
ipAddress IP address to get ManagedPGRGuid for.
Returns:
Unique ManagedPGRGuid for the camera.
ManagedPGRGuid GetCameraFromSerialNumber ( unsigned int serialNumber )

Gets the ManagedPGRGuid for a camera on the PC.

It uniquely identifies the camera specified by the serial number and is used to identify the camera during a ManagedCamera::Connect() call.

Parameters:
serialNumber Serial number of camera.
See also:
GetCameraFromIndex()
Returns:
Unique ManagedPGRGuid for the camera.
unsigned int GetCameraSerialNumberFromIndex ( unsigned int index )

Gets the serial number of the camera with the specified index.

Parameters:
index Zero based index of desired camera.
Returns:
Serial number of camera.
ManagedPGRGuid GetDeviceFromIndex ( unsigned int index )

Gets the ManagedPGRGuid for a device.

It uniquely identifies the device specified by the index.

Parameters:
index Zero based index of device.
See also:
GetNumOfDevices()
Returns:
Unique ManagedPGRGuid for the device.
InterfaceType GetInterfaceTypeFromGuid ( ManagedPGRGuid^ guid )

Gets the interface type associated with a ManagedPGRGuid.

This is useful in situations where there is a need to enumerate all cameras for a particular interface.

Parameters:
guid The ManagedPGRGuid to get the interface for.
Returns:
The interface type of the PGRGuid.
unsigned int GetNumOfCameras ( )

Gets the number of cameras attached to the PC.

Returns:
The number of cameras attached.
unsigned int GetNumOfDevices ( )

Gets the number of devices.

This may include hubs, host controllers and other hardware devices (including cameras).

Returns:
The number of devices found.
ManagedTopologyNode GetTopology ( )

Gets the topology information for the PC.

Returns:
ManagedTopologyNode object that will contain the topology
unsigned int GetUsbLinkInfo ( ManagedPGRGuid^ guid )

Read usb link info for the port that the specified device is connected to.

Parameters:
guid PGRGuid of the device to read from.
Returns:
Value read from the card register.
unsigned int GetUsbPortStatus ( ManagedPGRGuid^ guid )

Read usb port status for the port that the specified device is connected to.

Parameters:
guid PGRGuid of the device to read from.
Returns:
Value read from the card register.
bool IsCameraControlable ( ManagedPGRGuid^ guid )

Query CCP status on camera with corresponding PGRGuid.

This is useful to determine if a GigE camera can be controlled.

Parameters:
pGuid PGRGuid of the camera
Returns:
True means camera is controlable.
unsigned int ReadPhyRegister | ( | ManagedPGRGuid^ | guid,
 |  | unsigned int | page,
 |  | unsigned int | port,
 |  | unsigned int | address
 | ) |  |

Read a phy register on the specified device.

The full address to be read from is determined by the page, port and address.

Parameters:
guid | ManagedPGRGuid of the device to read from.
page | Page to read from.
port | Port to read from.
address | Address to read from.
Returns:
Value read from the phy register.
System::IntPtr RegisterCallback | ( | EnumCallback^ | hCallbackDelegate,
 |  | ManagedCallbackType | callbackType,
 |  | System::IntPtr | parameter
 | ) |  |

Register a callback function that will be called when the specified callback event occurs.

Parameters:
hCallbackDelegate | Handle to EnumCallback function to receive the callback.
callbackType | Type of callback to register for.
parameter | Callback parameter to be passed to callback.
See also:
UnregisterCallback()
Returns:
Unique callback handle used for unregistering callback.
void RescanBus ( )

Force a rescan of the buses.

This does not trigger a bus reset. The camera objects will be invalidated only if the camera network topology is changed (ie. a camera is disconnected or added)

void UnregisterCallback ( System::IntPtr callbackHandle )

Unregister a callback function.

Parameters:
callbackHandle Unique callback handle.
See also:
RegisterCallback()
void WritePhyRegister | ( | ManagedPGRGuid^ | guid,
 |  | unsigned int | page,
 |  | unsigned int | port,
 |  | unsigned int | address,
 |  | unsigned int | regVal
 | ) |  |

Write a phy register on the specified device.

The full address to be written to is determined by the page, port and address.

Parameters:
guid | ManagedPGRGuid of the device to write to.
page | Page to write to.
port | Port to write to.
address | Address to write to.
regVal | Value to write to phy register.
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedCamera Class Reference

  • FlyCapture2Managed
  • ManagedCamera
Public Member Functions | Protected Member Functions
ManagedCamera Class Reference

ManagedCamera represents a physical camera that uses the IIDC register set. More...

Inheritance diagram for ManagedCamera:
[legend]
Collaboration diagram for ManagedCamera:
[legend]

List of all members.

Public Member Functions

ManagedCamera ()
~ManagedCamera ()
virtual void | Connect (ManagedPGRGuid^ mgdPGRGuid) override
Connects the ManagedCamera object to the camera specified by the GUID.

Protected Member Functions

!ManagedCamera ()

DCAM Formats

These functions deal with DCAM video mode and frame rate on the camera.

They are only used for firewire and Usb2 cameras.

bool | GetVideoModeAndFrameRateInfo (VideoMode videoMode, FrameRate frameRate)
Query the camera to determine if the specified video mode and frame rate is supported.
void | GetVideoModeAndFrameRate (VideoMode% videoMode, FrameRate% frameRate)
Get the current video mode and frame rate from the camera.
void | SetVideoModeAndFrameRate (VideoMode videoMode, FrameRate frameRate)
Set the specified video mode and frame rate to the camera.

Format7

These functions deal with Format7 custom image control on the camera.

Format7Info^ | GetFormat7Info (Mode mode, bool% supported)
Retrieve the availability of Format7 custom image mode and the camera capabilities for the specified Format7 mode.
Format7PacketInfo^ | ValidateFormat7Settings (Format7ImageSettings^ imageSettings, bool% settingsAreValid)
Validates Format7ImageSettings structure and returns valid packet size information if the image settings are valid.
void | GetFormat7Configuration (Format7ImageSettings^ imageSettings, unsigned int% packetSize, float% percentSpeed)
Get the current Format7 configuration from the camera.
void | SetFormat7Configuration (Format7ImageSettings^ imageSettings, unsigned int recommendedPacketSize)
Set the current Format7 configuration to the camera.
void | SetFormat7Configuration (Format7ImageSettings^ imageSettings, float recommendedPercentSpeed)
Set the current Format7 configuration to the camera.
static void | StartSyncCapture (unsigned int numCameras, array< ManagedCamera^ >^ppCameras)
Start multiple cameras in synchronization.
static void | StartSyncCapture (unsigned int numCameras, array< ManagedCamera^ >^ppCameras, array< ImageEventCallback^ >^pCallbackFns, array< IntPtr^ >^pCallbackDataArray)
Start multiple cameras in synchronization using callbacks.

Detailed Description

ManagedCamera represents a physical camera that uses the IIDC register set.

The object must first be connected to using Connect() before any other operations can proceed.

It is possible for more than 1 Camera object to connect to a single physical camera. However, isochronous transmission to more than 1 Camera object is not supported.

Constructor & Destructor Documentation

ManagedCamera ( )
~ManagedCamera ( )
!ManagedCamera ( ) [protected]

Member Function Documentation

void Connect ( ManagedPGRGuid^ mgdPGRGuid ) [override, virtual]

Connects the ManagedCamera object to the camera specified by the GUID.

Parameters:
mgdPGRGuid The unique identifier for a specific camera on the PC.
See also:
ManagedBusManager::GetCameraFromIndex()
ManagedBusManager::GetCameraFromSerialNumber()

Reimplemented from ManagedCameraBase.

void GetFormat7Configuration | ( | Format7ImageSettings^ | imageSettings,
 |  | unsigned int% | packetSize,
 |  | float% | percentSpeed
 | ) |  |

Get the current Format7 configuration from the camera.

This call will only succeed if the camera is already in Format7.

Parameters:
imageSettings | Current image settings.
packetSize | Current packet size.
percentSpeed | Current packet size as a percentage.
See also:
GetFormat7Info()
ValidateFormat7Settings()
SetFormat7Configuration()
GetVideoModeAndFrameRate()
Format7Info GetFormat7Info | ( | Mode | mode,
 |  | bool% | supported
 | ) |  |

Retrieve the availability of Format7 custom image mode and the camera capabilities for the specified Format7 mode.

The mode must be specified in the Format7Info structure in order for the function to succeed.

Parameters:
mode | Format7 mode to query.
supported | Whether the specified mode is supported.
See also:
ValidateFormat7Settings()
GetFormat7Configuration()
SetFormat7Configuration()
Returns:
Format7Info structure filled with the capabilities of the specified mode and the current state in the specified mode.
void GetVideoModeAndFrameRate | ( | VideoMode% | videoMode,
 |  | FrameRate% | frameRate
 | ) |  |

Get the current video mode and frame rate from the camera.

If the camera is in Format7, the video mode will be VIDEOMODE_FORMAT7 and the frame rate will be FRAMERATE_FORMAT7.

Parameters:
videoMode | Current video mode.
frameRate | Current frame rate.
See also:
GetVideoModeAndFrameRateInfo()
SetVideoModeAndFrameRate()
bool GetVideoModeAndFrameRateInfo | ( | VideoMode | videoMode,
 |  | FrameRate | frameRate
 | ) |  |

Query the camera to determine if the specified video mode and frame rate is supported.

Parameters:
videoMode | Video mode to check.
frameRate | Frame rate to check.
See also:
GetVideoModeAndFrameRate()
SetVideoModeAndFrameRate()
Returns:
Whether the video mode and frame rate is supported.
void SetFormat7Configuration | ( | Format7ImageSettings^ | imageSettings,
 |  | unsigned int | recommendedPacketSize
 | ) |  |

Set the current Format7 configuration to the camera.

Parameters:
imageSettings | Image settings to be written to the camera.
recommendedPacketSize | Packet size to be written to the camera.
See also:
GetFormat7Info()
ValidateFormat7Settings()
GetFormat7Configuration()
void SetFormat7Configuration | ( | Format7ImageSettings^ | imageSettings,
 |  | float | recommendedPercentSpeed
 | ) |  |

Set the current Format7 configuration to the camera.

Parameters:
imageSettings | Image settings to be written to the camera.
recommendedPercentSpeed | Percentage of packet size to be written to the camera.
See also:
GetFormat7Info()
ValidateFormat7Settings()
GetFormat7Configuration()
void SetVideoModeAndFrameRate | ( | VideoMode | videoMode,
 |  | FrameRate | frameRate
 | ) |  |

Set the specified video mode and frame rate to the camera.

It is not possible to set the camera to VIDEOMODE_FORMAT7 or FRAMERATE_FORMAT7. Use the Format7 functions to set the camera into Format7.

Parameters:
videoMode | Video mode to set to camera.
frameRate | Frame rate to set to camera.
See also:
GetVideoModeAndFrameRateInfo()
GetVideoModeAndFrameRate()
void StartSyncCapture | ( | unsigned int | numCameras,
 |  | array< ManagedCamera^ >^ | ppCameras
 | ) |  | [static]

Start multiple cameras in synchronization.

This function is only used for firewire cameras.

Parameters:
numCameras | Number of cameras to start.
ppCameras | An array of ManagedCamera objects to be started.
See also:
StartCapture()
void StartSyncCapture | ( | unsigned int | numCameras,
 |  | array< ManagedCamera^ >^ | ppCameras,
 |  | array< ImageEventCallback^ >^ | pCallbackFns,
 |  | array< IntPtr^ >^ | pCallbackDataArray
 | ) |  | [static]

Start multiple cameras in synchronization using callbacks.

This function is only used for firewire cameras.

Parameters:
numCameras | Number of cameras to start.
ppCameras | An array of ManagedCamera objects to be started
pCallbackFns | An array of callback functions
pCallbackDataArray | An array of ManagedImage objects to be populated during callback
See also:
StartCapture()
Format7PacketInfo ValidateFormat7Settings | ( | Format7ImageSettings^ | imageSettings,
 |  | bool% | settingsAreValid
 | ) |  |

Validates Format7ImageSettings structure and returns valid packet size information if the image settings are valid.

The current image settings are cached while validation is taking place. The cached settings are restored when validation is complete.

Parameters:
imageSettings | Structure containing the image settings.
settingsAreValid | Whether the settings are valid.
See also:
GetFormat7Info()
GetFormat7Configuration()
SetFormat7Configuration()
Returns:
Packet size information that can be used to determine a valid packet size.
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedCameraBase Class Reference

  • FlyCapture2Managed
  • ManagedCameraBase
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Package Functions
ManagedCameraBase Class Reference

Abstract base class that represents a generic camera that defines a general interface to a camera. More...

Inheritance diagram for ManagedCameraBase:
[legend]

List of all members.

Public Member Functions

virtual | ~ManagedCameraBase ()
void | SetCamera (System::IntPtr otherCamera)
Set camera from a integer pointer camera.
virtual TimeStamp^ | GetCycleTime ()
Returns a Timestamp struct containing 1394 CYCLE_TIME information.
virtual CameraStats^ | GetStats ()
virtual void | ResetStats ()
virtual void | RegisterEvent (ManagedEventOptions^ hOpts)
virtual void | DeregisterEvent (ManagedEventOptions^ hOpts)
virtual void | RegisterAllEvents (ManagedEventOptions^ hOpts)
virtual void | DeregisterAllEvents ()
Connection and Image Retrieval

These functions deal with connections and image retrieval from the camera.

virtual void | Connect (ManagedPGRGuid^ mgdPGRGuid)
Connects the ManagedCamera object to the camera specified by the GUID.
virtual void | Disconnect ()
Disconnects the ManagedCamera object from the camera.
virtual bool | IsConnected ()
Checks if the ManagedCamera object is connected to a physical camera specified by a GUID.
virtual void | SetCallback (ImageEventCallback^ hCallbackDelegate)
Sets the callback data to be used on completion of image transfer.
virtual void | StartCapture ()
Starts isochronous image capture.
virtual void | StartCapture (ImageEventCallback^ hCallbackDelegate)
Starts isochronous image capture.
virtual void | StopCapture ()
Stops isochronous image transfer and cleans up all associated resources.
virtual void | RetrieveBuffer (ManagedImage^ image)
Retrieves the the next image object containing the next image.
virtual void | WaitForBufferEvent (ManagedImage^ image, unsigned int eventNumber)
Retrieves the next image event containing the next part of the image.
virtual void | SetUserBuffers (IntPtr pMemBuffers, int size, int numBuffers)
Specify user allocated buffers to use as image data buffers.
virtual FC2Config^ | GetConfiguration ()
Get the configuration associated with the camera object.
virtual void | SetConfiguration (FC2Config^ config)
Set the configuration associated with the camera object.
Information and Properties

These functions deal with information and properties can be retrieved from the camera.

virtual CameraInfo^ | GetCameraInfo ()
Retrieves information from the camera such as serial number, model name and other camera information.
virtual CameraPropertyInfo^ | GetPropertyInfo (PropertyType type)
Retrieves information about the specified camera property.
virtual CameraProperty^ | GetProperty (PropertyType type)
Reads the settings for the specified property from the camera.
virtual void | SetProperty (CameraProperty^ camProperty)
Writes the settings for the specified property to the camera.
virtual void | SetProperty (CameraProperty^ camProperty, bool broadcast)
Writes the settings for the specified property to the camera.
General Purpose Input / Output

These functions deal with general GPIO pin control on the camera.

virtual unsigned int | GetGPIOPinDirection (unsigned int pin)
Get the GPIO pin direction for the specified pin.
virtual void | SetGPIOPinDirection (unsigned int pin, unsigned int direction)
Set the GPIO pin direction for the specified pin.
virtual void | SetGPIOPinDirection (unsigned int pin, unsigned int direction, bool broadcast)
Set the GPIO pin direction for the specified pin.
Trigger

These functions deal with trigger control on the camera.

virtual TriggerModeInfo^ | GetTriggerModeInfo ()
Retrieve trigger information from the camera.
virtual TriggerMode^ | GetTriggerMode ()
Retrieve current trigger settings from the camera.
virtual void | SetTriggerMode (TriggerMode^ triggerMode)
Set the specified trigger settings to the camera.
virtual void | FireSoftwareTrigger (bool broadcast)
Fire the software trigger according to the DCAM specifications.
virtual CameraPropertyInfo^ | GetTriggerDelayInfo ()
Retrieve trigger delay information from the camera.
virtual CameraProperty^ | GetTriggerDelay ()
Retrieve current trigger delay settings from the camera.
virtual void | SetTriggerDelay (CameraProperty^ triggerDelay)
Set the specified trigger delay settings to the camera.
virtual void | SetTriggerDelay (CameraProperty^ triggerDelay, bool broadcast)
Set the specified trigger delay settings to the camera.
Strobe

These functions deal with strobe control on the camera.

virtual StrobeInfo^ | GetStrobeInfo (unsigned int source)
Retrieve strobe information from the camera.
virtual StrobeControl^ | GetStrobe (unsigned int source)
Retrieve current strobe settings from the camera.
virtual void | SetStrobe (StrobeControl^ strobeControl)
Set current strobe settings to the camera.
Look Up Table

These functions deal with Look Up Table control on the camera.

Note that some cameras may report support for the LUT and return an inputBitDepth of 0. In these cases use log2(numEntries) for the inputBitDepth.

virtual LutData^ | GetLUTInfo ()
Query if LUT support is available on the camera.
virtual void | GetLUTBankInfo (unsigned int bank, bool% readSupported, bool% writeSupported)
Query the read/write status of a single LUT bank.
virtual unsigned int | GetActiveLUTBank ()
Get the LUT bank that is currently being used.
virtual void | SetActiveLUTBank (unsigned int activeBank)
Set the LUT bank that will be used.
virtual void | EnableLUT (bool on)
Enable or disable LUT functionality on the camera.
virtual void | GetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries)
Get the LUT channel settings from the camera.
virtual void | SetLUTChannel (unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries)
Set the LUT channel settings to the camera.
Memory Channels

These functions deal with memory channel control on the camera.

virtual unsigned int | GetMemoryChannel ()
Retrieve the current memory channel from the camera.
virtual void | SaveToMemoryChannel (unsigned int channel)
Save the current settings to the specfied current memory channel.
virtual void | RestoreFromMemoryChannel (unsigned int channel)
Restore the specfied current memory channel.
virtual unsigned int | GetMemoryChannelInfo ()
Query the camera for memory channel support.
Embedded Image Information

These functions deal with embedded image information control on the camera.

virtual EmbeddedImageInfo^ | GetEmbeddedImageInfo ()
Get the current status of the embedded image information register, as well as the availability of each embedded property.
virtual void | SetEmbeddedImageInfo (EmbeddedImageInfo^ info)
Sets the on/off values of the embedded image information structure to the camera.
Register Operation

These functions deal with register operation on the camera.

virtual void | WriteRegister (unsigned int address, unsigned int value)
Write to the specified register on the camera.
virtual void | WriteRegister (unsigned int address, unsigned int value, bool broadcast)
Write to the specified register on the camera.
virtual unsigned int | ReadRegister (unsigned int address)
Read the specified register from the camera.
virtual void | WriteRegisterBlock (unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer)
Write to the specified register block on the camera.
virtual void | ReadRegisterBlock (unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer)
Read from the specified register block on the camera.

Static Public Member Functions

static System::String^ | GetRegisterString (unsigned int registerVal)
Returns a text representation of the register value.

Protected Member Functions

ManagedCameraBase ()
void | OnNativeCallback (FlyCapture2::Image *pImage, void *pCallbackData)
void | OnNativeCameraEventCallback (void *pCallbackData)

Protected Attributes

FlyCapture2::CameraBase * | m_pNativeCamBase
bool | m_isLocal
ImageEventCallback^ | m_externalDelegate
ImageCallbackDelegate^ | m_internalDelegate
ManagedCameraEventCallbackDelegate^ | m_internalCameraEventDelegate
IntPtr | m_p
Dictionary
< ManagedEventOptions^
, NativeEventStruct >^ 		m_specificInternalCameraEvents
Dictionary
< ManagedEventOptions^
, NativeEventStruct >^ 		m_allInternalCameraEvents

Package Functions

FlyCapture2::CameraBase * | GetNativeCamera ()

Detailed Description

Abstract base class that represents a generic camera that defines a general interface to a camera.

Constructor & Destructor Documentation

virtual ~ManagedCameraBase ( ) [inline, virtual]
ManagedCameraBase ( ) [inline, protected]

Member Function Documentation

void Connect ( ManagedPGRGuid^ mgdPGRGuid ) [virtual]

Connects the ManagedCamera object to the camera specified by the GUID.

Parameters:
mgdPGRGuid The unique identifier for a specific camera on the PC.
See also:
ManagedBusManager::GetCameraFromIndex()
ManagedBusManager::GetCameraFromSerialNumber()

Reimplemented in ManagedCamera, ManagedGigECamera, and ManagedGCCamera.

void DeregisterAllEvents ( ) [virtual]
void DeregisterEvent ( ManagedEventOptions^ hOpts ) [virtual]
void Disconnect ( void ) [virtual]

Disconnects the ManagedCamera object from the camera.

This allows another physical camera specified by a GUID to be connected to the ManagedCamera object.

See also:
Connect()

Reimplemented in ManagedGCCamera.

void EnableLUT ( bool on ) [virtual]

Enable or disable LUT functionality on the camera.

Parameters:
on Whether to enable or disable LUT.
See also:
GetLUTInfo()
GetLUTChannel()
SetLUTChannel()
void FireSoftwareTrigger ( bool broadcast ) [virtual]

Fire the software trigger according to the DCAM specifications.

Parameters:
broadcast Whether the action should be broadcast.
unsigned int GetActiveLUTBank ( ) [virtual]

Get the LUT bank that is currently being used.

For cameras with PGR LUT, the active bank is always 0.

Returns:
The currently active bank.
CameraInfo GetCameraInfo ( ) [virtual]

Retrieves information from the camera such as serial number, model name and other camera information.

Returns:
Structure containing camera information.
FC2Config GetConfiguration ( ) [virtual]

Get the configuration associated with the camera object.

See also:
SetConfiguration()
Returns:
Current configuration.
TimeStamp GetCycleTime ( ) [virtual]

Returns a Timestamp struct containing 1394 CYCLE_TIME information.

Parameters:
registerVal The register value to query.
Returns:
An Error indicating the success or failure of the function.
EmbeddedImageInfo GetEmbeddedImageInfo ( ) [virtual]

Get the current status of the embedded image information register, as well as the availability of each embedded property.

See also:
SetEmbeddedImageInfo()
Returns:
EmbeddedImageInfo structure containing embedded image information.
unsigned int GetGPIOPinDirection ( unsigned int pin ) [virtual]

Get the GPIO pin direction for the specified pin.

This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin Pin to get the direction for.
See also:
SetGPIOPinDirection()
Returns:
Direction of the pin. 0 for input, 1 for output.
void GetLUTBankInfo | ( | unsigned int | bank,
 |  | bool% | readSupported,
 |  | bool% | writeSupported
 | ) |  | [virtual]

Query the read/write status of a single LUT bank.

Parameters:
bank | The bank to query.
readSupported | Whether reading from the bank is supported.
writeSupported | Whether writing to the bank is supported.
void GetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | array< unsigned int >^ | entries
 | ) |  | [virtual]

Get the LUT channel settings from the camera.

Parameters:
bank | Bank to retrieve.
channel | Channel to retrieve.
sizeEntries | Number of entries in LUT table to read.
entries | Array to store LUT entries in.
See also:
GetLUTInfo()
EnableLUT()
SetLUTChannel()
LutData GetLUTInfo ( ) [virtual]

Query if LUT support is available on the camera.

See also:
EnableLUT()
GetLUTChannel()
SetLUTChannel()
Returns:
LutData structure containing the LUT information.
unsigned int GetMemoryChannel ( ) [virtual]

Retrieve the current memory channel from the camera.

See also:
SaveToMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
Returns:
Currently selected memory channel.
unsigned int GetMemoryChannelInfo ( ) [virtual]

Query the camera for memory channel support.

If the number of channels is 0, then memory channel support is not available.

See also:
GetMemoryChannel()
SaveToMemoryChannel()
RestoreFromMemoryChannel()
Returns:
Number of memory channels supported.
FlyCapture2::CameraBase * GetNativeCamera ( ) [package]
CameraProperty GetProperty ( PropertyType type ) [virtual]

Reads the settings for the specified property from the camera.

If auto is on, the integer and abs values returned may not be consistent with each other.

Parameters:
type The PropertyType to retrieve information about.
See also:
GetPropertyInfo()
SetProperty()
Returns:
Property structure containing property information.
CameraPropertyInfo GetPropertyInfo ( PropertyType type ) [virtual]

Retrieves information about the specified camera property.

Parameters:
type The PropertyType to retrieve information about.
See also:
GetProperty()
SetProperty()
Returns:
PropertyInfo structure containing property information.
System::String GetRegisterString ( unsigned int registerVal ) [static]

Returns a text representation of the register value.

Parameters:
registerVal The register value to query.
Returns:
The text representation of the register.
CameraStats GetStats ( ) [virtual]
StrobeControl GetStrobe ( unsigned int source ) [virtual]

Retrieve current strobe settings from the camera.

Parameters:
source Source pin for strobe information.
See also:
GetStrobeInfo()
SetStrobe()
Returns:
StrobeControl structure containing strobe information.
StrobeInfo GetStrobeInfo ( unsigned int source ) [virtual]

Retrieve strobe information from the camera.

Parameters:
source Source pin for strobe information.
See also:
GetStrobe()
SetStrobe()
Returns:
StrobeInfo structure containing strobe information.
CameraProperty GetTriggerDelay ( ) [virtual]

Retrieve current trigger delay settings from the camera.

See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
SetTriggerDelay()
Returns:
Structure to receive trigger delay settings.
CameraPropertyInfo GetTriggerDelayInfo ( ) [virtual]

Retrieve trigger delay information from the camera.

See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelay()
SetTriggerDelay()
Returns:
Structure to receive trigger delay information.
TriggerMode GetTriggerMode ( ) [virtual]

Retrieve current trigger settings from the camera.

See also:
GetTriggerModeInfo()
SetTriggerMode()
Returns:
TriggerMode structure containing trigger mode settings.
TriggerModeInfo GetTriggerModeInfo ( ) [virtual]

Retrieve trigger information from the camera.

See also:
GetTriggerMode()
SetTriggerMode()
Returns:
TriggerModeInfo structure containing receive trigger information.
bool IsConnected ( ) [virtual]

Checks if the ManagedCamera object is connected to a physical camera specified by a GUID.

See also:
Connect()
Disconnect()
Returns:
Whether Connect() was called on the ManagedCamera object.
void OnNativeCallback | ( | FlyCapture2::Image * | pImage,
 |  | void * | pCallbackData
 | ) |  | [protected]
void OnNativeCameraEventCallback ( void * pCallbackData ) [protected]
unsigned int ReadRegister ( unsigned int address ) [virtual]

Read the specified register from the camera.

Parameters:
address DCAM address to be read from.
See also:
WriteRegister()
Returns:
The register value that is read.
void ReadRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | array< unsigned int >^ | buffer
 | ) |  | [virtual]

Read from the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to read from.
addressLow | Bottom 32 bits of the 48 bits absolute address to read from.
buffer | Array to store read data.
See also:
WriteRegisterBlock()
void RegisterAllEvents ( ManagedEventOptions^ hOpts ) [virtual]
void RegisterEvent ( ManagedEventOptions^ hOpts ) [virtual]
void ResetStats ( ) [virtual]
void RestoreFromMemoryChannel ( unsigned int channel ) [virtual]

Restore the specfied current memory channel.

Parameters:
channel Memory channel to restore from.
See also:
GetMemoryChannel()
SaveToMemoryChannel()
GetMemoryChannelInfo()
void RetrieveBuffer ( ManagedImage^ image ) [virtual]

Retrieves the the next image object containing the next image.

If the grab mode has not been set, or has been set to DROP_FRAMES the default behavior is to requeue images for DMA if they have not been retrieved by the time the next image transfer completes. If BUFFER_FRAMES is specified, the next image in the sequence will be retrieved. Note that for the BUFFER_FRAMES case, if retrieval does not keep up with the DMA process, images will be lost. The default behavior is to perform DROP_FRAMES image retrieval.

Parameters:
image ManagedImage object to store image data.
See also:
StartCapture()
StopCapture()
WaitForBufferEvent()
void SaveToMemoryChannel ( unsigned int channel ) [virtual]

Save the current settings to the specfied current memory channel.

Parameters:
channel Memory channel to save to.
See also:
GetMemoryChannel()
RestoreFromMemoryChannel()
GetMemoryChannelInfo()
void SetActiveLUTBank ( unsigned int activeBank ) [virtual]

Set the LUT bank that will be used.

Parameters:
activeBank The bank to be set as active.
void SetCallback ( ImageEventCallback^ hCallbackDelegate ) [virtual]

Sets the callback data to be used on completion of image transfer.

To clear the current stored callback data, pass in NULL as the argument.

Parameters:
hCallbackDelegate A function to be called when a new image is received.
See also:
StartCapture()
Returns:
An Error indicating the success or failure of the function.
void SetCamera ( System::IntPtr otherCamera )

Set camera from a integer pointer camera.

void SetConfiguration ( FC2Config^ config ) [virtual]

Set the configuration associated with the camera object.

Parameters:
config Configuration structure to be used.
See also:
GetConfiguration()
void SetEmbeddedImageInfo ( EmbeddedImageInfo^ info ) [virtual]

Sets the on/off values of the embedded image information structure to the camera.

Parameters:
info Structure to be used.
See also:
GetEmbeddedImageInfo()
void SetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int | direction
 | ) |  | [virtual]

Set the GPIO pin direction for the specified pin.

This is useful if there is a need to set the pin into an input pin (i.e. to read the voltage) off the pin without setting it as a trigger source. This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
direction | Direction of the pin. 0 for input, 1 for output.
See also:
GetGPIOPinDirection()
void SetGPIOPinDirection | ( | unsigned int | pin,
 |  | unsigned int | direction,
 |  | bool | broadcast
 | ) |  | [virtual]

Set the GPIO pin direction for the specified pin.

This is useful if there is a need to set the pin into an input pin (i.e. to read the voltage) off the pin without setting it as a trigger source. This is not a required call when using the trigger or strobe functions as the pin direction is set automatically internally.

Parameters:
pin | Pin to get the direction for.
direction | Direction of the pin. 0 for input, 1 for output.
broadcast | Whether the action should be broadcast.
See also:
GetGPIOPinDirection()
void SetLUTChannel | ( | unsigned int | bank,
 |  | unsigned int | channel,
 |  | unsigned int | sizeEntries,
 |  | array< unsigned int >^ | entries
 | ) |  | [virtual]

Set the LUT channel settings to the camera.

Parameters:
bank | Bank to set.
channel | Channel to set.
sizeEntries | Number of entries in LUT table to write. This must be the same size as numEntries returned by GetLutInfo().
entries | Array containing LUT entries to write.
See also:
GetLUTInfo()
EnableLUT()
GetLUTChannel()
void SetProperty ( CameraProperty^ camProperty ) [virtual]

Writes the settings for the specified property to the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. The absControl flag controls whether the absolute or integer value is written to the camera.

Parameters:
camProperty CameraProperty structure to be used.
See also:
GetPropertyInfo()
GetProperty()
void SetProperty | ( | CameraProperty^ | camProperty,
 |  | bool | broadcast
 | ) |  | [virtual]

Writes the settings for the specified property to the camera.

The property type must be specified in the Property structure passed into the function in order for the function to succeed. The absControl flag controls whether the absolute or integer value is written to the camera.

Parameters:
camProperty | CameraProperty structure to be used.
broadcast | Whether the action should be broadcast.
See also:
GetPropertyInfo()
GetProperty()
void SetStrobe ( StrobeControl^ strobeControl ) [virtual]

Set current strobe settings to the camera.

The strobe pin must be specified in the structure before being passed in to the function.

Parameters:
strobeControl Structure providing strobe settings.
See also:
GetStrobeInfo()
GetStrobe()
void SetTriggerDelay ( CameraProperty^ triggerDelay ) [virtual]

Set the specified trigger delay settings to the camera.

Parameters:
triggerDelay Structure providing trigger delay settings.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.
void SetTriggerDelay | ( | CameraProperty^ | triggerDelay,
 |  | bool | broadcast
 | ) |  | [virtual]

Set the specified trigger delay settings to the camera.

Parameters:
triggerDelay | Structure providing trigger delay settings.
broadcast | Whether the action should be broadcast.
See also:
GetTriggerModeInfo()
GetTriggerMode()
SetTriggerMode()
GetTriggerDelayInfo()
GetTriggerDelay()
Returns:
An Error indicating the success or failure of the function.
void SetTriggerMode ( TriggerMode^ triggerMode ) [virtual]

Set the specified trigger settings to the camera.

Parameters:
triggerMode Structure providing trigger mode settings.
See also:
GetTriggerModeInfo()
GetTriggerMode()
void SetUserBuffers | ( | IntPtr | pMemBuffers,
 |  | int | size,
 |  | int | numBuffers
 | ) |  | [virtual]

Specify user allocated buffers to use as image data buffers.

To prevent image tearing, the size of each buffer should be equal to ((unsigned int)(bufferSize + packetSize - 1)/packetSize) * packetSize. The total size should be (size * numBuffers) or larger. The packet Size that should be used differs between interfaces: Firewire: Use the Format7 packet size. Usb2: First round to Format7 packet size then round to 512 bytes. Usb3: Use a packet size of 1024 bytes. GigE: No need to do any rounding on GigE

Parameters:
pMemBuffers | Pointer to memory buffers to be written to.
size | The size of each buffer (in bytes).
numBuffers | Number of buffers in the array.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
Returns:
An Error indicating the success or failure of the function.
void StartCapture ( ) [virtual]

Starts isochronous image capture.

It will use either the current video mode or the most recently set video mode of the camera. RetrieveBuffer() can be called to get the image data.

See also:
RetrieveBuffer()
StopCapture()
void StartCapture ( ImageEventCallback^ hCallbackDelegate ) [virtual]

Starts isochronous image capture.

It will use either the current video mode or the most recently set video mode of the camera. The callback function parameter is called on completion of image transfer.

Parameters:
hCallbackDelegate A function to be called when a new image is received.
See also:
RetrieveBuffer()
StopCapture()
void StopCapture ( ) [virtual]

Stops isochronous image transfer and cleans up all associated resources.

If an image callback function (specified in the StartCapture() call) is currently executing, StopCapture() will not return until after the callback has completed.

See also:
StartCapture()
RetrieveBuffer()
void WaitForBufferEvent | ( | ManagedImage^ | image,
 |  | unsigned int | eventNumber
 | ) |  | [virtual]

Retrieves the next image event containing the next part of the image.

Parameters:
image | ManagedImage object to store image data.
eventNumber | The event number to wait for.
See also:
StartCapture()
RetrieveBuffer()
StopCapture()
void WriteRegister | ( | unsigned int | address,
 |  | unsigned int | value
 | ) |  | [virtual]

Write to the specified register on the camera.

Parameters:
address | DCAM address to be written to.
value | The value to be written.
See also:
ReadRegister()
void WriteRegister | ( | unsigned int | address,
 |  | unsigned int | value,
 |  | bool | broadcast
 | ) |  | [virtual]

Write to the specified register on the camera.

Parameters:
address | DCAM address to be written to.
value | The value to be written.
broadcast | Whether the action should be broadcast.
See also:
ReadRegister()
void WriteRegisterBlock | ( | unsigned short | addressHigh,
 |  | unsigned int | addressLow,
 |  | array< unsigned int >^ | buffer
 | ) |  | [virtual]

Write to the specified register block on the camera.

Parameters:
addressHigh | Top 16 bits of the 48 bit absolute address to write to.
addressLow | Bottom 32 bits of the 48 bits absolute address to write to.
buffer | Array containing data to be written.
See also:
ReadRegisterBlock()

Member Data Documentation

Dictionary<ManagedEventOptions^, NativeEventStruct> ^ m_allInternalCameraEvents [protected]
ImageEventCallback ^ m_externalDelegate [protected]
ManagedCameraEventCallbackDelegate ^ m_internalCameraEventDelegate [protected]
ImageCallbackDelegate ^ m_internalDelegate [protected]
bool m_isLocal [protected]
IntPtr m_p [protected]
FlyCapture2::CameraBase* m_pNativeCamBase [protected]
Dictionary<ManagedEventOptions^, NativeEventStruct> ^ m_specificInternalCameraEvents [protected]
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedEventCallbackData Struct Reference

  • FlyCapture2Managed
  • ManagedEventCallbackData
Public Attributes
ManagedEventCallbackData Struct Reference

List of all members.

Public Attributes

System::String^ | EventName
The event name used to register the event.
UInt64 | EventID
The device register which EventName maps to.
UInt64 | EventTimestamp
Timestamp indicated the time (as reported by the camera) at which the camera exposure operation completed.

Member Data Documentation

UInt64 EventID

The device register which EventName maps to.

Provides an alternate means of indexing into different event types.

System::String ^ EventName

The event name used to register the event.

Provided so the user knows which event triggered the callback.

UInt64 EventTimestamp

Timestamp indicated the time (as reported by the camera) at which the camera exposure operation completed.

This can be compared with image stimestamps if there is a need to map event timestamps to specific images, if applicable.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedEventOptions Struct Reference

  • FlyCapture2Managed
  • ManagedEventOptions
Public Attributes
ManagedEventOptions Struct Reference

Options for enabling device event registration. More...

List of all members.

Public Attributes

ManagedCameraEventCallback^ | EventCallbackFcn
Callback function pointer.
System::String^ | EventName
Event name to register.

Detailed Description

Options for enabling device event registration.

Member Data Documentation

ManagedCameraEventCallback ^ EventCallbackFcn

Callback function pointer.

System::String ^ EventName

Event name to register.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedGCCamera Class Reference

  • FlyCapture2Managed
  • ManagedGCCamera
Public Member Functions | Protected Member Functions
ManagedGCCamera Class Reference
Inheritance diagram for ManagedGCCamera:
[legend]
Collaboration diagram for ManagedGCCamera:
[legend]

List of all members.

Public Member Functions

ManagedGCCamera (void)
virtual | ~ManagedGCCamera (void)
virtual void | Connect (ManagedPGRGuid^ mgdPGRGuid) override
Connects the ManagedCamera object to the camera specified by the GUID.
virtual void | Connect (ManagedPGRGuid^ mgdPGRGuid, String^ xmlPath) override
virtual void | Disconnect (void) override
Disconnects the ManagedCamera object from the camera.
void | SetCamera (ManagedCameraBase^ cameraBase)
void | SetCamera (ManagedCameraBase^ cameraBase, String^ xmlPath)
GenICam::GenApi::NodeMap^ | GetNodeMap ()

Protected Member Functions

!ManagedGCCamera ()

Constructor & Destructor Documentation

ManagedGCCamera ( void )
~ManagedGCCamera ( void ) [virtual]
!ManagedGCCamera ( ) [protected]

Member Function Documentation

void Connect ( ManagedPGRGuid^ mgdPGRGuid ) [override, virtual]

Connects the ManagedCamera object to the camera specified by the GUID.

Parameters:
mgdPGRGuid The unique identifier for a specific camera on the PC.
See also:
ManagedBusManager::GetCameraFromIndex()
ManagedBusManager::GetCameraFromSerialNumber()

Reimplemented from ManagedCameraBase.

void Connect | ( | ManagedPGRGuid^ | mgdPGRGuid,
 |  | String^ | xmlPath
 | ) |  | [override, virtual]
void Disconnect ( void ) [override, virtual]

Disconnects the ManagedCamera object from the camera.

This allows another physical camera specified by a GUID to be connected to the ManagedCamera object.

See also:
Connect()

Reimplemented from ManagedCameraBase.

GenICam::GenApi::NodeMap GetNodeMap ( )
void SetCamera ( ManagedCameraBase^ cameraBase )
void SetCamera | ( | ManagedCameraBase^ | cameraBase,
 |  | String^ | xmlPath
 | ) |  |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedGCPort Class Reference

  • FlyCapture2Managed
  • ManagedGCPort
Public Member Functions
ManagedGCPort Class Reference

List of all members.

Public Member Functions

ManagedGCPort (GCCamera *camera)
virtual | ~ManagedGCPort (void)
virtual void | Read (IntPtr buffer, __int64 address, __int64 length) override
virtual void | Write (IntPtr buffer, __int64 address, __int64 length) override

Constructor & Destructor Documentation

ManagedGCPort ( GCCamera * camera )
~ManagedGCPort ( void ) [virtual]

Member Function Documentation

void Read | ( | IntPtr | buffer,
 |  | __int64 | address,
 |  | __int64 | length
 | ) |  | [override, virtual]
void Write | ( | IntPtr | buffer,
 |  | __int64 | address,
 |  | __int64 | length
 | ) |  | [override, virtual]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedGigECamera Class Reference

  • FlyCapture2Managed
  • ManagedGigECamera
Public Member Functions | Protected Member Functions
ManagedGigECamera Class Reference

The GigECamera object represents a physical Gigabit Ethernet camera. More...

Inheritance diagram for ManagedGigECamera:
[legend]
Collaboration diagram for ManagedGigECamera:
[legend]

List of all members.

Public Member Functions

ManagedGigECamera ()
~ManagedGigECamera ()
virtual void | Connect (ManagedPGRGuid^ mgdPGRGuid) override
Connects the ManagedCamera object to the camera specified by the GUID.

Protected Member Functions

!ManagedGigECamera ()

GVCP Register Operation

These functions deal with GVCP register operation on the camera.

void | WriteGVCPRegister (unsigned int address, unsigned int value)
Write a GVCP register.
void | WriteGVCPRegister (unsigned int address, unsigned int value, bool broadcast)
Write a GVCP register.
unsigned int | ReadGVCPRegister (unsigned int address)
Read a GVCP register.
void | WriteGVCPRegisterBlock (unsigned int address, array< unsigned int >^buffer)
Write a GVCP register block.
void | ReadGVCPRegisterBlock (unsigned int address, array< unsigned int >^buffer)
Read a GVCP register block.
void | WriteGVCPMemory (unsigned int address, array< unsigned char >^buffer)
Write a GVCP memory block.
void | ReadGVCPMemory (unsigned int address, array< unsigned char >^buffer)
Read a GVCP memory block.

GigE property manipulation

These functions deal with GigE properties.

GigEProperty^ | GetGigEProperty (GigEPropertyType propType)
Get the specified GigEProperty.
void | SetGigEProperty (GigEProperty^ prop)
Set the specified GigEProperty.
unsigned int | DiscoverGigEPacketSize ()
Discover the largest packet size that works for the network link between the PC and the camera.

GigE image settings

These functions deal with GigE image setting.

bool | QueryGigEImagingMode (Mode mode)
Check if the particular imaging mode is supported by the camera.
Mode GetGigEImagingMode ()
Get the current imaging mode on the camera.
void | SetGigEImagingMode (Mode mode)
Set the current imaging mode to the camera.
GigEImageSettingsInfo^ GetGigEImageSettingsInfo ()
Get information about the image settings possible on the camera.
GigEImageSettings^ GetGigEImageSettings ()
Get the current image settings on the camera.
void | SetGigEImageSettings (GigEImageSettings^ settings)
Set the image settings specified to the camera.

GigE image binning settings

These functions deal with GigE image binning setting.

void | GetGigEImageBinningSettings (unsigned int% horzBinningValue, unsigned int% vertBinningValue)
Get the current binning settings on the camera.
void | SetGigEImageBinningSettings (unsigned int horzBinnningValue, unsigned int vertBinnningValue)
Set the specified binning values to the camera.

GigE image stream configuration

These functions deal with GigE image stream configuration.

unsigned int | GetNumStreamChannels ()
Get the number of stream channels present on the camera.
GigEStreamChannel^ | GetGigEStreamChannelInfo (unsigned int channel)
Get the stream channel information for the specified channel.
void | SetGigEStreamChannelInfo (unsigned int channel, GigEStreamChannel^ channelInfo)
Set the stream channel information for the specified channel.

GigE Configuration

These functions deal with configuring camera.

GigEConfig^ GetGigEConfig ()
Get the current configuration on the camera.
void | SetGigEConfig (GigEConfig^ config)
Set the configuration specified to the camera.

Detailed Description

The GigECamera object represents a physical Gigabit Ethernet camera.

The object must first be connected to using Connect() before any other operations can proceed.

Please see ManagedCameraBase for basic functions that this class inherits from.

Constructor & Destructor Documentation

ManagedGigECamera ( )
~ManagedGigECamera ( )
!ManagedGigECamera ( ) [protected]

Member Function Documentation

void Connect ( ManagedPGRGuid^ mgdPGRGuid ) [override, virtual]

Connects the ManagedCamera object to the camera specified by the GUID.

Parameters:
mgdPGRGuid The unique identifier for a specific camera on the PC.
See also:
ManagedBusManager::GetCameraFromIndex()
ManagedBusManager::GetCameraFromSerialNumber()

Reimplemented from ManagedCameraBase.

unsigned int DiscoverGigEPacketSize ( )

Discover the largest packet size that works for the network link between the PC and the camera.

This is useful in cases where there may be multiple links between the PC and the camera and there is a possiblity of a component not supporting the recommended jumbo frame packet size of 9000.

Returns:
The maximum packet size supported by the link.
GigEConfig GetGigEConfig ( )

Get the current configuration on the camera.

Returns:
Current configuration on camera.
void GetGigEImageBinningSettings | ( | unsigned int% | horzBinningValue,
 |  | unsigned int% | vertBinningValue
 | ) |  |

Get the current binning settings on the camera.

Parameters:
horzBinningValue | Current horizontal binning value.
vertBinningValue | Current vertical binning value.
GigEImageSettings GetGigEImageSettings ( )

Get the current image settings on the camera.

Returns:
Current image settings on camera.
GigEImageSettingsInfo GetGigEImageSettingsInfo ( )

Get information about the image settings possible on the camera.

Returns:
Image settings information.
Mode GetGigEImagingMode ( )

Get the current imaging mode on the camera.

Returns:
Current imaging mode on the camera.
GigEProperty GetGigEProperty ( GigEPropertyType propType )

Get the specified GigEProperty.

Returns:
The GigE property to get.
GigEStreamChannel GetGigEStreamChannelInfo ( unsigned int channel )

Get the stream channel information for the specified channel.

Parameters:
channel Channel number to use.
Returns:
Stream channel information for the specified channel.
unsigned int GetNumStreamChannels ( )

Get the number of stream channels present on the camera.

Returns:
Number of stream channels present.
bool QueryGigEImagingMode ( Mode mode )

Check if the particular imaging mode is supported by the camera.

Parameters:
mode The mode to check.
Returns:
Whether the mode is supported.
void ReadGVCPMemory | ( | unsigned int | address,
 |  | array< unsigned char >^ | buffer
 | ) |  |

Read a GVCP memory block.

Parameters:
address | GVCP address to be read from.
buffer | Array for data to be read into.
unsigned int ReadGVCPRegister ( unsigned int address )

Read a GVCP register.

Parameters:
address GVCP address to be read from.
Returns:
The value that is read.
void ReadGVCPRegisterBlock | ( | unsigned int | address,
 |  | array< unsigned int >^ | buffer
 | ) |  |

Read a GVCP register block.

Parameters:
address | GVCP address to be read from.
buffer | Array for data to be read into.
void SetGigEConfig ( GigEConfig^ config )

Set the configuration specified to the camera.

Parameters:
config Configuration to set to camera.
void SetGigEImageBinningSettings | ( | unsigned int | horzBinnningValue,
 |  | unsigned int | vertBinnningValue
 | ) |  |

Set the specified binning values to the camera.

It is recommended that GetGigEImageSettingsInfo() be called after this function succeeds to retrieve the new image settings information for the new binning mode.

Parameters:
horzBinnningValue | Horizontal binning value.
vertBinnningValue | Vertical binning value.
void SetGigEImageSettings ( GigEImageSettings^ settings )

Set the image settings specified to the camera.

Parameters:
settings Image settings to set to camera.
void SetGigEImagingMode ( Mode mode )

Set the current imaging mode to the camera.

This should only be done when the camera is not streaming images.

Parameters:
mode Imaging mode to set to the camera.
void SetGigEProperty ( GigEProperty^ prop )

Set the specified GigEProperty.

The GigEPropertyType field must be set in order for this function to succeed.

Parameters:
prop The GigE property to set.
void SetGigEStreamChannelInfo | ( | unsigned int | channel,
 |  | GigEStreamChannel^ | channelInfo
 | ) |  |

Set the stream channel information for the specified channel.

Parameters:
channel | Channel number to use.
channelInfo | Stream channel information to use for the specified channel.
void WriteGVCPMemory | ( | unsigned int | address,
 |  | array< unsigned char >^ | buffer
 | ) |  |

Write a GVCP memory block.

Parameters:
address | GVCP address to be write to.
buffer | Array containing data to be written.
void WriteGVCPRegister | ( | unsigned int | address,
 |  | unsigned int | value
 | ) |  |

Write a GVCP register.

Parameters:
address | GVCP address to be written to.
value | The value to be written.
void WriteGVCPRegister | ( | unsigned int | address,
 |  | unsigned int | value,
 |  | bool | broadcast
 | ) |  |

Write a GVCP register.

Parameters:
address | GVCP address to be written to.
value | The value to be written.
broadcast | Whether the action should be broadcast.
void WriteGVCPRegisterBlock | ( | unsigned int | address,
 |  | array< unsigned int >^ | buffer
 | ) |  |

Write a GVCP register block.

Parameters:
address | GVCP address to be write to.
buffer | Array containing data to be written.
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedImage Class Reference

  • FlyCapture2Managed
  • ManagedImage
Public Member Functions | Static Public Member Functions | Protected Member Functions | Package Functions | Properties
ManagedImage Class Reference

The ManagedImageImage class is used to retrieve images from a camera, convert between multiple pixel formats and save images to disk. More...

List of all members.

Public Member Functions

ManagedImage ()
ManagedImage (unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, PixelFormat format)
ManagedImage (unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, unsigned int receivedActualSize, PixelFormat format)
ManagedImage (unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, PixelFormat format, BayerTileFormat bayerFormat)
ManagedImage (unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, unsigned int receivedActualSize, PixelFormat format, BayerTileFormat bayerFormat)
ManagedImage (unsigned char *pData, unsigned int dataSize)
ManagedImage (unsigned int rows, unsigned int cols, PixelFormat format)
ManagedImage (unsigned int rows, unsigned int cols, PixelFormat format, BayerTileFormat bayerFormat)
ManagedImage (ManagedImage^ image)
~ManagedImage ()
void | SetDimensions (unsigned int rows, unsigned int cols, unsigned int stride, PixelFormat pixelFormat, BayerTileFormat bayerFormat)
Sets the dimensions of the ManagedImage object.
void | GetDimensions (unsigned int *pRows, unsigned int *pCols, unsigned int *pStride, PixelFormat^ pPixelFormat, BayerTileFormat^ pBayerFormat)
Get the image dimensions associated with the ManagedImage object.
void | SetData (unsigned char *pData, unsigned int dataSize)
Set the data of the ManagedImage object.
void | CalculateStatistics (ManagedImageStatistics^ statistics)
Calculate statistics associated with the image.
void | Save (System::String^ fileName)
Save the image to the specified file name.
void | Save (System::String^ fileName, ImageFileFormat format)
Save the image to the specified file name with the file format specified.
void | Save (System::String^ fileName, PngOption^ option)
Save the image to the specified file name with the options specified.
void | Save (System::String^ fileName, PpmOption^ option)
Save the image to the specified file name with the options specified.
void | Save (System::String^ fileName, PgmOption^ option)
Save the image to the specified file name with the options specified.
void | Save (System::String^ fileName, TiffOption^ option)
Save the image to the specified file name with the options specified.
void | Save (System::String^ fileName, JpegOption^ option)
Save the image to the specified file name with the options specified.
void | Save (System::String^ fileName, Jpg2Option^ option)
Save the image to the specified file name with the options specified.
void | Save (System::String^ fileName, BMPOption^ option)
Save the image to the specified file name with the options specified.
void | Convert (ManagedImage^ destImage)
Converts the current image buffer and stores the result in the specified image.
void | Convert (PixelFormat format, ManagedImage^ destImage)
Converts the current image buffer to the specified output format and stores the result in the specified image.
void | ReleaseBuffer ()
Release the buffer associated with the ManagedImage.
void * | GetRawNativeImagePointer ()

Static Public Member Functions

static unsigned int | DetermineBitsPerPixel (PixelFormat format)
Calculate the bits per pixel for the specified pixel format.

Protected Member Functions

!ManagedImage ()

Package Functions

ManagedImage (FlyCapture2::Image &image)
bool | IsNativeImageValid ()
FlyCapture2::Image * | GetNativeImage ()

Properties

static ColorProcessingAlgorithm | defaultColorProcessingAlgorithm [get, set]
The default color processing algorithm to be used.
static PixelFormat | defaultOutputPixelFormat [get, set]
The default output pixel format to be used.
ColorProcessingAlgorithm | colorProcessingAlgorithm [get, set]
Color processing algorithm to be used.
PixelFormat | pixelFormat [get]
Pixel format of the image.
BayerTileFormat | bayerTileFormat [get]
Bayer tile format of the image.
unsigned int | blockId [get, set]
Block id of the image.
unsigned int | cols [get]
Number of columns in the image.
unsigned int | rows [get]
Number of rows in the image.
unsigned int | stride [get]
Number of bytes between rows in the image.
unsigned int | bitsPerPixel [get]
Number of bits per pixel in the image.
unsigned char * | data [get]
Raw pointer to image data.
unsigned int | dataSize [get]
Size of the buffer associated with the image, in bytes.
unsigned int | receivedDataSize [get]
Get the size of the compressed data, in bytes.
ImageMetadata^ | imageMetadata [get]
Get the metadata associated with the image.
TimeStamp^ | timeStamp [get]
Get the timestamp data associated with the image.
System::Drawing::Bitmap^ | bitmap [get]
Get the internal bitmap representation associated with the image.

Detailed Description

The ManagedImageImage class is used to retrieve images from a camera, convert between multiple pixel formats and save images to disk.

Operations on Image objects are not guaranteed to be thread safe. It is recommended that operations on Image objects be protected by thread synchronization constructs such as mutexes.

Constructor & Destructor Documentation

ManagedImage ( )
ManagedImage | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | unsigned int | stride,
 |  | unsigned char * | pData,
 |  | unsigned int | dataSize,
 |  | PixelFormat | format
 | ) |  |
ManagedImage | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | unsigned int | stride,
 |  | unsigned char * | pData,
 |  | unsigned int | dataSize,
 |  | unsigned int | receivedActualSize,
 |  | PixelFormat | format
 | ) |  |
ManagedImage | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | unsigned int | stride,
 |  | unsigned char * | pData,
 |  | unsigned int | dataSize,
 |  | PixelFormat | format,
 |  | BayerTileFormat | bayerFormat
 | ) |  |
ManagedImage | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | unsigned int | stride,
 |  | unsigned char * | pData,
 |  | unsigned int | dataSize,
 |  | unsigned int | receivedActualSize,
 |  | PixelFormat | format,
 |  | BayerTileFormat | bayerFormat
 | ) |  |
ManagedImage | ( | unsigned char * | pData,
 |  | unsigned int | dataSize
 | ) |  |
ManagedImage | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | PixelFormat | format
 | ) |  |
ManagedImage | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | PixelFormat | format,
 |  | BayerTileFormat | bayerFormat
 | ) |  |
ManagedImage ( ManagedImage^ image )
~ManagedImage ( )
ManagedImage ( FlyCapture2::Image & image ) [package]
!ManagedImage ( ) [protected]

Member Function Documentation

void CalculateStatistics ( ManagedImageStatistics^ statistics )

Calculate statistics associated with the image.

In order to collect statistics for a particular channel, the enabled flag for the channel must be set to true. Statistics can only be collected for images in Mono8, Mono16, RGB, RGBU, BGR and BGRU.

Parameters:
statistics The ManagedImageStatistics object to hold the statistics.
void Convert ( ManagedImage^ destImage )

Converts the current image buffer and stores the result in the specified image.

The destination image does not need to be configured in any way before the call is made.

Parameters:
destImage Destination image.
void Convert | ( | PixelFormat | format,
 |  | ManagedImage^ | destImage
 | ) |  |

Converts the current image buffer to the specified output format and stores the result in the specified image.

The destination image does not need to be configured in any way before the call is made.

Parameters:
format | Output format of the converted image.
destImage | Destination image.
unsigned int DetermineBitsPerPixel ( PixelFormat format ) [static]

Calculate the bits per pixel for the specified pixel format.

Parameters:
format The pixel format.
Returns:
The bits per pixel.
void GetDimensions | ( | unsigned int * | pRows,
 |  | unsigned int * | pCols,
 |  | unsigned int * | pStride,
 |  | PixelFormat^ | pPixelFormat,
 |  | BayerTileFormat^ | pBayerFormat
 | ) |  |

Get the image dimensions associated with the ManagedImage object.

Parameters:
pRows | Number of rows.
pCols | Number of columns.
pStride | The stride.
pPixelFormat | Pixel format.
pBayerFormat | Bayer tile format.
FlyCapture2::Image * GetNativeImage ( ) [package]
void * GetRawNativeImagePointer ( )
bool IsNativeImageValid ( ) [package]
void ReleaseBuffer ( )

Release the buffer associated with the ManagedImage.

If no buffer is associated, the function does nothing.

void Save ( System::String^ fileName )

Save the image to the specified file name.

Parameters:
fileName Filename to save image with.
void Save | ( | System::String^ | fileName,
 |  | ImageFileFormat | format
 | ) |  |

Save the image to the specified file name with the file format specified.

Parameters:
fileName | Filename to save image with.
format | File format to save in.
void Save | ( | System::String^ | fileName,
 |  | PngOption^ | option
 | ) |  |

Save the image to the specified file name with the options specified.

Parameters:
fileName | Filename to save image with.
option | Options to use while saving image.
void Save | ( | System::String^ | fileName,
 |  | PpmOption^ | option
 | ) |  |

Save the image to the specified file name with the options specified.

Parameters:
fileName | Filename to save image with.
option | Options to use while saving image.
void Save | ( | System::String^ | fileName,
 |  | PgmOption^ | option
 | ) |  |

Save the image to the specified file name with the options specified.

Parameters:
fileName | Filename to save image with.
option | Options to use while saving image.
void Save | ( | System::String^ | fileName,
 |  | TiffOption^ | option
 | ) |  |

Save the image to the specified file name with the options specified.

Parameters:
fileName | Filename to save image with.
option | Options to use while saving image.
void Save | ( | System::String^ | fileName,
 |  | JpegOption^ | option
 | ) |  |

Save the image to the specified file name with the options specified.

Parameters:
fileName | Filename to save image with.
option | Options to use while saving image.
void Save | ( | System::String^ | fileName,
 |  | Jpg2Option^ | option
 | ) |  |

Save the image to the specified file name with the options specified.

Parameters:
fileName | Filename to save image with.
option | Options to use while saving image.
void Save | ( | System::String^ | fileName,
 |  | BMPOption^ | option
 | ) |  |

Save the image to the specified file name with the options specified.

Parameters:
pFilename | Filename to save image with.
pOption | Options to use while saving image.
void SetData | ( | unsigned char * | pData,
 |  | unsigned int | dataSize
 | ) |  |

Set the data of the ManagedImage object.

Ownership of the image buffer is not transferred to the ManagedImage object. It is the user's responsibility to delete the buffer when it is no longer in use.

Parameters:
pData | Pointer to the image buffer.
dataSize | Size of the image buffer.
void SetDimensions | ( | unsigned int | rows,
 |  | unsigned int | cols,
 |  | unsigned int | stride,
 |  | PixelFormat | pixelFormat,
 |  | BayerTileFormat | bayerFormat
 | ) |  |

Sets the dimensions of the ManagedImage object.

Parameters:
rows | Number of rows to set.
cols | Number of cols to set.
stride | Stride to set.
pixelFormat | Pixel format to set.
bayerFormat | Bayer tile format to set.

Property Documentation

BayerTileFormat bayerTileFormat [get]

Bayer tile format of the image.

System:: Drawing:: Bitmap^ bitmap [get]

Get the internal bitmap representation associated with the image.

Returns:
A System::Drawing::Bitmap containing the image data.
unsigned int bitsPerPixel [get]

Number of bits per pixel in the image.

unsigned int blockId [get, set]

Block id of the image.

ColorProcessingAlgorithm colorProcessingAlgorithm [get, set]

Color processing algorithm to be used.

unsigned int cols [get]

Number of columns in the image.

unsigned char* data [get]

Raw pointer to image data.

unsigned int dataSize [get]

Size of the buffer associated with the image, in bytes.

ColorProcessingAlgorithm defaultColorProcessingAlgorithm [static, get, set]

The default color processing algorithm to be used.

PixelFormat defaultOutputPixelFormat [static, get, set]

The default output pixel format to be used.

ImageMetadata^ imageMetadata [get]

Get the metadata associated with the image.

This includes embedded image information.

Returns:
Metadata associated with the image.
PixelFormat pixelFormat [get]

Pixel format of the image.

unsigned int receivedDataSize [get]

Get the size of the compressed data, in bytes.

A compressed image will have a maximum size equal to GetDataSize(), but may actually contain less data, depending on the compression level. For uncompressed images, a value smaller than the data size may indicate lost data.

unsigned int rows [get]

Number of rows in the image.

unsigned int stride [get]

Number of bytes between rows in the image.

TimeStamp^ timeStamp [get]

Get the timestamp data associated with the image.

Returns:
Timestamp data associated with the image.
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedImageStatistics Class Reference

  • FlyCapture2Managed
  • ManagedImageStatistics
Public Member Functions | Package Functions
ManagedImageStatistics Class Reference

List of all members.

Public Member Functions

ManagedImageStatistics ()
~ManagedImageStatistics ()
void | EnableAll ()
void | DisableAll ()
void | EnableGreyOnly ()
void | EnableRGBOnly ()
void | EnableHSLOnly ()
bool | GetChannelStatus (StatisticsChannel channel)
void | SetChannelStatus (StatisticsChannel channel, bool enabled)
void | GetRange (StatisticsChannel channel, unsigned int% min, unsigned int% max)
void | GetPixelValueRange (StatisticsChannel channel, unsigned int% pixelValueMin, unsigned int% pixelValueMax)
void | GetNumPixelValues (StatisticsChannel channel, unsigned int% numPixelValues)
void | GetMean (StatisticsChannel channel, float% mean)
void | GetHistogram (StatisticsChannel channel, array< int >^histogram)
void | GetStatistics (StatisticsChannel channel, unsigned int% rangeMin, unsigned int% rangeMax, unsigned int% pixelValueMin, unsigned int% pixelValueMax, unsigned int% numPixelValues, float% mean, array< int >^histogram)

Package Functions

FlyCapture2::ImageStatistics * | GetNativeImageStatistics ()

Constructor & Destructor Documentation

ManagedImageStatistics ( )
~ManagedImageStatistics ( )

Member Function Documentation

void DisableAll ( )
void EnableAll ( )
void EnableGreyOnly ( )
void EnableHSLOnly ( )
void EnableRGBOnly ( )
bool GetChannelStatus ( StatisticsChannel channel )
void GetHistogram | ( | StatisticsChannel | channel,
 |  | array< int >^ | histogram
 | ) |  |
void GetMean | ( | StatisticsChannel | channel,
 |  | float% | mean
 | ) |  |
FlyCapture2::ImageStatistics * GetNativeImageStatistics ( ) [package]
void GetNumPixelValues | ( | StatisticsChannel | channel,
 |  | unsigned int% | numPixelValues
 | ) |  |
void GetPixelValueRange | ( | StatisticsChannel | channel,
 |  | unsigned int% | pixelValueMin,
 |  | unsigned int% | pixelValueMax
 | ) |  |
void GetRange | ( | StatisticsChannel | channel,
 |  | unsigned int% | min,
 |  | unsigned int% | max
 | ) |  |
void GetStatistics | ( | StatisticsChannel | channel,
 |  | unsigned int% | rangeMin,
 |  | unsigned int% | rangeMax,
 |  | unsigned int% | pixelValueMin,
 |  | unsigned int% | pixelValueMax,
 |  | unsigned int% | numPixelValues,
 |  | float% | mean,
 |  | array< int >^ | histogram
 | ) |  |
void SetChannelStatus | ( | StatisticsChannel | channel,
 |  | bool | enabled
 | ) |  |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedPGRGuid Class Reference

  • FlyCapture2Managed
  • ManagedPGRGuid
Public Member Functions | Static Public Member Functions | Public Attributes
ManagedPGRGuid Class Reference

Managed version of a PGRGuid. More...

List of all members.

Public Member Functions

ManagedPGRGuid ()
Constructor.
ManagedPGRGuid (ManagedPGRGuid^ managedGuid)
Copy constructor.
ManagedPGRGuid (ManagedPGRGuid% managedGuid)
Copy constructor.
ManagedPGRGuid% | operator= (ManagedPGRGuid% managedGuid)
Assignment operator.
virtual bool | Equals (Object^ obj) override
virtual int | GetHashCode () override

Static Public Member Functions

static bool | operator== (ManagedPGRGuid% left, ManagedPGRGuid% right)
Equality operator.
static bool | operator!= (ManagedPGRGuid% left, ManagedPGRGuid% right)
Inequality operator.

Public Attributes

unsigned int | value0
unsigned int | value1
unsigned int | value2
unsigned int | value3

Detailed Description

Managed version of a PGRGuid.

It is used to uniquely identify a camera.

Constructor & Destructor Documentation

ManagedPGRGuid ( ) [inline]

Constructor.

ManagedPGRGuid ( ManagedPGRGuid^ managedGuid ) [inline]

Copy constructor.

ManagedPGRGuid ( ManagedPGRGuid% managedGuid ) [inline]

Copy constructor.

Member Function Documentation

virtual bool Equals ( Object^ obj ) [inline, override, virtual]
virtual int GetHashCode ( ) [inline, override, virtual]
static bool operator!= | ( | ManagedPGRGuid% | left,
 |  | ManagedPGRGuid% | right
 | ) |  | [inline, static]

Inequality operator.

ManagedPGRGuid % operator= ( ManagedPGRGuid% managedGuid ) [inline]

Assignment operator.

static bool operator== | ( | ManagedPGRGuid% | left,
 |  | ManagedPGRGuid% | right
 | ) |  | [inline, static]

Equality operator.

Member Data Documentation

unsigned int value0
unsigned int value1
unsigned int value2
unsigned int value3
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedTopologyNode Class Reference

  • FlyCapture2Managed
  • ManagedTopologyNode
Public Types | Public Member Functions | Package Functions | Static Package Functions
ManagedTopologyNode Class Reference

The ManagedTopologyNode class contains topology information that can be used to generate a tree structure of all cameras and devices connected to a computer. More...

List of all members.

Public Types

enum PortType {
NotConnected = 1,
ConnectedToParent,
ConnectedToChild
}
Possible states of a port on a node. More...
enum NodeType {
Computer,
Bus,
Camera,
Node
}
Type of node. More...

Public Member Functions

virtual | ~ManagedTopologyNode ()
ManagedTopologyNode (ManagedTopologyNode^ other)
ManagedTopologyNode (ManagedTopologyNode% other)
ManagedPGRGuid^ GetGuid ()
Get the PGRGuid associated with the node.
int | GetDeviceId ()
Get the device ID associated with the node.
NodeType GetNodeType ()
Get the node type associated with the node.
InterfaceType GetInterfaceType ()
Get the interface type associated with the node.
unsigned int | GetNumChildren ()
Get the number of child nodes.
ManagedTopologyNode^ | GetChild (unsigned int position)
Get child node located at the specified position.
unsigned int | GetNumPorts ()
Get the number of ports.
PortType | GetPortType (unsigned int position)
Get type of port located at the specified position.

Package Functions

ManagedTopologyNode (FlyCapture2::TopologyNode *pNode)

Static Package Functions

static
ManagedTopologyNode::PortType 		TranslatePortType (FlyCapture2::TopologyNode::PortType portType)
static
FlyCapture2::TopologyNode::PortType 		TranslatePortType (ManagedTopologyNode::PortType portType)
static
ManagedTopologyNode::NodeType 		TranslateNodeType (FlyCapture2::TopologyNode::NodeType portType)
static
FlyCapture2::TopologyNode::NodeType 		TranslateNodeType (ManagedTopologyNode::NodeType portType)

Detailed Description

The ManagedTopologyNode class contains topology information that can be used to generate a tree structure of all cameras and devices connected to a computer.

Member Enumeration Documentation

enum NodeType

Type of node.

Enumerator:
Computer
Bus
Camera
Node
enum PortType

Possible states of a port on a node.

Enumerator:
NotConnected
ConnectedToParent
ConnectedToChild

Constructor & Destructor Documentation

virtual ~ManagedTopologyNode ( ) [inline, virtual]
ManagedTopologyNode ( ManagedTopologyNode^ other )
ManagedTopologyNode ( ManagedTopologyNode% other )
ManagedTopologyNode ( FlyCapture2::TopologyNode * pNode ) [package]

Member Function Documentation

ManagedTopologyNode GetChild ( unsigned int position )

Get child node located at the specified position.

Parameters:
position Position of the node.
Returns:
ManagedTopologyNode at the specified position.
int GetDeviceId ( )

Get the device ID associated with the node.

Returns:
Device ID of the node.
ManagedPGRGuid GetGuid ( )

Get the PGRGuid associated with the node.

Returns:
PGRGuid of the node.
InterfaceType GetInterfaceType ( )

Get the interface type associated with the node.

Returns:
Interface type of the node.
ManagedTopologyNode::NodeType GetNodeType ( )

Get the node type associated with the node.

Returns:
Node type of the node.
unsigned int GetNumChildren ( )

Get the number of child nodes.

Returns:
Number of child nodes.
unsigned int GetNumPorts ( )

Get the number of ports.

Returns:
Number of ports.
ManagedTopologyNode::PortType GetPortType ( unsigned int position )

Get type of port located at the specified position.

Parameters:
position Position of the port.
Returns:
PortType at the specified position.
ManagedTopologyNode::NodeType TranslateNodeType ( FlyCapture2::TopologyNode::NodeType portType ) [static, package]
FlyCapture2::TopologyNode::NodeType TranslateNodeType ( ManagedTopologyNode::NodeType portType ) [static, package]
ManagedTopologyNode::PortType TranslatePortType ( FlyCapture2::TopologyNode::PortType portType ) [static, package]
FlyCapture2::TopologyNode::PortType TranslatePortType ( ManagedTopologyNode::PortType portType ) [static, package]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: ManagedUtilities Class Reference

  • FlyCapture2Managed
  • ManagedUtilities
Static Public Member Functions | Static Package Functions | Static Package Attributes | Properties
ManagedUtilities Class Reference

List of all members.

Static Public Member Functions

static void | CheckDriver (ManagedPGRGuid^ guid)
static System::String^ | GetDriverDeviceName (ManagedPGRGuid^ mgdPGRGuid)
static void | LaunchBrowser (System::String^ address)
static void | LaunchHelp (System::String^ fileName)
static void | LaunchCommand (System::String^ command)
static void | LaunchCommandAsync (System::String^ command, AsyncCommandCallback^ hCallbackDelegate)

Static Package Functions

static void | OnNativeCallback (FlyCapture2::Error retError, void *pUserData)

Static Package Attributes

static AsyncCommandCallback^ | m_externalDelegate
static CommandCallbackDelegate^ | m_internalDelegate

Properties

static SystemInfo^ | systemInfo [get]
static FC2Version^ | libraryVersion [get]

Member Function Documentation

void CheckDriver ( ManagedPGRGuid^ guid ) [static]
System::String GetDriverDeviceName ( ManagedPGRGuid^ mgdPGRGuid ) [static]
void LaunchBrowser ( System::String^ address ) [static]
void LaunchCommand ( System::String^ command ) [static]
void LaunchCommandAsync | ( | System::String^ | command,
 |  | AsyncCommandCallback^ | hCallbackDelegate
 | ) |  | [static]
void LaunchHelp ( System::String^ fileName ) [static]
void OnNativeCallback | ( | FlyCapture2::Error | retError,
 |  | void * | pUserData
 | ) |  | [static, package]

Member Data Documentation

AsyncCommandCallback ^ m_externalDelegate [static, package]
CommandCallbackDelegate ^ m_internalDelegate [static, package]

Property Documentation

FC2Version^ libraryVersion [static, get]
SystemInfo^ systemInfo [static, get]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: MJPGOption Struct Reference

  • FlyCapture2Managed
  • MJPGOption
Public Member Functions | Properties
MJPGOption Struct Reference
Image saving structures.

Options for saving MJPEG files. More...

List of all members.

Public Member Functions

MJPGOption ()

Properties

float | frameRate
Frame rate of the stream.
int | quality
Image quality (1-100)

Detailed Description

Options for saving MJPEG files.

Constructor & Destructor Documentation

MJPGOption ( ) [inline]

Property Documentation

float frameRate

Frame rate of the stream.

int quality

Image quality (1-100)

Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: NativeEventStruct Struct Reference

  • FlyCapture2Managed
  • NativeEventStruct
Public Attributes
NativeEventStruct Struct Reference

List of all members.

Public Attributes

FlyCapture2::EventOptions * ptr

Member Data Documentation

FlyCapture2::EventOptions* ptr
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: PgmOption Struct Reference

  • FlyCapture2Managed
  • PgmOption
Public Member Functions | Properties
PgmOption Struct Reference
Image saving structures.

Options for saving PGM images. More...

List of all members.

Public Member Functions

PgmOption ()

Properties

bool binaryFile
Whether to save the PPM as a binary file.

Detailed Description

Options for saving PGM images.

Constructor & Destructor Documentation

PgmOption ( ) [inline]

Property Documentation

bool binaryFile

Whether to save the PPM as a binary file.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: PngOption Struct Reference

  • FlyCapture2Managed
  • PngOption
Public Member Functions | Properties
PngOption Struct Reference
Structures | Image saving structures.

Options for saving PNG images. More...

List of all members.

Public Member Functions

PngOption ()

Properties

bool | interlaced
Whether to save the PNG as interlaced.
unsigned int | compressionLevel
Compression level (0-9).

Detailed Description

Options for saving PNG images.

Constructor & Destructor Documentation

PngOption ( ) [inline]

Property Documentation

unsigned int compressionLevel

Compression level (0-9).

0 is no compression, 9 is best compression.

bool interlaced

Whether to save the PNG as interlaced.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: PpmOption Struct Reference

  • FlyCapture2Managed
  • PpmOption
Public Member Functions | Properties
PpmOption Struct Reference
Image saving structures.

Options for saving PPM images. More...

List of all members.

Public Member Functions

PpmOption ()

Properties

bool binaryFile
Whether to save the PPM as a binary file.

Detailed Description

Options for saving PPM images.

Constructor & Destructor Documentation

PpmOption ( ) [inline]

Property Documentation

bool binaryFile

Whether to save the PPM as a binary file.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: StrobeControl Struct Reference

  • FlyCapture2Managed
  • StrobeControl
Properties
StrobeControl Struct Reference
Structures

A camera strobe. More...

List of all members.

Properties

unsigned int | source
Source value.
bool | onOff
Flag controlling on/off.
unsigned int | polarity
Signal polarity.
float | delay
Signal delay (in ms).
float | duration
Signal duration (in ms).

Detailed Description

A camera strobe.

Property Documentation

float delay

Signal delay (in ms).

float duration

Signal duration (in ms).

bool onOff

Flag controlling on/off.

unsigned int polarity

Signal polarity.

unsigned int source

Source value.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: StrobeInfo Struct Reference

  • FlyCapture2Managed
  • StrobeInfo
Properties
StrobeInfo Struct Reference
Structures

A camera strobe property. More...

List of all members.

Properties

unsigned int | source
Source value.
bool | present
Presence of strobe.
bool | readOutSupported
Flag indicating if strobe value can be read out.
bool | onOffSupported
Flag indicating if on/off is supported.
bool | polaritySupported
Flag indicating if polarity is supported.
float | minValue
Minimum value.
float | maxValue
Maximum value.

Detailed Description

A camera strobe property.

Property Documentation

float maxValue

Maximum value.

float minValue

Minimum value.

bool onOffSupported

Flag indicating if on/off is supported.

bool polaritySupported

Flag indicating if polarity is supported.

bool present

Presence of strobe.

bool readOutSupported

Flag indicating if strobe value can be read out.

unsigned int source

Source value.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: SystemInfo Struct Reference

  • FlyCapture2Managed
  • SystemInfo
Properties
SystemInfo Struct Reference
Image saving structures.

Description of the system. More...

List of all members.

Properties

OSType osType
Operating system type as described by OSType.
System::String^ | osDescription
Detailed description of the operating system.
ByteOrder byteOrder
Byte order of the system.
unsigned int | systemMemorySize
Amount of memory available on the system.
System::String^ | cpuDescription
Detailed description of the CPU.
unsigned int | numCpuCores
Number of cores on all CPUs on the system.
System::String^ | driverList
List of drivers used.
System::String^ | libraryList
List of libraries used.
System::String^ | gpuDescription
Detailed description of the GPU.
unsigned int | screenWidth
Screen resolution width in pixels.
unsigned int | screenHeight
Screen resolution height in pixels.

Detailed Description

Description of the system.

Property Documentation

ByteOrder byteOrder

Byte order of the system.

System:: String^ cpuDescription

Detailed description of the CPU.

System:: String^ driverList

List of drivers used.

System:: String^ gpuDescription

Detailed description of the GPU.

System:: String^ libraryList

List of libraries used.

unsigned int numCpuCores

Number of cores on all CPUs on the system.

System:: String^ osDescription

Detailed description of the operating system.

OSType osType

Operating system type as described by OSType.

unsigned int screenHeight

Screen resolution height in pixels.

unsigned int screenWidth

Screen resolution width in pixels.

unsigned int systemMemorySize

Amount of memory available on the system.

Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: TiffOption Struct Reference

  • FlyCapture2Managed
  • TiffOption
Public Types | Public Member Functions | Properties
TiffOption Struct Reference
Image saving structures.

Options for saving TIFF images. More...

List of all members.

Public Types

enum CompressionMethod {
None = 1,
PackBits,
Deflate,
AdobeDeflate,
CcittFax3,
CcittFax4,
Lzw,
Jpeg
}

Public Member Functions

TiffOption ()

Properties

CompressionMethod compression
Compression method to use for encoding TIFF images.

Detailed Description

Options for saving TIFF images.

Member Enumeration Documentation

enum CompressionMethod
Enumerator:
None

Save without any compression.

PackBits

Save using PACKBITS compression.

Deflate

Save using DEFLATE compression (ZLIB compression).

AdobeDeflate

Save using ADOBE DEFLATE compression.

CcittFax3

Save using CCITT Group 3 fax encoding.

This is only valid for 1-bit images only. Default to LZW for other bit depths.

CcittFax4

Save using CCITT Group 4 fax encoding.

This is only valid for 1-bit images only. Default to LZW for other bit depths.

Lzw

Save using LZW compression.

Jpeg

Save using JPEG compression.

This is only valid for 8-bit greyscale and 24-bit only. Default to LZW for other bit depths.

Constructor & Destructor Documentation

TiffOption ( ) [inline]

Property Documentation

CompressionMethod compression

Compression method to use for encoding TIFF images.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: TimeStamp Struct Reference

  • FlyCapture2Managed
  • TimeStamp
Properties
TimeStamp Struct Reference
Structures

Timestamp information. More...

List of all members.

Properties

long long | seconds
Seconds.
unsigned int | microSeconds
Microseconds.
unsigned int | cycleSeconds
1394 cycle time seconds.
unsigned int | cycleCount
1394 cycle time count.
unsigned int | cycleOffset
1394 cycle time offset.

Detailed Description

Timestamp information.

Property Documentation

unsigned int cycleCount

1394 cycle time count.

unsigned int cycleOffset

1394 cycle time offset.

unsigned int cycleSeconds

1394 cycle time seconds.

unsigned int microSeconds

Microseconds.

long long seconds

Seconds.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Translate Class Reference

  • FlyCapture2Managed
  • Translate
Static Package Functions
Translate Class Reference

List of all members.

Static Package Functions

static ErrorType | translate (FlyCapture2::ErrorType errorType)
static FlyCapture2::ErrorType | translate (ErrorType errorType)
static GrabMode | translate (FlyCapture2::GrabMode grabMode)
static FlyCapture2::GrabMode | translate (GrabMode grabMode)
static BandwidthAllocation | translate (FlyCapture2::BandwidthAllocation bandwidthAllocation)
static
FlyCapture2::BandwidthAllocation 		translate (BandwidthAllocation bandwidthAllocation)
static InterfaceType | translate (FlyCapture2::InterfaceType interfaceType)
static FlyCapture2::InterfaceType | translate (InterfaceType interfaceType)
static DriverType | translate (FlyCapture2::DriverType driverType)
static FlyCapture2::DriverType | translate (DriverType driverType)
static PropertyType | translate (FlyCapture2::PropertyType propertyType)
static FlyCapture2::PropertyType | translate (PropertyType propertyType)
static FrameRate | translate (FlyCapture2::FrameRate frmRate)
static FlyCapture2::FrameRate | translate (FrameRate frmRate)
static VideoMode | translate (FlyCapture2::VideoMode videoMode)
static FlyCapture2::VideoMode | translate (VideoMode videoMode)
static PixelFormat | translate (FlyCapture2::PixelFormat pixelFormat)
static FlyCapture2::PixelFormat | translate (PixelFormat pixelFormat)
static BayerTileFormat | translate (FlyCapture2::BayerTileFormat bayerFormat)
static FlyCapture2::BayerTileFormat | translate (BayerTileFormat bayerFormat)
static Mode | translate (FlyCapture2::Mode mode)
static FlyCapture2::Mode | translate (Mode mode)
static BusSpeed | translate (FlyCapture2::BusSpeed busSpeed)
static FlyCapture2::BusSpeed | translate (BusSpeed busSpeed)
static PCIeBusSpeed | translate (FlyCapture2::PCIeBusSpeed pcieBusSpeed)
static FlyCapture2::PCIeBusSpeed | translate (PCIeBusSpeed pcieBusSpeed)
static ColorProcessingAlgorithm | translate (FlyCapture2::ColorProcessingAlgorithm algorithm)
static
FlyCapture2::ColorProcessingAlgorithm 		translate (ColorProcessingAlgorithm algorithm)
static ImageFileFormat | translate (FlyCapture2::ImageFileFormat fileFmt)
static FlyCapture2::ImageFileFormat | translate (ImageFileFormat fileFmt)
static
TiffOption::CompressionMethod 		translate (FlyCapture2::TIFFOption::CompressionMethod method)
static
FlyCapture2::TIFFOption::CompressionMethod 		translate (TiffOption::CompressionMethod method)
static StatisticsChannel | translate (FlyCapture2::ImageStatistics::StatisticsChannel channel)
static
FlyCapture2::ImageStatistics::StatisticsChannel 		translate (StatisticsChannel channel)
static OSType | translate (FlyCapture2::OSType osType)
static FlyCapture2::OSType | translate (OSType osType)
static ByteOrder | translate (FlyCapture2::ByteOrder byteOrder)
static FlyCapture2::ByteOrder | translate (ByteOrder byteOrder)
static GigEPropertyType | translate (FlyCapture2::GigEPropertyType propType)
static
FlyCapture2::GigEPropertyType 		translate (GigEPropertyType propType)
static void | ToMgd (FlyCapture2::FC2Config *pNative, FC2Config^ mgd)
static void | ToNative (FC2Config^ mgd, FlyCapture2::FC2Config *pNative)
static void | ToMgd (FlyCapture2::PropertyInfo *pNative, CameraPropertyInfo^ mgd)
static void | ToNative (CameraPropertyInfo^ mgd, FlyCapture2::PropertyInfo *pNative)
static void | ToMgd (FlyCapture2::Property *pNative, CameraProperty^ mgd)
static void | ToNative (CameraProperty^ mgd, FlyCapture2::Property *pNative)
static void | ToMgd (FlyCapture2::TriggerModeInfo *pNative, TriggerModeInfo^ mgd)
static void | ToNative (TriggerModeInfo^ mgd, FlyCapture2::TriggerModeInfo *pNative)
static void | ToMgd (FlyCapture2::TriggerMode *pNative, TriggerMode^ mgd)
static void | ToNative (TriggerMode^ mgd, FlyCapture2::TriggerMode *pNative)
static void | ToMgd (FlyCapture2::StrobeInfo *pNative, StrobeInfo^ mgd)
static void | ToNative (StrobeInfo^ mgd, FlyCapture2::StrobeInfo *pNative)
static void | ToMgd (FlyCapture2::StrobeControl *pNative, StrobeControl^ mgd)
static void | ToNative (StrobeControl^ mgd, FlyCapture2::StrobeControl *pNative)
static void | ToMgd (FlyCapture2::Format7ImageSettings *pNative, Format7ImageSettings^ mgd)
static void | ToNative (Format7ImageSettings^ mgd, FlyCapture2::Format7ImageSettings *pNative)
static void | ToMgd (FlyCapture2::Format7Info *pNative, Format7Info^ mgd)
static void | ToNative (Format7Info^ mgd, FlyCapture2::Format7Info *pNative)
static void | ToMgd (FlyCapture2::Format7PacketInfo *pNative, Format7PacketInfo^ mgd)
static void | ToNative (Format7PacketInfo^ mgd, FlyCapture2::Format7PacketInfo *pNative)
static void | ToMgd (FlyCapture2::TimeStamp *pNative, TimeStamp^ mgd)
static void | ToNative (TimeStamp^ mgd, FlyCapture2::TimeStamp *pNative)
static void | ToMgd (FlyCapture2::ConfigROM *pNative, ConfigROM^ mgd)
static void | ToNative (ConfigROM^ mgd, FlyCapture2::ConfigROM *pNative)
static void | ToMgd (FlyCapture2::CameraInfo *pNative, CameraInfo^ mgd)
static void | ToNative (CameraInfo^ mgd, FlyCapture2::CameraInfo *pNative)
static void | ToMgd (FlyCapture2::ImageMetadata *pNative, ImageMetadata^ mgd)
static void | ToNative (ImageMetadata^ mgd, FlyCapture2::ImageMetadata *pNative)
static void | ToMgd (FlyCapture2::LUTData *pNative, LutData^ mgd)
static void | ToNative (LutData^ mgd, FlyCapture2::LUTData *pNative)
static void | ToMgd (FlyCapture2::EmbeddedImageInfoProperty *pNative, EmbeddedImageInfoProperty^ mgd)
static void | ToNative (EmbeddedImageInfoProperty^ mgd, FlyCapture2::EmbeddedImageInfoProperty *pNative)
static void | ToMgd (FlyCapture2::EmbeddedImageInfo *pNative, EmbeddedImageInfo^ mgd)
static void | ToNative (EmbeddedImageInfo^ mgd, FlyCapture2::EmbeddedImageInfo *pNative)
static void | ToMgd (FlyCapture2::PNGOption *pNative, PngOption^ mgd)
static void | ToNative (PngOption^ mgd, FlyCapture2::PNGOption *pNative)
static void | ToMgd (FlyCapture2::PPMOption *pNative, PpmOption^ mgd)
static void | ToNative (PpmOption^ mgd, FlyCapture2::PPMOption *pNative)
static void | ToMgd (FlyCapture2::PGMOption *pNative, PgmOption^ mgd)
static void | ToNative (PgmOption^ mgd, FlyCapture2::PGMOption *pNative)
static void | ToMgd (FlyCapture2::TIFFOption *pNative, TiffOption^ mgd)
static void | ToNative (TiffOption^ mgd, FlyCapture2::TIFFOption *pNative)
static void | ToMgd (FlyCapture2::JPEGOption *pNative, JpegOption^ mgd)
static void | ToNative (JpegOption^ mgd, FlyCapture2::JPEGOption *pNative)
static void | ToMgd (FlyCapture2::JPG2Option *pNative, Jpg2Option^ mgd)
static void | ToNative (Jpg2Option^ mgd, FlyCapture2::JPG2Option *pNative)
static void | ToMgd (FlyCapture2::BMPOption *pNative, BMPOption^ mgd)
static void | ToNative (BMPOption^ mgd, FlyCapture2::BMPOption *pNative)
static void | ToNative (AviOption^ mgd, FlyCapture2::AVIOption *pNative)
static void | ToNative (MJPGOption^ mgd, FlyCapture2::MJPGOption *pNative)
static void | ToNative (H264Option^ mgd, FlyCapture2::H264Option *pNative)
static void | ToMgd (FlyCapture2::SystemInfo *pNative, SystemInfo^ mgd)
static void | ToMgd (FlyCapture2::FC2Version *pNative, FC2Version^ mgd)
static void | ToMgd (FlyCapture2::IPAddress *pNative, System::Net::IPAddress^ %mgd)
static void | ToNative (System::Net::IPAddress^ mgd, FlyCapture2::IPAddress *pNative)
static void | ToMgd (FlyCapture2::MACAddress *pNative, System::Net::NetworkInformation::PhysicalAddress^ %mgd)
static void | ToNative (System::Net::NetworkInformation::PhysicalAddress^ mgd, FlyCapture2::MACAddress *pNative)
static void | ToMgd (FlyCapture2::GigEProperty *pNative, GigEProperty^ mgd)
static void | ToNative (GigEProperty^ mgd, FlyCapture2::GigEProperty *pNative)
static void | ToMgd (FlyCapture2::GigEImageSettingsInfo *pNative, GigEImageSettingsInfo^ mgd)
static void | ToNative (GigEImageSettingsInfo^ mgd, FlyCapture2::GigEImageSettingsInfo *pNative)
static void | ToMgd (FlyCapture2::GigEImageSettings *pNative, GigEImageSettings^ mgd)
static void | ToNative (GigEImageSettings^ mgd, FlyCapture2::GigEImageSettings *pNative)
static void | Translate::ToMgd (FlyCapture2::GigEConfig *pNative, GigEConfig^ mgd)
static void | Translate::ToNative (GigEConfig^ mgd, FlyCapture2::GigEConfig *pNative)
static void | ToMgd (FlyCapture2::GigEStreamChannel *pNative, GigEStreamChannel^ mgd)
static void | ToNative (GigEStreamChannel^ mgd, FlyCapture2::GigEStreamChannel *pNative)
static void | ToMgd (FlyCapture2::CameraStats *pNative, CameraStats^ mgd)

Member Function Documentation

void ToMgd | ( | FlyCapture2::FC2Config * | pNative,
 |  | FC2Config^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::PropertyInfo * | pNative,
 |  | CameraPropertyInfo^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::Property * | pNative,
 |  | CameraProperty^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::TriggerModeInfo * | pNative,
 |  | TriggerModeInfo^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::TriggerMode * | pNative,
 |  | TriggerMode^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::StrobeInfo * | pNative,
 |  | StrobeInfo^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::StrobeControl * | pNative,
 |  | StrobeControl^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::Format7ImageSettings * | pNative,
 |  | Format7ImageSettings^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::Format7Info * | pNative,
 |  | Format7Info^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::Format7PacketInfo * | pNative,
 |  | Format7PacketInfo^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::TimeStamp * | pNative,
 |  | TimeStamp^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::ConfigROM * | pNative,
 |  | ConfigROM^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::CameraInfo * | pNative,
 |  | CameraInfo^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::ImageMetadata * | pNative,
 |  | ImageMetadata^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::LUTData * | pNative,
 |  | LutData^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::EmbeddedImageInfoProperty * | pNative,
 |  | EmbeddedImageInfoProperty^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::EmbeddedImageInfo * | pNative,
 |  | EmbeddedImageInfo^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::PNGOption * | pNative,
 |  | PngOption^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::PPMOption * | pNative,
 |  | PpmOption^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::PGMOption * | pNative,
 |  | PgmOption^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::TIFFOption * | pNative,
 |  | TiffOption^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::JPEGOption * | pNative,
 |  | JpegOption^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::JPG2Option * | pNative,
 |  | Jpg2Option^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::BMPOption * | pNative,
 |  | BMPOption^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::SystemInfo * | pNative,
 |  | SystemInfo^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::FC2Version * | pNative,
 |  | FC2Version^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::IPAddress * | pNative,
 |  | System::Net::IPAddress^ % | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::MACAddress * | pNative,
 |  | System::Net::NetworkInformation::PhysicalAddress^ % | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::GigEProperty * | pNative,
 |  | GigEProperty^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::GigEImageSettingsInfo * | pNative,
 |  | GigEImageSettingsInfo^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::GigEImageSettings * | pNative,
 |  | GigEImageSettings^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::GigEStreamChannel * | pNative,
 |  | GigEStreamChannel^ | mgd
 | ) |  | [static, package]
void ToMgd | ( | FlyCapture2::CameraStats * | pNative,
 |  | CameraStats^ | mgd
 | ) |  | [static, package]
void ToNative | ( | FC2Config^ | mgd,
 |  | FlyCapture2::FC2Config * | pNative
 | ) |  | [static, package]
void ToNative | ( | CameraPropertyInfo^ | mgd,
 |  | FlyCapture2::PropertyInfo * | pNative
 | ) |  | [static, package]
void ToNative | ( | CameraProperty^ | mgd,
 |  | FlyCapture2::Property * | pNative
 | ) |  | [static, package]
void ToNative | ( | TriggerModeInfo^ | mgd,
 |  | FlyCapture2::TriggerModeInfo * | pNative
 | ) |  | [static, package]
void ToNative | ( | TriggerMode^ | mgd,
 |  | FlyCapture2::TriggerMode * | pNative
 | ) |  | [static, package]
void ToNative | ( | StrobeInfo^ | mgd,
 |  | FlyCapture2::StrobeInfo * | pNative
 | ) |  | [static, package]
void ToNative | ( | StrobeControl^ | mgd,
 |  | FlyCapture2::StrobeControl * | pNative
 | ) |  | [static, package]
void ToNative | ( | Format7ImageSettings^ | mgd,
 |  | FlyCapture2::Format7ImageSettings * | pNative
 | ) |  | [static, package]
void ToNative | ( | Format7Info^ | mgd,
 |  | FlyCapture2::Format7Info * | pNative
 | ) |  | [static, package]
void ToNative | ( | Format7PacketInfo^ | mgd,
 |  | FlyCapture2::Format7PacketInfo * | pNative
 | ) |  | [static, package]
void ToNative | ( | TimeStamp^ | mgd,
 |  | FlyCapture2::TimeStamp * | pNative
 | ) |  | [static, package]
void ToNative | ( | ConfigROM^ | mgd,
 |  | FlyCapture2::ConfigROM * | pNative
 | ) |  | [static, package]
void ToNative | ( | CameraInfo^ | mgd,
 |  | FlyCapture2::CameraInfo * | pNative
 | ) |  | [static, package]
void ToNative | ( | ImageMetadata^ | mgd,
 |  | FlyCapture2::ImageMetadata * | pNative
 | ) |  | [static, package]
void ToNative | ( | LutData^ | mgd,
 |  | FlyCapture2::LUTData * | pNative
 | ) |  | [static, package]
void ToNative | ( | EmbeddedImageInfoProperty^ | mgd,
 |  | FlyCapture2::EmbeddedImageInfoProperty * | pNative
 | ) |  | [static, package]
void ToNative | ( | EmbeddedImageInfo^ | mgd,
 |  | FlyCapture2::EmbeddedImageInfo * | pNative
 | ) |  | [static, package]
void ToNative | ( | PngOption^ | mgd,
 |  | FlyCapture2::PNGOption * | pNative
 | ) |  | [static, package]
void ToNative | ( | PpmOption^ | mgd,
 |  | FlyCapture2::PPMOption * | pNative
 | ) |  | [static, package]
void ToNative | ( | PgmOption^ | mgd,
 |  | FlyCapture2::PGMOption * | pNative
 | ) |  | [static, package]
void ToNative | ( | TiffOption^ | mgd,
 |  | FlyCapture2::TIFFOption * | pNative
 | ) |  | [static, package]
void ToNative | ( | JpegOption^ | mgd,
 |  | FlyCapture2::JPEGOption * | pNative
 | ) |  | [static, package]
void ToNative | ( | Jpg2Option^ | mgd,
 |  | FlyCapture2::JPG2Option * | pNative
 | ) |  | [static, package]
void ToNative | ( | BMPOption^ | mgd,
 |  | FlyCapture2::BMPOption * | pNative
 | ) |  | [static, package]
void ToNative | ( | AviOption^ | mgd,
 |  | FlyCapture2::AVIOption * | pNative
 | ) |  | [static, package]
void ToNative | ( | MJPGOption^ | mgd,
 |  | FlyCapture2::MJPGOption * | pNative
 | ) |  | [static, package]
void ToNative | ( | H264Option^ | mgd,
 |  | FlyCapture2::H264Option * | pNative
 | ) |  | [static, package]
void ToNative | ( | System::Net::IPAddress^ | mgd,
 |  | FlyCapture2::IPAddress * | pNative
 | ) |  | [static, package]
void ToNative | ( | System::Net::NetworkInformation::PhysicalAddress^ | mgd,
 |  | FlyCapture2::MACAddress * | pNative
 | ) |  | [static, package]
void ToNative | ( | GigEProperty^ | mgd,
 |  | FlyCapture2::GigEProperty * | pNative
 | ) |  | [static, package]
void ToNative | ( | GigEImageSettingsInfo^ | mgd,
 |  | FlyCapture2::GigEImageSettingsInfo * | pNative
 | ) |  | [static, package]
void ToNative | ( | GigEImageSettings^ | mgd,
 |  | FlyCapture2::GigEImageSettings * | pNative
 | ) |  | [static, package]
void ToNative | ( | GigEStreamChannel^ | mgd,
 |  | FlyCapture2::GigEStreamChannel * | pNative
 | ) |  | [static, package]
ErrorType translate ( FlyCapture2::ErrorType errorType ) [static, package]
FlyCapture2::ErrorType translate ( ErrorType errorType ) [static, package]
GrabMode translate ( FlyCapture2::GrabMode grabMode ) [static, package]
FlyCapture2::GrabMode translate ( GrabMode grabMode ) [static, package]
BandwidthAllocation translate ( FlyCapture2::BandwidthAllocation bandwidthAllocation ) [static, package]
FlyCapture2::BandwidthAllocation translate ( BandwidthAllocation bandwidthAllocation ) [static, package]
InterfaceType translate ( FlyCapture2::InterfaceType interfaceType ) [static, package]
FlyCapture2::InterfaceType translate ( InterfaceType interfaceType ) [static, package]
DriverType translate ( FlyCapture2::DriverType driverType ) [static, package]
FlyCapture2::DriverType translate ( DriverType driverType ) [static, package]
PropertyType translate ( FlyCapture2::PropertyType propertyType ) [static, package]
FlyCapture2::PropertyType translate ( PropertyType propertyType ) [static, package]
FrameRate translate ( FlyCapture2::FrameRate frmRate ) [static, package]
FlyCapture2::FrameRate translate ( FrameRate frmRate ) [static, package]
VideoMode translate ( FlyCapture2::VideoMode videoMode ) [static, package]
FlyCapture2::VideoMode translate ( VideoMode videoMode ) [static, package]
PixelFormat translate ( FlyCapture2::PixelFormat pixelFormat ) [static, package]
FlyCapture2::PixelFormat translate ( PixelFormat pixelFormat ) [static, package]
BayerTileFormat translate ( FlyCapture2::BayerTileFormat bayerFormat ) [static, package]
FlyCapture2::BayerTileFormat translate ( BayerTileFormat bayerFormat ) [static, package]
Mode translate ( FlyCapture2::Mode mode ) [static, package]
FlyCapture2::Mode translate ( Mode mode ) [static, package]
BusSpeed translate ( FlyCapture2::BusSpeed busSpeed ) [static, package]
FlyCapture2::BusSpeed translate ( BusSpeed busSpeed ) [static, package]
PCIeBusSpeed translate ( FlyCapture2::PCIeBusSpeed pcieBusSpeed ) [static, package]
FlyCapture2::PCIeBusSpeed translate ( PCIeBusSpeed pcieBusSpeed ) [static, package]
ColorProcessingAlgorithm translate ( FlyCapture2::ColorProcessingAlgorithm algorithm ) [static, package]
FlyCapture2::ColorProcessingAlgorithm translate ( ColorProcessingAlgorithm algorithm ) [static, package]
ImageFileFormat translate ( FlyCapture2::ImageFileFormat fileFmt ) [static, package]
FlyCapture2::ImageFileFormat translate ( ImageFileFormat fileFmt ) [static, package]
TiffOption::CompressionMethod translate ( FlyCapture2::TIFFOption::CompressionMethod method ) [static, package]
FlyCapture2::TIFFOption::CompressionMethod translate ( TiffOption::CompressionMethod method ) [static, package]
StatisticsChannel translate ( FlyCapture2::ImageStatistics::StatisticsChannel channel ) [static, package]
FlyCapture2::ImageStatistics::StatisticsChannel translate ( StatisticsChannel channel ) [static, package]
OSType translate ( FlyCapture2::OSType osType ) [static, package]
FlyCapture2::OSType translate ( OSType osType ) [static, package]
ByteOrder translate ( FlyCapture2::ByteOrder byteOrder ) [static, package]
FlyCapture2::ByteOrder translate ( ByteOrder byteOrder ) [static, package]
GigEPropertyType translate ( FlyCapture2::GigEPropertyType propType ) [static, package]
FlyCapture2::GigEPropertyType translate ( GigEPropertyType propType ) [static, package]
static void Translate::ToMgd | ( | FlyCapture2::GigEConfig * | pNative,
 |  | GigEConfig^ | mgd
 | ) |  | [static, package]
static void Translate::ToNative | ( | GigEConfig^ | mgd,
 |  | FlyCapture2::GigEConfig * | pNative
 | ) |  | [static, package]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: TriggerMode Struct Reference

  • FlyCapture2Managed
  • TriggerMode
Properties
TriggerMode Struct Reference
Structures

A camera trigger. More...

List of all members.

Properties

bool | onOff
Flag controlling on/off.
unsigned int | polarity
Polarity value.
unsigned int | source
Source value.
unsigned int | mode
Mode value.
unsigned int | parameter
Parameter value.

Detailed Description

A camera trigger.

Property Documentation

unsigned int mode

Mode value.

bool onOff

Flag controlling on/off.

unsigned int parameter

Parameter value.

unsigned int polarity

Polarity value.

unsigned int source

Source value.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: TriggerModeInfo Struct Reference

  • FlyCapture2Managed
  • TriggerModeInfo
Properties
TriggerModeInfo Struct Reference
Structures

Information about a camera trigger property. More...

List of all members.

Properties

bool | present
Presence of trigger mode.
bool | readOutSupported
Flag indicating if trigger value can be read out.
bool | onOffSupported
Flag indicating if on/off is supported.
bool | polaritySupported
Flag indicating if polarity is supported.
bool | valueReadable
Flag indicating if the value is readable.
unsigned int | sourceMask
Source mask.
bool | softwareTriggerSupported
Flag indicating if software trigger is supported.
unsigned int | modeMask
Mode mask.

Detailed Description

Information about a camera trigger property.

Property Documentation

unsigned int modeMask

Mode mask.

bool onOffSupported

Flag indicating if on/off is supported.

bool polaritySupported

Flag indicating if polarity is supported.

bool present

Presence of trigger mode.

bool readOutSupported

Flag indicating if trigger value can be read out.

bool softwareTriggerSupported

Flag indicating if software trigger is supported.

unsigned int sourceMask

Source mask.

bool valueReadable

Flag indicating if the value is readable.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Index

Class Index
A | B | C | E | F | G | H | I | J | L | M | N | P | S | T
A
EmbeddedImageInfoProperty (FlyCapture2Managed)
I
ManagedEventOptions (FlyCapture2Managed) PpmOption (FlyCapture2Managed)
F
ManagedGCCamera (FlyCapture2Managed)
S
AviOption (FlyCapture2Managed) ImageMetadata (FlyCapture2Managed) ManagedGCPort (FlyCapture2Managed)
B
FC2Config (FlyCapture2Managed)
J
ManagedGigECamera (FlyCapture2Managed) StrobeControl (FlyCapture2Managed)
FC2Exception (FlyCapture2Managed) ManagedImage (FlyCapture2Managed) StrobeInfo (FlyCapture2Managed)
BMPOption (FlyCapture2Managed) FC2Version (FlyCapture2Managed) JpegOption (FlyCapture2Managed) ManagedImageStatistics (FlyCapture2Managed) SystemInfo (FlyCapture2Managed)
C
Format7ImageSettings (FlyCapture2Managed) Jpg2Option (FlyCapture2Managed) ManagedPGRGuid (FlyCapture2Managed)
T
Format7Info (FlyCapture2Managed)
L
ManagedTopologyNode (FlyCapture2Managed)
CameraControlDialog (FlyCapture2Managed::Gui) Format7PacketInfo (FlyCapture2Managed) ManagedUtilities (FlyCapture2Managed) TiffOption (FlyCapture2Managed)
CameraInfo (FlyCapture2Managed)
G
LutData (FlyCapture2Managed) MJPGOption (FlyCapture2Managed) TimeStamp (FlyCapture2Managed)
CameraProperty (FlyCapture2Managed)
M
N
Translate (FlyCapture2Managed)
CameraPropertyInfo (FlyCapture2Managed) GigEConfig (FlyCapture2Managed) TriggerMode (FlyCapture2Managed)
CameraSelectionDialog (FlyCapture2Managed::Gui) GigEImageSettings (FlyCapture2Managed) ManagedAVIRecorder (FlyCapture2Managed) NativeEventStruct (FlyCapture2Managed) TriggerModeInfo (FlyCapture2Managed)
CameraStats (FlyCapture2Managed) GigEImageSettingsInfo (FlyCapture2Managed) ManagedBusManager (FlyCapture2Managed)
P
ConfigROM (FlyCapture2Managed) GigEProperty (FlyCapture2Managed) ManagedCamera (FlyCapture2Managed)
E
GigEStreamChannel (FlyCapture2Managed) ManagedCameraBase (FlyCapture2Managed) PgmOption (FlyCapture2Managed)
H
ManagedEventCallbackData (FlyCapture2Managed) PngOption (FlyCapture2Managed)
EmbeddedImageInfo (FlyCapture2Managed)
H264Option (FlyCapture2Managed)
A | B | C | E | F | G | H | I | J | L | M | N | P | S | T
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • AviOption
  • BMPOption
  • CameraControlDialog
  • CameraInfo
  • CameraProperty
  • CameraPropertyInfo
  • CameraSelectionDialog
  • CameraStats
  • ConfigROM
  • EmbeddedImageInfo
  • EmbeddedImageInfoProperty
  • FC2Config
  • FC2Exception
  • FC2Version
  • Format7ImageSettings
  • Format7Info
  • Format7PacketInfo
  • GigEConfig
  • GigEImageSettings
  • GigEImageSettingsInfo
  • GigEProperty
  • GigEStreamChannel
  • H264Option
  • ImageMetadata
  • JpegOption
  • Jpg2Option
  • LutData
  • ManagedAVIRecorder
  • ManagedBusManager
  • ManagedCameraBase
    • ManagedCamera
    • ManagedGCCamera
    • ManagedGigECamera
  • ManagedEventCallbackData
  • ManagedEventOptions
  • ManagedGCPort
  • ManagedImage
  • ManagedImageStatistics
  • ManagedPGRGuid
  • ManagedTopologyNode
  • ManagedUtilities
  • MJPGOption
  • NativeEventStruct
  • PgmOption
  • PngOption
  • PpmOption
  • StrobeControl
  • StrobeInfo
  • SystemInfo
  • TiffOption
  • TimeStamp
  • Translate
  • TriggerMode
  • TriggerModeInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- ! -

  • !ManagedBusManager() : ManagedBusManager
  • !ManagedCamera() : ManagedCamera
  • !ManagedGCCamera() : ManagedGCCamera
  • !ManagedGigECamera() : ManagedGigECamera
  • !ManagedImage() : ManagedImage
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
FlyCapture2
FlyCapture2Managed
FlyCapture2Managed::Gui
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: FlyCapture2 Namespace Reference

  • Namespace List
  • Namespace Members
FlyCapture2 Namespace Reference
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: FlyCapture2Managed Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations | Functions
FlyCapture2Managed Namespace Reference

Namespaces

namespace | Gui

Classes

class | FC2Exception
Exception that is thrown when an error is encountered. More...
class | ManagedAVIRecorder
ManagedAVIRecorder provides the functionality for the user to record images to an AVI file. More...
class | ManagedBusManager
ManagedBusManager provides the functionality for the user to get an PGRGuid for a desired camera or device easily. More...
class | ManagedCamera
ManagedCamera represents a physical camera that uses the IIDC register set. More...
struct | ManagedEventCallbackData
struct | ManagedEventOptions
Options for enabling device event registration. More...
struct | NativeEventStruct
class | ManagedCameraBase
Abstract base class that represents a generic camera that defines a general interface to a camera. More...
struct | FC2Version
The current version of the library. More...
struct | GigEProperty
A GigE property. More...
struct | GigEStreamChannel
Information about a single GigE stream channel. More...
struct | GigEConfig
Configuration for a GigE camera. More...
struct | GigEImageSettingsInfo
Format 7 information for a single mode. More...
struct | GigEImageSettings
Image settings for a GigE camera. More...
struct | FC2Config
Configuration for a camera. More...
struct | CameraPropertyInfo
Information about a specific camera property. More...
struct | CameraProperty
A specific camera property. More...
struct | TriggerModeInfo
Information about a camera trigger property. More...
struct | TriggerMode
A camera trigger. More...
struct | StrobeInfo
A camera strobe property. More...
struct | StrobeControl
A camera strobe. More...
struct | Format7ImageSettings
Format 7 image settings. More...
struct | Format7Info
Format 7 information for a single mode. More...
struct | Format7PacketInfo
Format 7 packet information. More...
struct | TimeStamp
Timestamp information. More...
struct | ConfigROM
Camera configuration ROM. More...
struct | CameraInfo
Camera information. More...
struct | EmbeddedImageInfoProperty
Properties of a single embedded image info property. More...
struct | EmbeddedImageInfo
Properties of the possible embedded image information. More...
struct | ImageMetadata
Metadata related to an image. More...
struct | LutData
Information about the camera's look up table. More...
struct | CameraStats
Camera diagnostic information. More...
struct | PngOption
Options for saving PNG images. More...
struct | PpmOption
Options for saving PPM images. More...
struct | PgmOption
Options for saving PGM images. More...
struct | TiffOption
Options for saving TIFF images. More...
struct | JpegOption
Options for saving JPEG image. More...
struct | Jpg2Option
Options for saving JPEG2000 image. More...
struct | BMPOption
Options for saving Bitmap image. More...
struct | AviOption
Options for saving AVI files. More...
struct | MJPGOption
Options for saving MJPEG files. More...
struct | H264Option
Options for saving H.264 files. More...
struct | SystemInfo
Description of the system. More...
class | ManagedGCCamera
class | ManagedGCPort
class | ManagedGigECamera
The GigECamera object represents a physical Gigabit Ethernet camera. More...
class | ManagedImage
The ManagedImageImage class is used to retrieve images from a camera, convert between multiple pixel formats and save images to disk. More...
class | ManagedImageStatistics
class | ManagedPGRGuid
Managed version of a PGRGuid. More...
class | ManagedTopologyNode
The ManagedTopologyNode class contains topology information that can be used to generate a tree structure of all cameras and devices connected to a computer. More...
class | ManagedUtilities
class | Translate

Enumerations

enum ErrorType {
Undefined = -1,
Ok,
Failed,
NotImplemented,
FailedBusMasterConnection,
NotConnected,
InitFailed,
NotInitialized,
InvalidParameter,
InvalidSettings,
InvalidBuManager,
MemoryAllocationFailed,
LowLevelFailure,
NotFound,
FailedGuid,
InvalidPacketSize,
InvalidMode,
NotInFormat7,
NotSupported,
Timeout,
BusMasterFailed,
InvalidGeneration,
LutFailed,
IidcFailed,
StrobeFailed,
TriggerFailed,
PropertyFailed,
PropertyNotPresent,
RegisterFailed,
ReadRegisterFailed,
WriteRegisterFailed,
IsochFailed,
IsochAlreadyStarted,
IsochNotStarted,
IsochStartFailed,
IsochRetrieveBufferFailed,
IsochStopFailed,
IsochSyncFailed,
IsochBandwidthExceeded,
ImageConversionFailed,
ImageLibraryFailure,
BufferTooSmall,
ImageConsistencyError,
IncompatibleDriver
}
The error types returned by functions. More...
enum ManagedCallbackType {
BusReset,
Arrival,
Removal
}
The type of bus callback to register a callback function for. More...
enum GrabMode {
DropFrames,
BufferFrames,
Unspecified = -2
}
The grab strategy employed during image transfer. More...
enum GrabTimeout {
None = 0,
Infinite = -1,
Unspecified = -2
}
Timeout options for grabbing images. More...
enum BandwidthAllocation {
Off = 0,
On = 1,
Unsupported = 2,
Unspecified = -2
}
Bandwidth allocation options for 1394 devices. More...
enum InterfaceType {
Ieee1394,
Usb2,
Usb3,
GigE,
Unknown = -1
}
Interfaces that a camera may use to communicate with a host. More...
enum PropertyType {
Brightness,
AutoExposure,
Sharpness,
WhiteBalance,
Hue,
Saturation,
Gamma,
Iris,
Focus,
Zoom,
Pan,
Tilt,
Shutter,
Gain,
TriggerMode,
TriggerDelay,
FrameRate,
Temperature,
Unspecified = -2
}
Camera properties. More...
enum FrameRate {
FrameRate1_875,
FrameRate3_75,
FrameRate7_5,
FrameRate15,
FrameRate30,
FrameRate60,
FrameRate120,
FrameRate240,
FrameRateFormat7,
NumberOfFrameRates
}
Frame rates in frames per second. More...
enum VideoMode {
VideoMode160x120Yuv444,
VideoMode320x240Yuv422,
VideoMode640x480Yuv411,
VideoMode640x480Yuv422,
VideoMode640x480Rgb,
VideoMode640x480Y8,
VideoMode640x480Y16,
VideoMode800x600Yuv422,
VideoMode800x600Rgb,
VideoMode800x600Y8,
VideoMode800x600Y16,
VideoMode1024x768Yuv422,
VideoMode1024x768Rgb,
VideoMode1024x768Y8,
VideoMode1024x768Y16,
VideoMode1280x960Yuv422,
VideoMode1280x960Rgb,
VideoMode1280x960Y8,
VideoMode1280x960Y16,
VideoMode1600x1200Yuv422,
VideoMode1600x1200Rgb,
VideoMode1600x1200Y8,
VideoMode1600x1200Y16,
VideoModeFormat7,
NumberOfVideoModes
}
DCAM video modes. More...
enum Mode {
Mode0 = 0,
Mode1,
Mode2,
Mode3,
Mode4,
Mode5,
Mode6,
Mode7,
Mode8,
Mode9,
Mode10,
Mode11,
Mode12,
Mode13,
Mode14,
Mode15,
Mode16,
Mode17,
Mode18,
Mode19,
Mode20,
Mode21,
Mode22,
Mode23,
Mode24,
Mode25,
Mode26,
Mode27,
Mode28,
Mode29,
Mode30,
Mode31,
NumberOfModes
}
Camera modes for DCAM formats as well as Format7. More...
enum PixelFormat {
PixelFormatMono8 = 0x80000000,
PixelFormat411Yuv8 = 0x40000000,
PixelFormat422Yuv8 = 0x20000000,
PixelFormat444Yuv8 = 0x10000000,
PixelFormatRgb8 = 0x08000000,
PixelFormatMono16 = 0x04000000,
PixelFormatRgb16 = 0x02000000,
PixelFormatSignedMono16 = 0x01000000,
PixelFormatSignedRgb16 = 0x00800000,
PixelFormatRaw8 = 0x00400000,
PixelFormatRaw16 = 0x00200000,
PixelFormatMono12 = 0x00100000,
PixelFormatRaw12 = 0x00080000,
PixelFormatBgr = 0x80000008,
PixelFormatBgru = 0x40000008,
PixelFormatRgb = PixelFormatRgb8,
PixelFormatRgbu = 0x40000002,
PixelFormatBgr16 = 0x02000001,
PixelFormatBgru16 = 0x02000002,
PixelFormat422Yuv8Jpeg = 0x40000001,
NumberOfPixelFormats = 20
}
Pixel formats available for Format7 modes. More...
enum BusSpeed {
S100,
S200,
S400,
S480,
S800,
S1600,
S3200,
S5000,
GigE_10Base_T,
GigE_100Base_T,
GigE_1000Base_T,
GigE_10000Base_T,
Fastest,
Any,
Unknown = -1
}
Bus speeds. More...
enum PCIeBusSpeed {
Speed_2_5,
Speed_5_0,
Unknown = -1
}
PCIe Bus Speeds. More...
enum DriverType {
Ieee1394_Cam,
Ieee1394_Pro,
Ieee1394_Juju,
Ieee1394_Video1394,
Ieee1394_Raw1394,
Usb_None,
Usb_Cam,
Usb3_Pro,
GigE_None,
GigE_Filter,
GigE_Pro,
GigE_Lwf,
Unknown = -1
}
Types of low level drivers that flycapture uses. More...
enum ColorProcessingAlgorithm {
Default,
NoColorProcessing,
NearestNeighbor,
EdgeSensing,
HQLinear,
Rigorous,
IPP,
Directional,
WeightedDirectional
}
Color processing algorithms. More...
enum BayerTileFormat {
None = 0,
RGGB,
GRBG,
GBRG,
BGGR
}
Bayer tile formats. More...
enum ImageFileFormat {
FromFileExtension = -1,
Pgm,
Ppm,
Bmp,
Jpeg,
Jpeg2000,
Tiff,
Png,
Raw
}
File formats to be used for saving images to disk. More...
enum GigEPropertyType {
Heartbeat,
HeartbeatTimeout,
PacketSize,
PacketDelay
}
Possible properties that can be queried from the camera. More...
enum StatisticsChannel {
Grey,
Red,
Green,
Blue,
Hue,
Saturation,
Lightness,
NumberOfStatisticsChannels
}
Channels that allow statistics to be calculated. More...
enum OSType {
WindowsX86,
WindowsX64,
LinuxX86,
LinuxX64,
Mac,
UnknownOS
}
Possible operating systems. More...
enum ByteOrder {
LittleEndian,
BigEndian
}
Possible byte orders. More...

Functions

public delegate void | EnumCallback (System::IntPtr parameter, unsigned int serialNumber)
Bus event callback function prototype.
public delegate void | ImageEventCallback (ManagedImage^ image)
The external callback that will be used by managed consumers.
protected delegate void | ImageCallbackDelegate (FlyCapture2::Image *image, void *data)
Internal callback that we use internally so we can create the proper external callback for users.
public delegate void | ManagedCameraEventCallback (ManagedEventCallbackData^ data)
The external callback that will be used by managed consumers.
protected delegate void | ManagedCameraEventCallbackDelegate (void *data)
Internal callback that we use internally so we can create the proper proper external callback for users.
unsigned long | htonl (unsigned long data)
public delegate void | AsyncCommandCallback (bool retError)
The external callback that will be used by managed consumers.
protected delegate void | CommandCallbackDelegate (FlyCapture2::Error retError, void *pUserData)
Internal callback that we use internally so we can create the proper external callback for users.

Function Documentation

public delegate void FlyCapture2Managed::AsyncCommandCallback ( bool retError )

The external callback that will be used by managed consumers.

protected delegate void FlyCapture2Managed::CommandCallbackDelegate | ( | FlyCapture2::Error | retError,
 |  | void * | pUserData
 | ) |  |

Internal callback that we use internally so we can create the proper external callback for users.

public delegate void FlyCapture2Managed::EnumCallback | ( | System::IntPtr | parameter,
 |  | unsigned int | serialNumber
 | ) |  |

Bus event callback function prototype.

Defines the syntax of the callback function that is passed into RegisterCallback() and UnregisterCallback().

unsigned long FlyCapture2Managed::htonl ( unsigned long data )
protected delegate void FlyCapture2Managed::ImageCallbackDelegate | ( | FlyCapture2::Image * | image,
 |  | void * | data
 | ) |  |

Internal callback that we use internally so we can create the proper external callback for users.

public delegate void FlyCapture2Managed::ImageEventCallback ( ManagedImage^ image )

The external callback that will be used by managed consumers.

public delegate void FlyCapture2Managed::ManagedCameraEventCallback ( ManagedEventCallbackData^ data )

The external callback that will be used by managed consumers.

protected delegate void FlyCapture2Managed::ManagedCameraEventCallbackDelegate ( void * data )

Internal callback that we use internally so we can create the proper proper external callback for users.

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: FlyCapture2Managed::Gui Namespace Reference

  • Namespace List
  • Namespace Members
  • FlyCapture2Managed
  • Gui
Classes
FlyCapture2Managed::Gui Namespace Reference

Classes

class | CameraControlDialog
CameraControlDialog: managed wrapper of FlyCapture2::CameraControlDialog (see for details) More...
class | CameraSelectionDialog
CameraControlDialog: managed wrapper of FlyCapture2::CameraSelectionDialog (see for details) More...
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • Any : FlyCapture2Managed
  • Arrival : FlyCapture2Managed
  • AsyncCommandCallback() : FlyCapture2Managed
  • AutoExposure : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • FC2Exception
FC2Exception Member List
This is the complete list of members for FC2Exception, including all inherited members.
CauseType | FC2Exception |
FC2Exception() | FC2Exception |
FC2Exception(String^ string) | FC2Exception |
FC2Exception(String^ string, Exception^ exception) | FC2Exception |
FC2Exception(Runtime::Serialization::SerializationInfo^ serializationInfo, Runtime::Serialization::StreamingContext context) | FC2Exception | [protected]
FC2Exception(FlyCapture2::Error error) | FC2Exception | [package]
NativeErrorTrace | FC2Exception |
Type | FC2Exception |
~FC2Exception() | FC2Exception |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • Gui
  • CameraControlDialog
CameraControlDialog Member List
This is the complete list of members for CameraControlDialog, including all inherited members.
CameraControlDialog() | CameraControlDialog
Connect(ManagedCameraBase^ camera) | CameraControlDialog
Disconnect() | CameraControlDialog
Hide() | CameraControlDialog
IsVisible() | CameraControlDialog
SetTitle(System::String^ title) | CameraControlDialog
Show() | CameraControlDialog
~CameraControlDialog() | CameraControlDialog
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • Gui
  • CameraSelectionDialog
CameraSelectionDialog Member List
This is the complete list of members for CameraSelectionDialog, including all inherited members.
CameraSelectionDialog() | CameraSelectionDialog
GetSelectedCameraGuids() | CameraSelectionDialog
SetTitle(System::String^ title) | CameraSelectionDialog
ShowModal() | CameraSelectionDialog
~CameraSelectionDialog() | CameraSelectionDialog
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedAVIRecorder
ManagedAVIRecorder Member List
This is the complete list of members for ManagedAVIRecorder, including all inherited members.
AVIAppend(ManagedImage^ image) | ManagedAVIRecorder
AVIClose() | ManagedAVIRecorder
AVIOpen(System::String^ fileName, AviOption^ option) | ManagedAVIRecorder
AVIOpen(System::String^ fileName, MJPGOption^ option) | ManagedAVIRecorder
AVIOpen(System::String^ fileName, H264Option^ option) | ManagedAVIRecorder
ManagedAVIRecorder() | ManagedAVIRecorder
SetMaximumAVISize(unsigned int size) | ManagedAVIRecorder
~ManagedAVIRecorder() | ManagedAVIRecorder
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedBusManager
ManagedBusManager Member List
This is the complete list of members for ManagedBusManager, including all inherited members.
!ManagedBusManager() | ManagedBusManager | [protected]
ConvertToManagedGuid(FlyCapture2::PGRGuid *pgrGuid, ManagedPGRGuid^ mgdPGRGuid) | ManagedBusManager | [inline, package, static]
ConvertToNativeGuid(ManagedPGRGuid^ mgdPGRGuid, FlyCapture2::PGRGuid *pgrGuid) | ManagedBusManager | [inline, package, static]
DiscoverGigECameras() | ManagedBusManager | [static]
FireBusReset(ManagedPGRGuid^ guid) | ManagedBusManager |
ForceAllIPAddressesAutomatically() | ManagedBusManager | [static]
ForceAllIPAddressesAutomatically(unsigned int serialNumber) | ManagedBusManager | [static]
ForceIPAddressToCamera(System::Net::NetworkInformation::PhysicalAddress^ macAddress, System::Net::IPAddress^ ipAddress, System::Net::IPAddress^ subnetMask, System::Net::IPAddress^ defaultGateway) | ManagedBusManager | [static]
GetCameraFromIndex(unsigned int index) | ManagedBusManager |
GetCameraFromIPAddress(System::Net::IPAddress^ ipAddress) | ManagedBusManager |
GetCameraFromSerialNumber(unsigned int serialNumber) | ManagedBusManager |
GetCameraSerialNumberFromIndex(unsigned int index) | ManagedBusManager |
GetDeviceFromIndex(unsigned int index) | ManagedBusManager |
GetInterfaceTypeFromGuid(ManagedPGRGuid^ guid) | ManagedBusManager |
GetNumOfCameras() | ManagedBusManager |
GetNumOfDevices() | ManagedBusManager |
GetTopology() | ManagedBusManager |
GetUsbLinkInfo(ManagedPGRGuid^ guid) | ManagedBusManager |
GetUsbPortStatus(ManagedPGRGuid^ guid) | ManagedBusManager |
IsCameraControlable(ManagedPGRGuid^ guid) | ManagedBusManager |
ManagedBusManager() | ManagedBusManager |
ReadPhyRegister(ManagedPGRGuid^ guid, unsigned int page, unsigned int port, unsigned int address) | ManagedBusManager |
RegisterCallback(EnumCallback^ hCallbackDelegate, ManagedCallbackType callbackType, System::IntPtr parameter) | ManagedBusManager |
RescanBus() | ManagedBusManager |
UnregisterCallback(System::IntPtr callbackHandle) | ManagedBusManager |
WritePhyRegister(ManagedPGRGuid^ guid, unsigned int page, unsigned int port, unsigned int address, unsigned int regVal) | ManagedBusManager |
~ManagedBusManager() | ManagedBusManager |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedCamera
ManagedCamera Member List
This is the complete list of members for ManagedCamera, including all inherited members.
!ManagedCamera() | ManagedCamera | [protected]
Connect(ManagedPGRGuid^ mgdPGRGuid) override | ManagedCamera | [virtual]
DeregisterAllEvents() | ManagedCameraBase | [virtual]
DeregisterEvent(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
Disconnect() | ManagedCameraBase | [virtual]
EnableLUT(bool on) | ManagedCameraBase | [virtual]
FireSoftwareTrigger(bool broadcast) | ManagedCameraBase | [virtual]
GetActiveLUTBank() | ManagedCameraBase | [virtual]
GetCameraInfo() | ManagedCameraBase | [virtual]
GetConfiguration() | ManagedCameraBase | [virtual]
GetCycleTime() | ManagedCameraBase | [virtual]
GetEmbeddedImageInfo() | ManagedCameraBase | [virtual]
GetFormat7Configuration(Format7ImageSettings^ imageSettings, unsigned int% packetSize, float% percentSpeed) | ManagedCamera |
GetFormat7Info(Mode mode, bool% supported) | ManagedCamera |
GetGPIOPinDirection(unsigned int pin) | ManagedCameraBase | [virtual]
GetLUTBankInfo(unsigned int bank, bool% readSupported, bool% writeSupported) | ManagedCameraBase | [virtual]
GetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries) | ManagedCameraBase | [virtual]
GetLUTInfo() | ManagedCameraBase | [virtual]
GetMemoryChannel() | ManagedCameraBase | [virtual]
GetMemoryChannelInfo() | ManagedCameraBase | [virtual]
GetNativeCamera() | ManagedCameraBase | [package]
GetProperty(PropertyType type) | ManagedCameraBase | [virtual]
GetPropertyInfo(PropertyType type) | ManagedCameraBase | [virtual]
GetRegisterString(unsigned int registerVal) | ManagedCameraBase | [static]
GetStats() | ManagedCameraBase | [virtual]
GetStrobe(unsigned int source) | ManagedCameraBase | [virtual]
GetStrobeInfo(unsigned int source) | ManagedCameraBase | [virtual]
GetTriggerDelay() | ManagedCameraBase | [virtual]
GetTriggerDelayInfo() | ManagedCameraBase | [virtual]
GetTriggerMode() | ManagedCameraBase | [virtual]
GetTriggerModeInfo() | ManagedCameraBase | [virtual]
GetVideoModeAndFrameRate(VideoMode% videoMode, FrameRate% frameRate) | ManagedCamera |
GetVideoModeAndFrameRateInfo(VideoMode videoMode, FrameRate frameRate) | ManagedCamera |
IsConnected() | ManagedCameraBase | [virtual]
m_allInternalCameraEvents | ManagedCameraBase | [protected]
m_externalDelegate | ManagedCameraBase | [protected]
m_internalCameraEventDelegate | ManagedCameraBase | [protected]
m_internalDelegate | ManagedCameraBase | [protected]
m_isLocal | ManagedCameraBase | [protected]
m_p | ManagedCameraBase | [protected]
m_pNativeCamBase | ManagedCameraBase | [protected]
m_specificInternalCameraEvents | ManagedCameraBase | [protected]
ManagedCamera() | ManagedCamera |
ManagedCameraBase() | ManagedCameraBase | [inline, protected]
OnNativeCallback(FlyCapture2::Image *pImage, void *pCallbackData) | ManagedCameraBase | [protected]
OnNativeCameraEventCallback(void *pCallbackData) | ManagedCameraBase | [protected]
ReadRegister(unsigned int address) | ManagedCameraBase | [virtual]
ReadRegisterBlock(unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer) | ManagedCameraBase | [virtual]
RegisterAllEvents(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
RegisterEvent(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
ResetStats() | ManagedCameraBase | [virtual]
RestoreFromMemoryChannel(unsigned int channel) | ManagedCameraBase | [virtual]
RetrieveBuffer(ManagedImage^ image) | ManagedCameraBase | [virtual]
SaveToMemoryChannel(unsigned int channel) | ManagedCameraBase | [virtual]
SetActiveLUTBank(unsigned int activeBank) | ManagedCameraBase | [virtual]
SetCallback(ImageEventCallback^ hCallbackDelegate) | ManagedCameraBase | [virtual]
SetCamera(System::IntPtr otherCamera) | ManagedCameraBase |
SetConfiguration(FC2Config^ config) | ManagedCameraBase | [virtual]
SetEmbeddedImageInfo(EmbeddedImageInfo^ info) | ManagedCameraBase | [virtual]
SetFormat7Configuration(Format7ImageSettings^ imageSettings, unsigned int recommendedPacketSize) | ManagedCamera |
SetFormat7Configuration(Format7ImageSettings^ imageSettings, float recommendedPercentSpeed) | ManagedCamera |
SetGPIOPinDirection(unsigned int pin, unsigned int direction) | ManagedCameraBase | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction, bool broadcast) | ManagedCameraBase | [virtual]
SetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries) | ManagedCameraBase | [virtual]
SetProperty(CameraProperty^ camProperty) | ManagedCameraBase | [virtual]
SetProperty(CameraProperty^ camProperty, bool broadcast) | ManagedCameraBase | [virtual]
SetStrobe(StrobeControl^ strobeControl) | ManagedCameraBase | [virtual]
SetTriggerDelay(CameraProperty^ triggerDelay) | ManagedCameraBase | [virtual]
SetTriggerDelay(CameraProperty^ triggerDelay, bool broadcast) | ManagedCameraBase | [virtual]
SetTriggerMode(TriggerMode^ triggerMode) | ManagedCameraBase | [virtual]
SetUserBuffers(IntPtr pMemBuffers, int size, int numBuffers) | ManagedCameraBase | [virtual]
SetVideoModeAndFrameRate(VideoMode videoMode, FrameRate frameRate) | ManagedCamera |
StartCapture() | ManagedCameraBase | [virtual]
StartCapture(ImageEventCallback^ hCallbackDelegate) | ManagedCameraBase | [virtual]
StartSyncCapture(unsigned int numCameras, array< ManagedCamera^ >^ppCameras) | ManagedCamera | [static]
StartSyncCapture(unsigned int numCameras, array< ManagedCamera^ >^ppCameras, array< ImageEventCallback^ >^pCallbackFns, array< IntPtr^ >^pCallbackDataArray) | ManagedCamera | [static]
StopCapture() | ManagedCameraBase | [virtual]
ValidateFormat7Settings(Format7ImageSettings^ imageSettings, bool% settingsAreValid) | ManagedCamera |
WaitForBufferEvent(ManagedImage^ image, unsigned int eventNumber) | ManagedCameraBase | [virtual]
WriteRegister(unsigned int address, unsigned int value) | ManagedCameraBase | [virtual]
WriteRegister(unsigned int address, unsigned int value, bool broadcast) | ManagedCameraBase | [virtual]
WriteRegisterBlock(unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer) | ManagedCameraBase | [virtual]
~ManagedCamera() | ManagedCamera |
~ManagedCameraBase() | ManagedCameraBase | [inline, virtual]
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedCameraBase
ManagedCameraBase Member List
This is the complete list of members for ManagedCameraBase, including all inherited members.
Connect(ManagedPGRGuid^ mgdPGRGuid) | ManagedCameraBase | [virtual]
DeregisterAllEvents() | ManagedCameraBase | [virtual]
DeregisterEvent(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
Disconnect() | ManagedCameraBase | [virtual]
EnableLUT(bool on) | ManagedCameraBase | [virtual]
FireSoftwareTrigger(bool broadcast) | ManagedCameraBase | [virtual]
GetActiveLUTBank() | ManagedCameraBase | [virtual]
GetCameraInfo() | ManagedCameraBase | [virtual]
GetConfiguration() | ManagedCameraBase | [virtual]
GetCycleTime() | ManagedCameraBase | [virtual]
GetEmbeddedImageInfo() | ManagedCameraBase | [virtual]
GetGPIOPinDirection(unsigned int pin) | ManagedCameraBase | [virtual]
GetLUTBankInfo(unsigned int bank, bool% readSupported, bool% writeSupported) | ManagedCameraBase | [virtual]
GetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries) | ManagedCameraBase | [virtual]
GetLUTInfo() | ManagedCameraBase | [virtual]
GetMemoryChannel() | ManagedCameraBase | [virtual]
GetMemoryChannelInfo() | ManagedCameraBase | [virtual]
GetNativeCamera() | ManagedCameraBase | [package]
GetProperty(PropertyType type) | ManagedCameraBase | [virtual]
GetPropertyInfo(PropertyType type) | ManagedCameraBase | [virtual]
GetRegisterString(unsigned int registerVal) | ManagedCameraBase | [static]
GetStats() | ManagedCameraBase | [virtual]
GetStrobe(unsigned int source) | ManagedCameraBase | [virtual]
GetStrobeInfo(unsigned int source) | ManagedCameraBase | [virtual]
GetTriggerDelay() | ManagedCameraBase | [virtual]
GetTriggerDelayInfo() | ManagedCameraBase | [virtual]
GetTriggerMode() | ManagedCameraBase | [virtual]
GetTriggerModeInfo() | ManagedCameraBase | [virtual]
IsConnected() | ManagedCameraBase | [virtual]
m_allInternalCameraEvents | ManagedCameraBase | [protected]
m_externalDelegate | ManagedCameraBase | [protected]
m_internalCameraEventDelegate | ManagedCameraBase | [protected]
m_internalDelegate | ManagedCameraBase | [protected]
m_isLocal | ManagedCameraBase | [protected]
m_p | ManagedCameraBase | [protected]
m_pNativeCamBase | ManagedCameraBase | [protected]
m_specificInternalCameraEvents | ManagedCameraBase | [protected]
ManagedCameraBase() | ManagedCameraBase | [inline, protected]
OnNativeCallback(FlyCapture2::Image *pImage, void *pCallbackData) | ManagedCameraBase | [protected]
OnNativeCameraEventCallback(void *pCallbackData) | ManagedCameraBase | [protected]
ReadRegister(unsigned int address) | ManagedCameraBase | [virtual]
ReadRegisterBlock(unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer) | ManagedCameraBase | [virtual]
RegisterAllEvents(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
RegisterEvent(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
ResetStats() | ManagedCameraBase | [virtual]
RestoreFromMemoryChannel(unsigned int channel) | ManagedCameraBase | [virtual]
RetrieveBuffer(ManagedImage^ image) | ManagedCameraBase | [virtual]
SaveToMemoryChannel(unsigned int channel) | ManagedCameraBase | [virtual]
SetActiveLUTBank(unsigned int activeBank) | ManagedCameraBase | [virtual]
SetCallback(ImageEventCallback^ hCallbackDelegate) | ManagedCameraBase | [virtual]
SetCamera(System::IntPtr otherCamera) | ManagedCameraBase |
SetConfiguration(FC2Config^ config) | ManagedCameraBase | [virtual]
SetEmbeddedImageInfo(EmbeddedImageInfo^ info) | ManagedCameraBase | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction) | ManagedCameraBase | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction, bool broadcast) | ManagedCameraBase | [virtual]
SetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries) | ManagedCameraBase | [virtual]
SetProperty(CameraProperty^ camProperty) | ManagedCameraBase | [virtual]
SetProperty(CameraProperty^ camProperty, bool broadcast) | ManagedCameraBase | [virtual]
SetStrobe(StrobeControl^ strobeControl) | ManagedCameraBase | [virtual]
SetTriggerDelay(CameraProperty^ triggerDelay) | ManagedCameraBase | [virtual]
SetTriggerDelay(CameraProperty^ triggerDelay, bool broadcast) | ManagedCameraBase | [virtual]
SetTriggerMode(TriggerMode^ triggerMode) | ManagedCameraBase | [virtual]
SetUserBuffers(IntPtr pMemBuffers, int size, int numBuffers) | ManagedCameraBase | [virtual]
StartCapture() | ManagedCameraBase | [virtual]
StartCapture(ImageEventCallback^ hCallbackDelegate) | ManagedCameraBase | [virtual]
StopCapture() | ManagedCameraBase | [virtual]
WaitForBufferEvent(ManagedImage^ image, unsigned int eventNumber) | ManagedCameraBase | [virtual]
WriteRegister(unsigned int address, unsigned int value) | ManagedCameraBase | [virtual]
WriteRegister(unsigned int address, unsigned int value, bool broadcast) | ManagedCameraBase | [virtual]
WriteRegisterBlock(unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer) | ManagedCameraBase | [virtual]
~ManagedCameraBase() | ManagedCameraBase | [inline, virtual]
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedGCCamera
ManagedGCCamera Member List
This is the complete list of members for ManagedGCCamera, including all inherited members.
!ManagedGCCamera() | ManagedGCCamera | [protected]
Connect(ManagedPGRGuid^ mgdPGRGuid) override | ManagedGCCamera | [virtual]
Connect(ManagedPGRGuid^ mgdPGRGuid, String^ xmlPath) override | ManagedGCCamera | [virtual]
DeregisterAllEvents() | ManagedCameraBase | [virtual]
DeregisterEvent(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
Disconnect(void) override | ManagedGCCamera | [virtual]
EnableLUT(bool on) | ManagedCameraBase | [virtual]
FireSoftwareTrigger(bool broadcast) | ManagedCameraBase | [virtual]
GetActiveLUTBank() | ManagedCameraBase | [virtual]
GetCameraInfo() | ManagedCameraBase | [virtual]
GetConfiguration() | ManagedCameraBase | [virtual]
GetCycleTime() | ManagedCameraBase | [virtual]
GetEmbeddedImageInfo() | ManagedCameraBase | [virtual]
GetGPIOPinDirection(unsigned int pin) | ManagedCameraBase | [virtual]
GetLUTBankInfo(unsigned int bank, bool% readSupported, bool% writeSupported) | ManagedCameraBase | [virtual]
GetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries) | ManagedCameraBase | [virtual]
GetLUTInfo() | ManagedCameraBase | [virtual]
GetMemoryChannel() | ManagedCameraBase | [virtual]
GetMemoryChannelInfo() | ManagedCameraBase | [virtual]
GetNativeCamera() | ManagedCameraBase | [package]
GetNodeMap() | ManagedGCCamera |
GetProperty(PropertyType type) | ManagedCameraBase | [virtual]
GetPropertyInfo(PropertyType type) | ManagedCameraBase | [virtual]
GetRegisterString(unsigned int registerVal) | ManagedCameraBase | [static]
GetStats() | ManagedCameraBase | [virtual]
GetStrobe(unsigned int source) | ManagedCameraBase | [virtual]
GetStrobeInfo(unsigned int source) | ManagedCameraBase | [virtual]
GetTriggerDelay() | ManagedCameraBase | [virtual]
GetTriggerDelayInfo() | ManagedCameraBase | [virtual]
GetTriggerMode() | ManagedCameraBase | [virtual]
GetTriggerModeInfo() | ManagedCameraBase | [virtual]
IsConnected() | ManagedCameraBase | [virtual]
m_allInternalCameraEvents | ManagedCameraBase | [protected]
m_externalDelegate | ManagedCameraBase | [protected]
m_internalCameraEventDelegate | ManagedCameraBase | [protected]
m_internalDelegate | ManagedCameraBase | [protected]
m_isLocal | ManagedCameraBase | [protected]
m_p | ManagedCameraBase | [protected]
m_pNativeCamBase | ManagedCameraBase | [protected]
m_specificInternalCameraEvents | ManagedCameraBase | [protected]
ManagedCameraBase() | ManagedCameraBase | [inline, protected]
ManagedGCCamera(void) | ManagedGCCamera |
OnNativeCallback(FlyCapture2::Image *pImage, void *pCallbackData) | ManagedCameraBase | [protected]
OnNativeCameraEventCallback(void *pCallbackData) | ManagedCameraBase | [protected]
ReadRegister(unsigned int address) | ManagedCameraBase | [virtual]
ReadRegisterBlock(unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer) | ManagedCameraBase | [virtual]
RegisterAllEvents(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
RegisterEvent(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
ResetStats() | ManagedCameraBase | [virtual]
RestoreFromMemoryChannel(unsigned int channel) | ManagedCameraBase | [virtual]
RetrieveBuffer(ManagedImage^ image) | ManagedCameraBase | [virtual]
SaveToMemoryChannel(unsigned int channel) | ManagedCameraBase | [virtual]
SetActiveLUTBank(unsigned int activeBank) | ManagedCameraBase | [virtual]
SetCallback(ImageEventCallback^ hCallbackDelegate) | ManagedCameraBase | [virtual]
SetCamera(ManagedCameraBase^ cameraBase) | ManagedGCCamera |
SetCamera(ManagedCameraBase^ cameraBase, String^ xmlPath) | ManagedGCCamera |
FlyCapture2Managed::ManagedCameraBase::SetCamera(System::IntPtr otherCamera) | ManagedCameraBase |
SetConfiguration(FC2Config^ config) | ManagedCameraBase | [virtual]
SetEmbeddedImageInfo(EmbeddedImageInfo^ info) | ManagedCameraBase | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction) | ManagedCameraBase | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction, bool broadcast) | ManagedCameraBase | [virtual]
SetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries) | ManagedCameraBase | [virtual]
SetProperty(CameraProperty^ camProperty) | ManagedCameraBase | [virtual]
SetProperty(CameraProperty^ camProperty, bool broadcast) | ManagedCameraBase | [virtual]
SetStrobe(StrobeControl^ strobeControl) | ManagedCameraBase | [virtual]
SetTriggerDelay(CameraProperty^ triggerDelay) | ManagedCameraBase | [virtual]
SetTriggerDelay(CameraProperty^ triggerDelay, bool broadcast) | ManagedCameraBase | [virtual]
SetTriggerMode(TriggerMode^ triggerMode) | ManagedCameraBase | [virtual]
SetUserBuffers(IntPtr pMemBuffers, int size, int numBuffers) | ManagedCameraBase | [virtual]
StartCapture() | ManagedCameraBase | [virtual]
StartCapture(ImageEventCallback^ hCallbackDelegate) | ManagedCameraBase | [virtual]
StopCapture() | ManagedCameraBase | [virtual]
WaitForBufferEvent(ManagedImage^ image, unsigned int eventNumber) | ManagedCameraBase | [virtual]
WriteRegister(unsigned int address, unsigned int value) | ManagedCameraBase | [virtual]
WriteRegister(unsigned int address, unsigned int value, bool broadcast) | ManagedCameraBase | [virtual]
WriteRegisterBlock(unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer) | ManagedCameraBase | [virtual]
~ManagedCameraBase() | ManagedCameraBase | [inline, virtual]
~ManagedGCCamera(void) | ManagedGCCamera | [virtual]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedGCPort
ManagedGCPort Member List
This is the complete list of members for ManagedGCPort, including all inherited members.
ManagedGCPort(GCCamera *camera) | ManagedGCPort |
Read(IntPtr buffer, __int64 address, __int64 length) override | ManagedGCPort | [virtual]
Write(IntPtr buffer, __int64 address, __int64 length) override | ManagedGCPort | [virtual]
~ManagedGCPort(void) | ManagedGCPort | [virtual]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedGigECamera
ManagedGigECamera Member List
This is the complete list of members for ManagedGigECamera, including all inherited members.
!ManagedGigECamera() | ManagedGigECamera | [protected]
Connect(ManagedPGRGuid^ mgdPGRGuid) override | ManagedGigECamera | [virtual]
DeregisterAllEvents() | ManagedCameraBase | [virtual]
DeregisterEvent(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
Disconnect() | ManagedCameraBase | [virtual]
DiscoverGigEPacketSize() | ManagedGigECamera |
EnableLUT(bool on) | ManagedCameraBase | [virtual]
FireSoftwareTrigger(bool broadcast) | ManagedCameraBase | [virtual]
GetActiveLUTBank() | ManagedCameraBase | [virtual]
GetCameraInfo() | ManagedCameraBase | [virtual]
GetConfiguration() | ManagedCameraBase | [virtual]
GetCycleTime() | ManagedCameraBase | [virtual]
GetEmbeddedImageInfo() | ManagedCameraBase | [virtual]
GetGigEConfig() | ManagedGigECamera |
GetGigEImageBinningSettings(unsigned int% horzBinningValue, unsigned int% vertBinningValue) | ManagedGigECamera |
GetGigEImageSettings() | ManagedGigECamera |
GetGigEImageSettingsInfo() | ManagedGigECamera |
GetGigEImagingMode() | ManagedGigECamera |
GetGigEProperty(GigEPropertyType propType) | ManagedGigECamera |
GetGigEStreamChannelInfo(unsigned int channel) | ManagedGigECamera |
GetGPIOPinDirection(unsigned int pin) | ManagedCameraBase | [virtual]
GetLUTBankInfo(unsigned int bank, bool% readSupported, bool% writeSupported) | ManagedCameraBase | [virtual]
GetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries) | ManagedCameraBase | [virtual]
GetLUTInfo() | ManagedCameraBase | [virtual]
GetMemoryChannel() | ManagedCameraBase | [virtual]
GetMemoryChannelInfo() | ManagedCameraBase | [virtual]
GetNativeCamera() | ManagedCameraBase | [package]
GetNumStreamChannels() | ManagedGigECamera |
GetProperty(PropertyType type) | ManagedCameraBase | [virtual]
GetPropertyInfo(PropertyType type) | ManagedCameraBase | [virtual]
GetRegisterString(unsigned int registerVal) | ManagedCameraBase | [static]
GetStats() | ManagedCameraBase | [virtual]
GetStrobe(unsigned int source) | ManagedCameraBase | [virtual]
GetStrobeInfo(unsigned int source) | ManagedCameraBase | [virtual]
GetTriggerDelay() | ManagedCameraBase | [virtual]
GetTriggerDelayInfo() | ManagedCameraBase | [virtual]
GetTriggerMode() | ManagedCameraBase | [virtual]
GetTriggerModeInfo() | ManagedCameraBase | [virtual]
IsConnected() | ManagedCameraBase | [virtual]
m_allInternalCameraEvents | ManagedCameraBase | [protected]
m_externalDelegate | ManagedCameraBase | [protected]
m_internalCameraEventDelegate | ManagedCameraBase | [protected]
m_internalDelegate | ManagedCameraBase | [protected]
m_isLocal | ManagedCameraBase | [protected]
m_p | ManagedCameraBase | [protected]
m_pNativeCamBase | ManagedCameraBase | [protected]
m_specificInternalCameraEvents | ManagedCameraBase | [protected]
ManagedCameraBase() | ManagedCameraBase | [inline, protected]
ManagedGigECamera() | ManagedGigECamera |
OnNativeCallback(FlyCapture2::Image *pImage, void *pCallbackData) | ManagedCameraBase | [protected]
OnNativeCameraEventCallback(void *pCallbackData) | ManagedCameraBase | [protected]
QueryGigEImagingMode(Mode mode) | ManagedGigECamera |
ReadGVCPMemory(unsigned int address, array< unsigned char >^buffer) | ManagedGigECamera |
ReadGVCPRegister(unsigned int address) | ManagedGigECamera |
ReadGVCPRegisterBlock(unsigned int address, array< unsigned int >^buffer) | ManagedGigECamera |
ReadRegister(unsigned int address) | ManagedCameraBase | [virtual]
ReadRegisterBlock(unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer) | ManagedCameraBase | [virtual]
RegisterAllEvents(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
RegisterEvent(ManagedEventOptions^ hOpts) | ManagedCameraBase | [virtual]
ResetStats() | ManagedCameraBase | [virtual]
RestoreFromMemoryChannel(unsigned int channel) | ManagedCameraBase | [virtual]
RetrieveBuffer(ManagedImage^ image) | ManagedCameraBase | [virtual]
SaveToMemoryChannel(unsigned int channel) | ManagedCameraBase | [virtual]
SetActiveLUTBank(unsigned int activeBank) | ManagedCameraBase | [virtual]
SetCallback(ImageEventCallback^ hCallbackDelegate) | ManagedCameraBase | [virtual]
SetCamera(System::IntPtr otherCamera) | ManagedCameraBase |
SetConfiguration(FC2Config^ config) | ManagedCameraBase | [virtual]
SetEmbeddedImageInfo(EmbeddedImageInfo^ info) | ManagedCameraBase | [virtual]
SetGigEConfig(GigEConfig^ config) | ManagedGigECamera |
SetGigEImageBinningSettings(unsigned int horzBinnningValue, unsigned int vertBinnningValue) | ManagedGigECamera |
SetGigEImageSettings(GigEImageSettings^ settings) | ManagedGigECamera |
SetGigEImagingMode(Mode mode) | ManagedGigECamera |
SetGigEProperty(GigEProperty^ prop) | ManagedGigECamera |
SetGigEStreamChannelInfo(unsigned int channel, GigEStreamChannel^ channelInfo) | ManagedGigECamera |
SetGPIOPinDirection(unsigned int pin, unsigned int direction) | ManagedCameraBase | [virtual]
SetGPIOPinDirection(unsigned int pin, unsigned int direction, bool broadcast) | ManagedCameraBase | [virtual]
SetLUTChannel(unsigned int bank, unsigned int channel, unsigned int sizeEntries, array< unsigned int >^entries) | ManagedCameraBase | [virtual]
SetProperty(CameraProperty^ camProperty) | ManagedCameraBase | [virtual]
SetProperty(CameraProperty^ camProperty, bool broadcast) | ManagedCameraBase | [virtual]
SetStrobe(StrobeControl^ strobeControl) | ManagedCameraBase | [virtual]
SetTriggerDelay(CameraProperty^ triggerDelay) | ManagedCameraBase | [virtual]
SetTriggerDelay(CameraProperty^ triggerDelay, bool broadcast) | ManagedCameraBase | [virtual]
SetTriggerMode(TriggerMode^ triggerMode) | ManagedCameraBase | [virtual]
SetUserBuffers(IntPtr pMemBuffers, int size, int numBuffers) | ManagedCameraBase | [virtual]
StartCapture() | ManagedCameraBase | [virtual]
StartCapture(ImageEventCallback^ hCallbackDelegate) | ManagedCameraBase | [virtual]
StopCapture() | ManagedCameraBase | [virtual]
WaitForBufferEvent(ManagedImage^ image, unsigned int eventNumber) | ManagedCameraBase | [virtual]
WriteGVCPMemory(unsigned int address, array< unsigned char >^buffer) | ManagedGigECamera |
WriteGVCPRegister(unsigned int address, unsigned int value) | ManagedGigECamera |
WriteGVCPRegister(unsigned int address, unsigned int value, bool broadcast) | ManagedGigECamera |
WriteGVCPRegisterBlock(unsigned int address, array< unsigned int >^buffer) | ManagedGigECamera |
WriteRegister(unsigned int address, unsigned int value) | ManagedCameraBase | [virtual]
WriteRegister(unsigned int address, unsigned int value, bool broadcast) | ManagedCameraBase | [virtual]
WriteRegisterBlock(unsigned short addressHigh, unsigned int addressLow, array< unsigned int >^buffer) | ManagedCameraBase | [virtual]
~ManagedCameraBase() | ManagedCameraBase | [inline, virtual]
~ManagedGigECamera() | ManagedGigECamera |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedImage
ManagedImage Member List
This is the complete list of members for ManagedImage, including all inherited members.
!ManagedImage() | ManagedImage | [protected]
bayerTileFormat | ManagedImage |
bitmap | ManagedImage |
bitsPerPixel | ManagedImage |
blockId | ManagedImage |
CalculateStatistics(ManagedImageStatistics^ statistics) | ManagedImage |
colorProcessingAlgorithm | ManagedImage |
cols | ManagedImage |
Convert(ManagedImage^ destImage) | ManagedImage |
Convert(PixelFormat format, ManagedImage^ destImage) | ManagedImage |
data | ManagedImage |
dataSize | ManagedImage |
defaultColorProcessingAlgorithm | ManagedImage | [static]
defaultOutputPixelFormat | ManagedImage | [static]
DetermineBitsPerPixel(PixelFormat format) | ManagedImage | [static]
GetDimensions(unsigned int *pRows, unsigned int *pCols, unsigned int *pStride, PixelFormat^ pPixelFormat, BayerTileFormat^ pBayerFormat) | ManagedImage |
GetNativeImage() | ManagedImage | [package]
GetRawNativeImagePointer() | ManagedImage |
imageMetadata | ManagedImage |
IsNativeImageValid() | ManagedImage | [package]
ManagedImage() | ManagedImage |
ManagedImage(unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, PixelFormat format) | ManagedImage |
ManagedImage(unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, unsigned int receivedActualSize, PixelFormat format) | ManagedImage |
ManagedImage(unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, PixelFormat format, BayerTileFormat bayerFormat) | ManagedImage |
ManagedImage(unsigned int rows, unsigned int cols, unsigned int stride, unsigned char *pData, unsigned int dataSize, unsigned int receivedActualSize, PixelFormat format, BayerTileFormat bayerFormat) | ManagedImage |
ManagedImage(unsigned char *pData, unsigned int dataSize) | ManagedImage |
ManagedImage(unsigned int rows, unsigned int cols, PixelFormat format) | ManagedImage |
ManagedImage(unsigned int rows, unsigned int cols, PixelFormat format, BayerTileFormat bayerFormat) | ManagedImage |
ManagedImage(ManagedImage^ image) | ManagedImage |
ManagedImage(FlyCapture2::Image &image) | ManagedImage | [package]
pixelFormat | ManagedImage |
receivedDataSize | ManagedImage |
ReleaseBuffer() | ManagedImage |
rows | ManagedImage |
Save(System::String^ fileName) | ManagedImage |
Save(System::String^ fileName, ImageFileFormat format) | ManagedImage |
Save(System::String^ fileName, PngOption^ option) | ManagedImage |
Save(System::String^ fileName, PpmOption^ option) | ManagedImage |
Save(System::String^ fileName, PgmOption^ option) | ManagedImage |
Save(System::String^ fileName, TiffOption^ option) | ManagedImage |
Save(System::String^ fileName, JpegOption^ option) | ManagedImage |
Save(System::String^ fileName, Jpg2Option^ option) | ManagedImage |
Save(System::String^ fileName, BMPOption^ option) | ManagedImage |
SetData(unsigned char *pData, unsigned int dataSize) | ManagedImage |
SetDimensions(unsigned int rows, unsigned int cols, unsigned int stride, PixelFormat pixelFormat, BayerTileFormat bayerFormat) | ManagedImage |
stride | ManagedImage |
timeStamp | ManagedImage |
~ManagedImage() | ManagedImage |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedImageStatistics
ManagedImageStatistics Member List
This is the complete list of members for ManagedImageStatistics, including all inherited members.
DisableAll() | ManagedImageStatistics |
EnableAll() | ManagedImageStatistics |
EnableGreyOnly() | ManagedImageStatistics |
EnableHSLOnly() | ManagedImageStatistics |
EnableRGBOnly() | ManagedImageStatistics |
GetChannelStatus(StatisticsChannel channel) | ManagedImageStatistics |
GetHistogram(StatisticsChannel channel, array< int >^histogram) | ManagedImageStatistics |
GetMean(StatisticsChannel channel, float% mean) | ManagedImageStatistics |
GetNativeImageStatistics() | ManagedImageStatistics | [package]
GetNumPixelValues(StatisticsChannel channel, unsigned int% numPixelValues) | ManagedImageStatistics |
GetPixelValueRange(StatisticsChannel channel, unsigned int% pixelValueMin, unsigned int% pixelValueMax) | ManagedImageStatistics |
GetRange(StatisticsChannel channel, unsigned int% min, unsigned int% max) | ManagedImageStatistics |
GetStatistics(StatisticsChannel channel, unsigned int% rangeMin, unsigned int% rangeMax, unsigned int% pixelValueMin, unsigned int% pixelValueMax, unsigned int% numPixelValues, float% mean, array< int >^histogram) | ManagedImageStatistics |
ManagedImageStatistics() | ManagedImageStatistics |
SetChannelStatus(StatisticsChannel channel, bool enabled) | ManagedImageStatistics |
~ManagedImageStatistics() | ManagedImageStatistics |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedPGRGuid
ManagedPGRGuid Member List
This is the complete list of members for ManagedPGRGuid, including all inherited members.
Equals(Object^ obj) override | ManagedPGRGuid | [inline, virtual]
GetHashCode() override | ManagedPGRGuid | [inline, virtual]
ManagedPGRGuid() | ManagedPGRGuid | [inline]
ManagedPGRGuid(ManagedPGRGuid^ managedGuid) | ManagedPGRGuid | [inline]
ManagedPGRGuid(ManagedPGRGuid% managedGuid) | ManagedPGRGuid | [inline]
operator!=(ManagedPGRGuid% left, ManagedPGRGuid% right) | ManagedPGRGuid | [inline, static]
operator=(ManagedPGRGuid% managedGuid) | ManagedPGRGuid | [inline]
operator==(ManagedPGRGuid% left, ManagedPGRGuid% right) | ManagedPGRGuid | [inline, static]
value0 | ManagedPGRGuid |
value1 | ManagedPGRGuid |
value2 | ManagedPGRGuid |
value3 | ManagedPGRGuid |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedTopologyNode
ManagedTopologyNode Member List
This is the complete list of members for ManagedTopologyNode, including all inherited members.
Bus enum value | ManagedTopologyNode |
Camera enum value | ManagedTopologyNode |
Computer enum value | ManagedTopologyNode |
ConnectedToChild enum value | ManagedTopologyNode |
ConnectedToParent enum value | ManagedTopologyNode |
GetChild(unsigned int position) | ManagedTopologyNode |
GetDeviceId() | ManagedTopologyNode |
GetGuid() | ManagedTopologyNode |
GetInterfaceType() | ManagedTopologyNode |
GetNodeType() | ManagedTopologyNode |
GetNumChildren() | ManagedTopologyNode |
GetNumPorts() | ManagedTopologyNode |
GetPortType(unsigned int position) | ManagedTopologyNode |
ManagedTopologyNode(ManagedTopologyNode^ other) | ManagedTopologyNode |
ManagedTopologyNode(ManagedTopologyNode% other) | ManagedTopologyNode |
ManagedTopologyNode(FlyCapture2::TopologyNode *pNode) | ManagedTopologyNode | [package]
Node enum value | ManagedTopologyNode |
NodeType enum name | ManagedTopologyNode |
NotConnected enum value | ManagedTopologyNode |
PortType enum name | ManagedTopologyNode |
TranslateNodeType(FlyCapture2::TopologyNode::NodeType portType) | ManagedTopologyNode | [package, static]
TranslateNodeType(ManagedTopologyNode::NodeType portType) | ManagedTopologyNode | [package, static]
TranslatePortType(FlyCapture2::TopologyNode::PortType portType) | ManagedTopologyNode | [package, static]
TranslatePortType(ManagedTopologyNode::PortType portType) | ManagedTopologyNode | [package, static]
~ManagedTopologyNode() | ManagedTopologyNode | [inline, virtual]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedUtilities
ManagedUtilities Member List
This is the complete list of members for ManagedUtilities, including all inherited members.
CheckDriver(ManagedPGRGuid^ guid) | ManagedUtilities | [static]
GetDriverDeviceName(ManagedPGRGuid^ mgdPGRGuid) | ManagedUtilities | [static]
LaunchBrowser(System::String^ address) | ManagedUtilities | [static]
LaunchCommand(System::String^ command) | ManagedUtilities | [static]
LaunchCommandAsync(System::String^ command, AsyncCommandCallback^ hCallbackDelegate) | ManagedUtilities | [static]
LaunchHelp(System::String^ fileName) | ManagedUtilities | [static]
libraryVersion | ManagedUtilities | [static]
m_externalDelegate | ManagedUtilities | [package, static]
m_internalDelegate | ManagedUtilities | [package, static]
OnNativeCallback(FlyCapture2::Error retError, void *pUserData) | ManagedUtilities | [package, static]
systemInfo | ManagedUtilities | [static]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • Translate
Translate Member List
This is the complete list of members for Translate, including all inherited members.
ToMgd(FlyCapture2::FC2Config *pNative, FC2Config^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::PropertyInfo *pNative, CameraPropertyInfo^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::Property *pNative, CameraProperty^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::TriggerModeInfo *pNative, TriggerModeInfo^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::TriggerMode *pNative, TriggerMode^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::StrobeInfo *pNative, StrobeInfo^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::StrobeControl *pNative, StrobeControl^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::Format7ImageSettings *pNative, Format7ImageSettings^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::Format7Info *pNative, Format7Info^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::Format7PacketInfo *pNative, Format7PacketInfo^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::TimeStamp *pNative, TimeStamp^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::ConfigROM *pNative, ConfigROM^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::CameraInfo *pNative, CameraInfo^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::ImageMetadata *pNative, ImageMetadata^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::LUTData *pNative, LutData^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::EmbeddedImageInfoProperty *pNative, EmbeddedImageInfoProperty^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::EmbeddedImageInfo *pNative, EmbeddedImageInfo^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::PNGOption *pNative, PngOption^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::PPMOption *pNative, PpmOption^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::PGMOption *pNative, PgmOption^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::TIFFOption *pNative, TiffOption^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::JPEGOption *pNative, JpegOption^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::JPG2Option *pNative, Jpg2Option^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::BMPOption *pNative, BMPOption^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::SystemInfo *pNative, SystemInfo^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::FC2Version *pNative, FC2Version^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::IPAddress *pNative, System::Net::IPAddress^ %mgd) | Translate | [package, static]
ToMgd(FlyCapture2::MACAddress *pNative, System::Net::NetworkInformation::PhysicalAddress^ %mgd) | Translate | [package, static]
ToMgd(FlyCapture2::GigEProperty *pNative, GigEProperty^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::GigEImageSettingsInfo *pNative, GigEImageSettingsInfo^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::GigEImageSettings *pNative, GigEImageSettings^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::GigEStreamChannel *pNative, GigEStreamChannel^ mgd) | Translate | [package, static]
ToMgd(FlyCapture2::CameraStats *pNative, CameraStats^ mgd) | Translate | [package, static]
ToNative(FC2Config^ mgd, FlyCapture2::FC2Config *pNative) | Translate | [package, static]
ToNative(CameraPropertyInfo^ mgd, FlyCapture2::PropertyInfo *pNative) | Translate | [package, static]
ToNative(CameraProperty^ mgd, FlyCapture2::Property *pNative) | Translate | [package, static]
ToNative(TriggerModeInfo^ mgd, FlyCapture2::TriggerModeInfo *pNative) | Translate | [package, static]
ToNative(TriggerMode^ mgd, FlyCapture2::TriggerMode *pNative) | Translate | [package, static]
ToNative(StrobeInfo^ mgd, FlyCapture2::StrobeInfo *pNative) | Translate | [package, static]
ToNative(StrobeControl^ mgd, FlyCapture2::StrobeControl *pNative) | Translate | [package, static]
ToNative(Format7ImageSettings^ mgd, FlyCapture2::Format7ImageSettings *pNative) | Translate | [package, static]
ToNative(Format7Info^ mgd, FlyCapture2::Format7Info *pNative) | Translate | [package, static]
ToNative(Format7PacketInfo^ mgd, FlyCapture2::Format7PacketInfo *pNative) | Translate | [package, static]
ToNative(TimeStamp^ mgd, FlyCapture2::TimeStamp *pNative) | Translate | [package, static]
ToNative(ConfigROM^ mgd, FlyCapture2::ConfigROM *pNative) | Translate | [package, static]
ToNative(CameraInfo^ mgd, FlyCapture2::CameraInfo *pNative) | Translate | [package, static]
ToNative(ImageMetadata^ mgd, FlyCapture2::ImageMetadata *pNative) | Translate | [package, static]
ToNative(LutData^ mgd, FlyCapture2::LUTData *pNative) | Translate | [package, static]
ToNative(EmbeddedImageInfoProperty^ mgd, FlyCapture2::EmbeddedImageInfoProperty *pNative) | Translate | [package, static]
ToNative(EmbeddedImageInfo^ mgd, FlyCapture2::EmbeddedImageInfo *pNative) | Translate | [package, static]
ToNative(PngOption^ mgd, FlyCapture2::PNGOption *pNative) | Translate | [package, static]
ToNative(PpmOption^ mgd, FlyCapture2::PPMOption *pNative) | Translate | [package, static]
ToNative(PgmOption^ mgd, FlyCapture2::PGMOption *pNative) | Translate | [package, static]
ToNative(TiffOption^ mgd, FlyCapture2::TIFFOption *pNative) | Translate | [package, static]
ToNative(JpegOption^ mgd, FlyCapture2::JPEGOption *pNative) | Translate | [package, static]
ToNative(Jpg2Option^ mgd, FlyCapture2::JPG2Option *pNative) | Translate | [package, static]
ToNative(BMPOption^ mgd, FlyCapture2::BMPOption *pNative) | Translate | [package, static]
ToNative(AviOption^ mgd, FlyCapture2::AVIOption *pNative) | Translate | [package, static]
ToNative(MJPGOption^ mgd, FlyCapture2::MJPGOption *pNative) | Translate | [package, static]
ToNative(H264Option^ mgd, FlyCapture2::H264Option *pNative) | Translate | [package, static]
ToNative(System::Net::IPAddress^ mgd, FlyCapture2::IPAddress *pNative) | Translate | [package, static]
ToNative(System::Net::NetworkInformation::PhysicalAddress^ mgd, FlyCapture2::MACAddress *pNative) | Translate | [package, static]
ToNative(GigEProperty^ mgd, FlyCapture2::GigEProperty *pNative) | Translate | [package, static]
ToNative(GigEImageSettingsInfo^ mgd, FlyCapture2::GigEImageSettingsInfo *pNative) | Translate | [package, static]
ToNative(GigEImageSettings^ mgd, FlyCapture2::GigEImageSettings *pNative) | Translate | [package, static]
ToNative(GigEStreamChannel^ mgd, FlyCapture2::GigEStreamChannel *pNative) | Translate | [package, static]
translate(FlyCapture2::ErrorType errorType) | Translate | [package, static]
translate(ErrorType errorType) | Translate | [package, static]
translate(FlyCapture2::GrabMode grabMode) | Translate | [package, static]
translate(GrabMode grabMode) | Translate | [package, static]
translate(FlyCapture2::BandwidthAllocation bandwidthAllocation) | Translate | [package, static]
translate(BandwidthAllocation bandwidthAllocation) | Translate | [package, static]
translate(FlyCapture2::InterfaceType interfaceType) | Translate | [package, static]
translate(InterfaceType interfaceType) | Translate | [package, static]
translate(FlyCapture2::DriverType driverType) | Translate | [package, static]
translate(DriverType driverType) | Translate | [package, static]
translate(FlyCapture2::PropertyType propertyType) | Translate | [package, static]
translate(PropertyType propertyType) | Translate | [package, static]
translate(FlyCapture2::FrameRate frmRate) | Translate | [package, static]
translate(FrameRate frmRate) | Translate | [package, static]
translate(FlyCapture2::VideoMode videoMode) | Translate | [package, static]
translate(VideoMode videoMode) | Translate | [package, static]
translate(FlyCapture2::PixelFormat pixelFormat) | Translate | [package, static]
translate(PixelFormat pixelFormat) | Translate | [package, static]
translate(FlyCapture2::BayerTileFormat bayerFormat) | Translate | [package, static]
translate(BayerTileFormat bayerFormat) | Translate | [package, static]
translate(FlyCapture2::Mode mode) | Translate | [package, static]
translate(Mode mode) | Translate | [package, static]
translate(FlyCapture2::BusSpeed busSpeed) | Translate | [package, static]
translate(BusSpeed busSpeed) | Translate | [package, static]
translate(FlyCapture2::PCIeBusSpeed pcieBusSpeed) | Translate | [package, static]
translate(PCIeBusSpeed pcieBusSpeed) | Translate | [package, static]
translate(FlyCapture2::ColorProcessingAlgorithm algorithm) | Translate | [package, static]
translate(ColorProcessingAlgorithm algorithm) | Translate | [package, static]
translate(FlyCapture2::ImageFileFormat fileFmt) | Translate | [package, static]
translate(ImageFileFormat fileFmt) | Translate | [package, static]
translate(FlyCapture2::TIFFOption::CompressionMethod method) | Translate | [package, static]
translate(TiffOption::CompressionMethod method) | Translate | [package, static]
translate(FlyCapture2::ImageStatistics::StatisticsChannel channel) | Translate | [package, static]
translate(StatisticsChannel channel) | Translate | [package, static]
translate(FlyCapture2::OSType osType) | Translate | [package, static]
translate(OSType osType) | Translate | [package, static]
translate(FlyCapture2::ByteOrder byteOrder) | Translate | [package, static]
translate(ByteOrder byteOrder) | Translate | [package, static]
translate(FlyCapture2::GigEPropertyType propType) | Translate | [package, static]
translate(GigEPropertyType propType) | Translate | [package, static]
Translate::ToMgd(FlyCapture2::GigEConfig *pNative, GigEConfig^ mgd) | Translate | [package, static]
Translate::ToNative(GigEConfig^ mgd, FlyCapture2::GigEConfig *pNative) | Translate | [package, static]
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • Jpeg : TiffOption
  • JpegOption() : JpegOption
  • Jpg2Option() : Jpg2Option
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- k -

  • keyword : ConfigROM
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • LaunchBrowser() : ManagedUtilities
  • LaunchCommand() : ManagedUtilities
  • LaunchCommandAsync() : ManagedUtilities
  • LaunchHelp() : ManagedUtilities
  • libraryList : SystemInfo
  • libraryVersion : ManagedUtilities
  • Lzw : TiffOption
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • m_allInternalCameraEvents : ManagedCameraBase
  • m_externalDelegate : ManagedCameraBase , ManagedUtilities
  • m_internalCameraEventDelegate : ManagedCameraBase
  • m_internalDelegate : ManagedCameraBase , ManagedUtilities
  • m_isLocal : ManagedCameraBase
  • m_p : ManagedCameraBase
  • m_pNativeCamBase : ManagedCameraBase
  • m_specificInternalCameraEvents : ManagedCameraBase
  • macAddress : CameraInfo
  • major : FC2Version
  • ManagedAVIRecorder() : ManagedAVIRecorder
  • ManagedBusManager() : ManagedBusManager
  • ManagedCamera() : ManagedCamera
  • ManagedCameraBase() : ManagedCameraBase
  • ManagedGCCamera() : ManagedGCCamera
  • ManagedGCPort() : ManagedGCPort
  • ManagedGigECamera() : ManagedGigECamera
  • ManagedImage() : ManagedImage
  • ManagedImageStatistics() : ManagedImageStatistics
  • ManagedPGRGuid() : ManagedPGRGuid
  • ManagedTopologyNode() : ManagedTopologyNode
  • manualSupported : CameraPropertyInfo
  • max : GigEProperty , CameraPropertyInfo
  • maxBytesPerPacket : Format7PacketInfo
  • maxHeight : GigEImageSettingsInfo , Format7Info
  • maximumBusSpeed : CameraInfo
  • maxPacketSize : Format7Info
  • maxValue : StrobeInfo
  • maxWidth : Format7Info , GigEImageSettingsInfo
  • microSeconds : TimeStamp
  • min : CameraPropertyInfo , GigEProperty
  • minNumImageNotifications : FC2Config
  • minor : FC2Version
  • minPacketSize : Format7Info
  • minValue : StrobeInfo
  • MJPGOption() : MJPGOption
  • mode : Format7ImageSettings , Format7Info , TriggerMode
  • modelName : CameraInfo
  • modeMask : TriggerModeInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • NativeErrorTrace : FC2Exception
  • networkInterfaceIndex : GigEStreamChannel
  • Node : ManagedTopologyNode
  • nodeNumber : CameraInfo
  • NodeType : ManagedTopologyNode
  • nodeVendorId : ConfigROM
  • None : TiffOption
  • NotConnected : ManagedTopologyNode
  • numBanks : LutData
  • numBuffers : FC2Config
  • numChannels : LutData
  • numCpuCores : SystemInfo
  • numCurrents : CameraStats
  • numEntries : LutData
  • numImageNotifications : FC2Config
  • numResendPacketsReceived : CameraStats
  • numResendPacketsRequested : CameraStats
  • numVoltages : CameraStats
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • offsetHStepSize : GigEImageSettingsInfo , Format7Info
  • offsetVStepSize : Format7Info , GigEImageSettingsInfo
  • offsetX : GigEImageSettings , Format7ImageSettings
  • offsetY : Format7ImageSettings , GigEImageSettings
  • onePush : CameraProperty
  • onePushSupported : CameraPropertyInfo
  • OnNativeCallback() : ManagedCameraBase , ManagedUtilities
  • OnNativeCameraEventCallback() : ManagedCameraBase
  • onOff : StrobeControl , EmbeddedImageInfoProperty , TriggerMode , CameraProperty
  • onOffSupported : CameraPropertyInfo , StrobeInfo , TriggerModeInfo
  • operator!=() : ManagedPGRGuid
  • operator=() : ManagedPGRGuid
  • operator==() : ManagedPGRGuid
  • osDescription : SystemInfo
  • osType : SystemInfo
  • outputBitDepth : LutData
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~CameraControlDialog() : CameraControlDialog
  • ~CameraSelectionDialog() : CameraSelectionDialog
  • ~FC2Exception() : FC2Exception
  • ~ManagedAVIRecorder() : ManagedAVIRecorder
  • ~ManagedBusManager() : ManagedBusManager
  • ~ManagedCamera() : ManagedCamera
  • ~ManagedCameraBase() : ManagedCameraBase
  • ~ManagedGCCamera() : ManagedGCCamera
  • ~ManagedGCPort() : ManagedGCPort
  • ~ManagedGigECamera() : ManagedGigECamera
  • ~ManagedImage() : ManagedImage
  • ~ManagedImageStatistics() : ManagedImageStatistics
  • ~ManagedTopologyNode() : ManagedTopologyNode
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • absControl : CameraProperty
  • absMax : CameraPropertyInfo
  • absMin : CameraPropertyInfo
  • absValSupported : CameraPropertyInfo
  • absValue : CameraProperty
  • AdobeDeflate : TiffOption
  • applicationIPAddress : CameraInfo
  • applicationPort : CameraInfo
  • asyncBusSpeed : FC2Config
  • autoManualMode : CameraProperty
  • autoSupported : CameraPropertyInfo
  • available : EmbeddedImageInfoProperty
  • AVIAppend() : ManagedAVIRecorder
  • AVIClose() : ManagedAVIRecorder
  • AVIOpen() : ManagedAVIRecorder
  • AviOption() : AviOption
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • bandwidthAllocation : FC2Config
  • bayerTileFormat : CameraInfo , ManagedImage
  • binaryFile : PpmOption , PgmOption
  • bitmap : ManagedImage
  • bitrate : H264Option
  • bitsPerPixel : ManagedImage
  • blockId : ManagedImage
  • BMPOption() : BMPOption
  • brightness : EmbeddedImageInfo
  • build : FC2Version
  • Bus : ManagedTopologyNode
  • busNumber : CameraInfo
  • byteOrder : SystemInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • CalculateStatistics() : ManagedImage
  • Camera : ManagedTopologyNode
  • CameraControlDialog() : CameraControlDialog
  • cameraCurrents : CameraStats
  • cameraPowerUp : CameraStats
  • CameraProperty() : CameraProperty
  • CameraPropertyInfo() : CameraPropertyInfo
  • CameraSelectionDialog() : CameraSelectionDialog
  • CameraStats() : CameraStats
  • cameraVoltages : CameraStats
  • CauseType : FC2Exception
  • CcittFax3 : TiffOption
  • CcittFax4 : TiffOption
  • ccpStatus : CameraInfo
  • CheckDriver() : ManagedUtilities
  • chipIdHi : ConfigROM
  • chipIdLo : ConfigROM
  • colorProcessingAlgorithm : ManagedImage
  • cols : ManagedImage
  • compression : TiffOption
  • compressionLevel : PngOption
  • CompressionMethod : TiffOption
  • Computer : ManagedTopologyNode
  • configROM : CameraInfo
  • Connect() : ManagedGigECamera , ManagedCamera , ManagedGCCamera , ManagedCameraBase , CameraControlDialog , ManagedGCCamera
  • ConnectedToChild : ManagedTopologyNode
  • ConnectedToParent : ManagedTopologyNode
  • Convert() : ManagedImage
  • ConvertToManagedGuid() : ManagedBusManager
  • ConvertToNativeGuid() : ManagedBusManager
  • cpuDescription : SystemInfo
  • cycleCount : TimeStamp
  • cycleOffset : TimeStamp
  • cycleSeconds : TimeStamp
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • data : ManagedImage
  • dataSize : ManagedImage
  • defaultColorProcessingAlgorithm : ManagedImage
  • defaultGateway : CameraInfo
  • defaultOutputPixelFormat : ManagedImage
  • Deflate : TiffOption
  • delay : StrobeControl
  • DeregisterAllEvents() : ManagedCameraBase
  • DeregisterEvent() : ManagedCameraBase
  • destinationIpAddress : GigEStreamChannel
  • DetermineBitsPerPixel() : ManagedImage
  • DisableAll() : ManagedImageStatistics
  • Disconnect() : ManagedGCCamera , ManagedCameraBase , CameraControlDialog
  • DiscoverGigECameras() : ManagedBusManager
  • DiscoverGigEPacketSize() : ManagedGigECamera
  • doNotFragment : GigEStreamChannel
  • driverList : SystemInfo
  • driverName : CameraInfo
  • driverType : CameraInfo
  • duration : StrobeControl
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • embeddedBrightness : ImageMetadata
  • embeddedExposure : ImageMetadata
  • embeddedFrameCounter : ImageMetadata
  • embeddedGain : ImageMetadata
  • embeddedGPIOPinState : ImageMetadata
  • EmbeddedImageInfo() : EmbeddedImageInfo
  • embeddedROIPosition : ImageMetadata
  • embeddedShutter : ImageMetadata
  • embeddedStrobePattern : ImageMetadata
  • embeddedTimeStamp : ImageMetadata
  • embeddedWhiteBalance : ImageMetadata
  • EnableAll() : ManagedImageStatistics
  • enabled : LutData
  • EnableGreyOnly() : ManagedImageStatistics
  • EnableHSLOnly() : ManagedImageStatistics
  • EnableLUT() : ManagedCameraBase
  • enablePacketResend : GigEConfig
  • EnableRGBOnly() : ManagedImageStatistics
  • Equals() : ManagedPGRGuid
  • EventCallbackFcn : ManagedEventOptions
  • EventID : ManagedEventCallbackData
  • EventName : ManagedEventCallbackData , ManagedEventOptions
  • EventTimestamp : ManagedEventCallbackData
  • exposure : EmbeddedImageInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • FC2Config() : FC2Config
  • FC2Exception() : FC2Exception
  • FireBusReset() : ManagedBusManager
  • FireSoftwareTrigger() : ManagedCameraBase
  • firmwareBuildTime : CameraInfo
  • firmwareVersion : CameraInfo
  • ForceAllIPAddressesAutomatically() : ManagedBusManager
  • ForceIPAddressToCamera() : ManagedBusManager
  • frameCounter : EmbeddedImageInfo
  • frameRate : AviOption , MJPGOption , H264Option
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • gain : EmbeddedImageInfo
  • GetActiveLUTBank() : ManagedCameraBase
  • GetCameraFromIndex() : ManagedBusManager
  • GetCameraFromIPAddress() : ManagedBusManager
  • GetCameraFromSerialNumber() : ManagedBusManager
  • GetCameraInfo() : ManagedCameraBase
  • GetCameraSerialNumberFromIndex() : ManagedBusManager
  • GetChannelStatus() : ManagedImageStatistics
  • GetChild() : ManagedTopologyNode
  • GetConfiguration() : ManagedCameraBase
  • GetCycleTime() : ManagedCameraBase
  • GetDeviceFromIndex() : ManagedBusManager
  • GetDeviceId() : ManagedTopologyNode
  • GetDimensions() : ManagedImage
  • GetDriverDeviceName() : ManagedUtilities
  • GetEmbeddedImageInfo() : ManagedCameraBase
  • GetFormat7Configuration() : ManagedCamera
  • GetFormat7Info() : ManagedCamera
  • GetGigEConfig() : ManagedGigECamera
  • GetGigEImageBinningSettings() : ManagedGigECamera
  • GetGigEImageSettings() : ManagedGigECamera
  • GetGigEImageSettingsInfo() : ManagedGigECamera
  • GetGigEImagingMode() : ManagedGigECamera
  • GetGigEProperty() : ManagedGigECamera
  • GetGigEStreamChannelInfo() : ManagedGigECamera
  • GetGPIOPinDirection() : ManagedCameraBase
  • GetGuid() : ManagedTopologyNode
  • GetHashCode() : ManagedPGRGuid
  • GetHistogram() : ManagedImageStatistics
  • GetInterfaceType() : ManagedTopologyNode
  • GetInterfaceTypeFromGuid() : ManagedBusManager
  • GetLUTBankInfo() : ManagedCameraBase
  • GetLUTChannel() : ManagedCameraBase
  • GetLUTInfo() : ManagedCameraBase
  • GetMean() : ManagedImageStatistics
  • GetMemoryChannel() : ManagedCameraBase
  • GetMemoryChannelInfo() : ManagedCameraBase
  • GetNativeCamera() : ManagedCameraBase
  • GetNativeImage() : ManagedImage
  • GetNativeImageStatistics() : ManagedImageStatistics
  • GetNodeMap() : ManagedGCCamera
  • GetNodeType() : ManagedTopologyNode
  • GetNumChildren() : ManagedTopologyNode
  • GetNumOfCameras() : ManagedBusManager
  • GetNumOfDevices() : ManagedBusManager
  • GetNumPixelValues() : ManagedImageStatistics
  • GetNumPorts() : ManagedTopologyNode
  • GetNumStreamChannels() : ManagedGigECamera
  • GetPixelValueRange() : ManagedImageStatistics
  • GetPortType() : ManagedTopologyNode
  • GetProperty() : ManagedCameraBase
  • GetPropertyInfo() : ManagedCameraBase
  • GetRange() : ManagedImageStatistics
  • GetRawNativeImagePointer() : ManagedImage
  • GetRegisterString() : ManagedCameraBase
  • GetSelectedCameraGuids() : CameraSelectionDialog
  • GetStatistics() : ManagedImageStatistics
  • GetStats() : ManagedCameraBase
  • GetStrobe() : ManagedCameraBase
  • GetStrobeInfo() : ManagedCameraBase
  • GetTopology() : ManagedBusManager
  • GetTriggerDelay() : ManagedCameraBase
  • GetTriggerDelayInfo() : ManagedCameraBase
  • GetTriggerMode() : ManagedCameraBase
  • GetTriggerModeInfo() : ManagedCameraBase
  • GetUsbLinkInfo() : ManagedBusManager
  • GetUsbPortStatus() : ManagedBusManager
  • GetVideoModeAndFrameRate() : ManagedCamera
  • GetVideoModeAndFrameRateInfo() : ManagedCamera
  • gigEMajorVersion : CameraInfo
  • gigEMinorVersion : CameraInfo
  • GPIOPinState : EmbeddedImageInfo
  • gpuDescription : SystemInfo
  • grabMode : FC2Config
  • grabTimeout : FC2Config
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • H264Option() : H264Option
  • height : GigEImageSettings , H264Option , Format7ImageSettings
  • Hide() : CameraControlDialog
  • highPerformanceRetrieveBuffer : FC2Config
  • hostPort : GigEStreamChannel
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • iidcVersion : CameraInfo
  • imageCorrupt : CameraStats
  • imageDriverDropped : CameraStats
  • imageDropped : CameraStats
  • imageHStepSize : GigEImageSettingsInfo , Format7Info
  • imageMetadata : ManagedImage
  • imageVStepSize : GigEImageSettingsInfo , Format7Info
  • imageXmitFailed : CameraStats
  • indexedColor_8bit : BMPOption
  • inputBitDepth : LutData
  • interfaceType : CameraInfo
  • interlaced : PngOption
  • interPacketDelay : GigEStreamChannel
  • ipAddress : CameraInfo
  • IsCameraControlable() : ManagedBusManager
  • isColorCamera : CameraInfo
  • IsConnected() : ManagedCameraBase
  • IsNativeImageValid() : ManagedImage
  • isochBusSpeed : FC2Config
  • isReadable : GigEProperty
  • IsVisible() : CameraControlDialog
  • isWritable : GigEProperty
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • PackBits : TiffOption
  • packetSize : GigEStreamChannel , Format7Info
  • parameter : TriggerMode
  • pcieBusSpeed : CameraInfo
  • percentage : Format7Info
  • PgmOption() : PgmOption
  • pixelFormat : GigEImageSettings , Format7ImageSettings , ManagedImage
  • pixelFormatBitField : GigEImageSettingsInfo , Format7Info
  • PngOption() : PngOption
  • polarity : TriggerMode , StrobeControl
  • polaritySupported : TriggerModeInfo , StrobeInfo
  • portErrors : CameraStats
  • PortType : ManagedTopologyNode
  • PpmOption() : PpmOption
  • present : CameraPropertyInfo , TriggerModeInfo , CameraProperty , StrobeInfo
  • progressive : JpegOption
  • propType : GigEProperty
  • ptr : NativeEventStruct
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • quality : JpegOption , Jpg2Option , MJPGOption
  • QueryGigEImagingMode() : ManagedGigECamera
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • Read() : ManagedGCPort
  • ReadGVCPMemory() : ManagedGigECamera
  • ReadGVCPRegister() : ManagedGigECamera
  • ReadGVCPRegisterBlock() : ManagedGigECamera
  • readOutSupported : CameraPropertyInfo , TriggerModeInfo , StrobeInfo
  • ReadPhyRegister() : ManagedBusManager
  • ReadRegister() : ManagedCameraBase
  • ReadRegisterBlock() : ManagedCameraBase
  • receivedDataSize : ManagedImage
  • recommendedBytesPerPacket : Format7PacketInfo
  • RegisterAllEvents() : ManagedCameraBase
  • RegisterCallback() : ManagedBusManager
  • RegisterEvent() : ManagedCameraBase
  • registerTimeout : FC2Config
  • registerTimeoutRetries : FC2Config
  • regReadFailed : CameraStats
  • regWriteFailed : CameraStats
  • ReleaseBuffer() : ManagedImage
  • RescanBus() : ManagedBusManager
  • ResetStats() : ManagedCameraBase
  • RestoreFromMemoryChannel() : ManagedCameraBase
  • RetrieveBuffer() : ManagedCameraBase
  • ROIPosition : EmbeddedImageInfo
  • rows : ManagedImage
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • Save() : ManagedImage
  • SaveToMemoryChannel() : ManagedCameraBase
  • screenHeight : SystemInfo
  • screenWidth : SystemInfo
  • seconds : TimeStamp
  • sensorInfo : CameraInfo
  • sensorResolution : CameraInfo
  • serialNumber : CameraInfo
  • SetActiveLUTBank() : ManagedCameraBase
  • SetCallback() : ManagedCameraBase
  • SetCamera() : ManagedCameraBase , ManagedGCCamera
  • SetChannelStatus() : ManagedImageStatistics
  • SetConfiguration() : ManagedCameraBase
  • SetData() : ManagedImage
  • SetDimensions() : ManagedImage
  • SetEmbeddedImageInfo() : ManagedCameraBase
  • SetFormat7Configuration() : ManagedCamera
  • SetGigEConfig() : ManagedGigECamera
  • SetGigEImageBinningSettings() : ManagedGigECamera
  • SetGigEImageSettings() : ManagedGigECamera
  • SetGigEImagingMode() : ManagedGigECamera
  • SetGigEProperty() : ManagedGigECamera
  • SetGigEStreamChannelInfo() : ManagedGigECamera
  • SetGPIOPinDirection() : ManagedCameraBase
  • SetLUTChannel() : ManagedCameraBase
  • SetMaximumAVISize() : ManagedAVIRecorder
  • SetProperty() : ManagedCameraBase
  • SetStrobe() : ManagedCameraBase
  • SetTitle() : CameraControlDialog , CameraSelectionDialog
  • SetTriggerDelay() : ManagedCameraBase
  • SetTriggerMode() : ManagedCameraBase
  • SetUserBuffers() : ManagedCameraBase
  • SetVideoModeAndFrameRate() : ManagedCamera
  • Show() : CameraControlDialog
  • ShowModal() : CameraSelectionDialog
  • shutter : EmbeddedImageInfo
  • softwareTriggerSupported : TriggerModeInfo
  • source : TriggerMode , StrobeInfo , StrobeControl
  • sourceMask : TriggerModeInfo
  • sourcePort : GigEStreamChannel
  • StartCapture() : ManagedCameraBase
  • StartSyncCapture() : ManagedCamera
  • StopCapture() : ManagedCameraBase
  • stride : ManagedImage
  • strobePattern : EmbeddedImageInfo
  • subnetMask : CameraInfo
  • supported : LutData
  • systemInfo : ManagedUtilities
  • systemMemorySize : SystemInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • temperature : CameraStats
  • TiffOption() : TiffOption
  • timeSinceBusReset : CameraStats
  • timeSinceInitialization : CameraStats
  • timeStamp : CameraStats , ManagedImage
  • timestamp : EmbeddedImageInfo
  • ToMgd() : Translate
  • ToNative() : Translate
  • translate() : Translate
  • Translate::ToMgd() : Translate
  • Translate::ToNative() : Translate
  • TranslateNodeType() : ManagedTopologyNode
  • TranslatePortType() : ManagedTopologyNode
  • type : FC2Version , CameraProperty
  • Type : FC2Exception
  • type : CameraPropertyInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • unitAbbr : CameraPropertyInfo
  • unitBytesPerPacket : Format7PacketInfo
  • units : CameraPropertyInfo
  • unitSpecId : ConfigROM
  • unitSubSWVer : ConfigROM
  • unitSWVer : ConfigROM
  • UnregisterCallback() : ManagedBusManager
  • userDefinedName : CameraInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • ValidateFormat7Settings() : ManagedCamera
  • value : GigEProperty
  • value0 : ManagedPGRGuid
  • value1 : ManagedPGRGuid
  • value2 : ManagedPGRGuid
  • value3 : ManagedPGRGuid
  • valueA : CameraProperty
  • valueB : CameraProperty
  • valueReadable : TriggerModeInfo
  • vendorName : CameraInfo
  • vendorPixelFormatBitField : GigEImageSettingsInfo , Format7Info
  • vendorUniqueInfo0 : ConfigROM
  • vendorUniqueInfo1 : ConfigROM
  • vendorUniqueInfo2 : ConfigROM
  • vendorUniqueInfo3 : ConfigROM
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitForBufferEvent() : ManagedCameraBase
  • whiteBalance : EmbeddedImageInfo
  • width : Format7ImageSettings , H264Option , GigEImageSettings
  • Write() : ManagedGCPort
  • WriteGVCPMemory() : ManagedGigECamera
  • WriteGVCPRegister() : ManagedGigECamera
  • WriteGVCPRegisterBlock() : ManagedGigECamera
  • WritePhyRegister() : ManagedBusManager
  • WriteRegister() : ManagedCameraBase
  • WriteRegisterBlock() : ManagedCameraBase
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all class members with links to the classes they belong to:

- x -

  • xmlURL1 : CameraInfo
  • xmlURL2 : CameraInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • CompressionMethod : TiffOption
  • NodeType : ManagedTopologyNode
  • PortType : ManagedTopologyNode
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Enumerator

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • AdobeDeflate : TiffOption
  • Bus : ManagedTopologyNode
  • Camera : ManagedTopologyNode
  • CcittFax3 : TiffOption
  • CcittFax4 : TiffOption
  • Computer : ManagedTopologyNode
  • ConnectedToChild : ManagedTopologyNode
  • ConnectedToParent : ManagedTopologyNode
  • Deflate : TiffOption
  • Jpeg : TiffOption
  • Lzw : TiffOption
  • Node : ManagedTopologyNode
  • None : TiffOption
  • NotConnected : ManagedTopologyNode
  • PackBits : TiffOption
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ! -

  • !ManagedBusManager() : ManagedBusManager
  • !ManagedCamera() : ManagedCamera
  • !ManagedGCCamera() : ManagedGCCamera
  • !ManagedGigECamera() : ManagedGigECamera
  • !ManagedImage() : ManagedImage
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- j -

  • JpegOption() : JpegOption
  • Jpg2Option() : Jpg2Option
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • LaunchBrowser() : ManagedUtilities
  • LaunchCommand() : ManagedUtilities
  • LaunchCommandAsync() : ManagedUtilities
  • LaunchHelp() : ManagedUtilities
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • ManagedAVIRecorder() : ManagedAVIRecorder
  • ManagedBusManager() : ManagedBusManager
  • ManagedCamera() : ManagedCamera
  • ManagedCameraBase() : ManagedCameraBase
  • ManagedGCCamera() : ManagedGCCamera
  • ManagedGCPort() : ManagedGCPort
  • ManagedGigECamera() : ManagedGigECamera
  • ManagedImage() : ManagedImage
  • ManagedImageStatistics() : ManagedImageStatistics
  • ManagedPGRGuid() : ManagedPGRGuid
  • ManagedTopologyNode() : ManagedTopologyNode
  • MJPGOption() : MJPGOption
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • OnNativeCallback() : ManagedCameraBase , ManagedUtilities
  • OnNativeCameraEventCallback() : ManagedCameraBase
  • operator!=() : ManagedPGRGuid
  • operator=() : ManagedPGRGuid
  • operator==() : ManagedPGRGuid
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~CameraControlDialog() : CameraControlDialog
  • ~CameraSelectionDialog() : CameraSelectionDialog
  • ~FC2Exception() : FC2Exception
  • ~ManagedAVIRecorder() : ManagedAVIRecorder
  • ~ManagedBusManager() : ManagedBusManager
  • ~ManagedCamera() : ManagedCamera
  • ~ManagedCameraBase() : ManagedCameraBase
  • ~ManagedGCCamera() : ManagedGCCamera
  • ~ManagedGCPort() : ManagedGCPort
  • ~ManagedGigECamera() : ManagedGigECamera
  • ~ManagedImage() : ManagedImage
  • ~ManagedImageStatistics() : ManagedImageStatistics
  • ~ManagedTopologyNode() : ManagedTopologyNode
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • AVIAppend() : ManagedAVIRecorder
  • AVIClose() : ManagedAVIRecorder
  • AVIOpen() : ManagedAVIRecorder
  • AviOption() : AviOption
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • BMPOption() : BMPOption
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • CalculateStatistics() : ManagedImage
  • CameraControlDialog() : CameraControlDialog
  • CameraProperty() : CameraProperty
  • CameraPropertyInfo() : CameraPropertyInfo
  • CameraSelectionDialog() : CameraSelectionDialog
  • CameraStats() : CameraStats
  • CheckDriver() : ManagedUtilities
  • Connect() : ManagedCameraBase , ManagedGCCamera , ManagedCamera , ManagedGCCamera , ManagedGigECamera , CameraControlDialog
  • Convert() : ManagedImage
  • ConvertToManagedGuid() : ManagedBusManager
  • ConvertToNativeGuid() : ManagedBusManager
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • DeregisterAllEvents() : ManagedCameraBase
  • DeregisterEvent() : ManagedCameraBase
  • DetermineBitsPerPixel() : ManagedImage
  • DisableAll() : ManagedImageStatistics
  • Disconnect() : ManagedGCCamera , ManagedCameraBase , CameraControlDialog
  • DiscoverGigECameras() : ManagedBusManager
  • DiscoverGigEPacketSize() : ManagedGigECamera
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • EmbeddedImageInfo() : EmbeddedImageInfo
  • EnableAll() : ManagedImageStatistics
  • EnableGreyOnly() : ManagedImageStatistics
  • EnableHSLOnly() : ManagedImageStatistics
  • EnableLUT() : ManagedCameraBase
  • EnableRGBOnly() : ManagedImageStatistics
  • Equals() : ManagedPGRGuid
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • FC2Config() : FC2Config
  • FC2Exception() : FC2Exception
  • FireBusReset() : ManagedBusManager
  • FireSoftwareTrigger() : ManagedCameraBase
  • ForceAllIPAddressesAutomatically() : ManagedBusManager
  • ForceIPAddressToCamera() : ManagedBusManager
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • GetActiveLUTBank() : ManagedCameraBase
  • GetCameraFromIndex() : ManagedBusManager
  • GetCameraFromIPAddress() : ManagedBusManager
  • GetCameraFromSerialNumber() : ManagedBusManager
  • GetCameraInfo() : ManagedCameraBase
  • GetCameraSerialNumberFromIndex() : ManagedBusManager
  • GetChannelStatus() : ManagedImageStatistics
  • GetChild() : ManagedTopologyNode
  • GetConfiguration() : ManagedCameraBase
  • GetCycleTime() : ManagedCameraBase
  • GetDeviceFromIndex() : ManagedBusManager
  • GetDeviceId() : ManagedTopologyNode
  • GetDimensions() : ManagedImage
  • GetDriverDeviceName() : ManagedUtilities
  • GetEmbeddedImageInfo() : ManagedCameraBase
  • GetFormat7Configuration() : ManagedCamera
  • GetFormat7Info() : ManagedCamera
  • GetGigEConfig() : ManagedGigECamera
  • GetGigEImageBinningSettings() : ManagedGigECamera
  • GetGigEImageSettings() : ManagedGigECamera
  • GetGigEImageSettingsInfo() : ManagedGigECamera
  • GetGigEImagingMode() : ManagedGigECamera
  • GetGigEProperty() : ManagedGigECamera
  • GetGigEStreamChannelInfo() : ManagedGigECamera
  • GetGPIOPinDirection() : ManagedCameraBase
  • GetGuid() : ManagedTopologyNode
  • GetHashCode() : ManagedPGRGuid
  • GetHistogram() : ManagedImageStatistics
  • GetInterfaceType() : ManagedTopologyNode
  • GetInterfaceTypeFromGuid() : ManagedBusManager
  • GetLUTBankInfo() : ManagedCameraBase
  • GetLUTChannel() : ManagedCameraBase
  • GetLUTInfo() : ManagedCameraBase
  • GetMean() : ManagedImageStatistics
  • GetMemoryChannel() : ManagedCameraBase
  • GetMemoryChannelInfo() : ManagedCameraBase
  • GetNativeCamera() : ManagedCameraBase
  • GetNativeImage() : ManagedImage
  • GetNativeImageStatistics() : ManagedImageStatistics
  • GetNodeMap() : ManagedGCCamera
  • GetNodeType() : ManagedTopologyNode
  • GetNumChildren() : ManagedTopologyNode
  • GetNumOfCameras() : ManagedBusManager
  • GetNumOfDevices() : ManagedBusManager
  • GetNumPixelValues() : ManagedImageStatistics
  • GetNumPorts() : ManagedTopologyNode
  • GetNumStreamChannels() : ManagedGigECamera
  • GetPixelValueRange() : ManagedImageStatistics
  • GetPortType() : ManagedTopologyNode
  • GetProperty() : ManagedCameraBase
  • GetPropertyInfo() : ManagedCameraBase
  • GetRange() : ManagedImageStatistics
  • GetRawNativeImagePointer() : ManagedImage
  • GetRegisterString() : ManagedCameraBase
  • GetSelectedCameraGuids() : CameraSelectionDialog
  • GetStatistics() : ManagedImageStatistics
  • GetStats() : ManagedCameraBase
  • GetStrobe() : ManagedCameraBase
  • GetStrobeInfo() : ManagedCameraBase
  • GetTopology() : ManagedBusManager
  • GetTriggerDelay() : ManagedCameraBase
  • GetTriggerDelayInfo() : ManagedCameraBase
  • GetTriggerMode() : ManagedCameraBase
  • GetTriggerModeInfo() : ManagedCameraBase
  • GetUsbLinkInfo() : ManagedBusManager
  • GetUsbPortStatus() : ManagedBusManager
  • GetVideoModeAndFrameRate() : ManagedCamera
  • GetVideoModeAndFrameRateInfo() : ManagedCamera
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • H264Option() : H264Option
  • Hide() : CameraControlDialog
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • IsCameraControlable() : ManagedBusManager
  • IsConnected() : ManagedCameraBase
  • IsNativeImageValid() : ManagedImage
  • IsVisible() : CameraControlDialog
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • PgmOption() : PgmOption
  • PngOption() : PngOption
  • PpmOption() : PpmOption
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- q -

  • QueryGigEImagingMode() : ManagedGigECamera
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • Read() : ManagedGCPort
  • ReadGVCPMemory() : ManagedGigECamera
  • ReadGVCPRegister() : ManagedGigECamera
  • ReadGVCPRegisterBlock() : ManagedGigECamera
  • ReadPhyRegister() : ManagedBusManager
  • ReadRegister() : ManagedCameraBase
  • ReadRegisterBlock() : ManagedCameraBase
  • RegisterAllEvents() : ManagedCameraBase
  • RegisterCallback() : ManagedBusManager
  • RegisterEvent() : ManagedCameraBase
  • ReleaseBuffer() : ManagedImage
  • RescanBus() : ManagedBusManager
  • ResetStats() : ManagedCameraBase
  • RestoreFromMemoryChannel() : ManagedCameraBase
  • RetrieveBuffer() : ManagedCameraBase
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • Save() : ManagedImage
  • SaveToMemoryChannel() : ManagedCameraBase
  • SetActiveLUTBank() : ManagedCameraBase
  • SetCallback() : ManagedCameraBase
  • SetCamera() : ManagedCameraBase , ManagedGCCamera
  • SetChannelStatus() : ManagedImageStatistics
  • SetConfiguration() : ManagedCameraBase
  • SetData() : ManagedImage
  • SetDimensions() : ManagedImage
  • SetEmbeddedImageInfo() : ManagedCameraBase
  • SetFormat7Configuration() : ManagedCamera
  • SetGigEConfig() : ManagedGigECamera
  • SetGigEImageBinningSettings() : ManagedGigECamera
  • SetGigEImageSettings() : ManagedGigECamera
  • SetGigEImagingMode() : ManagedGigECamera
  • SetGigEProperty() : ManagedGigECamera
  • SetGigEStreamChannelInfo() : ManagedGigECamera
  • SetGPIOPinDirection() : ManagedCameraBase
  • SetLUTChannel() : ManagedCameraBase
  • SetMaximumAVISize() : ManagedAVIRecorder
  • SetProperty() : ManagedCameraBase
  • SetStrobe() : ManagedCameraBase
  • SetTitle() : CameraControlDialog , CameraSelectionDialog
  • SetTriggerDelay() : ManagedCameraBase
  • SetTriggerMode() : ManagedCameraBase
  • SetUserBuffers() : ManagedCameraBase
  • SetVideoModeAndFrameRate() : ManagedCamera
  • Show() : CameraControlDialog
  • ShowModal() : CameraSelectionDialog
  • StartCapture() : ManagedCameraBase
  • StartSyncCapture() : ManagedCamera
  • StopCapture() : ManagedCameraBase
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • TiffOption() : TiffOption
  • ToMgd() : Translate
  • ToNative() : Translate
  • translate() : Translate
  • Translate::ToMgd() : Translate
  • Translate::ToNative() : Translate
  • TranslateNodeType() : ManagedTopologyNode
  • TranslatePortType() : ManagedTopologyNode
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • UnregisterCallback() : ManagedBusManager
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • ValidateFormat7Settings() : ManagedCamera
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • !
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • WaitForBufferEvent() : ManagedCameraBase
  • Write() : ManagedGCPort
  • WriteGVCPMemory() : ManagedGigECamera
  • WriteGVCPRegister() : ManagedGigECamera
  • WriteGVCPRegisterBlock() : ManagedGigECamera
  • WritePhyRegister() : ManagedBusManager
  • WriteRegister() : ManagedCameraBase
  • WriteRegisterBlock() : ManagedCameraBase
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- a -

  • absControl : CameraProperty
  • absMax : CameraPropertyInfo
  • absMin : CameraPropertyInfo
  • absValSupported : CameraPropertyInfo
  • absValue : CameraProperty
  • applicationIPAddress : CameraInfo
  • applicationPort : CameraInfo
  • asyncBusSpeed : FC2Config
  • autoManualMode : CameraProperty
  • autoSupported : CameraPropertyInfo
  • available : EmbeddedImageInfoProperty
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- k -

  • keyword : ConfigROM
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- l -

  • libraryList : SystemInfo
  • libraryVersion : ManagedUtilities
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- m -

  • macAddress : CameraInfo
  • major : FC2Version
  • manualSupported : CameraPropertyInfo
  • max : GigEProperty , CameraPropertyInfo
  • maxBytesPerPacket : Format7PacketInfo
  • maxHeight : Format7Info , GigEImageSettingsInfo
  • maximumBusSpeed : CameraInfo
  • maxPacketSize : Format7Info
  • maxValue : StrobeInfo
  • maxWidth : GigEImageSettingsInfo , Format7Info
  • microSeconds : TimeStamp
  • min : CameraPropertyInfo , GigEProperty
  • minNumImageNotifications : FC2Config
  • minor : FC2Version
  • minPacketSize : Format7Info
  • minValue : StrobeInfo
  • mode : TriggerMode , Format7Info , Format7ImageSettings
  • modelName : CameraInfo
  • modeMask : TriggerModeInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- n -

  • NativeErrorTrace : FC2Exception
  • networkInterfaceIndex : GigEStreamChannel
  • nodeNumber : CameraInfo
  • nodeVendorId : ConfigROM
  • numBanks : LutData
  • numBuffers : FC2Config
  • numChannels : LutData
  • numCpuCores : SystemInfo
  • numCurrents : CameraStats
  • numEntries : LutData
  • numImageNotifications : FC2Config
  • numResendPacketsReceived : CameraStats
  • numResendPacketsRequested : CameraStats
  • numVoltages : CameraStats
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- o -

  • offsetHStepSize : GigEImageSettingsInfo , Format7Info
  • offsetVStepSize : Format7Info , GigEImageSettingsInfo
  • offsetX : GigEImageSettings , Format7ImageSettings
  • offsetY : Format7ImageSettings , GigEImageSettings
  • onePush : CameraProperty
  • onePushSupported : CameraPropertyInfo
  • onOff : CameraProperty , TriggerMode , StrobeControl , EmbeddedImageInfoProperty
  • onOffSupported : CameraPropertyInfo , TriggerModeInfo , StrobeInfo
  • osDescription : SystemInfo
  • osType : SystemInfo
  • outputBitDepth : LutData
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- b -

  • bandwidthAllocation : FC2Config
  • bayerTileFormat : CameraInfo , ManagedImage
  • binaryFile : PpmOption , PgmOption
  • bitmap : ManagedImage
  • bitrate : H264Option
  • bitsPerPixel : ManagedImage
  • blockId : ManagedImage
  • brightness : EmbeddedImageInfo
  • build : FC2Version
  • busNumber : CameraInfo
  • byteOrder : SystemInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- c -

  • cameraCurrents : CameraStats
  • cameraPowerUp : CameraStats
  • cameraVoltages : CameraStats
  • CauseType : FC2Exception
  • ccpStatus : CameraInfo
  • chipIdHi : ConfigROM
  • chipIdLo : ConfigROM
  • colorProcessingAlgorithm : ManagedImage
  • cols : ManagedImage
  • compression : TiffOption
  • compressionLevel : PngOption
  • configROM : CameraInfo
  • cpuDescription : SystemInfo
  • cycleCount : TimeStamp
  • cycleOffset : TimeStamp
  • cycleSeconds : TimeStamp
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- d -

  • data : ManagedImage
  • dataSize : ManagedImage
  • defaultColorProcessingAlgorithm : ManagedImage
  • defaultGateway : CameraInfo
  • defaultOutputPixelFormat : ManagedImage
  • delay : StrobeControl
  • destinationIpAddress : GigEStreamChannel
  • doNotFragment : GigEStreamChannel
  • driverList : SystemInfo
  • driverName : CameraInfo
  • driverType : CameraInfo
  • duration : StrobeControl
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- e -

  • embeddedBrightness : ImageMetadata
  • embeddedExposure : ImageMetadata
  • embeddedFrameCounter : ImageMetadata
  • embeddedGain : ImageMetadata
  • embeddedGPIOPinState : ImageMetadata
  • embeddedROIPosition : ImageMetadata
  • embeddedShutter : ImageMetadata
  • embeddedStrobePattern : ImageMetadata
  • embeddedTimeStamp : ImageMetadata
  • embeddedWhiteBalance : ImageMetadata
  • enabled : LutData
  • enablePacketResend : GigEConfig
  • exposure : EmbeddedImageInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- f -

  • firmwareBuildTime : CameraInfo
  • firmwareVersion : CameraInfo
  • frameCounter : EmbeddedImageInfo
  • frameRate : AviOption , MJPGOption , H264Option
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- g -

  • gain : EmbeddedImageInfo
  • gigEMajorVersion : CameraInfo
  • gigEMinorVersion : CameraInfo
  • GPIOPinState : EmbeddedImageInfo
  • gpuDescription : SystemInfo
  • grabMode : FC2Config
  • grabTimeout : FC2Config
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- h -

  • height : GigEImageSettings , Format7ImageSettings , H264Option
  • highPerformanceRetrieveBuffer : FC2Config
  • hostPort : GigEStreamChannel
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- i -

  • iidcVersion : CameraInfo
  • imageCorrupt : CameraStats
  • imageDriverDropped : CameraStats
  • imageDropped : CameraStats
  • imageHStepSize : GigEImageSettingsInfo , Format7Info
  • imageMetadata : ManagedImage
  • imageVStepSize : GigEImageSettingsInfo , Format7Info
  • imageXmitFailed : CameraStats
  • indexedColor_8bit : BMPOption
  • inputBitDepth : LutData
  • interfaceType : CameraInfo
  • interlaced : PngOption
  • interPacketDelay : GigEStreamChannel
  • ipAddress : CameraInfo
  • isColorCamera : CameraInfo
  • isochBusSpeed : FC2Config
  • isReadable : GigEProperty
  • isWritable : GigEProperty
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- p -

  • packetSize : GigEStreamChannel , Format7Info
  • parameter : TriggerMode
  • pcieBusSpeed : CameraInfo
  • percentage : Format7Info
  • pixelFormat : ManagedImage , GigEImageSettings , Format7ImageSettings
  • pixelFormatBitField : GigEImageSettingsInfo , Format7Info
  • polarity : TriggerMode , StrobeControl
  • polaritySupported : TriggerModeInfo , StrobeInfo
  • portErrors : CameraStats
  • present : CameraPropertyInfo , CameraProperty , StrobeInfo , TriggerModeInfo
  • progressive : JpegOption
  • propType : GigEProperty
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- q -

  • quality : JpegOption , MJPGOption , Jpg2Option
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- r -

  • readOutSupported : CameraPropertyInfo , TriggerModeInfo , StrobeInfo
  • receivedDataSize : ManagedImage
  • recommendedBytesPerPacket : Format7PacketInfo
  • registerTimeout : FC2Config
  • registerTimeoutRetries : FC2Config
  • regReadFailed : CameraStats
  • regWriteFailed : CameraStats
  • ROIPosition : EmbeddedImageInfo
  • rows : ManagedImage
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- s -

  • screenHeight : SystemInfo
  • screenWidth : SystemInfo
  • seconds : TimeStamp
  • sensorInfo : CameraInfo
  • sensorResolution : CameraInfo
  • serialNumber : CameraInfo
  • shutter : EmbeddedImageInfo
  • softwareTriggerSupported : TriggerModeInfo
  • source : TriggerMode , StrobeInfo , StrobeControl
  • sourceMask : TriggerModeInfo
  • sourcePort : GigEStreamChannel
  • stride : ManagedImage
  • strobePattern : EmbeddedImageInfo
  • subnetMask : CameraInfo
  • supported : LutData
  • systemInfo : ManagedUtilities
  • systemMemorySize : SystemInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- t -

  • temperature : CameraStats
  • timeSinceBusReset : CameraStats
  • timeSinceInitialization : CameraStats
  • timeStamp : CameraStats , ManagedImage
  • timestamp : EmbeddedImageInfo
  • type : CameraPropertyInfo
  • Type : FC2Exception
  • type : CameraProperty , FC2Version
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- u -

  • unitAbbr : CameraPropertyInfo
  • unitBytesPerPacket : Format7PacketInfo
  • units : CameraPropertyInfo
  • unitSpecId : ConfigROM
  • unitSubSWVer : ConfigROM
  • unitSWVer : ConfigROM
  • userDefinedName : CameraInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- v -

  • value : GigEProperty
  • valueA : CameraProperty
  • valueB : CameraProperty
  • valueReadable : TriggerModeInfo
  • vendorName : CameraInfo
  • vendorPixelFormatBitField : Format7Info , GigEImageSettingsInfo
  • vendorUniqueInfo0 : ConfigROM
  • vendorUniqueInfo1 : ConfigROM
  • vendorUniqueInfo2 : ConfigROM
  • vendorUniqueInfo3 : ConfigROM
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- w -

  • whiteBalance : EmbeddedImageInfo
  • width : H264Option , Format7ImageSettings , GigEImageSettings
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- x -

  • xmlURL1 : CameraInfo
  • xmlURL2 : CameraInfo
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • Properties
  • EventCallbackFcn : ManagedEventOptions
  • EventID : ManagedEventCallbackData
  • EventName : ManagedEventOptions , ManagedEventCallbackData
  • EventTimestamp : ManagedEventCallbackData
  • m_allInternalCameraEvents : ManagedCameraBase
  • m_externalDelegate : ManagedCameraBase , ManagedUtilities
  • m_internalCameraEventDelegate : ManagedCameraBase
  • m_internalDelegate : ManagedCameraBase , ManagedUtilities
  • m_isLocal : ManagedCameraBase
  • m_p : ManagedCameraBase
  • m_pNativeCamBase : ManagedCameraBase
  • m_specificInternalCameraEvents : ManagedCameraBase
  • ptr : NativeEventStruct
  • value0 : ManagedPGRGuid
  • value1 : ManagedPGRGuid
  • value2 : ManagedPGRGuid
  • value3 : ManagedPGRGuid
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Main Page

FlyCapture2 Managed Documentation
Generated on Tue Jan 9 2018 22:00:04 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy

Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- j -

  • Jpeg : FlyCapture2Managed
  • Jpeg2000 : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- l -

  • Lightness : FlyCapture2Managed
  • LinuxX64 : FlyCapture2Managed
  • LinuxX86 : FlyCapture2Managed
  • LittleEndian : FlyCapture2Managed
  • LowLevelFailure : FlyCapture2Managed
  • LutFailed : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- m -

  • Mac : FlyCapture2Managed
  • ManagedCallbackType : FlyCapture2Managed
  • ManagedCameraEventCallback() : FlyCapture2Managed
  • ManagedCameraEventCallbackDelegate() : FlyCapture2Managed
  • MemoryAllocationFailed : FlyCapture2Managed
  • Mode : FlyCapture2Managed
  • Mode0 : FlyCapture2Managed
  • Mode1 : FlyCapture2Managed
  • Mode10 : FlyCapture2Managed
  • Mode11 : FlyCapture2Managed
  • Mode12 : FlyCapture2Managed
  • Mode13 : FlyCapture2Managed
  • Mode14 : FlyCapture2Managed
  • Mode15 : FlyCapture2Managed
  • Mode16 : FlyCapture2Managed
  • Mode17 : FlyCapture2Managed
  • Mode18 : FlyCapture2Managed
  • Mode19 : FlyCapture2Managed
  • Mode2 : FlyCapture2Managed
  • Mode20 : FlyCapture2Managed
  • Mode21 : FlyCapture2Managed
  • Mode22 : FlyCapture2Managed
  • Mode23 : FlyCapture2Managed
  • Mode24 : FlyCapture2Managed
  • Mode25 : FlyCapture2Managed
  • Mode26 : FlyCapture2Managed
  • Mode27 : FlyCapture2Managed
  • Mode28 : FlyCapture2Managed
  • Mode29 : FlyCapture2Managed
  • Mode3 : FlyCapture2Managed
  • Mode30 : FlyCapture2Managed
  • Mode31 : FlyCapture2Managed
  • Mode4 : FlyCapture2Managed
  • Mode5 : FlyCapture2Managed
  • Mode6 : FlyCapture2Managed
  • Mode7 : FlyCapture2Managed
  • Mode8 : FlyCapture2Managed
  • Mode9 : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- n -

  • NearestNeighbor : FlyCapture2Managed
  • NoColorProcessing : FlyCapture2Managed
  • None : FlyCapture2Managed
  • NotConnected : FlyCapture2Managed
  • NotFound : FlyCapture2Managed
  • NotImplemented : FlyCapture2Managed
  • NotInFormat7 : FlyCapture2Managed
  • NotInitialized : FlyCapture2Managed
  • NotSupported : FlyCapture2Managed
  • NumberOfFrameRates : FlyCapture2Managed
  • NumberOfModes : FlyCapture2Managed
  • NumberOfPixelFormats : FlyCapture2Managed
  • NumberOfStatisticsChannels : FlyCapture2Managed
  • NumberOfVideoModes : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- o -

  • Off : FlyCapture2Managed
  • Ok : FlyCapture2Managed
  • On : FlyCapture2Managed
  • OSType : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- z -

  • Zoom : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- b -

  • BandwidthAllocation : FlyCapture2Managed
  • BayerTileFormat : FlyCapture2Managed
  • BGGR : FlyCapture2Managed
  • BigEndian : FlyCapture2Managed
  • Blue : FlyCapture2Managed
  • Bmp : FlyCapture2Managed
  • Brightness : FlyCapture2Managed
  • BufferFrames : FlyCapture2Managed
  • BufferTooSmall : FlyCapture2Managed
  • BusMasterFailed : FlyCapture2Managed
  • BusReset : FlyCapture2Managed
  • BusSpeed : FlyCapture2Managed
  • ByteOrder : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • ColorProcessingAlgorithm : FlyCapture2Managed
  • CommandCallbackDelegate() : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- d -

  • Default : FlyCapture2Managed
  • Directional : FlyCapture2Managed
  • DriverType : FlyCapture2Managed
  • DropFrames : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- e -

  • EdgeSensing : FlyCapture2Managed
  • EnumCallback() : FlyCapture2Managed
  • ErrorType : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- f -

  • Failed : FlyCapture2Managed
  • FailedBusMasterConnection : FlyCapture2Managed
  • FailedGuid : FlyCapture2Managed
  • Fastest : FlyCapture2Managed
  • Focus : FlyCapture2Managed
  • FrameRate : FlyCapture2Managed
  • FrameRate120 : FlyCapture2Managed
  • FrameRate15 : FlyCapture2Managed
  • FrameRate1_875 : FlyCapture2Managed
  • FrameRate240 : FlyCapture2Managed
  • FrameRate30 : FlyCapture2Managed
  • FrameRate3_75 : FlyCapture2Managed
  • FrameRate60 : FlyCapture2Managed
  • FrameRate7_5 : FlyCapture2Managed
  • FrameRateFormat7 : FlyCapture2Managed
  • FromFileExtension : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- g -

  • Gain : FlyCapture2Managed
  • Gamma : FlyCapture2Managed
  • GBRG : FlyCapture2Managed
  • GigE : FlyCapture2Managed
  • GigE_10000Base_T : FlyCapture2Managed
  • GigE_1000Base_T : FlyCapture2Managed
  • GigE_100Base_T : FlyCapture2Managed
  • GigE_10Base_T : FlyCapture2Managed
  • GigE_Filter : FlyCapture2Managed
  • GigE_Lwf : FlyCapture2Managed
  • GigE_None : FlyCapture2Managed
  • GigE_Pro : FlyCapture2Managed
  • GigEPropertyType : FlyCapture2Managed
  • GrabMode : FlyCapture2Managed
  • GrabTimeout : FlyCapture2Managed
  • GRBG : FlyCapture2Managed
  • Green : FlyCapture2Managed
  • Grey : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- h -

  • Heartbeat : FlyCapture2Managed
  • HeartbeatTimeout : FlyCapture2Managed
  • HQLinear : FlyCapture2Managed
  • htonl() : FlyCapture2Managed
  • Hue : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- i -

  • Ieee1394 : FlyCapture2Managed
  • Ieee1394_Cam : FlyCapture2Managed
  • Ieee1394_Juju : FlyCapture2Managed
  • Ieee1394_Pro : FlyCapture2Managed
  • Ieee1394_Raw1394 : FlyCapture2Managed
  • Ieee1394_Video1394 : FlyCapture2Managed
  • IidcFailed : FlyCapture2Managed
  • ImageCallbackDelegate() : FlyCapture2Managed
  • ImageConsistencyError : FlyCapture2Managed
  • ImageConversionFailed : FlyCapture2Managed
  • ImageEventCallback() : FlyCapture2Managed
  • ImageFileFormat : FlyCapture2Managed
  • ImageLibraryFailure : FlyCapture2Managed
  • IncompatibleDriver : FlyCapture2Managed
  • Infinite : FlyCapture2Managed
  • InitFailed : FlyCapture2Managed
  • InterfaceType : FlyCapture2Managed
  • InvalidBuManager : FlyCapture2Managed
  • InvalidGeneration : FlyCapture2Managed
  • InvalidMode : FlyCapture2Managed
  • InvalidPacketSize : FlyCapture2Managed
  • InvalidParameter : FlyCapture2Managed
  • InvalidSettings : FlyCapture2Managed
  • IPP : FlyCapture2Managed
  • Iris : FlyCapture2Managed
  • IsochAlreadyStarted : FlyCapture2Managed
  • IsochBandwidthExceeded : FlyCapture2Managed
  • IsochFailed : FlyCapture2Managed
  • IsochNotStarted : FlyCapture2Managed
  • IsochRetrieveBufferFailed : FlyCapture2Managed
  • IsochStartFailed : FlyCapture2Managed
  • IsochStopFailed : FlyCapture2Managed
  • IsochSyncFailed : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- p -

  • PacketDelay : FlyCapture2Managed
  • PacketSize : FlyCapture2Managed
  • Pan : FlyCapture2Managed
  • PCIeBusSpeed : FlyCapture2Managed
  • Pgm : FlyCapture2Managed
  • PixelFormat : FlyCapture2Managed
  • PixelFormat411Yuv8 : FlyCapture2Managed
  • PixelFormat422Yuv8 : FlyCapture2Managed
  • PixelFormat422Yuv8Jpeg : FlyCapture2Managed
  • PixelFormat444Yuv8 : FlyCapture2Managed
  • PixelFormatBgr : FlyCapture2Managed
  • PixelFormatBgr16 : FlyCapture2Managed
  • PixelFormatBgru : FlyCapture2Managed
  • PixelFormatBgru16 : FlyCapture2Managed
  • PixelFormatMono12 : FlyCapture2Managed
  • PixelFormatMono16 : FlyCapture2Managed
  • PixelFormatMono8 : FlyCapture2Managed
  • PixelFormatRaw12 : FlyCapture2Managed
  • PixelFormatRaw16 : FlyCapture2Managed
  • PixelFormatRaw8 : FlyCapture2Managed
  • PixelFormatRgb : FlyCapture2Managed
  • PixelFormatRgb16 : FlyCapture2Managed
  • PixelFormatRgb8 : FlyCapture2Managed
  • PixelFormatRgbu : FlyCapture2Managed
  • PixelFormatSignedMono16 : FlyCapture2Managed
  • PixelFormatSignedRgb16 : FlyCapture2Managed
  • Png : FlyCapture2Managed
  • Ppm : FlyCapture2Managed
  • PropertyFailed : FlyCapture2Managed
  • PropertyNotPresent : FlyCapture2Managed
  • PropertyType : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- r -

  • Raw : FlyCapture2Managed
  • ReadRegisterFailed : FlyCapture2Managed
  • Red : FlyCapture2Managed
  • RegisterFailed : FlyCapture2Managed
  • Removal : FlyCapture2Managed
  • RGGB : FlyCapture2Managed
  • Rigorous : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- s -

  • S100 : FlyCapture2Managed
  • S1600 : FlyCapture2Managed
  • S200 : FlyCapture2Managed
  • S3200 : FlyCapture2Managed
  • S400 : FlyCapture2Managed
  • S480 : FlyCapture2Managed
  • S5000 : FlyCapture2Managed
  • S800 : FlyCapture2Managed
  • Saturation : FlyCapture2Managed
  • Sharpness : FlyCapture2Managed
  • Shutter : FlyCapture2Managed
  • Speed_2_5 : FlyCapture2Managed
  • Speed_5_0 : FlyCapture2Managed
  • StatisticsChannel : FlyCapture2Managed
  • StrobeFailed : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- t -

  • Temperature : FlyCapture2Managed
  • Tiff : FlyCapture2Managed
  • Tilt : FlyCapture2Managed
  • Timeout : FlyCapture2Managed
  • TriggerDelay : FlyCapture2Managed
  • TriggerFailed : FlyCapture2Managed
  • TriggerMode : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- u -

  • Undefined : FlyCapture2Managed
  • Unknown : FlyCapture2Managed
  • UnknownOS : FlyCapture2Managed
  • Unspecified : FlyCapture2Managed
  • Unsupported : FlyCapture2Managed
  • Usb2 : FlyCapture2Managed
  • Usb3 : FlyCapture2Managed
  • Usb3_Pro : FlyCapture2Managed
  • Usb_Cam : FlyCapture2Managed
  • Usb_None : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- v -

  • VideoMode : FlyCapture2Managed
  • VideoMode1024x768Rgb : FlyCapture2Managed
  • VideoMode1024x768Y16 : FlyCapture2Managed
  • VideoMode1024x768Y8 : FlyCapture2Managed
  • VideoMode1024x768Yuv422 : FlyCapture2Managed
  • VideoMode1280x960Rgb : FlyCapture2Managed
  • VideoMode1280x960Y16 : FlyCapture2Managed
  • VideoMode1280x960Y8 : FlyCapture2Managed
  • VideoMode1280x960Yuv422 : FlyCapture2Managed
  • VideoMode1600x1200Rgb : FlyCapture2Managed
  • VideoMode1600x1200Y16 : FlyCapture2Managed
  • VideoMode1600x1200Y8 : FlyCapture2Managed
  • VideoMode1600x1200Yuv422 : FlyCapture2Managed
  • VideoMode160x120Yuv444 : FlyCapture2Managed
  • VideoMode320x240Yuv422 : FlyCapture2Managed
  • VideoMode640x480Rgb : FlyCapture2Managed
  • VideoMode640x480Y16 : FlyCapture2Managed
  • VideoMode640x480Y8 : FlyCapture2Managed
  • VideoMode640x480Yuv411 : FlyCapture2Managed
  • VideoMode640x480Yuv422 : FlyCapture2Managed
  • VideoMode800x600Rgb : FlyCapture2Managed
  • VideoMode800x600Y16 : FlyCapture2Managed
  • VideoMode800x600Y8 : FlyCapture2Managed
  • VideoMode800x600Yuv422 : FlyCapture2Managed
  • VideoModeFormat7 : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all namespace members with links to the namespace documentation for each member:

- w -

  • WeightedDirectional : FlyCapture2Managed
  • WhiteBalance : FlyCapture2Managed
  • WindowsX64 : FlyCapture2Managed
  • WindowsX86 : FlyCapture2Managed
  • WriteRegisterFailed : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • BandwidthAllocation : FlyCapture2Managed
  • BayerTileFormat : FlyCapture2Managed
  • BusSpeed : FlyCapture2Managed
  • ByteOrder : FlyCapture2Managed
  • ColorProcessingAlgorithm : FlyCapture2Managed
  • DriverType : FlyCapture2Managed
  • ErrorType : FlyCapture2Managed
  • FrameRate : FlyCapture2Managed
  • GigEPropertyType : FlyCapture2Managed
  • GrabMode : FlyCapture2Managed
  • GrabTimeout : FlyCapture2Managed
  • ImageFileFormat : FlyCapture2Managed
  • InterfaceType : FlyCapture2Managed
  • ManagedCallbackType : FlyCapture2Managed
  • Mode : FlyCapture2Managed
  • OSType : FlyCapture2Managed
  • PCIeBusSpeed : FlyCapture2Managed
  • PixelFormat : FlyCapture2Managed
  • PropertyType : FlyCapture2Managed
  • StatisticsChannel : FlyCapture2Managed
  • VideoMode : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- a -

  • Any : FlyCapture2Managed
  • Arrival : FlyCapture2Managed
  • AutoExposure : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- j -

  • Jpeg : FlyCapture2Managed
  • Jpeg2000 : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- l -

  • Lightness : FlyCapture2Managed
  • LinuxX64 : FlyCapture2Managed
  • LinuxX86 : FlyCapture2Managed
  • LittleEndian : FlyCapture2Managed
  • LowLevelFailure : FlyCapture2Managed
  • LutFailed : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- m -

  • Mac : FlyCapture2Managed
  • MemoryAllocationFailed : FlyCapture2Managed
  • Mode0 : FlyCapture2Managed
  • Mode1 : FlyCapture2Managed
  • Mode10 : FlyCapture2Managed
  • Mode11 : FlyCapture2Managed
  • Mode12 : FlyCapture2Managed
  • Mode13 : FlyCapture2Managed
  • Mode14 : FlyCapture2Managed
  • Mode15 : FlyCapture2Managed
  • Mode16 : FlyCapture2Managed
  • Mode17 : FlyCapture2Managed
  • Mode18 : FlyCapture2Managed
  • Mode19 : FlyCapture2Managed
  • Mode2 : FlyCapture2Managed
  • Mode20 : FlyCapture2Managed
  • Mode21 : FlyCapture2Managed
  • Mode22 : FlyCapture2Managed
  • Mode23 : FlyCapture2Managed
  • Mode24 : FlyCapture2Managed
  • Mode25 : FlyCapture2Managed
  • Mode26 : FlyCapture2Managed
  • Mode27 : FlyCapture2Managed
  • Mode28 : FlyCapture2Managed
  • Mode29 : FlyCapture2Managed
  • Mode3 : FlyCapture2Managed
  • Mode30 : FlyCapture2Managed
  • Mode31 : FlyCapture2Managed
  • Mode4 : FlyCapture2Managed
  • Mode5 : FlyCapture2Managed
  • Mode6 : FlyCapture2Managed
  • Mode7 : FlyCapture2Managed
  • Mode8 : FlyCapture2Managed
  • Mode9 : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- n -

  • NearestNeighbor : FlyCapture2Managed
  • NoColorProcessing : FlyCapture2Managed
  • None : FlyCapture2Managed
  • NotConnected : FlyCapture2Managed
  • NotFound : FlyCapture2Managed
  • NotImplemented : FlyCapture2Managed
  • NotInFormat7 : FlyCapture2Managed
  • NotInitialized : FlyCapture2Managed
  • NotSupported : FlyCapture2Managed
  • NumberOfFrameRates : FlyCapture2Managed
  • NumberOfModes : FlyCapture2Managed
  • NumberOfPixelFormats : FlyCapture2Managed
  • NumberOfStatisticsChannels : FlyCapture2Managed
  • NumberOfVideoModes : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- o -

  • Off : FlyCapture2Managed
  • Ok : FlyCapture2Managed
  • On : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- z -

  • Zoom : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- b -

  • BGGR : FlyCapture2Managed
  • BigEndian : FlyCapture2Managed
  • Blue : FlyCapture2Managed
  • Bmp : FlyCapture2Managed
  • Brightness : FlyCapture2Managed
  • BufferFrames : FlyCapture2Managed
  • BufferTooSmall : FlyCapture2Managed
  • BusMasterFailed : FlyCapture2Managed
  • BusReset : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- d -

  • Default : FlyCapture2Managed
  • Directional : FlyCapture2Managed
  • DropFrames : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- e -

  • EdgeSensing : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- f -

  • Failed : FlyCapture2Managed
  • FailedBusMasterConnection : FlyCapture2Managed
  • FailedGuid : FlyCapture2Managed
  • Fastest : FlyCapture2Managed
  • Focus : FlyCapture2Managed
  • FrameRate : FlyCapture2Managed
  • FrameRate120 : FlyCapture2Managed
  • FrameRate15 : FlyCapture2Managed
  • FrameRate1_875 : FlyCapture2Managed
  • FrameRate240 : FlyCapture2Managed
  • FrameRate30 : FlyCapture2Managed
  • FrameRate3_75 : FlyCapture2Managed
  • FrameRate60 : FlyCapture2Managed
  • FrameRate7_5 : FlyCapture2Managed
  • FrameRateFormat7 : FlyCapture2Managed
  • FromFileExtension : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- g -

  • Gain : FlyCapture2Managed
  • Gamma : FlyCapture2Managed
  • GBRG : FlyCapture2Managed
  • GigE : FlyCapture2Managed
  • GigE_10000Base_T : FlyCapture2Managed
  • GigE_1000Base_T : FlyCapture2Managed
  • GigE_100Base_T : FlyCapture2Managed
  • GigE_10Base_T : FlyCapture2Managed
  • GigE_Filter : FlyCapture2Managed
  • GigE_Lwf : FlyCapture2Managed
  • GigE_None : FlyCapture2Managed
  • GigE_Pro : FlyCapture2Managed
  • GRBG : FlyCapture2Managed
  • Green : FlyCapture2Managed
  • Grey : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- h -

  • Heartbeat : FlyCapture2Managed
  • HeartbeatTimeout : FlyCapture2Managed
  • HQLinear : FlyCapture2Managed
  • Hue : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- i -

  • Ieee1394 : FlyCapture2Managed
  • Ieee1394_Cam : FlyCapture2Managed
  • Ieee1394_Juju : FlyCapture2Managed
  • Ieee1394_Pro : FlyCapture2Managed
  • Ieee1394_Raw1394 : FlyCapture2Managed
  • Ieee1394_Video1394 : FlyCapture2Managed
  • IidcFailed : FlyCapture2Managed
  • ImageConsistencyError : FlyCapture2Managed
  • ImageConversionFailed : FlyCapture2Managed
  • ImageLibraryFailure : FlyCapture2Managed
  • IncompatibleDriver : FlyCapture2Managed
  • Infinite : FlyCapture2Managed
  • InitFailed : FlyCapture2Managed
  • InvalidBuManager : FlyCapture2Managed
  • InvalidGeneration : FlyCapture2Managed
  • InvalidMode : FlyCapture2Managed
  • InvalidPacketSize : FlyCapture2Managed
  • InvalidParameter : FlyCapture2Managed
  • InvalidSettings : FlyCapture2Managed
  • IPP : FlyCapture2Managed
  • Iris : FlyCapture2Managed
  • IsochAlreadyStarted : FlyCapture2Managed
  • IsochBandwidthExceeded : FlyCapture2Managed
  • IsochFailed : FlyCapture2Managed
  • IsochNotStarted : FlyCapture2Managed
  • IsochRetrieveBufferFailed : FlyCapture2Managed
  • IsochStartFailed : FlyCapture2Managed
  • IsochStopFailed : FlyCapture2Managed
  • IsochSyncFailed : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- p -

  • PacketDelay : FlyCapture2Managed
  • PacketSize : FlyCapture2Managed
  • Pan : FlyCapture2Managed
  • Pgm : FlyCapture2Managed
  • PixelFormat411Yuv8 : FlyCapture2Managed
  • PixelFormat422Yuv8 : FlyCapture2Managed
  • PixelFormat422Yuv8Jpeg : FlyCapture2Managed
  • PixelFormat444Yuv8 : FlyCapture2Managed
  • PixelFormatBgr : FlyCapture2Managed
  • PixelFormatBgr16 : FlyCapture2Managed
  • PixelFormatBgru : FlyCapture2Managed
  • PixelFormatBgru16 : FlyCapture2Managed
  • PixelFormatMono12 : FlyCapture2Managed
  • PixelFormatMono16 : FlyCapture2Managed
  • PixelFormatMono8 : FlyCapture2Managed
  • PixelFormatRaw12 : FlyCapture2Managed
  • PixelFormatRaw16 : FlyCapture2Managed
  • PixelFormatRaw8 : FlyCapture2Managed
  • PixelFormatRgb : FlyCapture2Managed
  • PixelFormatRgb16 : FlyCapture2Managed
  • PixelFormatRgb8 : FlyCapture2Managed
  • PixelFormatRgbu : FlyCapture2Managed
  • PixelFormatSignedMono16 : FlyCapture2Managed
  • PixelFormatSignedRgb16 : FlyCapture2Managed
  • Png : FlyCapture2Managed
  • Ppm : FlyCapture2Managed
  • PropertyFailed : FlyCapture2Managed
  • PropertyNotPresent : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- r -

  • Raw : FlyCapture2Managed
  • ReadRegisterFailed : FlyCapture2Managed
  • Red : FlyCapture2Managed
  • RegisterFailed : FlyCapture2Managed
  • Removal : FlyCapture2Managed
  • RGGB : FlyCapture2Managed
  • Rigorous : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- s -

  • S100 : FlyCapture2Managed
  • S1600 : FlyCapture2Managed
  • S200 : FlyCapture2Managed
  • S3200 : FlyCapture2Managed
  • S400 : FlyCapture2Managed
  • S480 : FlyCapture2Managed
  • S5000 : FlyCapture2Managed
  • S800 : FlyCapture2Managed
  • Saturation : FlyCapture2Managed
  • Sharpness : FlyCapture2Managed
  • Shutter : FlyCapture2Managed
  • Speed_2_5 : FlyCapture2Managed
  • Speed_5_0 : FlyCapture2Managed
  • StrobeFailed : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- t -

  • Temperature : FlyCapture2Managed
  • Tiff : FlyCapture2Managed
  • Tilt : FlyCapture2Managed
  • Timeout : FlyCapture2Managed
  • TriggerDelay : FlyCapture2Managed
  • TriggerFailed : FlyCapture2Managed
  • TriggerMode : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- u -

  • Undefined : FlyCapture2Managed
  • Unknown : FlyCapture2Managed
  • UnknownOS : FlyCapture2Managed
  • Unspecified : FlyCapture2Managed
  • Unsupported : FlyCapture2Managed
  • Usb2 : FlyCapture2Managed
  • Usb3 : FlyCapture2Managed
  • Usb3_Pro : FlyCapture2Managed
  • Usb_Cam : FlyCapture2Managed
  • Usb_None : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- v -

  • VideoMode1024x768Rgb : FlyCapture2Managed
  • VideoMode1024x768Y16 : FlyCapture2Managed
  • VideoMode1024x768Y8 : FlyCapture2Managed
  • VideoMode1024x768Yuv422 : FlyCapture2Managed
  • VideoMode1280x960Rgb : FlyCapture2Managed
  • VideoMode1280x960Y16 : FlyCapture2Managed
  • VideoMode1280x960Y8 : FlyCapture2Managed
  • VideoMode1280x960Yuv422 : FlyCapture2Managed
  • VideoMode1600x1200Rgb : FlyCapture2Managed
  • VideoMode1600x1200Y16 : FlyCapture2Managed
  • VideoMode1600x1200Y8 : FlyCapture2Managed
  • VideoMode1600x1200Yuv422 : FlyCapture2Managed
  • VideoMode160x120Yuv444 : FlyCapture2Managed
  • VideoMode320x240Yuv422 : FlyCapture2Managed
  • VideoMode640x480Rgb : FlyCapture2Managed
  • VideoMode640x480Y16 : FlyCapture2Managed
  • VideoMode640x480Y8 : FlyCapture2Managed
  • VideoMode640x480Yuv411 : FlyCapture2Managed
  • VideoMode640x480Yuv422 : FlyCapture2Managed
  • VideoMode800x600Rgb : FlyCapture2Managed
  • VideoMode800x600Y16 : FlyCapture2Managed
  • VideoMode800x600Y8 : FlyCapture2Managed
  • VideoMode800x600Yuv422 : FlyCapture2Managed
  • VideoModeFormat7 : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- w -

  • WeightedDirectional : FlyCapture2Managed
  • WhiteBalance : FlyCapture2Managed
  • WindowsX64 : FlyCapture2Managed
  • WindowsX86 : FlyCapture2Managed
  • WriteRegisterFailed : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • AsyncCommandCallback() : FlyCapture2Managed
  • CommandCallbackDelegate() : FlyCapture2Managed
  • EnumCallback() : FlyCapture2Managed
  • htonl() : FlyCapture2Managed
  • ImageCallbackDelegate() : FlyCapture2Managed
  • ImageEventCallback() : FlyCapture2Managed
  • ManagedCameraEventCallback() : FlyCapture2Managed
  • ManagedCameraEventCallbackDelegate() : FlyCapture2Managed
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • AviOption
AviOption Member List
This is the complete list of members for AviOption, including all inherited members.
AviOption() | AviOption | [inline]
frameRate | AviOption |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • BMPOption
BMPOption Member List
This is the complete list of members for BMPOption, including all inherited members.
BMPOption() | BMPOption | [inline]
indexedColor_8bit | BMPOption |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • CameraInfo
CameraInfo Member List
This is the complete list of members for CameraInfo, including all inherited members.
applicationIPAddress | CameraInfo
applicationPort | CameraInfo
bayerTileFormat | CameraInfo
busNumber | CameraInfo
ccpStatus | CameraInfo
configROM | CameraInfo
defaultGateway | CameraInfo
driverName | CameraInfo
driverType | CameraInfo
firmwareBuildTime | CameraInfo
firmwareVersion | CameraInfo
gigEMajorVersion | CameraInfo
gigEMinorVersion | CameraInfo
iidcVersion | CameraInfo
interfaceType | CameraInfo
ipAddress | CameraInfo
isColorCamera | CameraInfo
macAddress | CameraInfo
maximumBusSpeed | CameraInfo
modelName | CameraInfo
nodeNumber | CameraInfo
pcieBusSpeed | CameraInfo
sensorInfo | CameraInfo
sensorResolution | CameraInfo
serialNumber | CameraInfo
subnetMask | CameraInfo
userDefinedName | CameraInfo
vendorName | CameraInfo
xmlURL1 | CameraInfo
xmlURL2 | CameraInfo
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • CameraProperty
CameraProperty Member List
This is the complete list of members for CameraProperty, including all inherited members.
absControl | CameraProperty |
absValue | CameraProperty |
autoManualMode | CameraProperty |
CameraProperty() | CameraProperty | [inline]
CameraProperty(PropertyType type) | CameraProperty | [inline]
onePush | CameraProperty |
onOff | CameraProperty |
present | CameraProperty |
type | CameraProperty |
valueA | CameraProperty |
valueB | CameraProperty |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • CameraPropertyInfo
CameraPropertyInfo Member List
This is the complete list of members for CameraPropertyInfo, including all inherited members.
absMax | CameraPropertyInfo |
absMin | CameraPropertyInfo |
absValSupported | CameraPropertyInfo |
autoSupported | CameraPropertyInfo |
CameraPropertyInfo() | CameraPropertyInfo | [inline]
CameraPropertyInfo(PropertyType type) | CameraPropertyInfo | [inline]
manualSupported | CameraPropertyInfo |
max | CameraPropertyInfo |
min | CameraPropertyInfo |
onePushSupported | CameraPropertyInfo |
onOffSupported | CameraPropertyInfo |
present | CameraPropertyInfo |
readOutSupported | CameraPropertyInfo |
type | CameraPropertyInfo |
unitAbbr | CameraPropertyInfo |
units | CameraPropertyInfo |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • CameraStats
CameraStats Member List
This is the complete list of members for CameraStats, including all inherited members.
cameraCurrents | CameraStats |
cameraPowerUp | CameraStats |
CameraStats() | CameraStats | [inline]
cameraVoltages | CameraStats |
imageCorrupt | CameraStats |
imageDriverDropped | CameraStats |
imageDropped | CameraStats |
imageXmitFailed | CameraStats |
numCurrents | CameraStats |
numResendPacketsReceived | CameraStats |
numResendPacketsRequested | CameraStats |
numVoltages | CameraStats |
portErrors | CameraStats |
regReadFailed | CameraStats |
regWriteFailed | CameraStats |
temperature | CameraStats |
timeSinceBusReset | CameraStats |
timeSinceInitialization | CameraStats |
timeStamp | CameraStats |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ConfigROM
ConfigROM Member List
This is the complete list of members for ConfigROM, including all inherited members.
chipIdHi | ConfigROM
chipIdLo | ConfigROM
keyword | ConfigROM
nodeVendorId | ConfigROM
unitSpecId | ConfigROM
unitSubSWVer | ConfigROM
unitSWVer | ConfigROM
vendorUniqueInfo0 | ConfigROM
vendorUniqueInfo1 | ConfigROM
vendorUniqueInfo2 | ConfigROM
vendorUniqueInfo3 | ConfigROM
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • EmbeddedImageInfo
EmbeddedImageInfo Member List
This is the complete list of members for EmbeddedImageInfo, including all inherited members.
brightness | EmbeddedImageInfo |
EmbeddedImageInfo() | EmbeddedImageInfo | [inline]
exposure | EmbeddedImageInfo |
frameCounter | EmbeddedImageInfo |
gain | EmbeddedImageInfo |
GPIOPinState | EmbeddedImageInfo |
ROIPosition | EmbeddedImageInfo |
shutter | EmbeddedImageInfo |
strobePattern | EmbeddedImageInfo |
timestamp | EmbeddedImageInfo |
whiteBalance | EmbeddedImageInfo |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • EmbeddedImageInfoProperty
EmbeddedImageInfoProperty Member List
This is the complete list of members for EmbeddedImageInfoProperty, including all inherited members.
available | EmbeddedImageInfoProperty
onOff | EmbeddedImageInfoProperty
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • FC2Config
FC2Config Member List
This is the complete list of members for FC2Config, including all inherited members.
asyncBusSpeed | FC2Config |
bandwidthAllocation | FC2Config |
FC2Config() | FC2Config | [inline]
grabMode | FC2Config |
grabTimeout | FC2Config |
highPerformanceRetrieveBuffer | FC2Config |
isochBusSpeed | FC2Config |
minNumImageNotifications | FC2Config |
numBuffers | FC2Config |
numImageNotifications | FC2Config |
registerTimeout | FC2Config |
registerTimeoutRetries | FC2Config |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • FC2Version
FC2Version Member List
This is the complete list of members for FC2Version, including all inherited members.
build | FC2Version
major | FC2Version
minor | FC2Version
type | FC2Version
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • Format7ImageSettings
Format7ImageSettings Member List
This is the complete list of members for Format7ImageSettings, including all inherited members.
height | Format7ImageSettings
mode | Format7ImageSettings
offsetX | Format7ImageSettings
offsetY | Format7ImageSettings
pixelFormat | Format7ImageSettings
width | Format7ImageSettings
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • Format7Info
Format7Info Member List
This is the complete list of members for Format7Info, including all inherited members.
imageHStepSize | Format7Info
imageVStepSize | Format7Info
maxHeight | Format7Info
maxPacketSize | Format7Info
maxWidth | Format7Info
minPacketSize | Format7Info
mode | Format7Info
offsetHStepSize | Format7Info
offsetVStepSize | Format7Info
packetSize | Format7Info
percentage | Format7Info
pixelFormatBitField | Format7Info
vendorPixelFormatBitField | Format7Info
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • Format7PacketInfo
Format7PacketInfo Member List
This is the complete list of members for Format7PacketInfo, including all inherited members.
maxBytesPerPacket | Format7PacketInfo
recommendedBytesPerPacket | Format7PacketInfo
unitBytesPerPacket | Format7PacketInfo
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • GigEConfig
GigEConfig Member List
This is the complete list of members for GigEConfig, including all inherited members.
enablePacketResend GigEConfig
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • GigEImageSettings
GigEImageSettings Member List
This is the complete list of members for GigEImageSettings, including all inherited members.
height | GigEImageSettings
offsetX | GigEImageSettings
offsetY | GigEImageSettings
pixelFormat | GigEImageSettings
width | GigEImageSettings
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • GigEImageSettingsInfo
GigEImageSettingsInfo Member List
This is the complete list of members for GigEImageSettingsInfo, including all inherited members.
imageHStepSize | GigEImageSettingsInfo
imageVStepSize | GigEImageSettingsInfo
maxHeight | GigEImageSettingsInfo
maxWidth | GigEImageSettingsInfo
offsetHStepSize | GigEImageSettingsInfo
offsetVStepSize | GigEImageSettingsInfo
pixelFormatBitField | GigEImageSettingsInfo
vendorPixelFormatBitField | GigEImageSettingsInfo
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • GigEProperty
GigEProperty Member List
This is the complete list of members for GigEProperty, including all inherited members.
isReadable | GigEProperty
isWritable | GigEProperty
max | GigEProperty
min | GigEProperty
propType | GigEProperty
value | GigEProperty
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • GigEStreamChannel
GigEStreamChannel Member List
This is the complete list of members for GigEStreamChannel, including all inherited members.
destinationIpAddress | GigEStreamChannel
doNotFragment | GigEStreamChannel
hostPort | GigEStreamChannel
interPacketDelay | GigEStreamChannel
networkInterfaceIndex | GigEStreamChannel
packetSize | GigEStreamChannel
sourcePort | GigEStreamChannel
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • H264Option
H264Option Member List
This is the complete list of members for H264Option, including all inherited members.
bitrate | H264Option |
frameRate | H264Option |
H264Option() | H264Option | [inline]
height | H264Option |
width | H264Option |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ImageMetadata
ImageMetadata Member List
This is the complete list of members for ImageMetadata, including all inherited members.
embeddedBrightness | ImageMetadata
embeddedExposure | ImageMetadata
embeddedFrameCounter | ImageMetadata
embeddedGain | ImageMetadata
embeddedGPIOPinState | ImageMetadata
embeddedROIPosition | ImageMetadata
embeddedShutter | ImageMetadata
embeddedStrobePattern | ImageMetadata
embeddedTimeStamp | ImageMetadata
embeddedWhiteBalance | ImageMetadata
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • JpegOption
JpegOption Member List
This is the complete list of members for JpegOption, including all inherited members.
JpegOption() | JpegOption | [inline]
progressive | JpegOption |
quality | JpegOption |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • Jpg2Option
Jpg2Option Member List
This is the complete list of members for Jpg2Option, including all inherited members.
Jpg2Option() | Jpg2Option | [inline]
quality | Jpg2Option |
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • LutData
LutData Member List
This is the complete list of members for LutData, including all inherited members.
enabled | LutData
inputBitDepth | LutData
numBanks | LutData
numChannels | LutData
numEntries | LutData
outputBitDepth | LutData
supported | LutData
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • MJPGOption
MJPGOption Member List
This is the complete list of members for MJPGOption, including all inherited members.
frameRate | MJPGOption |
MJPGOption() | MJPGOption | [inline]
quality | MJPGOption |
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedEventCallbackData
ManagedEventCallbackData Member List
This is the complete list of members for ManagedEventCallbackData, including all inherited members.
EventID | ManagedEventCallbackData
EventName | ManagedEventCallbackData
EventTimestamp | ManagedEventCallbackData
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • ManagedEventOptions
ManagedEventOptions Member List
This is the complete list of members for ManagedEventOptions, including all inherited members.
EventCallbackFcn | ManagedEventOptions
EventName | ManagedEventOptions
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • NativeEventStruct
NativeEventStruct Member List
This is the complete list of members for NativeEventStruct, including all inherited members.
ptr NativeEventStruct
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • PgmOption
PgmOption Member List
This is the complete list of members for PgmOption, including all inherited members.
binaryFile | PgmOption |
PgmOption() | PgmOption | [inline]
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • PngOption
PngOption Member List
This is the complete list of members for PngOption, including all inherited members.
compressionLevel | PngOption |
interlaced | PngOption |
PngOption() | PngOption | [inline]
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • PpmOption
PpmOption Member List
This is the complete list of members for PpmOption, including all inherited members.
binaryFile | PpmOption |
PpmOption() | PpmOption | [inline]
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • StrobeControl
StrobeControl Member List
This is the complete list of members for StrobeControl, including all inherited members.
delay | StrobeControl
duration | StrobeControl
onOff | StrobeControl
polarity | StrobeControl
source | StrobeControl
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • StrobeInfo
StrobeInfo Member List
This is the complete list of members for StrobeInfo, including all inherited members.
maxValue | StrobeInfo
minValue | StrobeInfo
onOffSupported | StrobeInfo
polaritySupported | StrobeInfo
present | StrobeInfo
readOutSupported | StrobeInfo
source | StrobeInfo
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • SystemInfo
SystemInfo Member List
This is the complete list of members for SystemInfo, including all inherited members.
byteOrder | SystemInfo
cpuDescription | SystemInfo
driverList | SystemInfo
gpuDescription | SystemInfo
libraryList | SystemInfo
numCpuCores | SystemInfo
osDescription | SystemInfo
osType | SystemInfo
screenHeight | SystemInfo
screenWidth | SystemInfo
systemMemorySize | SystemInfo
Generated on Tue Jan 9 2018 22:00:06 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • TiffOption
TiffOption Member List
This is the complete list of members for TiffOption, including all inherited members.
AdobeDeflate enum value | TiffOption |
CcittFax3 enum value | TiffOption |
CcittFax4 enum value | TiffOption |
compression | TiffOption |
CompressionMethod enum name | TiffOption |
Deflate enum value | TiffOption |
Jpeg enum value | TiffOption |
Lzw enum value | TiffOption |
None enum value | TiffOption |
PackBits enum value | TiffOption |
TiffOption() | TiffOption | [inline]
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • TimeStamp
TimeStamp Member List
This is the complete list of members for TimeStamp, including all inherited members.
cycleCount | TimeStamp
cycleOffset | TimeStamp
cycleSeconds | TimeStamp
microSeconds | TimeStamp
seconds | TimeStamp
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • TriggerMode
TriggerMode Member List
This is the complete list of members for TriggerMode, including all inherited members.
mode | TriggerMode
onOff | TriggerMode
parameter | TriggerMode
polarity | TriggerMode
source | TriggerMode
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5


FlyCapture2 Managed: Member List

  • FlyCapture2Managed
  • TriggerModeInfo
TriggerModeInfo Member List
This is the complete list of members for TriggerModeInfo, including all inherited members.
modeMask | TriggerModeInfo
onOffSupported | TriggerModeInfo
polaritySupported | TriggerModeInfo
present | TriggerModeInfo
readOutSupported | TriggerModeInfo
softwareTriggerSupported | TriggerModeInfo
sourceMask | TriggerModeInfo
valueReadable | TriggerModeInfo
Generated on Tue Jan 9 2018 22:00:05 for FlyCapture2 Managed by doxygen 1.7.5